> Tous les forums > Forum Windows 10
 " Système + Actif " dans partition de données
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Pierre.Yves
  Posté le 08/04/2017 @ 21:13 
Aller en bas de la page 
Astucien

Bonsoir tout le monde,

Voilà donc le petit problème nouveau à résoudre ce week-end.

Expo des faits :

Après réinstall propre j'ai voulu " changer la lettre de la partition de données ".

Normalement c'est simple, sauf que j'ai glissé au moment de cliquer, et j'ai atterri sur:

" rendre la partition active " (la ligne au-dessus)...

Donc pas d’affolement, je ressort une commande Diskpart (d'enfermedehors) qui m'avait servi une fois.

Heu... ... résultat des courses : ça fonctionne (je viens de redémarre), mais c'est un peu bizarre...

Je me retrouve avec 2 partitions actives, + " Systéme " dans ma partition de données.

J'aimerai bien retrouver ma partition de données toute propre (pour l'avenir)

Je précise, ce sont 2 disques distincts (SSD + HDD).

Une capture pour éclairer tout ça :

Voilà le topo, a vous de jouer. Merci...

Publicité
Daneel Olivaw
 Posté le 08/04/2017 à 21:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour

Il n'y a aucun inconvénient à avoir plusieurs partitions actives. Actif indique simplement au BIOS que la partition est bootable. Au démarrage, le BIOS va rechercher sur le premier disque la première partition. Si elle est active, il va booter dessus. Sinon, il va à la seconde partition (même si la première comporte un OS Bootable), puis la troisième, puis second DD et ainsi de suite jusqu'à trouver un partition active avec un OS fonctionnel. Il choisi les DD selon l'ordre dans le BIOS.

En fait sur un même disque, il ne peut y avoir qu'une seule partition active, mais plusieurs disques peuvent avoir chacun une partition active sans aucun inconvénient.



Modifié par Daneel Olivaw le 08/04/2017 21:55
enfermedehors
 Posté le 08/04/2017 à 22:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grande Maîtresse astucienne

Là, le système démarre sur le deuxième disque (système, actif), c'est différent de ton autre sujet : https://forum.pcastuces.com/partitions_systeme_sur_2_disques-f4s87442.htm

Tu veux réinstaller le gestionnaire de démarrage sur le SSD pour revenir à ton ancienne configuration ?

Daneel Olivaw
 Posté le 08/04/2017 à 22:05 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Re...

Tu peux la désactiver avec diskpart.

Ouvre une invite de commande en mode administrateur.

tape :

diskpart

list volume

repère quel est le No de la partition

select volume X (x = le numéro relevé plus haut).

inactive

exit

Il y a une étoile au début de la ligne du volume sélectionné.

enfermedehors
 Posté le 08/04/2017 à 22:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grande Maîtresse astucienne

Avant de la rendre inactive, il faut réinstaller le gestionnaire de démarrage sur la partition (C:), sinon, il ne démarre pas.

Daneel Olivaw
 Posté le 08/04/2017 à 22:12 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

enfermedehors a écrit :

Là, le système démarre sur le deuxième disque (système, actif),

Bonjour

Pourquoi ? Le premier disque est actif aussi et et c'est le disque de démarrage (Actif Démarrer). Les fichiers de boot sont dessus et pas sur le second. La BIOS va commencer par le premier et démarrer dessus.

Daneel Olivaw
 Posté le 08/04/2017 à 22:14 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

enfermedehors a écrit :

Avant de la rendre inactive, il faut réinstaller le gestionnaire de démarrage sur la partition (C:), sinon, il ne démarre pas.

Ah ! Il ne dit pas qu'il a modifié le système de démarrage.

enfermedehors
 Posté le 08/04/2017 à 22:14 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grande Maîtresse astucienne

Actif, Démarrer, pas "système"
Le flag système indique la partition de démarrage.

Pierre.Yves
 Posté le 08/04/2017 à 22:15 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

...Merci de vos réponses.

Daneel, ton explication est claire concernant 2 partitions actives sur 2 disques différents...

dans ma tête je n'avais pas percuté sur le fait qu'il s'agit de 2 disques, et non pas 2 partitions

sur le même disque.J'ai compris...

enfermedehors, (je savais que tu mordrai )... oui, parce que si j'ai bien compris, si mon HD casse,

je ne peux plus démarrer le système. C'est bien ça ?...

Pour ce qui est de mon autre sujet, je trouve celui là plus sympathique... (et ce n'est pas sur le même ordi !)

Je vais donc suivre tes conseils (avec plaisir)...

Publicité
Daneel Olivaw
 Posté le 08/04/2017 à 22:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Son système était parfaitement fonctionnel, à moins que je ne me trompe.

Il a simplement fait une erreur. Sa main a glissé et a activé en plus une autre partition. Il n'y a eu aucune modification des fichiers systèmes, boot, démarrage ou autre.

Il n'y a qu'à désactiver la partion du deuxième DD.

Ou alors ai-je manqué quelque chose ?



Modifié par Daneel Olivaw le 08/04/2017 22:23
enfermedehors
 Posté le 08/04/2017 à 22:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grande Maîtresse astucienne

si mon HD casse, je ne peux plus démarrer le système. C'est bien ça ?...

Oui, parce que là le démarrage se fait sur le HDD 1.
Soit tu laisses comme ça, partition de données active, soit on remet le gestionnaire de boot sur le disque 0, c'est toi qui décide.

Pierre.Yves
 Posté le 08/04/2017 à 22:24 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

...

Je viens de lire vos mails, à un moment j'étais parvenu à rendre la partition de données inactives

après avoir lancé une commande pour mettre système sur C:, mais j'ai du mal faire la commande,

et j'ai désactivé P: sans avoir mis le système sur C: Résultat : écran noir, pas de système.

Je me suis donc servi de DART (avec (AOMEI) pour réparer le démarrage, et après redémmarrage

me retrouver comme sur la capture.

Je crois que ce qu'il faut absolument, c'est " Système " sur C: avant toute chose...

Pierre.Yves
 Posté le 08/04/2017 à 22:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

...

Oui oui, j'aimerairemettre le boot sur le disque 0, surtout en prévision de futures réinstall...

J'aimerai bien aussi avoir ma partition de données propre...

enfermedehors
 Posté le 08/04/2017 à 22:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grande Maîtresse astucienne

Je crois que ce qu'il faut absolument, c'est " Système " sur C: avant toute chose...

Ben oui, c'est que je disais.

Ouvre une invite de commande (Admin)
Dans la fenêtre de commande colle la ligne suivante :
bcdboot c:\windows /l fr-fr /s c:

Ensuite, vérifie qu'un dossier Boot a bien été créé sur (C:), c'est un dossier caché, puis fais la manip avec diskpart pour rendre la partition de données inactive.
Avant de redémarrer, va dans le bios mets le SSD en premier dans l'ordre de démarrage.

Pierre.Yves
 Posté le 08/04/2017 à 22:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

...

C'est cette commande que j'ai envoyé en premier !

Mais par "Powershell " en admin. Ça fait une différence ?

Autre chose c'est bien un " l " (pour langue) avant fr (je cherche où j'ai merdé) ?

J'attend ta réponse avant d'envoyer...

enfermedehors
 Posté le 08/04/2017 à 22:39 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grande Maîtresse astucienne

C'est bien un l minuscule.

je cherche où j'ai merdé

Le SSD qui n'est pas en first boot dans le bios ?

Pierre.Yves
 Posté le 08/04/2017 à 22:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

...

Voilà c'est fait :

La commande je l'avais tapé d'après une capture, donc... là j'ai fais un copié-collé.

Je vérifierai pour le SSD...

Publicité
Pierre.Yves
 Posté le 08/04/2017 à 22:52 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

...

Voilà la " Gestion des Disques " :

Là c'est bon, non ?

Ta commande " Diskpart " ne correspond pas tout à fait à celle de Daneel, laquelle j'envoie ?

enfermedehors
 Posté le 08/04/2017 à 22:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grande Maîtresse astucienne

Ne rend pas la partition de données inactive tout de suite.
Fais un redémarrage en mettant le SSD en first boot.
Si c'est bon, il sera marqué système.

enfermedehors
 Posté le 08/04/2017 à 23:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grande Maîtresse astucienne

Ta commande " Diskpart " ne correspond pas tout à fait à celle de Daneel, laquelle j'envoie

Je ne sais pas de quelle commande tu parles.
J'ai peut-être employé list part à la place de list volume, c'est pareil.
Redémarre avant de le faire.

Pierre.Yves
 Posté le 08/04/2017 à 23:13 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

...

Je viens de redémarrer sans problème, mais en allant dans " LE CHOIX " de Boot (F2), car mon

SSD n'apparait pas la " GESTION de l'ORDRE de DEMARRAGE " (n°1, n°2...). Bizarre.

Ta commande la voilà :

Je l'ai gardée, hein...

A ton signal (je viens de redémarrer) j'envoie la commande...

enfermedehors
 Posté le 08/04/2017 à 23:18 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grande Maîtresse astucienne

Tu peux faire l'une ou l'autre, le résultat est le même.
Si tu ne redémarrais pas, passe par F2.

Au redémarrage, la partition (C:) est indiquée "système" ?

SSD n'apparait pas la " GESTION de l'ORDRE de DEMARRAGE " (n°1, n°2...). Bizarre.

Le SSD apparait dans le bios ?

Pierre.Yves
 Posté le 08/04/2017 à 23:25 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

...

Oui oui, il n'y a plus qu'a désactiver l'autre :

J'envoie la commande...

Pierre.Yves
 Posté le 08/04/2017 à 23:38 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

...

Résultat des courses :

C'est du miel de suivre tes indications (je pense que j'ai mal écrit la 1ère commande), mais faut que j'fasse gaffe,

j'ai peur d'y prendre goût !.. Merci

Merci aussi à Daneel, quelquefois je pense sans réfléchir...

Publicité
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Sauvegarder ses données dans le cloud
Installer Windows XP Pro dans 2ème partition
Données déplacées sur une autre partition que C : visibles par tous les com
D'ou proviens cette partition dans Windows 10 ?
Partition Windows de 16 MB
partition de disque
Modifier l’heure dans Windows 10 Pro
Défaut règlage du contraste dans W10 Pro
Comment changer les attributs d'un dossier dans Windows 10 ?
je ne vois plus mon lecteur/graveur dans l explorateur
Plus de sujets relatifs à " Système + Actif " dans partition de données
 > Tous les forums > Forum Windows 10