> Tous les forums > Forum Windows 10
 Accès impossible à Win10 par dualbootSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
daniel74
  Posté le 02/09/2017 @ 11:47 
Aller en bas de la page 
Petit astucien

Bonjour à tous,

jJe viens d'installer Linux Mint 18 sur ma tour avec W10 en dual boot.

l'opération s'est bien passée, sans message d'erreur.

Mon souci: au démarrage, je ne peux pas venir sur le choix de Windows, mon clavier est inactif. pensant que c'est à cause du clavier sans fil, je suis all' chez Bou**ger acheter un clavier filaire.

Ce clavier, branché sur un port USB, je démarre ma tour, même problème!

Ma question: que faire??

Au pire, je supprime Linux mais comment??

Merci pour votre aide

Daniel

[Configuration automatique à compléter]
Système inconnu
Firefox 55.0

Publicité
Ikewdu_
 Posté le 02/09/2017 à 12:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Salut,


En principe, tu as une touche de fonction qui permet d'accéder au bios (-uefi) de ta tour. De là, tu peux aller dans l'onglet boot, et voir si tu as moyen de permuter l'entrée Windows Boot Manager avec celle de Mint. Regarde en même temps si tu n'as pas une option activable pour le clavier USB. En principe. Grub utilise ce que le BIOS autorise.

Mais une chose m'étonne. GRUB est supposé lancer ta Linux Mint automatiquement au bout de 5 secondes. Est-ce le cas ? Si oui, il sera possible de faire le point depuis Linux Mint.

daniel74
 Posté le 02/09/2017 à 15:25 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Merci pour ta réponse,

J'ai bien accès à GRUB et Linux démarre correctement.

mon souci est que je ne peux pas changer la ligne active dans cet écran GRUB

Ikewdu_
 Posté le 02/09/2017 à 18:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bien.

Lance un terminal, et donne le résultat de la commande

sudo efibootmgr -v

daniel74
 Posté le 02/09/2017 à 19:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

daniel@daniel-desktop ~ $ sudo efibootmgr -v
[sudo] password for daniel:
efibootmgr: EFI variables are not supported on this system.
daniel@daniel-desktop ~ $

Xerta
 Posté le 02/09/2017 à 19:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Est-ce que avez installez Linux Mint en mode Legacy alors que Windows 10 a lui été installé en UEFI ? Si c’est le cas ça pourrait être une cause du problème :

https://forums.linuxmint.com/viewtopic.php?t=240897

voyez aussi la recherche Google.



Modifié par Xerta le 02/09/2017 19:27
daniel74
 Posté le 02/09/2017 à 20:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Xerta a écrit :

Est-ce que avez installez Linux Mint en mode Legacy alors que Windows 10 a lui été installé en UEFI ? Si c’est le cas ça pourrait être une cause du problème :

https://forums.linuxmint.com/viewtopic.php?t=240897

voyez aussi la recherche Google.

Ma carte-mère date de 2012, elle tourne sous DOS et pas UEFI...

Ikewdu_
 Posté le 02/09/2017 à 23:46 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien
daniel74 a écrit :

daniel@daniel-desktop ~ $ sudo efibootmgr -v
[sudo] password for daniel:
efibootmgr: EFI variables are not supported on this system.
daniel@daniel-desktop ~ $

Ton PC est au format Legacy. Il faut donc réparer le mbr de manière traditionnelle.

1. Solution 1.

https://doc.ubuntu-fr.org/desinstallation#deuxieme_cas_-_suppression_d_un_multi-amorcage

Ca restaure le mbr de Windows (Boot-Repair sait le faire aussi, de même que ms-sys)

2. Solution 2.

Autre solution. Si tu veux garder ton Linux le temps de trouver une solution, et simplement inverser l'ordre de démarrage.

cd /etc/grub.d
sudo mv 30_os-prober 08_os-prober
sudo update-grub

Grub sera toujours là, mais Windows se lancera en priorité.

3. Solution 3.

Tu démarres le PC sur un DVD d'installation ou de réparation de Windows et, en invite de commandes, tu envoies :

bootrec /fixmbr
bootrec /fixboot



Modifié par Ikewdu_ le 02/09/2017 23:51
daniel74
 Posté le 03/09/2017 à 10:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Ikewdu_ a écrit :
daniel74 a écrit :

daniel@daniel-desktop ~ $ sudo efibootmgr -v
[sudo] password for daniel:
efibootmgr: EFI variables are not supported on this system.
daniel@daniel-desktop ~ $

Ton PC est au format Legacy. Il faut donc réparer le mbr de manière traditionnelle.

1. Solution 1.

https://doc.ubuntu-fr.org/desinstallation#deuxieme_cas_-_suppression_d_un_multi-amorcage

Ca restaure le mbr de Windows (Boot-Repair sait le faire aussi, de même que ms-sys)

2. Solution 2.

Autre solution. Si tu veux garder ton Linux le temps de trouver une solution, et simplement inverser l'ordre de démarrage.

cd /etc/grub.d
sudo mv 30_os-prober 08_os-prober
sudo update-grub

Grub sera toujours là, mais Windows se lancera en priorité.

3. Solution 3.

Tu démarres le PC sur un DVD d'installation ou de réparation de Windows et, en invite de commandes, tu envoies :

bootrec /fixmbr
bootrec /fixboot

J'ai pris ta deuxième solution, je lance bien W10 au démarrage mais je ne peux toujours pas me déplacer dans GRUB

On verra plus tard

Merci pour ton aide et bon dimanche

Daniel

Publicité
Ikewdu_
 Posté le 03/09/2017 à 10:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Ton problème de clavier doit se régler par l'essai d'autres claviers, d'autres ports USB. Mais surtout par la recherche dans le BIOS d'une option désactivée.

https://doc.ubuntu-fr.org/clavier_usb_grub

Ah ! Ne supprime pas tes partitions Linux, car, dans cette situation, ton Windows ne démarrerait plus. Bye.

Edit. Et profites-en pour fabriquer une clé de réparation. La solution 3 risque de servir un jour.



Modifié par Ikewdu_ le 03/09/2017 11:08
daniel74
 Posté le 03/09/2017 à 11:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

J'ai activé USB Legacy dans le BIOS, le problème est réglé

Encore merci pour ton aide

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Aucun sujet pertinent lié trouvé
 > Tous les forums > Forum Windows 10