> Tous les forums > Forum Windows 7
 ActiveX impossible à charger sous Win7 et IE11Sujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
RJN
  Posté le 30/10/2014 @ 22:37 
Aller en bas de la page 
Petit astucien

Bonjour,

1) j'ai un DVR de vidéosurveillance ( DVR4L5 Velleman ) qui intègre un ActiveX nommé AVTECH AMCCtrl Class. ) Comme cet ActiveX est implanté sur mon portable depuis 2010, en regardant ses propriétés, je sais que le fichier se nomme AVC_AX_742_VIEWER.dll. A l'époque, il s'était implanté simplement, sous Vista, et avec IE8. Lors de la 1ere utilisation de mon DVR, en tapant dans IE8 son adresse IP ( http://192.168.1.10 ) il m'avait été proposé d'exécuter ce module complémentaire !!!!!!!!!!!!!!!

2) aujourd'hui, changement de PC, passage à Windows 7 et IE11. Je n'arrive plus à recréer cette situation, impossible de charger cet ActiveX ( pas de barre jaune demandant si je veux l'implanter ). J'ai bien essayé d'effectuer ce qui est décrit par ex sur LOZA’S BLOG "Avtech Dvr Web View Unverified Active X Content" en autorisant le téléchargement des ActiveX non signées, en vidant les historiques d'IE11, etc..... mais rien n'y fait !

ci après procédure décrite sur loza's blog :

http://lozaelec.blogspot.fr/2011/01/avtech-dvr-web-view-unverified-active-x.html

auriez vous une idée qui me permettrait de recharger cet ActiveX dans IE11 ?

( nota : je n'ai rien trouvé non plus du coté de chez Avtech et je n'ai pas trouvé non plus d'astuce qui me permettrait de récupérer l'ActiveX de mon ancien PC pour l'exporter sur le nouveau ! )

D'avance merci à tous ceux qui pourraient m'aider

Publicité
Anonyme
 Posté le 31/10/2014 à 07:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

RJN

Dans ton vieux XP,si tu as toujours accès, regarde si elle y est toujours: C:\Windows\System32 et copie sur une clé usb.

Voici la procédure que j'ai trouvé (traduite avec google):

sauvegarder d'abord ton system, faire un backup (Acronis ou Aomei) ou un point de restauration.

Copiez AVC_AX_742_VIEWER.dll dans le répertoire d'installation du programme qui nécessite.
Si cela ne fonctionne pas, vous devrez copier et coller AVC_AX_742_VIEWER.dll à votre répertoire système. Par défaut, ce sont:
C: \ Windows \ System (Windows 95/98 / Me)
C: \ WINNT \ System32 (Windows NT / 2000)
C: \ Windows \ System32 (Windows XP, Vista, 7,8)
Si vous utilisez une version 64-bit de Windows, vous devrez aussi placer AVC_AX_742_VIEWER.dll dans C: \ Windows \ SysWOW64 \ Assurez-vous d'écraser tout fichier existant (mais faites une copie de sauvegarde du fichier original).
Redémarrez votre ordinateur.

Si le problème persiste, essayez ce qui suit:
1. Ouvrez le menu Démarrer de Windows et sélectionnez "Exécuter ...".
2. Tapez cmd et appuyez sur Entrée (ou si vous utilisez Windows ME, tapez COMMAND)).
3. Tapez regsvr32 AVC_AX_742_VIEWER.dll et appuyez sur Entrée



Modifié par Anonyme le 31/10/2014 07:18
pcastuces
 Posté le 31/10/2014 à 09:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Equipe PC Astuces
Bonjour,

Le sujet a été déplacé par la modération dans le forum Windows 7 qui semble plus adéquat.

Vous pouvez continuer la discussion à la suite de ce message.

A bientôt.
loupenequet
 Posté le 01/11/2014 à 01:00 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour RJN

Regarde ici; http://www.microsoft.com/fr-fr/search/result.aspx?q=activex%20download

peut-être trouveras-tu ton bonheur.

astucieusement

RJN
 Posté le 03/11/2014 à 12:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

et merci à ceux qui ont participé !

Pour l'instant, j'ai réussi à charger l'activeX dans la base de registre ( je suis sous Windows 7 en version 32 bits )

"chargement du module effectué avec succès c:\windows\system32\AVC_AX_742_VIEWER.dll "

dans le registre, je le retrouve bien dans HKEY_CLASSES_ROOT\CLSID puis si je déroule la clef {971FC730-55F1-461F-83FD-B3BF5E1F039E} je trouve les modules "control", "inprocserveur32, "miscstatus", "progID", "programmable", "toolboxbitmap32", "typelib", "version", "VersionIndependantProgID"

=> mais cet activeX Avtech n'apparaît pas pour autant dans IE11 !!!!!!!!!

il n'y est pas si je vais dans "gérer les modules complémentaires->afficher->tous les modules complémentaires"

Auriez vous une astuce qui me permettrait d'aller plus loin ?

Anonyme
 Posté le 03/11/2014 à 21:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

RNJ

tu l'as bien coller dans le "repertoire d'instalation" ?

dans ordinateur--> C:\Programmes files\ DVR4L5 Velleman (je suppose que c'est ça le nom)

Tu est sur d'avoir un 32 bits?

RJN
 Posté le 03/11/2014 à 22:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir ReineClaude,

1) en fait, c'est beaucoup plus compliqué ( mais tout semble identique sur mon vieux PC équipé de Vista).

il n'y a pas de "répertoire d'installation"

Au niveau de la procédure d'utilisation : je lance Internet Explorer puis je rentre l'adresse de mon DVR : soit http://192.168.1.10.

là, le DVR me demande un identifiant puis un mot de passe + 1 Code Capcha à recopier.

après quoi, dans Internet Explorer, un logiciel s'affiche qui semble directement venir du DVR et me lance 4 fenêtres.

Ensuite, pour afficher mes 4 caméras en LIVE, j'ai 3 formats vidéo que je peux sélectionner :

sur mon vieux PC :

a) format "M-JPEG" mais java bloque car le certificat est révoqué ( le DVR date de 2007 )

b) format "QuickTime" fonctionnement plus qu' aléatoire ( ne marche que 1 fois sur 5 avec des lenteurs )

c) format "H.264" qui fonctionne parfaitement

sur mon nouveau PC :

a) idem

b) idem

c) comme l'ActiveX n'apparait pas dans IE et ne peut donc être activé, le format "H.264" n'existe pas ! il est remplacé par un format "VLC" qui lui n'affiche rien du tout !

2) Pour ma version de Win 7 : dans ordinateur, puis propriétés , j'ai Windows 7 Professional système d'exploitation 32 bits

j'ai bien essayé de regarder dans "program files" -> "internet explorer", mais je n'ai rien trouvé !

Anonyme
 Posté le 03/11/2014 à 23:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien
RJN a écrit :

Bonsoir ReineClaude,

j'ai bien essayé de regarder dans "program files" -> "internet explorer", mais je n'ai rien trouvé !

RNJ

fait une sauvegarde ou un point de restauration,au cas ou.

Ferme toutes tes fenêtres,navigateurs logs etc.

Va sur Program files-->internet explorer--> ouvre le dossier et colle ton active x.

Ferme tout et redémarre l'ordi.

Qu'est-ce que tu as comme AV?

RJN
 Posté le 03/11/2014 à 23:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

ReineClaude,

le problème est coriace ! Avec le fichier de base de l'ActiveX -> AVC_AX_742_VIEWER.dll, il y avait des fichiers "dépendants". C'est donc un total de 18 fichiers que j'ai recopiés dans le dossier "program files/Internet Explorer".

=> Mais pas de chance, ça ne marche toujours pas !

je peux peut-être essayer de désinstaller VLC pour voir en relançant IE et le DVR par http://192.168.1.10 ce qu'il va me proposer à nouveau pour les 3 formats !

j'aurai toujours certainement

1) M-JPEG

2) Quicktime

3) mais à la place de VLC ?........... bein je verrai bien !

il me semble que j'avais déjà essayé cette manip il y a quelques jours, mais je ne me souviens plus du résultat ! Et depuis, l'activeX a été inscrite dans le registre !

Publicité
Anonyme
 Posté le 04/11/2014 à 00:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

RNJ

pourtant VLC gère les H.264, si mes souvenirs sont bons, et ils sont bons:

Joue tous les médias : Fichiers, Disques, Webcams, Périphériques et Flux réseaux.

Supporte tous les codecs sans codec pack :
MPEG-2, DivX, H.264, MKV, WebM, WMV, MP3...

Fonctionne sur toutes les plateformes : Windows, Linux, Mac OS X, Unix...

As-tu essayez avec un autre navigateur, comme firefox, opera,safari etc

dans les mises a jour de Windows, il n'y aurait pas une maj qui est proposé pour ce "Active X" ou un firmware quelconque en rapport avec ton DVR?

Peut-être voir dans les réglages de VLC aussi

C'est une solution de désinstaller,mais comme il faut, le VLC, mais redémarrer l'ordi après désinstallation.

Peut-être qu'il n'est pas compatible avec W7?

mais pourtant dans l'astuce que j'avais mis,ils parlaient bien que l'active X allait pour W7.

RJN
 Posté le 04/11/2014 à 00:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

j'ai désinstallé VLC, arrêté puis relancé le PC. Ensuite j'ai relancé IE11 et le DVR (http://192.168......etc ) Pas de chance, j'ai toujours les 3 mêmes options de format, mais le dernier me demande de recharger le plugin VLC ......... pour Mozzila !!!!!!

Donc, quelque part, il y a vraisemblablement un problème d'incompatibilité avec IE11 . Dans les années 2007/2008, quand j'ai fait l'installation du DVR sur mon vieux PC, j'étais sous Vista avec IE8 ( voire même peut-être IE6 !! )

Du coup, je viens de remettre VLC (j'ai vu lors de la réinstallation qu'il y a 1 case spécifique à cocher pour charger ce plugin Mozzila !!)

Donc, effectivement, je vais essayer un autre explorateur. Je vais tout remettre en ordre demain dans la journée ( retraits du registre, suppression des fichiersque j'avais rajouté dans le dossier IE....etc, etc !),....... puis télécharger la dernière version de Firefox !

Avec un peu de chance, peut-être qu'avec le plugin VLC pour firefox ça va marcher en H.264 !!

Je te ferai part de l'avancement

Merci encore !

syq33
 Posté le 04/11/2014 à 01:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir,

j'ai eu un problème identique avec une caméra ip Foscam , résolu comme suit:

Pour fonctionner avec IE 11:

- Si le contrôle ActiveX (chez moi, le fichier DVM_IPCam2.ocx) ne veut pas s'installer, aller dans IE et Options -> Avancé -> Sécurité et cocher "Autoriser le logiciel à s'exécuter ou à s'installer même si la signature n'est pas valide".

Une autre solution qui n'avait pas fonctionné chez moi mais chez d'autres :

Si le contrôle ActiveX ne veut toujours pas s'installer, voici la procédure manuelle :
- Copier le fichier DVM_IPCam2.ocx à la racine (c:\)
- Lancer l'invité de commande et taper
regsvr32 C:\DVM_IPCam2.ocx
- Relancer l'ordinateur.

(Pour toi, remplacer DVM_IPCam2.ocx par AVTECH AMCCtrl Class.)

RJN
 Posté le 04/11/2014 à 18:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

1) j'ai aussi essayé avec la méthode de syq33, mais le problème reste le même : le contrôle AVTECH s'inscrit correctement dans le registre mais n'apparaît toujours pas dans IE11 !!!

2) du coup, cette fois, j'ai tout remis en ordre et téléchargé Firefox ! Avec son plugin spécifique à ce navigateur cette fois , tout fonctionne correctement !!

merci à tous les participants

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
packard bell esy note fonctionnant sous win7 n'arrive plus a démarrer
Maj Win7 impossible
demarrage impossible WIN7
impossible d'ouvrir mes documents enregistrés sous Word ou Excel
Epson Status Monitor 3 --> Invalid Parameter sous WIN7
skype impossible a telecharger sous windows 7
impossible de lancer IE11
impossible d'installer Win7 BootUpdater.exe
IE11 sous W7 pro
Imprimante Brother et OCR sous win7
Plus de sujets relatifs à ActiveX impossible à charger sous Win7 et IE11
 > Tous les forums > Forum Windows 7