× Aidez la recherche contre le COVID-19 avec votre ordi ! Rejoignez l'équipe PC Astuces Folding@home
 > Tous les forums > Forum des Webmasters
 Affichage sur smartphone
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
mac_marco
  Posté le 16/02/2019 @ 19:01 
Aller en bas de la page 
Petit astucien

Bonjour.

Je suis en train de faire un site web pour l'association de mon fils. J'ai téléchargé un template pour une vidéo en pleine page sur l'accueil, mais, je ne comprend pas pourquoi

elle ne s'affiche pas sur mon iPhone ??

Quelqu'un aurait une idée du pourquoi ?

Voilà la page : http://test.webandyou.ch/skillzoo/index.html

Par avance merci.

Publicité
Malcolm
 Posté le 17/02/2019 à 15:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut,

Elle semble faire 82 Mo, donc sur une connexion 3G, il faudra un peu de temps pour qu'elle s'affiche ... (en gros ça dépend aussi de la vitesse de connexion). peux-tu dire quel smartphone est concerné ?

mac_marco
 Posté le 17/02/2019 à 15:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour Malcolm. Et merci de t'y intéresser.

En effet, elle fait 82Mo en .mp4 et 35Mo en .webm.

J'ai une connexion haut débit en Wi-Fi à la maison et je teste sur un iPhone 7Plus.

Mais aucun signe que la vidéo est en train de se charger ! Je pensais plus à des propriétés CSS ou JS mais je vois pas où !?

Malcolm
 Posté le 17/02/2019 à 19:06 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

je confirme ... http://www.responsinator.com/?url=test.webandyou.ch%2Fskillzoo%2Findex.html

plusieurs hypothèses :

- est-ce que la vidéo (qui est en position relative) n'est pas "mal placée" càd que vu la résolution de l'iphone on ne voir que le coin supérieur gauche qui reste noir tout le temps (auquel cas la vidéo s'afficherait bien, mais hors écran)

- est-ce que tu as accès aux logs du serveur apache pour voir si la vidéo est bien chargée par l'iphone ?

- sur quel navigateur testes-tu ? Par défaut je ne prends que safari et sur mon iphone 6s+ la vidéo ne semble pas être lue (le fond d'écran reste noir) que ce soit en portrait ou en paysage - ce qui ne veut pas dire qu'elle n'est pas lue, cf. plus haut.

peux-tu essayer ces quelques manips : https://stackoverflow.com/questions/20347352/html5-video-tag-not-working-in-safari-iphone-and-ipad

Scapo
 Posté le 17/02/2019 à 21:24 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Slt,

pour info,

sur Android Mate10 pro/4G , pas plus de vidéo qui apparait,
en wifi , pas mieux.
Fond d'écran reste noir en mode paysage comme en mode portrait.
Navigateur Chrome/Firefox.

--->Par contre sur chrome comme FF ,en faisant : menu 3Points -->" Voir version ordinateur" --> bingo la vidéo passe

avec ce visu



Modifié par Scapo le 17/02/2019 21:51
mac_marco
 Posté le 18/02/2019 à 06:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Malcolm: sur ton premier lien la vidéo s'affiche partout.

- est-ce que tu as accès aux logs du serveur apache pour voir si la vidéo est bien chargée par l'iphone ? Je ne sais pas, comment le savoir?

- sur quel navigateur testes-tu ? Par défaut je ne prends que safari et sur mon iphone 6s+ la vidéo ne semble pas être lue (le fond d'écran reste noir) que ce soit en portrait ou en paysage - ce qui ne veut pas dire qu'elle n'est pas lue, cf. plus haut. Je teste avec Safari, Google Chrome, Firefox et Opera sur mon iMac et sur mon iPhone (7s Plus) seulement avec Safari.

peux-tu essayer ces quelques manips : https://stackoverflow.com/questions/20347352/html5-video-tag-not-working-in-safari-iphone-and-ipad. Je vais regarder ça ce soir.

Scapo:

--->Par contre sur chrome comme FF ,en faisant : menu 3Points -->" Voir version ordinateur" --> bingo la vidéo passe

avec ce visu. Mais toujours sur smartphone ?

Merci à vous



Modifié par mac_marco le 18/02/2019 06:12
Scapo
 Posté le 18/02/2019 à 08:25 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Re,

oui , toujours sur le même smartphone,
autrement dit, accès au site avec le smartphone que ce soit avec Chrome ou FF
Rien, pas de vidéo ( le fond reste noir)
mais si dans l'un ou l'autre des 2 navigateurs du smarphone je fais
menu 3Points -->" Voir version ordinateur"
la vidéo devient visible.

mac_marco
 Posté le 18/02/2019 à 18:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Et quelqu'un aurait une explication, parce que moi je sèche !!!

zoulouman
 Posté le 18/02/2019 à 19:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Sur les petits écrans, ça passe, pas de souci. Il faut juste être très patient, le chargement peut durer très longtemps !

La vidéo est bien trop lourde pour un usage sur mobile où beaucoup ont des forfaits au quota.
De plus, il n'existe aucune politique de cache efficace, ce qui signifie que la vidéo est rechargée à chaque fois qu'on passe sur la page/actualise !

C'est le genre de page que Google risque de pénaliser et qui ne sortira pas dans une recherche...

Alors oui, c'est très sympa, ça fait joli.
Mais un fond d'écran vidéo en 1280x720, c'est du suicide ou de la folie (voir les deux) !

Publicité
Scapo
 Posté le 18/02/2019 à 20:13 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien
mac_marco a écrit :

Et quelqu'un aurait une explication, parce que moi je sèche !!!

Ben je n’en sais rien mais c’est marrant si on peut dire ,

ca passe de fond noir à la vidéo qui passe sans l'ombre d’un problème de freeze ou de chargement ...juste en validant « voir version ordinateur » Ou la elle charge instantanément.



Modifié par Scapo le 18/02/2019 20:16
mac_marco
 Posté le 19/02/2019 à 06:18 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

zoulouman a écrit :

Sur les petits écrans, ça passe, pas de souci. Il faut juste être très patient, le chargement peut durer très longtemps !

La vidéo est bien trop lourde pour un usage sur mobile où beaucoup ont des forfaits au quota.
De plus, il n'existe aucune politique de cache efficace, ce qui signifie que la vidéo est rechargée à chaque fois qu'on passe sur la page/actualise !

C'est le genre de page que Google risque de pénaliser et qui ne sortira pas dans une recherche...

Alors oui, c'est très sympa, ça fait joli.
Mais un fond d'écran vidéo en 1280x720, c'est du suicide ou de la folie (voir les deux) !

Bonjour Zoulouman.

Et si je réduit la définition de la vidéo ?

Ce que je ne comprend pas, c'est que comme dit Scapo, si on affiche la version pour ordinateur, la vidéo est lue sans problème et se charge instantanément !?!

Quand tu dis que sur les petits écrans "ça passe", tu parles de téléphone portable ?

sidoche
 Posté le 19/02/2019 à 14:38 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Alors juste une remarque. il me semble que dernièrement Safari bloque les vidéos en autoplay. Je ne sais pas à quel point cette mise à jour est diffusée et impacte ce type de vidéo en background. Mais si c'est le cas ça pourrait venir de là. Essaie juste de remettre les controles de la vidéo en affichage pour voir si ça peut provenir de là (voir si la vidéo est bien chargé mais qu'il faut encore faire play). Pour ce faire il te suffit d'ajouter l'attribut "controls" dans la balise vidéo.

Tiens nous au courant de tes découvertes :)

mac_marco
 Posté le 20/02/2019 à 06:06 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Alors voilà : j'ai réduis la taille de la vidéo, elle ne fait plus que 4,6Mo en .mp4 et 11,7Mo en .webm. Mais toujours pas d'affichage !!!

Essaie juste de remettre les controles de la vidéo en affichage pour voir si ça peut provenir de là (voir si la vidéo est bien chargé mais qu'il faut encore faire play). Pour ce faire il te suffit d'ajouter l'attribut "controls" dans la balise vidéo.

Bonjour sidoche. Il n'y a pas de balise vidéo dans le code html, tout est dans un fichier JS et je ne vois pas ou rajouter les contrôles.

Est-ce que quelqu'un pourrait tester sur smartphone avec un autre navigateur que Safari et me donner un retour ? Merci.

J'ai tester sur ordinateur avec Firefox en simulant un iPhone 7 et tout fonctionne ! alors je comprend pas pourquoi la vidéo ne passe pas sur mon iPhone ?

Merci .

Scapo
 Posté le 20/02/2019 à 07:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Re,

test fait (chrome et firefox) sur le même mate10 Pro

et rien de mieux.
toujours le même fond noir
et toujours la vidéo qui se lance en demandant " voir la version ordinateur"
Le poids de la vidéo n'est donc pas le facteur qui bloque.

sidoche
 Posté le 20/02/2019 à 08:54 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Alors si je lit bien le code source de ton fichier Javascript il interdit le chargement de la vidéo sur iOS et Android http://test.webandyou.ch/skillzoo/web/js/jquery.vide.min.js

Si tu supprimes les lignes 173 et 219 ça devrait fonctionner sur mobile aussi.

mac_marco
 Posté le 20/02/2019 à 19:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

sidoche a écrit :

Alors si je lit bien le code source de ton fichier Javascript il interdit le chargement de la vidéo sur iOS et Android http://test.webandyou.ch/skillzoo/web/js/jquery.vide.min.js

Si tu supprimes les lignes 173 et 219 ça devrait fonctionner sur mobile aussi.

Hello.

173 ET 219 ou 173 A 219 ???

zoulouman
 Posté le 20/02/2019 à 22:28 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

173 ET 219.
Si tu supprimes le bloc complet, tu n'auras plus aucune vidéo, sur mobile comme sur PC.

Publicité
mac_marco
 Posté le 21/02/2019 à 06:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

zoulouman a écrit :

173 ET 219.
Si tu supprimes le bloc complet, tu n'auras plus aucune vidéo, sur mobile comme sur PC.

Je vais donc supprimer ça:

if (!iOS && !android) {

et ça:

}

J'essaie ce soir et vous tiens au courant, merci.

sidoche
 Posté le 21/02/2019 à 07:37 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

mac_marco
 Posté le 21/02/2019 à 18:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bin non !

Toujours pas de vidéo sur smartphone malgré l'effacement des deux lignes désignées !

Je crois que je vais laisser tomber... Tant pis pour la vidéo.

Mais ça m'énerve profondément !

Scapo
 Posté le 21/02/2019 à 18:56 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien
mac_marco a écrit :

Bin non !

Toujours pas de vidéo sur smartphone malgré l'effacement des deux lignes désignées !

Je crois que je vais laisser tomber... Tant pis pour la vidéo.

Mais ça m'énerve profondément !

re,

si si👍 , la vidéo est bien là pour ce qui concerne Android,
plus besoin de faire appel à " voir la version ordinateur".



Modifié par Scapo le 21/02/2019 18:57
mac_marco
 Posté le 21/02/2019 à 19:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Scapo a écrit :
mac_marco a écrit :

Bin non !

Toujours pas de vidéo sur smartphone malgré l'effacement des deux lignes désignées !

Je crois que je vais laisser tomber... Tant pis pour la vidéo.

Mais ça m'énerve profondément !

re,

si si👍 , la vidéo est bien là pour ce qui concerne Android,
plus besoin de faire appel à " voir la version ordinateur".

Moi je la vois pas ! iPhone 7 !

Quelqu'un a une idée ?

Bon appétit, vais manger

mac_marco
 Posté le 25/02/2019 à 06:14 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour.

Bon, pas de résultat concluant. Je verrais avec un autre template. Merci de votre aide.

Bonne journée.

Publicité
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
84,99 €Disque dur externe portable Seagate Expansion 4 To USB 3.0 à 84,99 €
Valable jusqu'au 11 Août

Amazon fait une promotion sur le disque dur externe portable Seagate Expansion d'une capacité de 4 To à 84,99 € livré gratuitement alors qu'on le trouve ailleurs à partir de 120 €. Ce disque dur externe portable au format 2,5 pouces dispose d'une interface USB 3.0 compatible USB 2.0. Une excellente affaire pour ce disque dur qui offre des débits de 115 Mo/s. Il n'est pas soudé et est donc démontable si vous souhaitez le réutiliser ailleurs (console, NAS, PC).


> Voir l'offre
19,71 €Prise connectée Wi-Fi TP-Link HS100 à 19,71 €
Valable jusqu'au 11 Août

Amazon fait une promotion sur la prise intelligente Wi-Fi TP-Link HS100 qui passe à 19,71 € alors qu'on la trouve habituellement autour de 35 €. Cette prise peut être contrôlée à distance en utilisant l'app gratuite KASA sur votre smartphone (iOS ou Android). Vous pouvez créer des planifications horaires pour allumer ou éteindre automatiquement et quand vous le souhaitez, l'appareil qui y est branché. Pour en savoir plus, n'hésitez pas à lire notre dossier pratique Contrôler une prise électrique à distance.


> Voir l'offre
62,38 €Kit mémoire 16 Go DDR4 SO-DIMM HyperX (2x8 Go) à 62,38 € livré
Valable jusqu'au 10 Août

Amazon Allemagne propose actuellement le Kit mémoire 16 Go DDR4 SO-DIMM HyperX Impact à 57,83 €. Comptez 4,55 € pour la livraison en France soit un total de 62,38 € livré alors qu'on le trouve ailleurs à partir de 75 €. Un excellent prix pour ce kit mémoire dédié aux ordinateurs portables et composé de 2 modules de 8 Go DDR4 2666 MHz CL15. Notez que la version 32 Go (2x16 Go) est également en promotion à 114,10 € livrée.


> Voir l'offre

Sujets relatifs
Affichage bannières pub bloqueur sur mon site p3x
Problème avec les header affichage des caractères
Affichage apparence WMP
problème affichage tableau
Problème affichage images en cache
Affichage 4:3 sur toutes résolutions
Pas d'affichage de la zone de saisie avec IE11
affichage du jour en anglais
listage et affichage
affichage dans navigateur IE 8
Plus de sujets relatifs à Affichage sur smartphone
 > Tous les forums > Forum Forum des Webmasters