> Tous les forums > Forum Linux
 altération de l'heure de W7 après Linux enfin solutionnéSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Mimile
  Posté le 14/06/2015 @ 12:28 
Aller en bas de la page 
Astucien

Bonjour,

Sur mon PC, j'ai, en multiple boot : W7 SP1 - Debian 8.0 Jessie - Archlinux - Linux Mint 17.1

Quand, après avoir utilisé Debian ou Linux Lint, je repasse sur W7, systématiquement, il y a un décalage de deux heures affichées dans le coin inférieur droit (quand il est midi, l'horloge affiche 14 h 00).

Au bout de quelques minutes, la bonne heure s'affiche automatiquement, ce qui est logique au vu de ceci :

Mais il serait essentiel pour moi que la mise à jour de l'heure se fasse dès le démarrage et pas après plusieurs minutes pour diverses raisons, notamment si j'envoie un mail avant la mise à l'heure correcte, ce mail indiquera l'heure erronée, ce qui, dans mon métier peut avoir un impact négatif.

Il va de soi que la plupart du temps, j'opère manuellement la synchronisation avec l'un des serveurs de temps internet mais il m'arrive de l'oublier.

Donc, si quelqu'un pouvait me dire comment faire en sorte que la synchronisation se fasse automatiquement dès le démarrage de W7, je lui serais reconnaissant.

Pour le surplus et à titre indicatif, je précise que les trois distributions Linux indiquent toujours la bonne heure.

Exception à ce qui précède, quand je passe d'Archlinux à W7, l'horloge de W7 indique directement la bonne heure.

En résumé : Debian et Mint perturbent l'horloge de W7 et pas Archlinux.

J'ai le sentiment qu'à la fermeture de Debian et de Mint, l'horloge du BIOS est modifiée ...

Merci pour vos avis et renseignements éventuels.

Amicalement,

Mimile

EDIT : l'heure de mon BIOS affiche normalement l'heure GMT/UTC.

Quand j'utilise Debian ou Mint, l'heure affichée par le BIOS est l'heure locale (GMT + 2 heures en été).

De la sorte quand je passe sous W7, il lit l'heure du BIOS et lui ajoute les 2 heures d'été, ce qui explique le décalage.

Bizarrement, seul Archlinux n'interfère pas, sans doute grâce au service ntpd qui est activé au démarrage.



Modifié par Mimile le 18/06/2015 10:26
Publicité
hido
 Posté le 14/06/2015 à 14:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

bonjour

il faut créer une clé dans le registre pour que windows 7 soit en UTC : http://crashmag.net/configuring-windows-7-support-for-utc-bios-time

Mimile
 Posté le 15/06/2015 à 11:51 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Merci pour vois réponses ... mais :

@ sranda : j'ai téléchargé et installé TimeSync depuis le site pour lequel tu m'as fourni le lien.

Le nom du programme est devenu "SP TimeSync.exe" ; je viens de faire un test : d'abord booter Debian (qui transforme donc l'heure GMT du BIOS en heure locale) puis je suis repassé sous W7 et j'ai exécuté manuellement la commande SP TimeSync.exe, ce qui donne ceci :

Comme on le voit, c'est toujours l'heure locale qui apparaît. Pour avoir l'heure UTC/GMT, il faut cliquer sur "Récupérer l'heure NTP", ce qui donne ceci :

Malheureusement, ça n'a pas d'impact direct sur l'affichage de l'heure fournie par W7 qui reste obstinément sur l'heure décalée ; il faut ensuite cliquer sur "ajuster" pour que la bonne heure s'affiche enfin.

Pour utiliser TimeSync efficacement, il faudrait créer un raccourci à ajouter aux programmes lancés au démarrage dont la commande intègrerait les options "silent", "récupérer heure ntp" et "ajuster" mais l'aide fournie est plutôt succincte et ne donne pas d'indication à ce sujet.

De plus, lors du lancement de la commande, le contrôle du compte utilisateur demande s'il faut exécuter ou non la commande (éditeur inconnu) mais ça, ça doit pourvoir se régler.

Quoi qu'il en soit, et tant qu'à faire, autant utiliser la mise à jour manuelle qu'on peut faire directement en cliquant sur l'horloge de W7 (voir la capture d'écran de mon poste).

Merci quand même.

@ Hido : la clef du registre était déjà configurée comme indiqué dans le tuto anglais auquel ton lien renvoie.

Merci à toi aussi.

Amicalement



Modifié par Mimile le 15/06/2015 11:52
Logicien
 Posté le 16/06/2015 à 00:13 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

ce matin, j'ai fait une recherche liée au sujet de Mimile. J'ai découvert beaucoup de choses. Tout d'abord, le noyau Linux des distributions est configuré pour régler de lui-même l'horloge système à partir de l'horloge matérielle au démarrage. Qui plus est, il est configuré pour écrire l'horloge matérielle à partir de l'horloge système à toutes les 11 minutes s'il décèle que cette dernière a été mise-à-jour via le protocole NTP !! Éléments de configuration

CONFIG_RTC_HCTOSYS=y
CONFIG_RTC_SYSTOHC=y

Je n'ai pas trouvé comment Linux détecte s'il doit lire et écrire l'horloge matérielle en UTC ou en LOCAL.

Donc en principe, aucun script de démarrage et d'arrêt n'est nécessaire pour régler l'horloge système au démarrage et écrire l'horloge matérielle à l'arrêt. Je me suis aussi posé la question "Est-il possible de connaître l'état de la pile de la carte-mère qui alimente l'horloge de la mémoire CMOS?" J'ai découvert qu'en faisant

cat /proc/driver/rtc

rtc_time : 21:45:20
rtc_date : 2015-06-15
alrm_time : 00:01:58
alrm_date : 2015-06-14
alarm_IRQ : no
alrm_pending : no
update IRQ enabled : no
periodic IRQ enabled : no
periodic IRQ frequency : 1024
max user IRQ frequency : 64
24hr : yes
periodic_IRQ : no
update_IRQ : no
HPET_emulated : yes
BCD : yes
DST_enable : no
periodic_freq : 1024
batt_status : okay


on peut avoir cette information et pleins d'autres. Jusqu'à présent, je me chargeais de mettre à jours manuellement les horloges système et matérielle de la façon suivante:

ntpdate -b pool.ntp.org

hwclock -uw

Pour que l'heure obtenue corresponde votre zone de temps (timezone) il faut qu'elle soit correctement configurée. Sous Debian et dérivées on peut faire

sudo dpkg-reconfigure tzdata

Sous la Arch avec Systemd (et peut-être Jessie aussi), il faut utiliser timedatectl.

Le paramètre -u d'hwclock permet d'écrire l'horloge matérielle en UTC. Pour s'assurer que le système reconnait l'heure matérielle comme étant en UTC, il faut éditer le fichier /etc/default/rcS sous Debian pour que la variable UTC=yes. Sous Systemd (Arch, Jessie?) on utilise timedatectl.Il faut aussi que la dernière ligne du fichier /etc/adjtime contienne la ligne UTC et non LOCAL.

Il est certain qu'un client NTP est nécessaire pour garder l'horloge système et au final l'horloge matérielle à jours. Sous Systemd on peut activer un client NTP à l'aide de timedatectl. Il n'est pas nécessaire d'utiliser un démon à part. Depuis Jessie qui utilise Systemd, je ne sais plus très bien si c'est grâce à timedatectl ou par la méthode traditionnelle qu'on configure l'UTC et NTP.

Voici un lien en anglais pour plus d'explications:

Time - ArchWiki - Arch Linux



Modifié par Logicien le 16/06/2015 00:42
Mimile
 Posté le 16/06/2015 à 11:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut Paul,

J'espère que tu vas bien.

Ce qui m'étonne, c'est que Debian et Mint affichent l'heure locale (alors que, vérification faite au démarrage du BIOS, c'est bien l'heure UTC qui est indiquée).

Donc, Debian et Mint lisent l'heure du BIOS et en fonction de ma zone (Europe / Bruxelles), ils affichent UTC +1 en hiver et UTC + 2 en été) ce qui explique que c'est bien l'heure locale qui apparaît lors de l'ouverture de la session.

Le problème est qu'à la fermeture de la session, ils modifient l'heure du BIOS pour y indiquer l'heure locale.

Quand, dans la foulée, je repasse sous W7 (en mettant fin aux sessions Debian ou Mint -> redémarrer (donc à chaud)), W7 lit l'heure du BIOS et agit comme Debian et Mint en ajoutant une ou deux heures selon la saison, de sorte que l'heure affichée est avancée d'une ou deux heures.

En revanche, après avoir arrêté le PC complètement en clôturant Debian ou Mint, quand je rallume le PC, le BIOS affiche l'heure UTC et W7 affiche alors la bonne heure (locale).

Exception à la règle : Archlinux : si je passe d'Arch à W7, ce dernier affiche l'heure locale correcte.

J'en déduis qu'Arch ne modifie pas l'heure du BIOS.

Je pense que cela est dû au service ntpd configuré comme ceci dans /etc/ntp.conf :

server 0.fr.pool.ntp.org iburst
server 1.fr.pool.ntp.org iburst
server 2.fr.pool.ntp.org iburst
server 3.fr.pool.ntp.org iburst

Selon le wiki : "L'option iburst permet de se synchroniser avec les serveurs de temps dès que la connexion au réseau se met en place"

J'en déduis qu'Arch se contrefiche de l'heure du BIOS et ne la modifie pas, contrairement à Debian et Mint.

Pour le surplus, j'avais déjà testé sous debian : sudo dpkg-reconfigure tzdata sans résultat, pas plus que d'avoir passé à "yes" l'option UTC dans /etc/default/rcS.

Pour l'instant, je suis sous W7.

Je vais voir ce qu'il en est de ma pile (2 ans c'est peu mais sait-on jamais ?) et voir s'il n'y aurait pas pas un /etc/ntp.conf dans debian que je pourrais éventuellement configurer comme sous Arch.

Je reviens de suite...

EDIT : me revoici sous Debian :

Pour ce qui concerne la pile :

okapi@Jessie:~$ cat /proc/driver/rtc
rtc_time : 11:55:45
rtc_date : 2015-06-16
alrm_time : 12:51:43
alrm_date : 2015-06-16
alarm_IRQ : no
alrm_pending : no
update IRQ enabled : no
periodic IRQ enabled : no
periodic IRQ frequency : 1024
max user IRQ frequency : 64
24hr : yes
periodic_IRQ : no
update_IRQ : no
HPET_emulated : yes
BCD : yes
DST_enable : no
periodic_freq : 1024
batt_status : okay
okapi@Jessie:~$

En ce qui concerne /etc/ntp.conf : pas trace de ça dans debian ...



Modifié par Mimile le 16/06/2015 12:02
Mimile
 Posté le 16/06/2015 à 13:25 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

sranda a écrit :

, chez mois la commande indiqué (silent) et au démarrage depuis des années, sans problème ..

Sans doute, as-tu une ancienne version de TimeSync.exe qui s'appelle maintenant SE TimeSync.exe et qui se trouve dans un dossier TimeSync 2.4

Même si je modifie en conséquence ta ligne de commande, avec l'option "silent", il ne se passe visuellement rien et ça ne rétablit pas l'heure locale correcte...

reivillo
 Posté le 16/06/2015 à 15:38 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour @ Toutes & Tous.

@ Mimile.

Je viens de Tester en me mettant en Dual Boot avec Win7 Home SP1.

L'heure du BIOS étant réglé sur UTC, soit en ce moment Heure d'été moins 2 heures.

_ Je démarre Debian80, Heure Correcte sur le Bureau.
_ Bios, toujours UTC.
_ Lancement de Win7, Heure Incorrecte sur le Bureau( Heure UTC )
_ Bios, toujours UTC.
_ Je démarre linux Mint 17.1, Heure Correcte sur le Bureau.
_ Bios, toujours UTC.
_ Lancement de Win7, Heure Incorrecte sur le Bureau( Heure UTC )

Conclusion: Même résultat que toi!

Maintenant en Rajoutant/Modifiant la clé DWORD du Registre, comme sur la Capture ci-dessous:
Tous les Tests ci-dessus sont Correctes, avec le Bios toujours en UTC.

Reivillo.



Modifié par reivillo le 16/06/2015 15:44
Logicien
 Posté le 16/06/2015 à 21:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Avec Debian Jessie il faut utiliser timedatectl pour configurer l'heure en UTC, activer le client NTP et la bonne zone de temps. Systemd contrôle Debian avec Jessie. J'ai lu qu'un client DHCP peut aussi servir de client NTP. Donc l'heure Internet peut venir d'une connexion à Internet par DHCP tels les clients dhcpcd, dhclient, pump et autres.



Modifié par Logicien le 16/06/2015 21:36
Mimile
 Posté le 17/06/2015 à 10:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour :

@ Reivillo

Les choses ne se présentent pas exactement chez moi comme tu l'indiques :

  • Démarrage (à froid) du PC : l'heure du BIOS est UTC (soit heure d'été - 2 heures).
  • démarrage de Jessie : heure affichée correcte (UTC + 2), soit l'heure locale
  • sortie de Jessie par "redémarrage"
  • examen du BIOS avant que Grub démarre : heure du BIOS incorrecte (UTC + 2)
  • démarrage de W7 : affichage de l'heure incorrecte (heure du BIOS mofifié par Jessie, soit UTC + 2) = UTC +2 + 2 incorrecte
  • arrêt complet du PC puis redémarrage (à froid) : heure du BIOS correcte (UTC)

A noter que ça se passe de la même manière si je lance Linux Mint au lieu de Jessie.

Chose curieuse : si je passe de Jessie (qui a donc modifié l'heure du BIOS) à Linux Mint, ce dernier affiche l'heure locale correcte !

En ce qui concerne RealTimeIsUniversal, j'ai vérifié : il avait la bien la valeur dword = 1

Enfin, en ce qui concerne le réglage de l'heure sous W7, je te reproduis la capture faite dans mon poste de départ et qui correspond à ce que tu montres :

Je conclurais en disant ceci :

Si je passe de Jessie (qui a donc modifié l'horloge du BIOS : UTC + 2) à Arch, celle-ci affiche l'heure locale correcte.

Et si je passe de Arch à W7, l'heure affichée par W7 est correcte ...

Je pense que cela résulte peut-être du fait que Arch utilise ntpd.service et dhcpd.service ...

Qu'en penses-tu ?

@ Logicien : je vais essayer ce que tu suggères et je reviens dire ce que ce donnera (ça prendra évidemment quelques minutes ...

EDIT :

Me revoici avec une bonne nouvelle

En ce qui concerne Jessie, j'ai installé ntp et j'ai "activé" (enabled ?) puis démarré.

Ensuite, j'ai exécuté : timedatctl qui m'a indiqué le RTC time était égal à local time. Un message d'avertissement indiquait que cette similitude pouvait causer divers problème et que pour y parer, il fallait exécuter : timedatectl set-local-rtc 0

J'ai ré-exécuté timedatectl qui a alors indiqué que RTC Time était égal à Universal Time

J'ai quitté Jessie pour démarrer W7 et avant le grub, j'ai affiché mon BIOS et constaté que l'heure affichée était enfin redevenue UTC.

Il va de soi que W7 a alors affiché l'heure locale correcte.

Je vais essayé de faire de même avec Linux Mint. Je reviens dans quelques minutes pour dire le résultat.



Modifié par Mimile le 20/06/2015 11:51
Mimile
 Posté le 17/06/2015 à 12:12 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

EDIT 1 :

Désillusion avec Mint 17.1.

Apparemment, cette version n'utilise pas encore systemd mais timedatectl me dit que NTP est enabled.

J'ai consulté le man de timedatectl qui me confirme la mise en garde affichée sous Jessie, savoir qu'il est préférable que le RTC time soit égal à l'Universal Time et que pour cela, il faut exécuter la même commande que sous Jessie (timedatectl -set-local-rtc 0), ce que j'ai fait.

Voici ce que me renvoie alors timedatectl :

okapi@Linux17 ~ $ timedatectl
Local time: mer 2015-06-17 12:07:11 CEST
Universal time: mer 2015-06-17 10:07:11 UTC
Timezone: Europe/Brussels (CEST, +0200)
NTP enabled: yes
NTP synchronized: no
RTC in local TZ: no
DST active: yes
Last DST change: DST began at
dim 2015-03-29 01:59:59 CET
dim 2015-03-29 03:00:00 CEST
Next DST change: DST ends (the clock jumps one hour backwards) at
dim 2015-10-25 02:59:59 CEST
dim 2015-10-25 02:00:00 CET

Aucune différence avec ce qui apparaissait avant que j'exécute timedatectl -set-local-rtc 0

A la différence de Jessie, il n'y a pas de ligne "RTC time : mer 2015-06-17 10:07:11" comparable à la valeur de Universal Time

A tout hasard, j'ai rebooté et au vu du BIOS, j'ai bien dû constaté que l'heure affichée était le local time et pas le UTC...

Problème donc non résolu en ce qui concerne Mint.

Hélas ...

Mimile
 Posté le 17/06/2015 à 14:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Je reviens sur ce problème qui me rend de plus en plus perplexe.

Sous Linux Mint, j'ai donc exécuté en root : timedatectl -set-local-rtc 0 qui est sensé faire en sorte que RTC est équivalent à UTC et non à localtime.

Voici ce que ça donne ensuite :

On constate que RTC Time = Universal Time, ce qui en principe, à la fermeture de Mint, ne devrait pas modifier l'heure du BIOS.

Or, il n'en est rien : à la fermeture de Mint, ce n'est plus l'heure UTC qui apparaît dans le BIOS mais bien le localtime de Mint.

A toutes fins, j'ai aussi exécuté : sudo hwclock --utc qui renvoie :

okapi@Linux17 ~/Bureau $ sudo hwclock --utc
mer 17 jun 2015 14:25:00 CEST -0.625429 secondes

qui indique l'heure locale compte tenu de l'UTC.

Pourquoi diable, l'horloge du BIOS est-elle modifiée alors que la configuration est identique à cette de Jessie qui fonctionne correctement maintenant.



Modifié par Mimile le 20/06/2015 11:52
reivillo
 Posté le 17/06/2015 à 19:37 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

@ Mimile. ( Je te donne un ch'tit plus d'infos pour la route... )

Je viens de faire Scrupuleusement ce qui suit, et je n'ai pas de problème d'heure!

Les choses ne se présentent pas exactement chez moi comme tu l'indiques :

  • Démarrage (à froid) du PC : l'heure du BIOS est UTC (soit heure d'été - 2 heures).
  • démarrage de Jessie : heure affichée correcte (UTC + 2), soit l'heure locale
  • sortie de Jessie par "redémarrage"
  • examen du BIOS avant que Grub démarre : heure du BIOS incorrecte (UTC + 2)
  • démarrage de W7 : affichage de l'heure incorrecte (heure du BIOS mofifié par Jessie, soit UTC + 2) = UTC +2 + 2 incorrecte
  • arrêt complet du PC puis redémarrage (à froid) : heure du BIOS correcte (UTC)

Ci-dessous les 2 infos sur les OS testés. [ Linux Mint 17.1(Rebecca) sous MATE ] & [ Debian 8.0(Jessie) sous LXDE ].
( Nous ne sommes peut-être pas sous la même Configuration System... )







Modifié par reivillo le 17/06/2015 23:25
Logicien
 Posté le 18/06/2015 à 07:28 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Mimile,

avant d'utiliser les outils de Systemd comme localectl et timedatectl avec Linux Mint, assures-toi que Mint démarre avec Systemd. Je viens de lire que Mint offre Upstart et Systemd comme mode de démarrage. Si tu utilises Upstart, il serait bon de regarder dans /etc/default/rcS afin de voir si UTC=yes et l'ajouter au besoin.

Aussi /etc/adjtime doit avoir UTC comme ligne de contenu. Valable pour toutes les distributions.

Chez moi, quand NTP enabled: yes , Systemd synchronise l'horloge système avec un serveur NTP après un certain temps. J'obtiens alors NTP synchronized: yes . Avant de redémarrer depuis Mint assure-toi que Systemd a fait cette synchronisation. Sinon, ton problème peut venir du fait que tu utilises les outils de Systemd sans être démarré sur Systemd.

timedatectl status

Local time: jeu. 2015-06-18 01:23:40 EDT
Universal time: jeu. 2015-06-18 05:23:40 UTC
RTC time: jeu. 2015-06-18 05:23:40
Time zone: America/Montreal (EDT, -0400)
NTP enabled: yes
NTP synchronized: yes
RTC in local TZ: no
DST active: yes
Last DST change: DST began at
dim. 2015-03-08 01:59:59 EST
dim. 2015-03-08 03:00:00 EDT
Next DST change: DST ends (the clock jumps one hour backwards) at
dim. 2015-11-01 01:59:59 EDT
dim. 2015-11-01 01:00:00 EST



Modifié par Logicien le 18/06/2015 07:29
Mimile
 Posté le 18/06/2015 à 10:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Paul,

Je suppose que je démarre Mint avec systemd puisque la commande timedatectl fonctionne.

Malgré cela, NTP synchornized restait sur : no

J'ai un peu navigué avec Google et j'ai trouvé un site qui suggérait de vérifier les serveurs de temps avec la commande nptq.

Or, je ne disposais pas de cette commande et dans ce cas, le site suggérais d'installer ntp (ce que - me semble-t'il j'avais déjà fait en utilisant le système de gestionnaire de logiciels du menu administration) ; j'ai néanmoins recommencé en utilisant cette fois apt-get et dans la foulée et à l'arrivée, j'avais bien ntpq.

J'ai ouvert le fichier /etc/ntp.conf et j'ai ajouté à chaque serveur l'option "iburst" qui avait résolu le problème sous Arch.

Résultat, j'ai maintenant :

Pour ne rien négliger, j'ai modifié /etc/default/rsC en indiquant "yes" à UTC

Je vais redémarrer Mint et dire si, enfin, il n'aura pas modifier l'heure du BIOS

Je reviens dans quelques minutes ...

EDIT : Hourra !!! Mint ne modifie plus l'heure du BIOS qui reste donc en UTC.

De ce fait, quelle que soit la façon dont je passe d'un OS à un autre, c'est toujours la bonne heure (locale) qui s'affiche.

Problème résolu grâce à toi une fois de plus.

Mille mercis.

Amitiés,

Mimile

EDIT : cette dernière observation : au redémarrage de Mint, j'ai constate que NTP n'était pas synchronisé. J'ai exécuté : sudo ntpq et la synchronisation s'est effectuée aussitôt.

Solution : ajouter : sudo /usr/sbin/ntpd dans les programmes lancés au démarrage avec un délai de 5 secondes pour laisser le temps d'établir la connexion internet.

Redémarrage pour voir et effectivement, la synchronisation de NTP était immédiatement sur yes.

Résolu définitivement cette fois.

Ouf !



Modifié par Mimile le 20/06/2015 11:54
reivillo
 Posté le 18/06/2015 à 15:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

@ Logicien & Mimile.

Comme on peut le voir ci-dessous, Linux Mint 17.1 Mate ici est sous upstart,
et non sous systemd comme la Debian 8.0 Lxde.
( J'aurai du vérifier cela, avant de poster dans ce sujet... Sorry )



Modifié par reivillo le 18/06/2015 15:49
Logicien
 Posté le 18/06/2015 à 15:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Je suis content pour toi Mimile. Je veux dire que je n'ai aucun paquet NTP d'installé sous ma Debian nouvelle (installée elle-même grâce au paquet debbootstrap (AUR) depuis ArchLinux !). L'horloge système se synchronise avec un serveur de temps Internet après un certain temps, ce que confirme timedatectl dans mon précédent message.

C'est le service systemd-timesyncd.service qui s'en occupe. Il est enabled quand je fais

systemctl list-unit-files

Je pense que ce qui active ce service, c'est la commande

timedatectl set-ntp 1

Enfin, la redondance peut aussi être un signe de bon fonctionnement, pas seulement un signe de répétition inutile d'une même tâche. Ça pourrait être le sujet d'une discussion.



Modifié par Logicien le 18/06/2015 16:05
Mimile
 Posté le 18/06/2015 à 17:00 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Pour ma part, comme indiqué ci-dessus, j'ai opté pour la solution consistant à intégrer la commande /etc/sbin/ntpd dans la liste des programmes lancés automatiquement au démarrage.

La synchronisation est immédiate.

En ce qui concerne le fait d'avoir mis "yes" à CPU dans /etc/default/rsC est probablement superflu mais, comme on dit, abondance de biens ne nuit pas

L'important, c'est que, d'une manière ou d'une autre, mon problème soit résolu.

Amicalement à toi ainsi qu'à Reivillo qui s'est intéressé à ce poste.

P.S. je constate qu'à quelques reprises, dans mes messages précédents, j'ai parlé de ntpq ; il fallait évidemment lire : ntpd



Modifié par Mimile le 18/06/2015 17:07
Publicité
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
64,52 €Kit de 16 Go (2 x 8 Go) de mémoire DDR4 Corsair Vengeance LPX 3200 MHz à 64,52 € livré
88 € -27%

Amazon Allemagne fait une belle promotion sur le kit de 16 Go (2x8 Go) de mémoire DDR4 Corsair Vengeance LPX 3200 MHz qui passe à 59,40 €. Comptez 5,12 € pour la livraison en France soit un total de 64,52 € livré. Une très bonne affaire !


Voir l'offre
529,99 €Portable 15,6 pouces HP (FHD, Ryzen 5 5500U, 8Go/512Go, Win10) + imprimante HP 2710e à 529,99 €
650 € -18%

Cdiscount fait une belle promotion sur un pack comprenant l'ordinateur portable HP Pavilion 15-eh1022nf (FHD, Ryzen 5 5500U, 8Go/512Go, Win10) et une imprimante multifonction DeskJet 2710e (USB, WiFi, Bluetooth, Instant Ink 6 mois) qui passe à 529,99 € avec le code 20EUROS au lieu de plus 650 €.

Le portable possède un écran 15.6 pouces Full HD (1920x1080), un processeur AMD Ryzen 5 5500U (6 coeurs), 8 Go de RAM (extensible), un SSD NVMe de 512 Go et un chip graphique Vega 7. Le tout tourne sous Windows 10 que vous pourrez passer à Windows 11.

De quoi faire de la bureautique, surfer sur Internet, du multimédia et des petits jeux en toute tranquillité.

L'imprimante HP DeskJet 2710e est 3 en 1. Elle fait donc imprimante, photocopieur et scanner. Elle dispose d'un chargeur automatique de documents. Elle fonctionne avec 2 cartouches d'encre (une noire et une 3 couleurs). Connexion via USB, Bluetooth et Wifi. Vous pourrez facilement imprimer et numériser avec votre ordinateur, tablette, smartphone. Avec 6 mois d'Instant Ink inclus.


Voir l'offre
147,99 €SSD Crucial P2 2 To (3D NAND, NVMe, PCIe, M.2, 2400 Mo/s) à 147,99 €
182,99 € -19%

Amazon fait une promotion sur le SSD Crucial P2 2 To (3D NAND, NVMe, PCIe, M.2) qui passe à 147,99 € livré gratuitement. On le trouve ailleurs à partir de 182,99 €. Ce SSD offre des vitesses de lecture/écriture séquentielle allant jusqu’à 2 400/ 1 900 Mo/s. Il est garanti 5 ans.


Voir l'offre
279 €Tablette 11 pouces Lenovo Tab P11 Plus (2K, 4Go/128Go) + station d'accueil + coque + stylet à 279 €
349 € -20%

Boulanger fait une promotion sur la tablette tactile 11 pouces Lenovo Tab P11 Plus accompagnée d'un stylet, d'une coque et de sa station d'accueil qui passe à 329 €. Or Lenovo rembourse actuellement 50 € pour l'achat de ce pack qui vous reviendra à 279 € au lieu de 349 €. Cette excellente tablette 11 pouces possède un écran 2K, un processeur 8 coeurs Snapdragon 662, 4 Go de RAM, 128 Go de stockage, une autonomie de 12 heures et un port USB Type C. Le tout tourne sous Android 10. La station d'accueil permet de poser la tablette et de la recharger.


Voir l'offre

Sujets relatifs
Pas de connexion Wifi après installation Linux Mint 17.1
Archlinux : extinction de l'écran après une heure
Mandriva Linux et après ? Mageia !
Comment installer xp après linux (sur un 2éme dd)?
Pas de Linux après install
Installer Linux après avoir formatté mon disque
Boot trop long apres installation Linux
installer linux après windows xp
Pas d'affichage après installation linux
Probleme sous winxp apres install de Linux
Plus de sujets relatifs à altération de l''heure de W7 après Linux enfin solutionné
 > Tous les forums > Forum Linux