× Aidez la recherche contre le COVID-19 avec votre ordi ! Rejoignez l'équipe PC Astuces Folding@home
 > Tous les forums > Forum Linux
 Arch : obtenir la gtk+ 3.3.3 ? + pb catalyst
Ajouter un message à la discussion
Pages : [1] 2 ... Fin
Page 1 sur 2 [Fin]
Esclapion
  Posté le 30/03/2012 @ 21:48 
Aller en bas de la page 
Grand Maître astucien

Bonsoir à tous,

Lors de la compilation de muffin-git (nécessaire à Cinnamon), j'obtiens :

Requested 'gtk+-3.0 >= 3.3.3' but version of GTK+ is 3.2.3

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables MUFFIN_MESSAGE_CFLAGS
and MUFFIN_MESSAGE_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Quelle démarche faut-il adopter, dans ces cas-là ?

Merci d'avance.



Modifié par Esclapion le 06/04/2012 03:08
Publicité
Esclapion
 Posté le 03/04/2012 à 12:46 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Bon, je pense que je vais abandonner Archlinux, notamment à cause de Cinnamon et de ATI.

Si on commence à avoir des versions de développement dans le stable, pas la peine d'insister.

Voir ICI.

Sorry everyone, I'm on vacation right now for spring break, so I can't update this package. I'll do it as soon as I get back :)

Si je rajoute à ça que le pilote libre ATI fait vrombir mon ventilateur au repos, et que le propriétaire ne marche pas, je m'aperçois que j'ai perdu beaucoup de temps pour rien avec cette distribution.

Je reviens à LMDE.



Modifié par Esclapion le 03/04/2012 12:48
Logicien
 Posté le 03/04/2012 à 14:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Présentement, j'utilise une mini-tour AX1470-EF30P avec une carte graphique nom de code Caicos, HD 6450.

Tout ce que j'ai essayé afin d'avoir l'accélération matérielle et les effets 3D avec le pilote libre Radeon a échoué. En 64 bits, Gentoo, ArchLinux, live-cds Fedora 16, Lubuntu 11.10 et Knoppix 32 bits me donnent un écran noir dans les consoles virtuelles et le pilote Radeon d'Xorg refuse de fonctionner sans KMS. Même le pilote Radeonhd qui doit être utilisé sans KMS, que je désactive, refuse de démarrer.

Je dois utiliser le pilote du noyau Vesafb ou Uvesafb avec le pilote Fbdev ou Vesa d'Xorg. Ça fontionne à merveille, sauf que je ne peux utiliser Compiz et tout ce qui est effet graphique. Je n'ai pas encore et je ne sais pas si j'utiliserai un jour les pilotes propriétaires Amd/Ati.

Alors, il y a peut-être un temps de latence et des ratés sous ArchLinux, mais quand le problème est du côté du noyau Linux, seul un patch de distribution ou autre peut résoudre le problème. J'espère que les prochaines versions du noyau Linux résoudront mon problème. Une recherche sur Internet ne résoud rien présentement.

Esclapion
 Posté le 03/04/2012 à 14:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Oui, mais sous LMDE, le pilote propriétaire s'installe bien.

Et il est nécessaire, non tellement pour avoir des accélérations 3D, mais pour gérer correctement la carte, sur le plan efficacité. Elle chauffe trop, sinon (même au repos), ce qui se traduit par ce bruit de ventilateur. Ou alors, c'est le ventilateur qui est mal géré, mais comme ce bruit augmente au fur et à mesure..

En tout cas, quand le bruit de ma CG commence à rivaliser avec celui de ma TV, je commence à m'inquiéter. Sous LXDE, ça va à peu près. Mais sous GS, pas moyen.

Le pilote Catalyst du Wiki Arch aboutit sur le fait qu'il faut un Xorg < 12.0. En lisant plus loin, ils proposent un downgrade vers le Xorg 11.0. Mais ce downgrade remplace des tas de trucs, notamment la libgl, et rien à faire pour avoir la main au redémarrage.

Quant à installer directement le pilote propriétaire depuis le site d'ATI, j'ai essayé, ça plante pareil.

Alors, pour le pilote, il faut un downgrade, qui ne fonctionne pas, et pour Cinnamon, un semi-upgrade (passer de la 3.2.3 à la 3.3.3 de GTK, alors que la 3.4.0 bêta 2 est sortie ?).

Et je n'ai *aucun* dépôt testing d'activé.

En posant la question sur le forum Arch, qqn m'a répondu qu'il avait résolu le pb en passant à la version suivante du noyau, donc en recompilant les sources de celui-ci. Là, on est dans le Gentoo. Un autre, que le pilote libre lui non plus ne marchait pas chez lui pour l'instant.

J'ai essayé de passer par la compilation à la main des gits de muffin et en-dessous, mais je ne suis pas passé. Je me suis arrêté, car s'il faut intervenir dans le code pour continuer...



Modifié par Esclapion le 03/04/2012 14:59
Logicien
 Posté le 04/04/2012 à 00:18 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Dit-moi Esclapion, connais-tu une distribution Linux en cd live qui utilise les pilotes Calatyst? Au stade où j'en suis, avant d'essayer de les installer sous Gentoo, ArchLinux et Debian, je ne détesterais pas les voir à l'oeuvre sans rien toucher.

Esclapion
 Posté le 04/04/2012 à 00:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

D'emblée, non.

C'est particulièrment facile sous une LMDE (donc Debian), voir ICI. Un peu plus embêtant sous LM12.

Par contre, comme il faut redémarrer le PC, ça ne t'aide pas.

Logicien
 Posté le 04/04/2012 à 03:18 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

J'ai retrouvé les effets 3D et Compiz. J'ai installé les pilotes Catalyst sous Gentoo. Mon noyau était déjà configuré correctement. Le pilote Radeon libre était désactivé dans le noyau, condition essentielle pour utiliser fglrx. Je n'ai eu qu'à désinstaller le pilote Radeon d'Xorg.

L'agpgart est bien compilé encore en dur, mais comme ma carte graphique est sur port PCIe, le gart agp du pilote Ati n'étant pas utilisé, il n'entre pas en conflit avec celui du noyau Linux.

Avec le pilote libre Radeon, j'oscillais entre 700 et 800 FPS avec Glxgears. Avec le pilote propriétaire Ati, j'en ai près de 6000 ! Seul problème constaté, c'est que maintenant, il y a un pilote pour les consoles virtuelles, Vesafb et un pour Xorg, Fglrx. Quand je passe de l'un à l'autre, il y a un délai quand la carte graphique change de pilote.

J'ai mis la résolution graphique à la même fréquence que celle des consoles virtuelles, 75 kHz mais ce délai est encore présent. Je suis en profondeur 16 en consoles et 24 sous Xorg. Je vais voir ce que je peux faire pour harmoniser le pilote vidéo Linux avec celui d'Ati.

J'ai tout essayé, sans succès, afin d'activer l'accélération matérielle de ma carte graphique avec le pilote libre, je n'avais pas le choix d'utiliser le pilote propriétaire. Il ne m'intrigue plus. Je m'adapte. Je te tiens au courant et toi aussi j'espère, pour l'optimisation et vais essayer d'installer Fglrx sous Archlinux. Salut.

Un totoriel qui, sans être complètement à jour, est une bonne référence:

fglrx - Gentoo Linux Wiki



Modifié par Logicien le 04/04/2012 03:30
Esclapion
 Posté le 04/04/2012 à 11:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

condition essentielle pour utiliser fglrx

Oui et non. Je l'avais lu, mais si regardes mon lien, ça passe. D'ailleurs, ça m'avait étonné. Dépend des configurations, des versions.

Avec le pilote libre Radeon, j'oscillais entre 700 et 800 FPS avec Glxgears. Avec le pilote propriétaire Ati, j'en ai près de 6000 !

Oui, mais pour moi, c'est à prendre avec des pincettes. D'autant que glxgears fait partie du propriétaire. Par contre, quand je lis (sur le Wiki d'arch ?) que le libre est meilleur en 2D, non, je ne trouve pas.

Je n'ai pas étudié la question des fréquences ni de profondeur de couleur. Sous W7, je suis pas défaut à 60 hz, ce que je trouve bien suffisant avec un LCD, n'en déplaise aux gamers.

Il faudra que je regarde, ça explique peut-être pourquoi je trouve que Linux consomme autant.

Attention à la version de Xorg, sous Arch. Si tu passes, ça m'intéresse.

Logicien
 Posté le 04/04/2012 à 14:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Si Fglrx passe avec Radeon KMS c'est peut-être parce-que le paramètre du noyau radeon.modeset=0 a été passé ou que la ligne

options radeon modeset=0

existe dans un fichier du répertoire /etc/modprobe.d/ . C'est ce que je ferai sous ArchLinux avant une première utilisation de Fglrx si je réussi à l'installer sans problème. Je ne suis pas pressé pour installer Fglrx sous ArchLinux j'ai pleins de choses à analyser présentement sous Gentoo avec ce pilote.

Quoi qu'il en soit, glxgears appartient au paquet mesa-demos sous ArchLinux. Ce n'est pas un utilitaire des pilotes propriétaires d'Amd. L'utilitaire fgl_glxgears lui appartient aux pilotes propriétaires d'Amd.

Publicité
Esclapion
 Posté le 04/04/2012 à 15:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Si Fglrx passe avec Radeon KMS c'est peut-être parce-que le paramètre du noyau radeon.modeset=0 a été passé ou que la ligne

options radeon modeset=0

existe dans un fichier du répertoire /etc/modprobe.d/ .

C'est pour activer KMS, ça, non ? Je le croyais activé par défaut depuis la version 2.6.33 du noyau (cf. le wiki).

Quoi qu'il en soit, glxgears appartient au paquet mesa-demos sous ArchLinux. Ce n'est pas un utilitaire des pilotes propriétaires d'Amd. L'utilitaire fgl_glxgears lui appartient aux pilotes propriétaires d'Amd.

Autant pour moi, j'ignorais, merci. Par contre, les résultats qu'il donne ne me semblent pas très crédibles. Il est de plus bridé (plafonné) chez moi (c'est lié à la fréquence de rafraîchissement écran ou qqch comme ça).

Logicien
 Posté le 04/04/2012 à 16:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

C'est vrai que KMS est activé par défaut dans le noyau pour les cartes graphiques Amd, Nvidia et Intel. Les autres fabriquants de cartes graphiques ne supportent pas KMS pour l'instant. C'est plutôt le paramètre radeon.modeset=1 qui active le support KMS du pilote Radeon. 0 le désactive.

Sur le site de Gentoo, on dit que Glxgears n'est pas un banc d'essai. Par défaut, il n'affiche pas plus de FPS que la fréquence de rafraîchissement de l'écran. Essai comme ceci pour désactiver ce comportement:

vblank_mode=0 glxgears

Une proposition pour ArchLinux, si tu veux Catalyst, est de placer dans /etc/default/grub ou dans une entrée de /etc/grub.d/40_custom les paramètres du noyau

radeon.modeset=0 vga=0x318 video=vesafb:1024x768-24,mtrr:3,ywrap

Cela va désactiver KMS et activer le framebuffer Vesafb en résolution 1024x768. En plus, fait

echo "options radeon modeset=0" > /etc/modprobe.d/kms-radeon.conf

parce-que le pilote Radeon peut être chargé comme module et KMS doit aussi être désactivé dans ce cas. Il faut refaire l'initrd:

mkinitcpio -p linux

La première chose à faire est d'arrêter le serveur X et d'ouvrir une session utilisateur dans une console en mode caractères. Il faut désinstaller le serveur X et ses dépendances, serveur qui en est à la version 12 et que Catalyst ne supporte pas. Il ne supporte actuellement que des versions antérieures à 12. Exemple:

yaourt -R xorg-server xf86-input-evdev xf86-input-keyboard xf86-input-mouse xf86-input-wacom xf86-video-fbdev xf86-video-v4l xf86-video-vesa

Tu ajoutes et retranches ce qu'il faut. Ensuite, tu modifies /etc/pacman.conf afin d'ajouter les dépôts suivants en premiers:

[catalyst-11.8]
Server = http://catalyst.apocalypsus.net/repo/catalyst/$arch

[xorg111]
Server = http://catalyst.apocalypsus.net/repo/xorg111/$arch

Le dépôt [multilib] doit aussi être décommenté. Faire

yaourt -Suy

et

yaourt -S xorg-server xf86-input-evdev xf86-input-keyboard xf86-input-mouse xf86-input-wacom xf86-video-fbdev xf86-video-v4l xf86-video-vesa

Tu ajoutes et retranches ici aussi ce qu'il faut. Moi j'ai installé

yaourt -S catalyst-total

et ça passe. Ensuite

sudo modprobe fglrx

sudo aticonfig --initial --input=/etc/X11/xorg.conf

Faire startx ou démarrer le gestionnaire d'affichage. Chez moi ArchLinux fonctionne avec Catalyst.

Édition: le dépôt [catalyst-11.8] n'est essentiel je pense que si on n'utilise pas AUR. La version AUR est plus récente mais exige elle-aussi Xorg-server 11. Il est peut-être possible de ne pas utiliser les librairies 32 bits. À vérifier.



Modifié par Logicien le 04/04/2012 17:30
Esclapion
 Posté le 04/04/2012 à 18:00 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Merci, je vais essayer.

J'ai bien trouvé glxgears dans mesa-demos.

302 frames in 5.0 seconds = 60.273 FPS
300 frames in 5.0 seconds = 59.954 FPS
300 frames in 5.0 seconds = 59.955 FPS

Mais c'est 60 ou 60 000 ?

(edit)

Effectivement, ça marche avec vblank mode :

vblank_mode=0 glxgears
ATTENTION: default value of option vblank_mode overridden by environment.
ATTENTION: default value of option vblank_mode overridden by environment.
23469 frames in 5.0 seconds = 4693.743 FPS
23616 frames in 5.0 seconds = 4722.965 FPS
23264 frames in 5.0 seconds = 4652.727 FPS



Modifié par Esclapion le 04/04/2012 18:04
Esclapion
 Posté le 04/04/2012 à 20:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Re,

non, ça ne marcher pas.

J'ai modifié ma procédure d'install auto pour :

1) inclure en premier xorg111 ;

2) ne pas installer le pilote libre.

J'ai ensuite suivi ton mode d'emploi (du moins, je l'espère), mais il refuse catalyst-total :

--------
2012-04-04 20:01:43
Building fglrx module for 3.2.11-1-ARCH kernel ...
--------
Kernel header files are absent: directory /lib/modules/3.2.11-1-ARCH/build doesn
't exist! Game over

--------
2012-04-04 20:08:13
Building fglrx module for 3.2.11-1-ARCH kernel ...
--------
Kernel header files are absent: directory /lib/modules/3.2.11-1-ARCH/build doesn
't exist! Game over



Modifié par Esclapion le 04/04/2012 20:20
Esclapion
 Posté le 04/04/2012 à 20:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

cd 3.2.11-1-ARCH/
[root@arch 3.2.11-1-ARCH]# ls
extramodules modules.builtin modules.devname modules.symbols.bin
kernel modules.builtin.bin modules.order
modules.alias modules.dep modules.softdep
modules.alias.bin modules.dep.bin modules.symbols

J'ai tout fait en tant que root, donc ce n'est pas un pb de droit.

Logicien
 Posté le 05/04/2012 à 02:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

yaourt -S linux-headers

Tout module externe a de besoin des sources du noyau Linux pour compiler. Cela va également créer un lien symbolique /lib/modules/$(uname -r)/build qui va pointer vers les entêtes du noyau courant /usr/src/linux-$(uname -r).



Modifié par Logicien le 05/04/2012 02:13
Esclapion
 Posté le 05/04/2012 à 12:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Bon, c'est pas ça. Mon linux-header (j'ai regardé, je vois mieux ce que c'est. Le terme header, en-tête me faisait tromper) était correctement installé.

J'ai tenté un nouveau yaourt -Syu aujourd'hui, et ça me ramène un flot de paquet, visiblement ils sont en train de passer de la 3.2.11 à la 3.2.13.

J'ai tout reconstruit, pour essayer d'éviter ce mélange, mais ça ne me sembler pas très net.

En tout cas, maintenant, je trouve un build, mais dans la 3.2.13 :

lrwxrwxrwx 1 root root 36 24 mars 09:19 build -> ../../../usr/src/linux-3.2.13-1-ARCH
lrwxrwxrwx 1 root root 24 24 mars 09:19 extramodules -> ../extramodules-3.2-ARCH
drwxr-xr-x 12 root root 4096 24 mars 09:17 kernel
-rw-r--r-- 1 root root 690166 5 avril 12:25 modules.alias
-rw-r--r-- 1 root root 676714 5 avril 12:25 modules.alias.bin
-rw-r--r-- 1 root root 2459 24 mars 09:17 modules.builtin
-rw-r--r-- 1 root root 3413 5 avril 12:25 modules.builtin.bin
-rw-r--r-- 1 root root 372430 5 avril 12:25 modules.dep
-rw-r--r-- 1 root root 506520 5 avril 12:25 modules.dep.bin
-rw-r--r-- 1 root root 325 5 avril 12:25 modules.devname
-rw-r--r-- 1 root root 115580 24 mars 09:17 modules.order
-rw-r--r-- 1 root root 131 5 avril 12:25 modules.softdep
-rw-r--r-- 1 root root 278922 5 avril 12:25 modules.symbols
-rw-r--r-- 1 root root 351978 5 avril 12:25 modules.symbols.bin

Par contre, l'installation de catalyst-total (que je ne connaissais pas, je ne sais pas d'où il sort ) échoue :

2012-04-05 12:30:33
Building fglrx module for 3.2.11-1-ARCH kernel ...
--------
Kernel header files are absent: directory /lib/modules/3.2.11-1-ARCH/build doesn't
exist! Game over

C'est la salade, apparemment. Je vais essayer de faire un Rcs du catalyst, puis de le réinstaller.

Esclapion
 Posté le 05/04/2012 à 12:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Ce qui est bizarre, c'est que l'uname -r pointe toujours sur la 3.2.11, alors que les fichiers sont de la 3.2.13.

Le fait de virer catalyst-total supprime beaucoup de fichiers, certains appartenant à xorg.

(...)

Bon, idem :

Kernel header files are absent: directory /lib/modules/3.2.11-1-ARCH/build doesn't exist! Game over

Je vais peut-être regarder comment essayer de changer le uname.

(edit)

Bon, il suffisait de redémarrer après l'upgrade. Je recommence la manip entière.



Modifié par Esclapion le 05/04/2012 13:21
Publicité
Esclapion
 Posté le 05/04/2012 à 13:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Bon, OK. Pffffiiiiiuuuuhhhh !

grep -B2 'Module class: X.Org Video Driver' /var/log/Xorg.0.log
[ 11.698] (II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
[ 11.699] compiled for 1.4.99.906, module version = 8.95.3
[ 11.699] Module class: X.Org Video Driver

Par contre, question perfs...

glxgears
23405 frames in 5.0 seconds = 4680.983 FPS
24074 frames in 5.0 seconds = 4814.707 FPS
24446 frames in 5.0 seconds = 4889.030 FPS
23484 frames in 5.0 seconds = 4696.687 FPS

J'ai l'impression que ce n'est pas encore ça, mais il y a déjà progrès.

Reste à attendre que la personne (chenxiaolong ?) qui s'occupe de muffin revienne de vacances.

Requested 'gtk+-3.0 >= 3.3.3' but version of GTK+ is 3.2.3

Par contre, l'affichage semble "tremblant", par à-coups, notamment sur l'écran d'accueil.

De plus, je n'ai pas le centre de contrôle Catalyst.



Modifié par Esclapion le 05/04/2012 13:54
Logicien
 Posté le 06/04/2012 à 02:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Tu as le Centre de Contrôle Catalyst. L'exécutable se nomme amdcccle :

whereis amdcccle
amdcccle: /usr/bin/amdcccle

Pour placer une icône sur le bureau si tu ne peux pas y arriver par le Menu, sous Gnome, tu copies /usr/share/applications/amdcccle.desktop vers $HOME/Desktop/ . Ça devrait faire apparaître l'icône dans les applications.



Modifié par Logicien le 06/04/2012 02:15
Esclapion
 Posté le 06/04/2012 à 02:42 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

J'ai déjà l'icône dans la liste des applications, sous Gnome. Mais quand je la lance, il ne se passe rien.

En lançant amdccle, j'obtiens :

/usr/bin/amdcccle: error while loading shared libraries: libQtGui.so.4: cannot open shared object file: No such file or directory

Il doit me manquer une bibliiothèque. Je vais chercher comment elle s'appelle sous Arch.

Sinon, l'affichage du premier écran se fait en trois ou quatre fois. D'après les perfs glxgears données plus haut, il n'y a pas de gain de perfs, mais je n'entends pas le ventilateur.

(edit)

Oui, je viens de faire un pacman -S qt, et ça marche.



Modifié par Esclapion le 06/04/2012 03:05
Esclapion
 Posté le 06/04/2012 à 02:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Je viens de regarder sous LMDE, où il me semble mieux marcher, et là, j'ai un pilote plus récent :

Si je regarde les perfs, lors même que la LMDE est de 30 à 50% plus lente que Arch au démarrage, le gain est important :

glxgears
36123 frames in 5.0 seconds = 7224.587 FPS
36264 frames in 5.0 seconds = 7252.658 FPS
36218 frames in 5.0 seconds = 7243.473 FPS
37925 frames in 5.0 seconds = 7584.958 FPS



Modifié par Esclapion le 06/04/2012 03:00
Logicien
 Posté le 06/04/2012 à 03:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Si kde n'est pas installé peut-être que la librairie Qt ne l'est pas non plus. Si la sortie de la commande

pacman -Qs qt

ne contient pas

local/qt 4.8.1-1
A cross-platform application and UI framework

alors,

pacman -S extra/qt

Le seul navigateur disponible dans le Centre de Contrôle Catalyst est Konqueror. Qt 4 est une dépendance optionnelle de calalyst-total:

yaourt -Si catalyst-total
Dépôt : aur
Nom : catalyst-total
Version : 12.3-1
URL : http://www.ati.amd.com
AUR URL : http://aur.archlinux.org/packages.php?ID=31914
Licences : custom
Votes : 86
Périmé : Non
Groupes : None
Fournit : libgl libatical=12.3 catalyst=12.3 catalyst-utils=12.3 catalyst-hook=12.3 libcl
Dépend de : linux>=3.0 linux<3.4 linux-headers xorg-server>=1.7.0 xorg-server<1.12.0 netkit-bsd-finger libxrandr libsm fontconfig
libxcursor libxi gcc-libs gcc>4.0.0 make patch libxinerama
Dépendances opt. : qt: to run ATi Catalyst Control Center (amdcccle)
libxxf86vm: to run ATi Catalyst Control Center (amdcccle)
opencl-headers: headers necessary for OpenCL development
Est en conflit avec : libgl xf86-video-ati xf86-video-radeonhd ati-dri catalyst-test nvidia-utils nvidia catalyst catalyst-daemon
catalyst-generator catalyst-hook catalyst-utils libcl
Remplace : libgl catalyst catalyst-daemon catalyst-hook catalyst-utils libcl
Maintainer : Vi0L0
Architecture : i686 x86_64
Dernière soumission : sam. 31 mars 2012 08:10:54 EDT
Description : AMD/ATI drivers. catalyst-hook + catalyst-utils + lib32-catalyst-utils





Modifié par Logicien le 06/04/2012 03:35
Esclapion
 Posté le 06/04/2012 à 13:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Merci, je ne connaissais pas cette démarche (yaourt -Si catalyst-total).

Une bonne habitude à prendre.

La librairie Qt n'était pas installé avec l'ensemble Gnome et Gnome-extra, donc. KDE ne me plaît pas vraiment.

Apparemment, ton Catalyst est le tout dernier, j'avais mal lu le N° de version. Je me demande par contre pourquoi il y a une telle différence de performances avec la LMDE. Une 6870 est quand même une carte rapide, et je me demande si elle n'est pas encore bridée.

Lors d'anciens essais, il y a qqes mois, j'avais vu passer une valeur de glxgears de 20 000 environ.

J'ai rajouté la libxxf86vm à tout hasard, sans réfléchir qu'elle ne devait être que pour les 32 bits, et effectivement ça ne change rien.



Modifié par Esclapion le 06/04/2012 13:34
Esclapion
 Posté le 06/04/2012 à 20:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

J'ai tenté de regarder une vidéo, mais il ne marche pas très bien quand même, ce pilote (sauts d'images, bord d'image parfois pixellisé, etc...).

Sous les systèmes voisins, cette même vidéo passe sans pb.



Modifié par Esclapion le 06/04/2012 20:32
Logicien
 Posté le 07/04/2012 à 00:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Tu dis que sous les systèmes voisins, LMDE probablement, lire une vidéo passe sans problème. C'est élémentaire.

As-tu un /etc/X11/xorg.conf sous ArchLinux que tu peux comparer à un système voisin? Sur le forum de Gentoo on dit qu'avec les pilotes graphiques libres, pas seulement Radeon, Xorg n'a pas de besoin de fichier de configuration pour de démarrer. Comme Fglrx est propriétaire, il en a de besoin.

J'ai vu quelques options qu'on peut ajouter à xorg.conf telles

Option "OpenGLOverlay" "off"

Option "TexturedVideo" "on"

#Option "UseInternalAGPGART" "off"

#Option "VideoOverlay" "off"

#Option "XAANoOffscreenPixmaps" "on

Celles en remarques Fglrx dit qu'elles ne sont pas utilisées. De mon côté, Compiz fonctionne bien et la vidéo aussi. J'ai libéré le maximum de mémoire vive dans le BIOS pour la carte graphique.

Je te laisse mon xorg.conf . Il me suit d'un ordinateur à l'autre comme mes distributions, ArchLinux, Debian et Gentoo. J'ai autant confiance aux distributions basées sur Debian que celles que j'utilise. Il y a bien des nuances, mais rien pour en écarter une.



Modifié par Logicien le 07/04/2012 01:02
Esclapion
 Posté le 07/04/2012 à 01:18 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Merci. Ma LMDE venant de sauter, pour cause de saturation des serveurs Mint, je vais devoir attendre ceux-ci pour essayer, peut-être qqes jours.

Je pensais effectivement à elle (et à W7, mais bon... ).

Publicité
Pages : [1] 2 ... Fin
Page 1 sur 2 [Fin]

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
256,99 €Disque dur externe WD Black D10 Game Drive 12 To à 256,99 €
Valable jusqu'au 08 Juin

Amazon fait une superbe promotion sur le disque dur externe WD Black D10 Game Drive 12 To qui passe à 256,99 € livré. On le trouve ailleurs à plus de 350 €. Ce disque dur USB 3.1 est dédié pour gérer et stocker votre bibliothèque de jeux sur Xbox One (d'où le logo sur le boitier) mais il fonctionne également parfaitement bien sur PC et PS4. 3 mois d'abonnement Xbox Game Pass sont aussi offerts. Vous pouvez démonter le disque dur à l'intérieur du boitier pour le réutiliser ailleurs (un HGST DC HC520 12 To vendu plus de 400 € ailleurs)


> Voir l'offre
29,72 €Carte mémoire microSDXC UHS-I SanDisk Ultra 200 Go à 29,72 € livrée
Valable jusqu'au 11 Juin

Amazon Allemagne fait une promotion sur la carte mémoire microSDHC UHS-I SanDisk Ultra 200 Go qui passe à 25,21 € avec la TVA ajustée. Comptez 4,51 € pour la livraison en France soit un total de 29,72 € livrée en France. On la trouve ailleurs à partir de 40 €. Cette carte mémoire offre des vitesses jusqu'à 90 Mo/s et est idéale pour les téléphones, caméras et appareils photo HD. Elle est certifiée GoPro, Switch et est accompagnée d'un adaptateur SD. Une très bonne affaire. 

Vous pouvez utiliser votre compte Amazon France sur Amazon Allemagne et il n'y a pas de douanes. Si vous êtes perdu en allemand, vous pouvez traduire le site en anglais.


> Voir l'offre
-15%15% de réduction sur les écrans ViewSonic chez Materiel.net
Valable jusqu'au 07 Juin

Materiel.net offre actuellement 15% de remise immédiate sur tous les écrans ViewSonic de son catalogue. Utilisez pour cela le code BUTIN dans votre panier.


> Voir l'offre

Sujets relatifs
Arch Linux Installateur
inscription , Arch forum
S'inscrire sur le Forum d'Arch: Impossible.
Cd/Dvd/Usb live Linux avec Catalyst ou Wayland ou Mir
LibreOffice ne fonctionne plus sous Arch
Info : Kompozer sous Manjaro (Arch)
Arch : le gnome 3.6 nouveau est arrivé
Arch : connecter une webcam ?
Arch : util-linux et eject
catalyst-test : No supported adapters found
Plus de sujets relatifs à Arch : obtenir la gtk+ 3.3.3 ? + pb catalyst
 > Tous les forums > Forum Linux