> Tous les forums > Forum Linux
 Archlinux : nouvelle installation problématique (résolu ... presque)
Ajouter un message à la discussion
Pages : [1] 2 3 ... Fin
Page 1 sur 3 [Fin]
Mimile
  Posté le 16/07/2017 @ 14:45 
Aller en bas de la page 
Astucien

Bonjour

Ma chère Arch ayant définitivement rendu l'âme, je décide d'en installer une toute neuve à sa place.

Voici à quoi ressemble mon sda1 : http://www.hostingpics.net/viewer.php?id=378677gparted1.png


J'ai formaté (avec gparted sous mint) en ext4 les partitions qui contenaient ma défunte Arch : sda5 pour la racine et sda6 pour /home

J'ai gravé l'ISO du 1.7.2017 sur un CD, je zappe la phase de partitionnement puisque les partitions existent déjà et je lance l'installation en faisant pacstrap /mnt base base-devel. conformément à ce qui est dit dans le guide.

Une longue liste de paquets défile à toute vitesse et je finalise l'installation en exécutant les multiples commandes prévues.

Reboot : je démarre sur Arch (grub généré par Mint) : écran noir.

Vérification faite : toute l'installation de base a été positionnée dans sda6.

Dans le guide d'installation, il est dit qu'il faut indiquer à pacstrap la partition de destination de base et base-devel.

Je formate sda6 pour la vider et je recommence en tentant : pacstrap /mnt/dev/sda5 base base-devel mais je me heurte à un message du genre /dev/sda5 est un fichier alors que, comme on le voit, il s'agit d'une partition, logique, certes, mais partition quand-même.

Que faut-il faire pour que pacstrap considère sda5 en tant que telle ?

Quand je tape simplement pacstrap, il y a différentes options mais pour autant que je les comprenne, aucune ne fait référence à cela.

Merci d'avance.



Modifié par Mimile le 14/08/2017 15:26
Publicité
Logicien
 Posté le 16/07/2017 à 22:06 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut Mimile,

tu as peut-être oublié de monter la partition racine de ta nouvelle Arch depuis le cd d'installation. Tu ne le mentionnes pas dans ton message. Si tel est le cas, tu as installé ta nouvelle Arch dans le répertoire /mnt du cd d'installation et non dans le système de fichiers Ext4 de /dev/sda5. Voici la méthode que je te propose d'utiliser. Tu démarres sur le cd d'installation de la Arch qui devrait te connecter à Internet dès le démarrage. Tu arrives à l'invite de commandes Zsh en root. Tu fais immédiatement

bash

pour utiliser Bash que tu connais mieux que Zsh. Ensuite tu charges le clavier Belge et tu te donnes la possibilité de faire du copier/coller à la console avec la souris à l'aide de Gpm

loadkeys be

systemctl start gpm.service

Ensuite tu formates tes partitions /dev/sda5 et /dev/sda6 avec les outils de la Arch plutôt qu'avec ceux de LinuxMint. Comme cela tu t'assures d'utiliser la version du paquet e2fsprogs supportée par la Arch et non la version supportée par LinuxMInt.

mkfs.ext4 -L Arch_root /dev/sda5

mkfs.ext4 -L Arch_home /dev/sda6

Ensuite moi je crée un répertoire dédié à la Arch mais c'est facultatif. Souviens-toi que le répertoire racine de la Arch nouvelle est /mnt/arch dans ce cas-ci.

mkdir /mnt/arch

Monter la partition home n'est nécessaire qu'à partir du moment que tu crées un ou des comptes utilisateurs normaux et que tu ouvres des sessions graphiques ou non graphiques avec ces comptes. Pour l'instant seule la partition racine est nécessaire d'être montée pour installer le système de base.

mount -t ext4 /dev/sda5 /mnt/arch

Tu es prêt pour l'installation

pacstrap /mnt/arch base base-devel

Après l'excétution de cette commande le système de base est installé dans la partition /dev/sda5 mais il reste pleins de choses à faire pour pouvoir démarrer sur elle à l'aide de Grub2 de Linuxmint. La première chose est de passer depuis le cd d'installation en chroot dans ta nouvelle Arch selon la méthode que tu connais ou

mount -o bind /dev /mnt/arch/dev

mount -o bind /proc /mnt/arch/proc

mount -o bind /sys /mnt/arch/sys

HOME=/root SHELL=/bin/bash USER=root chroot /mnt/arch

afin de donner un mot-de-passe au root de ta nouvelle Arch et pouvoir te connecter à ta nouvelle installation après le premier démarrage sur elle.

passwd

En chroot dans ta nouvelle Arch depuis le cd d'installation (ou depuis Linuxmint) tu peux installer pleins de logiciels et configurer ta nouvelle Arch avant le premier démarrage. Entre autres il faut que tu sois connecté à Internet au premier démarrage en installant au besoin le paquet dhcpcd et en activant le service

systemctl enable dhcpcd.service

Il faut configurer le fichier /etc/fstab pour que les partitions racine et home soient montées correctement au démarrage.

/dev/sda5 / ext4 defaults 1 1

/dev/sda6 /home/ ext4 defaults 1 2

Il faut créer toujours en chroot un nouvel initramfs pour ta nouvelle arch qui inclue le module nouveau dans /etc/mkinitcpio.conf

MODULES="nouveau"

puis faire

mkinitcpio -p linux

Tu dois t'assurer que l'entrée pour ta nouvelle Arch dans /etc/grub.d/40_custom de LinuxMint est correct avant de regénérer le fichier de configuration de Grub2 sous LinuxMint.

update-grub

Avec ça, tu as plus de chances de voir l'invite de connexion de ta nouvelle Arch à son démarrage réel et pouvoir ouvrir une session root pour poursuivre l'installation. Le chemin est encore long avant de voir ton bureau. Il faut créer un utilisateur normal avec la commande useradd

useradd -G cdrom,video,wheel -m -s /bin/bash -u 1000 -U akopi

lui donner un mot-de-passe

passwd okapi

Il faut installer les paquets nécessaires, gérer les services, etc. Il faut activer le gestionnaire d'affichage, exemple avec lightdm

systemctl enable lightdm.service

puis redémarrer.



Modifié par Logicien le 17/07/2017 09:15
Mimile
 Posté le 17/07/2017 à 16:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Merci mon cher Paul,

Comme toujours, tu n'as pas ménagé ta peine et ton temps pour me fournir, une fois de plus, un maximum d'informations et je t'en remercie vivement.

Cela dit - et j'en suis conscient - je suis loin de voir le bout du tunnel...

Quand je pense à tout le temps que j'ai passé à peaufiner ma défunte arch, je me sens par moments découragé au point de renoncer à Linux, d'autant que d'un point de vue professionnel (adapté aux circonstances de la vie), je dispose de beaucoup moins de temps libre pour m'y consacrer en toute quiétude... [par ailleurs, j'ai une charmante épouse -nous nous sommes mariés en 1977 mais nous connaissons depuis 1974 soit depuis 43 ans ! tu parles d'un bail !] qui, à aucun moment, ne m'a pas laissé tomber dans une période difficile de ma vie - professionnellement parlant - je ne lui en aurais pas voulu qu'elle le fît - et je ne peux absolument pas donner tout mon peu de temps libre à ce qui n'est en sorte que très accessoire : ai-je réellement besoin d'archlinux ? non, évidemment mais cette distribution représente pour moi un défi intellectuel à relever).

Mais, mordious ! je ne renoncerai pas à poster, en sachant que, manifestement, tu es aux aguets des postes et messages postés dans la rubrique Linux de PCastuces et que tu es le bon samaritain de bon nombre de linuxo-pharisiens dans la détresse (cf. la Bible).

Amicalement (comme d'habitude ).

Mimile



Modifié par Mimile le 17/07/2017 17:11
Logicien
 Posté le 18/07/2017 à 02:25 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Si tu renonces à la Arch ce n'est pas moi qui va t'en faire un cas de conscience. Dit bonjour à ton épouse de ma part et qu'elle ne s'en fasse pas trop avec tes frugalités GNU/Linuxienne car, je ne vise qu'à te faire économiser du temps.

Mimile
 Posté le 18/07/2017 à 16:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Mon cher Mentor,

Il est irrévocablement hors de question que je renonce à Arch qui est le seul OS qui exige de mes neurones un travail pour lesquels ils n'ont pas été configurés au départ (mon domaine professionnel étant le droit qui est en perpétuelle évolution dans mon pays, ce qui demande ipso facto une perpétuelle remise en question des savoirs que je possédais sur le bout des doigts au début de ma carrière).

Tiens, pour le fun, une petite histoire :

- un ami rencontre un autre ami qu'il n'a plus vu depuis longtemps.

- le 1er : qu'est-ce que ta fille fait dans la vie ?

- réponse du 2ème : j'ai honte de le dire mais elle exerce le plus vieux métier du monde ... (silence gêné de deux compères) puis, le 2ème, pour faire diversion) s'adressant à son ami : et ton fils, que fait-il dans la vie ?

- le 2ème : Mon fils, il exerce le 2ème plus vieux métier du monde : il est avocat ... (silence gêné de part et d'autre ...)

Il m'en vient une 2ème :

même contexte : un ami rencontre un vieil ami qu'il plus vu depuis longtemps.

Le 1er : qu'est-ce qu'il fait dans la vie, ton fils ?

Le 2ème : il travaille son droit.

Le 1er : il veut devenir avocat ?

Le 2ème : non, il veut devenir boxeur ...

Ca nous éloigne d'Arch mais un peu de détente est la bienvenue .... non ?

Cela dit, vendredi prochain 21 juillet étant le jour de la fête nationale belge, je disposerai de trois belles journées fériées (variante : chômées) pour me permettre de procéder à l'accouchement de ma nouvelle arch (pas de problème avec mon épouse qui part en vadrouille sur la côte normande ou bretonne (de France) avec ses amies - toutes sexagénaires, ce qui est rasssurant - (avec ma voiture , ce qui est moins rassurant ) pour se gaver de fruits de mer qu'elle adorent (c'est du moins ce qu'elles m'ont annoncé ...) et visiter le coin.

J'en profiterai pour mettre un terme à la malédiction qui a frappé ma pauvre arch et lui donner une descendance digne de ce nom que j'ai d'ores-et-déjà décidé d'appeler archibald en référence à ma généaolgie lointaine qui situe une branche éloignée de mes ancêtres en Ecosse et une autre en angleterre, voici quelques siècles.

Chassés de leur pays en raison de leurs convictions religieuses, il ont émigré aux Pays-Bas, pays très libéral pour l'époque, et finalement, leurs propres descendants, en Belgique, qui fut, à une époque un pays de premier ordre dans de nombreux domaines scientifiques.

Une pensée particulière pour le chanoine catholique Lemaître qui fut précurseur de la théorie du Big Bang qui gênait Einstein mais qui selon mes lectures passionnées récentes pour ce domaine, n'a pas encore pu être sérieusement contestée ...

Par modestie, je n'évoquerai pas le nombre d'inventeurs qui n'ont pas pris de brevets, qui sont tombés dans l'oubli, et dont de nombreux étrangers ont exploité les trouvailles.

Exemple : la dynamo essentielle dans toute industrie ! inventeur : zénobe Gramme etc...

Je suis fier d'être Belge et j'en veux à ce con de je ne sais plus quel Roi de France qui, à la suite d'une défaite cuisante, a dû abandonner une partie de son Royaume à des hollandais qui ont fait que maintenant, mon pays est divisé en deux avec une majorité de flamands (qui exercent leurs diktats).

Bon, je vais en rester là sinon, couic !, je m'exposerai à une amende des Contrôleurs du site et ce n'est vraiment pas le moment ....

Tiens, aujourd'hui, je suis à cours d'idée pour ma finale, alors je dirais

Merci Paul



Modifié par Mimile le 18/07/2017 17:04
Mimile
 Posté le 21/07/2017 à 14:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut Paul,

J'ai fait l'installation de base de ma nouvelle Arch conformément à tes suggestions en parallèle avec le guide d'installation d'Arch et tout s'est bien passé (pas de message d'erreur).

Je passe sous Mint (qui génère le grub), je fais un update-grub puis je reboote et opte pour Arch : écran noir.

L'explication est simple : l'UUID de ma racine a changé. Je consulte blkid qui me le confirme. Je rectifie donc dans 40_custom l'UUID d'Arch et je reboote sur Arch qui commence par me dire que intel-ucode.img est introuvable. S'en suite une série de lignes à la fin desquelles le PC est totalement freezé;

Je jette un coup d'oeil sur grub.cfg de Mint et je constate que le texte du menu Arch est exactement celui de ma défunte arch avec son UUID, les ajouts que j'ai faits /boot/intel-code.img, le rw ajouté à la fin de la ligne Linux ...etc...

Je ne comprends vraiment pas comment cela est possible puisque les partitions sda5 et 6 sur lesquelles se trouvait mon ancienne Arch ont été effacées au début des opérations (mkfs.ext4 /dev/sda5 et mkfs.ext4 /dev/sda6).

Peut-être devrais-je les effacer avec dd (dd if /dev/sda5 of /dev/null ou quelque chose comme ça) ? Tu m'avais donné la commande exacte quand j'ai transféré XP de mon petit DD de 40 Go sur une gros (pour l'époque) de 200 Go préalablement partitionné.

J'ai beau cherché dans "mes suivis", je ne retrouve pas ton message.

Pourrais-tu me dire si, d'une part, c'est une bonne idée et d'autre part, si oui, quelle est la commande exacte ?

A ton avis ?

Mimile
 Posté le 21/07/2017 à 17:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Mon Cher Paul

Un intervenant sous Arch (Waitnsea) a attiré mon attention sur le fait que la présence de /boot/intel-code.img après initrc pouvait avoir un effet néfaste.

A cours d'idée, j'ai supprimé cela et miraculeuseement, Arch s'est mis à fonctionner (je parle de la base).

Défilé d'un tas de lignes, et à la fin, demande de login. pas le choix : root et passwd de root.

Mais après cela .... le bec dans l'eau.

Retour sur Mint pour avoir des infos sxur le guide de Arch mais sans succès.

Aurais-tu un,e idée sur la façon de poursuivre la construction d'Arch ?

Merci d'avance.

Mimile

Logicien
 Posté le 22/07/2017 à 15:21 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut,

pour avoir le fichier initramfs /boot/intel-code.img si tu as un processeur Intel tu dois installer le paquet intel-ucode.

pacman -S intel-ucode

Tu dois ensuite ajouter cet initramfs à ton entrée Grub2 de Mint en modifiant comme ceci dans 40_custom la ligne commencant par initrd:

initrd /boot/intel-code.img /boot/initramfs-linux.img

et toujours

update-grub

Si tu veux mettre à zéro tes partitions sda5 et sda6, imstalle sous Mint le paquet dcfldd . Il affiche des informations en cours d'exécution ce que la commande dd ne fait pas. Tu fais

dcfldd if=/dev/zero of=/dev/sda5 ibs=4M obs=4M

dcfldd if=/dev/zero of=/dev/sda6 ibs=4M obs=4M

N'oublie pas que tout est effacé et rien n'est récupérable. S'il y a un message d'erreur c'est probablement parce-que tu as un secteur défectueux dans lequel dcfldd ne peut écrire.

Si tu exécutes sous ta nouvelle Arch en réel ou en chroot la commande

pacman -Sg

Tu auras la liste de tous les groupes de paquets que tu peux installer. Un groupe de paquets installe tous les paquets pertinents à un groupe. Par exemple pour avoir Xorg et ses amis, tu peux faire

pacman -S xorg xorg-apps xorg-drivers xorg-fonts

Tous les composants d'Xorg seront installés. Pour installer Xfce4 tu fais ensuite

pacman -S xfce4 xfce4-goodies

Pour avoir un gestionnaire d'affichage, par exemple Lightdm, tu fais

pacman -S lightdm lightdm-gtk-greeter

Tu dois ensuite savoir si ta nouvelle Arch est configurée pour démarrer en mode texte ou graphique. Fait

systemctl get-default

et si la sortie ne donne pas graphical.target alors tu fais

systemctl set-default graphical.target

et tu active Lightdm comme gestionnaire d'affichage.

systemctl enable lightdm.service

À partir de là, tu peux redémarrer ce que je pense être plus sûr quand tu installes plusieurs nouveaux paquets. Sinon et seulement en démarrage réel (jamais en chroot) tu peux faire

systemctl start lightdm.service

et tu peux ouvrir une session graphique avec un utilisateur normal et continuer ton installation en mode graphique en installant les autres paquets dont tu as besoin, un navigateur Web, etc. En installant les paquets par groupes, tu t'évites des oublies et des commandes en plus.Tu peux savoir quels paquets sont contenus dans un groupe, ici le groupe xfce4, grâce à la commande

pacman -Sg xfce4

Tous les paquets installables ne sont pas inclus dans un groupe. Tu auras aussi à installer des paquets individuellement non inclus dans un groupe comme Vlc et Mplayer. Quand un paquet fait parti d'un groupe Pacman l'affiche en sortie.



Modifié par Logicien le 22/07/2017 15:45
Mimile
 Posté le 22/07/2017 à 16:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Cher Paul,

Une fois de plus, merci pour ton dévouement à me venir en aide.

Grâce à tes conseils, à l'heure actuellement, ma partition racine contient tous les dossiers habituels (usr, var, etc, share etc...) et ma partition home contient peu de chose (un dossier lost+found) et un dossier okapi contenant bash.logout, bash_profile et bashrc, dossier qui n'attend que de se remplir.

Au début de l'installation de base, le guide Arch donnait un moyen pour sélectionner les 10 miroirs les plus rapides avant de lancer pacstrap et cela a bien fonctionné.

Mon fstab est correct, j'ai modifié les UUID (fournis par blkid) de Arch_root et Arch_home (dans 40_custom) . Le mkinitcpio exécuté ensuite a bien pris en compte ces modifications et quand je démarre Arch tout se passe bien (je n'ai même plus les lignes d'erreur ACPI) et je me retrouve avec un écran noir et un prompt qui attend comme login "root" et son mot de passe.

Je suis maintenant au stade où je m'attaque à xorg et là, ça coince.

La commande indiquée dans le guide Arch est : pacman -Syu xorg-server xorg-xinit

Malheureusement, il s'en suit une ligne d'erreurs telle que celle-ci :

ERROR : failed retrieving file "extra.db" from "un quelconque des 10 miroirs" : could not resolve host "le miroir en question" et c'est ainsi pour tous les autres miroirs.

Si bien que je ne peux plus avancer.

On dirait qu'à ce stade, je n'ai pas de connexion internet mais je ne sais comment le vérifier, des commandes comme ifconfig -a (commande introuvable) ou ip link show (sans réponse) et ping qui ne reconnaît aucune destination (hormis 127.0.0.1 évidemment).

La lecture du guide Arch ne m'est d'aucune utilité.

Peut-être que toi ... ?



Modifié par Mimile le 22/07/2017 16:09
Publicité
Logicien
 Posté le 22/07/2017 à 16:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Tu vas peut-être devoir travailler en chroot sous Mint pour un moment. J'avais, à un second regard, oublié une commande dans mon premier message sur ma procédure de chroot

mount -o bind /dev /mnt/arch/dev

mount -o bind /proc /mnt/arch/proc

mount -o bind /sys /mnt/arch/sys

cp /etc/resolv.conf /mnt/arch/etc/

HOME=/root SHELL=/bin/bash USER=root chroot /mnt/arch

Il faut copier resolv.conf de Mint vers la Arch (ici la racine montée dans /mnt/arch, à toi de rectifier selon ce que tu fais) pour la résolution des noms de domaines en chroot. Pour avoir la commande ifconfig, il faut installer le paquet

pacman -S net-tools

Je t'avais dit dans mon premier message que pour avoir Internet dès le démarrage il faut que tu installes le paquet dhcpcd s'il ne l'est pas

pacman -S dhcpcd

et activer le service

systemctl enable dhcpcd.service

Avec ça, Dhcpcd lance une requête dhcp sur toutes les interfaces réseaux sauf lo. Ça devrait te donner accès à Internet via ta carte réseau Ethernet filiaire. Il est possible de configurer Dhcpcd plus finement mais, si après ce que je te dis tu n'as pas Internet en réel sous Arch, fais

systemctl restart dhcpcd.service

La commande ip appartient au paquet iproute2. Pour connaître les interfaces réseaux disponibles tu fais

ip link show

Pour connaître les adresses Ip de ces cartes, tu fais

ip addr show

Pour connaître le routage réseau, tu fais

ip route show



Modifié par Logicien le 22/07/2017 16:48
Mimile
 Posté le 23/07/2017 à 16:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Cher Paul,

Merci pour tes explications et indications parfaitement claires qui rencontrent des questions que j'avais précédemment posées et dont je vais m'empresser de conserver le contenu.

De mon côté, par je ne sais par quelle inspiration du saint-Esprit, j'ai réussi à activer ma connexion internet ce qui m'a permis de télécharger et installer xorg-server et xorg-xinit qui sont, selon le guide Arch les éléments de base pour accéder à la phase d'installation d'un écran graphique.

Je suis donc content dans la mesure où j'ai maintenant un accès à internet.

Mais, maintenant, je ne sais plus quoi faire.

J'ai tenté l'installation du module correspondant à ma carte nvidia (304 etc...) mais aucun résultat (j'avais indiqué "nouveau" dans les modules de mkinitcpio.conf

A ma grande déception, J'ai été trahi par mes obligations familiales qui m'ont privé de nombreuses heures dont je croyais pouvoir disposer pendant ce long week-end de 3 jours (fête nationale belge ce vendredi 21 juillet + samedi et dimanche).

Lassé de booter et rebooter d'arch vers Mint et vice et versa, dans un éclair de lucidité, je me suis dit que l'ordinosaure de mon épouse (15 ans ... euh le PC, pas ma chère et tendre) allait me permettre d'éviter de multiplier les allers-retours arch / mint et économiser mes DD. Effectivement, je lui ai installé W7 qui fonctionne correctement en mode sans échec (sinon, ça prend des heures avant que son PC s'éveille) avec possibilité de se connecter en internet.

Ca ne me coûte que quelques allers-retours (3 mètres - 60 pieds environ) de sa chambre à la mienne qui me sert de bureau (chambre à parts because mes ronflements insupportables (pour elle ... et quelques voisins proches ! )

Bref, j'en suis à un point où même le guide d'Arch ne m'est plus d'aucun secours.

Que dois-je faire pour enfin avoir un affichage graphique ?

Je suis d'autant plus contrarié que les premières fois que j'ai installé Arch (voici quelques années) - que ce soit en virtualbox ou en dur sur mon ancien PC, je n'ai pas le souvenir d'avoir rencontré autant de difficultés.

Je viens une fois de plus à toi en espérant une fois de plus un conseil pertinent.

Amicalement (comme d'habitude ...)

Logicien
 Posté le 23/07/2017 à 23:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Mimile,

le module nouveau de Linux va avec le module nouveau d'Xorg.

vesafb (qui est en dur dans le noyau Linux) ou le module uvesafb de Linux va avec le module nvidia d'Xorg.

Il ne faut pas mettre le module nouveau de Linux dans /etc/mkinitcpio.conf si tu utilises nvidia Xorg. Ces modules sont incompatibles entre eux. Tu dois utiliser vesafb avec Nvidia. Il faudrait même dans ce cas désactiver complètement le module nouveau de Linux pour permettre à vesafb de piloter l'affichage côté Linux.. C'est certain que le pilote d'affichage doit être fonctionnel avant de démarrer l'interface graphique et nouveau Linux avec nouveau Xorg est un bon début.

Je t'ai dit precédemment que la commande

pacman -S xorg xorg-apps xorg-drivers xorg-fonts

va installer tous les composants d'Xorg. Il ne te reste plus qu'à installer un environnement de bureau et un gestionnaire d'affichage. Passe en revue les groupes de paquets de la Arch avec la commande

pacman -Sg | less

et installe les groupes de paquets que tu veux. La Arch est la distribution Linux que je trouve la plus facile à administrer en lignes de commandes en autant qu'on la configure comme du monde. Parole de geek.

Note Mimile que depuis que j'ai une carte graphique Amd/Ati je n'ai eu aucun plantage et ce avec la Arch et VoidLinux que j'ai découvert récemment.

lspci

...

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Caicos [Radeon HD 6450/7450/8450 / R5 230 OEM]

...



Modifié par Logicien le 23/07/2017 23:59
Mimile
 Posté le 24/07/2017 à 16:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Merci, Cher Paul,

Encore une fois, des explications claires et une solution en vue.

Cela dit, après lecture de ta réponse : Petite question accessoire : penses-tu que le module "nouveau" soit plus performant que le pilote propriétaire nVidia (a priori celui qui devrait gérer ma carte graphique) attendu que selon ce que j'ai lu je ne sais plus où, le pilote de ma carte nVidia (204...) ne sera plus suivi à la fin de 2017.

On a encore du temps devant nous, mais clock is ticking (j'aime bien te titiller - gentiment - avec mes incursions dans ta langue nationale antagoniste () et j'aimerais avoir l'avis d'un vrai connaisseur comme toi à ce sujet.

Je me souviens d'un échange neutre (via mon PC) entre ton alter ego Arch (Benjarobin qui réagissait catégoriquement en affirmant que le pilote nVidia était de loin supérieur....)

Pour lui, le pilote nVidia était le meilleur, mais peut-être parlait-il à propos de cartes graphiques BEAUCOUP plus récentes que la mienne (01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 630] (rev a1)?

D'aussi loin que je me souvienne, tu m'as toujours orienté vers "nouveau" et je n'ai pas eu à m'en plaindre. En revanche, depuis que j'ai malencontreusement voulu jouer avec Arch en évacuant "nouveau" au profit de nVidia, mes problèmes ont commencé à apparaître ....

Il n'y a peut-être pas de relations de cause à effet mais quand même, j'ai des doutes.

Quoi qu'il en soit, je vais appliquer à la lettre les instructions de ton précédent message.

Sans doute pas aujourd'hui, vu que je suis vraiment à plat après une journée infernale ... et archi-pluvieuse ! (visibilité 30 mètres, essuie-glaces full speed complètement dépassés, camions à la queue-leu-leu soulevant des torrents d'eau à côté desquels les chutes du Niagara auraient pu passer pour des pipis de chats...)

Quoi qu'il en soit, je trouverais bien un moment creux pour exécuter tes lignes de commandes et ne manquerait pas de t'en faire retour.

Cordialement (.. tu connais mes habitudes )

Mimile


.



Modifié par Mimile le 24/07/2017 16:53
Logicien
 Posté le 24/07/2017 à 18:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Avec ma carte

01:00.0 VGA compatible controller: NVIDIA Corporation GK208 [GeForce GT 730] (rev a1)"

nouveau plantait périodiquement. Sous Debian j'ai installé les pilotes propriétaires Nvidia et ça merdait. Je n'ai pas cherché à résoudre le problème. J'ai changé pour une carte graphique Amd/Ati usagée. Je n'ai pas de problème encore après un bon moment.

Nvidia protège les fonctionnalités de ses cartes graphiques à ce que j'ai lu en vérifiant que la signature des pilotes utilisés est la sienne sinon certaines fonctions sont désactivées. Cela explique pourquoi les pilotes propriétaires Nvidia sont plus performants d'autant que nouveau est le fruit de l'ingénérie inverse (déduction du code source du microcode des chipsets Nvidia à partir des blobs (binaires à code source fermé). Peut-être que nouveau convient à ta carte Nvidia si tu n'as pas eu de problème avec. Nouveau est moins performant mais facile à mettre en oeuvre.

Tu te souviens peut-être de ce doigt d'honneur de Linus à Nvidia pour le manque de coopération de la compagnie avec Linux que j'ai déjà affiché ici et que j'aime bien revoir. Au fond c'est tout ce que je sais des rapports de Linux avec Nvidia. Ce n'est pas sympathique.

http://www.lessentiel.lu/dyim/ffb8b5/T786,384/images/content/1/5/0/15053439/2/teaserbreit.jpg



Modifié par Logicien le 24/07/2017 18:13
Mimile
 Posté le 25/07/2017 à 15:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Le doigt d'honneur : déclaration symbolique de guerre de Linus à nVidia ?

Bref, tu vas probablement te demander ce qui me prend.

Mais, je ne saisis pas bien ce que tu entends pas :

Il ne te reste plus qu'à installer un environnement de bureau et un gestionnaire d'affichage

Dis-moi si je me trompe :

environnement de bureau : gnome, KDE, Cinnamon (j'aime bien), XFce4, etc...

gestionnaire d'affichage : ??? gdm ? kdm ?

Je t'embête avec ces questions, mais, pour une raison que j'ignore, j'ai manifestement un trou de mémoire à leur sujet ...

Peut-être qu'Aloïs me guette (Alzheimer au cas où ).

Cordial... (non, je m'arrête pour cette fois).

Mimile

Logicien
 Posté le 25/07/2017 à 17:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

C'est ça Mimile tu n'as pas de trou de mémoire dans le cas d'un environnement de bureau (Cinnamon, Gnome, Kde, Lxde, Mate, Xfce4, etc) et d'un gestionnaire d'affichage (Entrance, Gdm, Kdm, Lightdm, Lxdm, Mdm, Slim, Xdm, etc).

Linus n'est pas un homme de guerre à ce que je sais de lui, il en est tout le contraire. Je pense qu'il est dépité face à Nvidia alors que plusieurs grosses entreprises ont fait des pas de géants face aux logiciels libres, Asus, Dell, Hp, Intel et d'autres encore. La coopération des entreprises privées avec les logiciels libres et vice-versa est un sujet intéressant.



Modifié par Logicien le 25/07/2017 17:43
Mimile
 Posté le 27/07/2017 à 14:38 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut Paul

J'ai suivi à la lettre (à partir de pacman -Sg) la marche à suivre que tu donnes ici https://forum.pcastuces.com/sujet.asp?page=-1&f=8&s=15486&REP_ID=5707452

Bien que je n'apprécie pas xfce4 - et pour ne pas partir à l'aventure, j'ai exécuté toutes les indications que tu y donnes.

A la fin, reboot : ecran noir avec le curseur de ma souris et au milieu une petite fenêtre avec mon nom d'user (okapi) et une demande mot de passe que je dois donner comme si mon clavier était anglais ( a =q, z = w, etc...).

Après cela, écran noir et PC freezé d'où obligation d'éteindre le PC à la barbare.

Où est l'erreur ?



Modifié par Mimile le 27/07/2017 14:39
Publicité
Logicien
 Posté le 27/07/2017 à 20:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Affiche la sortie des commandes

cat /proc/cmdline

dmesg | grep -i -e drm -e fb0

grep -v \# /etc/mkinitcpio.conf

pacman -Qs lightdm

pacman -Qs nvidia

systemctl get-default

systemctl status lightdm.service

systemctl --no-pager list-unit-files | grep -i lightdm



Modifié par Logicien le 27/07/2017 20:09
Mimile
 Posté le 28/07/2017 à 15:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Je ne demanderais pas mieux que de te fournir les réponses à ces différentes commandes mais pour ça encore eut-il fallu que je puisse les exécuter.

Or, le problème est que quand je démarre Arch, il freeze directement après que je lui aie fourni mon mot de passe.

Aucun tty accessible, clavier et souris inertes donc impossibilité de te fournir les réponses que tu attends et obligation d'un arrêt du PC à la barbare.

Je me suis dit : j'installe mon CD d'installation et je chroote dans Arch.

Problème : le montage préalable selon le guide d'installation d'Arch) n'aboutit pas après le cd /mnt

mount -t proc proc proc/
mount --rbind /sys sys/
mount --rbind /dev dev/

Réponse : les dossiers (proc sys dev n'existent pas).

Je me dis : tant pis : j'exécute chroot /mnt /bin/bash et à tout hasard, j'ai essayé tes commandes qui malheureusement échouent.

J'ai essayé nano /etc/mkinitcpio.conf et j'ai constaté qu'aucun module n'était indiqué (ni nouveau, ni nv) - une piste à creuser ?

Par contre, les hooks sont bien là : users et compagnie ...

les commandes pacman échouent en indiquant que les dépôts core, et cie étaient inaccessibles.

Je n'ai probablement pas d'accès internet malgré que j'aie exécuté cp /etc/resolv.conf /etc : réponse : les fichiers sont identiques

systemctl get-default renvoie : multi-users.target

Les autres (lightdm.service et la dernière .... no-pager) déclarent ne pas connaître lightdm...

Tout ça est évidemment foireux vu que, finalement, je ne sais même pas exécuter quoi que ce soit.

Bref, à moins que tu aies une de tes miraculeuses suggestions, je pense n'avoir d'autre choix que de reprendre tout depuis le début.

Bien à toi (ça change, hein ? )

Mimile



Modifié par Mimile le 28/07/2017 15:35
Logicien
 Posté le 28/07/2017 à 16:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Je ne sais que dire Mimile. Si ta Debian, dérivée en Ubuntu, elle-même dérivée en Mint (à moins que tu utilises la version Debian de Mint) fonctionne bien, je ne vois aucune raison pour que la Arch ne fonctionne pas bien avec le même matériel. Peut-être serait-il bon pour toi d'installer Antergos, elle est basée sur la Arch et a une interface d'installation à ce que je sais. Je pense que la ligne de commandes n'est pas pour toi, du moins pour installer un système.

De mon côté je pense avoir résolu un problème intermitent avec Xfce4. À l'ouverture de la session je me retrouvais avec un bureau sans fond d'écran et sans icônes. Je pensais que c'était Thunar qui gérait le bureau mais non, il y a une application dédiée au bureau, Xfdesktop. Elle n'est pas toujours lancée avec la session d'où le problème. Il s'agit de sauvegarder sa session à la fermeture avec Xfdesktop actif pour qu'il soit lancé lors de la prochaine session. Que de recherches stériles à gauche et à droite, de reconfigurations du bureau à partir de zéro pour une solution facile. Une mauvaise compréhension du bureau Xfce4 de ma part qui a fait traîner le problème pendant longtemps.

Avec Linux, il faut être en mode solution si on ne veut pas avoir que des maux de têtes. Enfin, d'une distribution à l'autre ce sont les mêmes problèmes que je constate qui se manifestent. Il ne faut pas procrastiner pour les résoudre sinon, c'est comme le suplice de la goutte quand par exemple, un service prend 1 minute et 30 secondes pour se lancer ou s'arrêter avec Systemd ou quand Pulseaudio ne fonctionne pas ou encore une erreur de segmentation d'une application. Linux me rend triste parfois.

Je pense que ça prend un ordinateur pour travailler et un autre pour résoudre les problèmes sinon, le système ne fonctionne qu'entre les tests, les redémarrages, etc. Avec les logicels libres nous sommes des béta testeurs à bien des égards même avec les versions stables. Le bon côté est qu'à la fin on sait quelque chose. Vaut mieux moins mais mieux Mimile. J'utilise presque toujours les mêmes distributions et logiciels. J'en connais moins mais mieux si je ne fais pas de stupidité.



Modifié par Logicien le 28/07/2017 16:46
Mimile
 Posté le 29/07/2017 à 13:05 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Cher Paul,

Aussi incroyable que cela puisse paraître (à tes yeux), j'ai enfin une Arch qui fonctionne avec xfce4 comme environnement de bureau.

A ce stade, elle est un peu désertique par rapport à ma précédente Arch, mais je m'acharne et tel un pitt-bull, je ne lacherai jamais ma proie ...

Je dois dire qu'à ce stade, il me reste encore à configurer mon clavier (qui est en qwerty) et mon écran encore que l'affichage soit très correct (nouveau).

Hier, quand je t'ai rapporté que mon écran restait noir après avoir donné mon mot de passe, je me suis souvenu que, finalement, j'avais choisi gnome comme WM au lieu de XFCE4 que je n'aime pas du tout.

Quoi qu'il en soit, je ne vois pas pourquoi lightdm.service ne l'a pas lancé.

Comme je n'apprécie pas du tout XFCE4, penses-tu que je puisse -sans tout casser - changer de WM à ce stade au profit - par exemple - de Cinnamon qui a ma préférence ?

Merci de me donner ton avis.

Cordialement

Mimile

EDIT : J'ai ajouté à /etc/X11/xorg.d un fichier 10-keyboard.layout.conf qui, logiquement devrait faire passer mon clavier qwerty en azerty belge mais, ça n'a aucun effet.

Il est facile de se souvenir que telle touche qwerty correspond à une touche azerty (exemple a = q, w = z, etc...) mais pour ce qui est de signes comme ", il faut se souvenir que c'est maj + ù, etc...

J'ai cherché sur le net mais sans résultat à l'arrivée.

Une idée ?



Modifié par Mimile le 29/07/2017 15:02
Logicien
 Posté le 29/07/2017 à 15:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Je savais que tu n'abandonnerais pas la Arch même pour une de ses dérivées que je te proposais. C'était pour te mettre au défi pour te stimuler à résoudre les problèmes de la Arch.

Une distribution GNU/Linux se divise entre l'affichage qui est géré par le noyau Linux dans les terminaux virtuels (les ttyx) et l'affichage qui est géré par Xorg en mode graphique. Configurer le clavier et les polices de caractères d'un bureau n'a pas d'effet sur le clavier et les polices des terminaux virtuels. Il faut tout configurer en double de ce côté. Les préférences du bureau te permettent de le faire pour le mode graphique. Pour les terminaux virtuels il y a la commande localectl qui permet de définir les locales par défaut de tout le système et le jeu de caractères côté Linux et Xorg. La commande hostnamectl permet de donner un nom à l'ordinateur.

Si Lightdm t'offre de démarrer Gnome ça doit être parce-que Xfce4 dépend de certains composants de Gnome. Mais tant que tu n'installes pas les paquets du groupe gnome et facultativement du groupe gnome-extra tu ne pourras pas ouvrir une session Gnome avec n'importe quel gestionnaire d'affichage.

pacman -S gnome gnome-extra

De la même manière, pour pouvoir démarrer Cinnamon tu dois installer le paquet cinnamon qui n'est pas un groupe de paquets mais qui installe toutes les dépendances requises.

pacman -S cinnamon

Après cela, tu fermes ta session Xfce4 si elle est ouverte sinon, si Lightdm ne t'offre pas le choix de Gnome, Cinnamon et Xfce4, tu fais dans un terminal virtuel

systemctl restart lightdm.service

Litghtdm devrait t'offrir le choix de démarrer Cinnamon ou Gnome en plus d'Xfce4 et là, comme tous les composants sont installés, la session devrait s'ouvrir correctement.



Modifié par Logicien le 29/07/2017 15:17
Mimile
 Posté le 29/07/2017 à 15:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Merci Paul,

Je dois dire que ta précédente réponse m'avait un peu peiné.

C'est pourquoi, dès ce matin, j'ai retroussé mes manches, allumé le PC de ma femme (ce qui me dispense de faire des allers-retours Arch/Mint), repris les différentes réponses que tu m'as fournies au long de cet interminable poste et j'ai fait un melting-pot de tout ce que j'avais noté et imprimé).

Bon, finalement, je me bat avec XFCE4 que j'ai enfin pu mettre en français, mon écran est configuré après avoir examiné le résultat de cvt.

Bref, tout commence à se mettre en place.

Au passagé, je suis effaré de la vitesse avec laquelle des programmes lourds (comme firefox et thunderbird notamment) démarrent.

Cela dit, je ne me fais pas trop d'illusions : XFCE4 en est encore à son bas âge et use très peu de mémoire et de CPU.

Je vais installé Conky qui va m'en dire plus.

Pour ce qui est des autres environnement, je vais encore un peu attendre (Chat échaudé craint l'eau froide).

XFCE4 fonctionne et c'est déjà pour moi une victoire (que je te dois en grande partie vu que le guide d'Arch est un peu réducteur.

Je continue ...

Bien à toi

Mimile

Mimile
 Posté le 30/07/2017 à 12:39 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour Paul,

Je te sollicite pour deux problèmes que je n'arrive pas à résoudre malgré de longues recherches sur le net :

1°) au démarrage, je dois encoder mon mot de passe en le convertissant en qwerty (a = q, z = w) alors qu'une fois ma session démarrée tout est bien en azerty. Aurais-tu une idée pour résoudre ce petit problème (peu gênant, je l'admets).

2°) j'ai installé gnome et gnome-extra ainsi que cinnamon. L'écran de démarrage me permet de choisir celui de mon choix MAIS : si je choisis gnome, après entrée de mon mot de passe : écran noir et PC freezé. Si je choisis cinnamon, message : cinnamon a planté. voulez-vous réessayer ? si oui, le même message réapparaît, si non, écran noir comme gnome.

Heureusement, si j'opte pour xfce, ma session démarre normalement.

Serait-ce dû à lightdm qui ne convient au démarrage des sessions gnome et/ou cinnamon ? ne faudrait-il pas utiliser gdm ?

Tu me diras que je n'ai qu'à essayer mais tu comprendras que je marche sur des oeufs vu les difficultés que j'ai rencontrées hier pour mettre une arch en route.

Je ne voudrais pas tout bousiller pour devoir tout recommencer.

Merci d'avance pour ton avis.

Mimile

Logicien
 Posté le 30/07/2017 à 18:38 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Je pense que tu n'as pas défini tes locales pour le système et par conséquent tu n'as pas le clavier belge côté Linux mais US. C'est pourquoi Lightdm est en qwerty. Tout d'abord, il faut compiler les locales qu'on souhaite utiliser. Sous la Arch elles ne le sont pas d'avance. Tu dois éditer le fichier de la glibc /etc/locale.gen . Ce fichier ne peut pas ne pas exister car il appartient à la Glibc qui est installée avec le système de base. Toutes les locales de ce fichier sont commentées par défaut. Si tu entend n'utiliser que les locales belges alors décommente les lignes

fr_BE.UTF-8 UTF-8
fr_BE ISO-8859-1
fr_BE@euro ISO-8859-15

Sauvegarde les modifications puis fait

locale-gen

Cette commande va compiler les locales belges et tu pourras les utiliser. Ensuite, tu dois configurer les locales belges pour tout le système. Édite ou crée le fichier /etc/locale.conf pour n'avoir que les lignes suivantes

LANG=fr_BE.utf8
LANGUAGE=fr_BE:fr
LC_CTYPE=fr_BE.utf8
LC_NUMERIC=fr_BE.utf8
LC_TIME=fr_BE.utf8
LC_COLLATE=fr_BE.utf8
LC_MONETARY=fr_BE.utf8
LC_MESSAGES=fr_BE.utf8
LC_PAPER=fr_BE.utf8
LC_NAME=fr_BE.utf8
LC_ADDRESS=fr_BE.utf8
LC_TELEPHONE=fr_BE.utf8
LC_MEASUREMENT=fr_BE.utf8
LC_IDENTIFICATION=fr_BE.utf8

Sauvegarde les modifications. Édite ou crée le fichier /etc/vconsole.conf pour n'avoir que ces lignes

FONT=ter-v18b
KEYMAP=be

Cela te donne le clavier belge à la console et les polices terminus-font , mes préférées dans les teminaux Linux. Si tu les trouves trop grosses ou trop petites tu peux changer 18 pour 16 ou 20 dans vconsole.conf. Mais il faut les installer pour pouvoir les utiliser

pacman -S terminus-font

Tu peux si ce n'est pas fait définir le clavier belge pour X11 avec la commande

localectl set-x11-keymap be

Cela te donne le clavier belge avec tout environnement de bureau sans plus de configuration. Tu dois aussi te définir un nom d'hôte, par exemple

hostnamectl set-hostname mimile

À toi de choisir le nom qui te convient. Normalement Lightdm devrait reconnaître le clavier belge. Lightdm ne m'a jamais posé de problème à démarrer quelqu'environnement de bureau que ce soit. Mais si tu veux passer à Gdm, fait ce qui suit, Gdm doit être installé si tu as installé le groupe de paquets gnome:

systemctl disable lightdm.service

systemctl enable gdm.service

En ce qui concerne l'écran noir, si tu comptes n'utiliser que nouveau c'est mieux de désinstaller les pilotes propriétaires Nvidia complètement.

pacman -cnR nvidia

Assure-toi que tu as le module nouveau dans /etc/mkinitcpio.conf .

MODULES="nouveau"

Sauvegarde et fait sans faute

mkinitcpio -p linux

Fait ces étapes minutieusement en suivant mes instructions et redémarre pour voir si tout est correct.



Modifié par Logicien le 31/07/2017 01:26
Mimile
 Posté le 31/07/2017 à 16:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut Paul

Merci pour cette nouvelle intervention de ta part.

Cela dit :

En ce qui concerne locale.gen, le contenu a été créé pendant l'installation d'Arch et correspond exactement à ce que tu montres

fr_BE.UTF-8 UTF-8
fr_BE ISO-8859-1
fr_BE@euro ISO-8859-15

En revanche, locale.conf ne contenait que : LANG=fr_BE.utf8

J'y ai ajouté les valeurs que tu indiques :

LANGUAGE=fr_BE:fr
LC_CTYPE=fr_BE.utf8
LC_NUMERIC=fr_BE.utf8
LC_TIME=fr_BE.utf8
LC_COLLATE=fr_BE.utf8
LC_MONETARY=fr_BE.utf8
LC_MESSAGES=fr_BE.utf8
LC_PAPER=fr_BE.utf8
LC_NAME=fr_BE.utf8
LC_ADDRESS=fr_BE.utf8
LC_TELEPHONE=fr_BE.utf8
LC_MEASUREMENT=fr_BE.utf8
LC_IDENTIFICATION=fr_BE.utf8

En ce qui concerne mon clavier, il est en azerty belge depuis que j'ai ajouté 10-keyboard à X11 :

[okapi@archie ~]$ cat /etc/X11/xorg.conf.d/10-keyboard-layout.conf
Section "InputClass"
Identifier "Keyboard Layout"
MatchIsKeyboard "yes"
Option "XkbLayout" "be"
Option "XkbVariant" "latin9"
EndSection

Mon hostname est - comme tu le sais - okapi qui a été fixé lors du adduser que j'ai fait conformément à tes instructions.

Preuve en est que, lorsque j'ouvre un terminal, j'ai :

[okapi@archie ~]$

(archie étant le nom de mon ancienne arch et dont j'ai voulu garder un souvenir ému )

Cela dit, le module en place est "nouveau" et mes hooks sont :

MODULES="nouveau"

...

HOOKS="base udev autodetect modconf block filesystems keyboard fsck"

En ce qui concerne vconsole.conf, il ne contenait que KEYMAP=fr_BE.UTF-8

Je l'ai modifié comme tu l'indiques :

FONT=ter-v18b
KEYMAP=be

Je vais voir ce que donne la fonte terminus ...

Pour l'heure, je peux te dire que à tous les stades de ma session, j'avais un clavier français belge qui ne me posait aucun problème.

Le seul que je voudrais résoudre, c'est mettre le clavier en azerty au démarrage, au moment d'introduire mon mot de passe (qui contient un "a" et un "z"., ce qui me contraint à les convertir en "q" et "w" (il y a d'autres lettres qui ne posent pas problème et des chiffres (idem).

L'autre problème - plus gênant - est que lighdm ne lance que xfce4, gnome et connamon donnant un écran noir et un PC totalement inerte.

C'est pourquoi, j'ai évoqué l'hypothèse que lightdm ne convenait pas à ces WM.

Pour le fun, je vais jeté un coup d'oeil sur ce que donne la fonte terminus ...

Je reviens asap.

RETOUR après 2 essais.

les caractères des lignes de démarrage sont, dans un premier temps, ceux que j'avais auparavant.

A un moment, donné, ils passent effectivement sous une autre forme qui est celle que tu apprécies (terminus) et qui, je l'admets, sont plus élégants.

Mais, par la suite, en session, aucun changement : toujours la fonte du début et ta fonte terminus est inactive.

Je modifie la valeur 18 > 16 (dans vconsole.conf) et je reboote.

Et là, plus aucune manifestation de la fonte terminus pendant le boot, ni après.

Où est l'erreur que j'ai commise ?

PS quid du dilemne lighdm/gdm ?



Modifié par Mimile le 31/07/2017 16:30
Publicité
Pages : [1] 2 3 ... Fin
Page 1 sur 3 [Fin]

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Archlinux : pb installation fontes Ubuntu
installation archlinux
Archlinux : pb DHCP à l'installation
Installation distribution sur nouvelle machine
nouvelle installation légère de linux
Archlinux : quelques progrès mais besoin d'aide
Problème avec Cinnamon sur Archlinux
[requiescat in pace] archlinux
Ecran noir au début de l'installation
ArchLinux et le problème de libharfbuzz avec infinality ?!
Plus de sujets relatifs à Archlinux : nouvelle installation problématique (résolu ... presque)
 > Tous les forums > Forum Linux