> Tous les forums > Forum Linux
 Archlinux : Plus de son dans les écouteurs
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
rodak
  Posté le 25/06/2019 @ 13:17 
Aller en bas de la page 
Petit astucien

Bonjour,

J'ai lu le fil suivant, sur ce même forum : Archlinux : plus de son ! avec intérêt car il m'arrive un problème assez similaire (disons que ça fait quelque temps que je cherche et que c'est le problème le plus proche du mien), mais sans qu'il aboutisse positivement de mon côté.

À la suite d'une mise à jour que je ne saurais dater (le problème date d'il y a un peu moins d'un an je dirais), je n'ai plus de son dans les écouteurs ou dans les enceintes que je branche à mon ordi sous Archlinux. Le son fonctionne sur les enceintes, je branche les écouteurs qui sont reconnus, mais dont aucun son ne sort. Et (j'ai l'impression, peut-être fausse, que les deux problèmes sont liés) je n'arrive pas à relier ma chaîne audio en Bluetooth sur mon Archlinux.

Je précise que les deux opérations (brancher les écouteurs et relier la chaîne en Bluetooth) fonctionnent parfaitement sur l'autre OS que j'ai installé sur mon PC (un Dell Inspiron), une Debian 9.

Le problème est survenu à la suite d'une mise à jour ; j'ai essayé de faire un downgrade pour revenir à l'état d'avant mais j'ai été bloqué par un problème de dépendance (pour la version de février) et je n'ai pas osé désinstaller les paquets correspondants pour pouvoir continuer. De mémoire, c'est au moment d'une mise à jour d'alsa ou de jack remplacé par jack2, mais je n'en ai pas la certitude absolue.

lspci donne ceci :

[antoine@arch ~]$ lspci -nn | grep -i audio
00:03.0 Audio device [0403]: Intel Corporation Haswell-ULT HD Audio Controller [8086:0a0c] (rev 0b)
00:1b.0 Audio device [0403]: Intel Corporation 8 Series HD Audio Controller [8086:9c20] (rev 04)

pacmd dump donne ceci (je ne sais pas vraiment l'interpréter) :

[antoine@arch ~]$ pacmd dump
### Configuration dump generated at Tue Jun 25 12:36:47 2019

load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore
load-module module-augment-properties
load-module module-switch-on-port-available
load-module module-udev-detect
load-module module-alsa-card device_id="1" name="pci-0000_00_03.0" card_name="alsa_card.pci-0000_00_03.0" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes card_properties="module-udev-detect.discovered=1"
load-module module-alsa-card device_id="0" name="pci-0000_00_1b.0" card_name="alsa_card.pci-0000_00_1b.0" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes card_properties="module-udev-detect.discovered=1"
load-module module-bluetooth-policy
load-module module-bluetooth-discover
load-module module-bluez5-discover
load-module module-dbus-protocol
load-module module-esound-protocol-unix
load-module module-native-protocol-unix
load-module module-gsettings
load-module module-default-device-restore
load-module module-rescue-streams
load-module module-always-sink
load-module module-intended-roles
load-module module-suspend-on-idle
load-module module-console-kit
load-module module-systemd-login
load-module module-position-event-sounds
load-module module-role-cork
load-module module-filter-heuristics
load-module module-filter-apply
load-module module-x11-publish display=:0.0
load-module module-x11-xsmp display=:0.0 session_manager=local/arch:@/tmp/.ICE-unix/663,unix/arch:/tmp/.ICE-unix/663
load-module module-cli-protocol-unix

set-sink-volume alsa_output.pci-0000_00_1b.0.analog-stereo 0x3851
set-sink-mute alsa_output.pci-0000_00_1b.0.analog-stereo yes
suspend-sink alsa_output.pci-0000_00_1b.0.analog-stereo yes

set-source-volume alsa_output.pci-0000_00_1b.0.analog-stereo.monitor 0x10000
set-source-mute alsa_output.pci-0000_00_1b.0.analog-stereo.monitor no
suspend-source alsa_output.pci-0000_00_1b.0.analog-stereo.monitor yes
set-source-volume alsa_input.pci-0000_00_1b.0.analog-stereo 0x10004
set-source-mute alsa_input.pci-0000_00_1b.0.analog-stereo yes
suspend-source alsa_input.pci-0000_00_1b.0.analog-stereo yes

set-card-profile alsa_card.pci-0000_00_03.0 off
set-card-profile alsa_card.pci-0000_00_1b.0 output:analog-stereo+input:analog-stereo

set-default-sink alsa_output.pci-0000_00_1b.0.analog-stereo
set-default-source alsa_output.pci-0000_00_1b.0.analog-stereo.monitor

### EOF

le contenu de ~/.asoundrc :

[antoine@arch ~]$ more ~/.asoundrc
# réglage de la carte son par défaut, selon la commande « aplay -l », card = car
te et device = périphérique
defaults.pcm.card 0
defaults.pcm.device 0
defaults.ctl.card 0
#
# # fréquence d'échantillonnage
defaults.pcm.dmix.rate 44100
#
# # algorithme de re-échantillonnage
defaults.pcm.rate_converter "samplerate_best"

et Pulseaudio est bien actif :

[antoine@arch ~]$ ps aux | grep pulseaudio
antoine 674 0.6 0.3 2682112 14048 ? S<sl 10:27 0:49 /usr/bin/pulseaudio --daemonize=no
antoine 728 0.1 1.2 878804 47768 ? Sl 10:27 0:10 /usr/lib/xfce4/panel/wrapper-2.0 /usr/lib/xfce4/panel/plugins/libpulseaudio-plugin.so 2 12582953 pulseaudio Greffon PulseAudio Ajuster le volume du système audio PulseAudio
antoine 2184 0.0 0.0 6288 2296 pts/0 S+ 12:40 0:00 grep pulseaudio

Avec alsamixer (ou pavucontrol), je vois que les sorties audio ne sont pas silencieuses. Le problème ne vient pas de là. Autre commande :

[antoine@arch ~]$ aplay -l
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: PCH [HDA Intel PCH], périphérique 0: ALC3234 Analog [ALC3234 Analog]
Sous-périphériques: 1/1
Sous-périphérique #0: subdevice #0
carte 1: Generic1 [HDA Intel HDMI], périphérique 3: HDMI 0 [HDMI 0]
Sous-périphériques: 1/1
Sous-périphérique #0: subdevice #0
carte 1: Generic1 [HDA Intel HDMI], périphérique 7: HDMI 1 [HDMI 1]
Sous-périphériques: 1/1
Sous-périphérique #0: subdevice #0
carte 1: Generic1 [HDA Intel HDMI], périphérique 8: HDMI 2 [HDMI 2]
Sous-périphériques: 1/1
Sous-périphérique #0: subdevice #0
carte 1: Generic1 [HDA Intel HDMI], périphérique 9: HDMI 3 [HDMI 3]
Sous-périphériques: 1/1
Sous-périphérique #0: subdevice #0
carte 1: Generic1 [HDA Intel HDMI], périphérique 10: HDMI 4 [HDMI 4]
Sous-périphériques: 1/1
Sous-périphérique #0: subdevice #0

ou encore :

[antoine@arch ~]$ ls -alR /dev/snd
/dev/snd:
total 0
drwxr-xr-x 3 root root 320 25 juin 10:27 .
drwxr-xr-x 21 root root 3800 25 juin 11:11 ..
drwxr-xr-x 2 root root 80 25 juin 10:27 by-path
crw-rw----+ 1 root audio 116, 5 25 juin 10:27 controlC0
crw-rw----+ 1 root audio 116, 12 25 juin 10:27 controlC1
crw-rw----+ 1 root audio 116, 4 25 juin 10:27 hwC0D0
crw-rw----+ 1 root audio 116, 11 25 juin 10:27 hwC1D0
crw-rw----+ 1 root audio 116, 3 25 juin 10:27 pcmC0D0c
crw-rw----+ 1 root audio 116, 2 25 juin 11:03 pcmC0D0p
crw-rw----+ 1 root audio 116, 10 25 juin 10:27 pcmC1D10p
crw-rw----+ 1 root audio 116, 6 25 juin 10:27 pcmC1D3p
crw-rw----+ 1 root audio 116, 7 25 juin 10:27 pcmC1D7p
crw-rw----+ 1 root audio 116, 8 25 juin 10:27 pcmC1D8p
crw-rw----+ 1 root audio 116, 9 25 juin 10:27 pcmC1D9p
crw-rw----+ 1 root audio 116, 1 25 juin 10:27 seq
crw-rw----+ 1 root audio 116, 33 25 juin 10:27 timer

/dev/snd/by-path:
total 0
drwxr-xr-x 2 root root 80 25 juin 10:27 .
drwxr-xr-x 3 root root 320 25 juin 10:27 ..
lrwxrwxrwx 1 root root 12 25 juin 10:27 pci-0000:00:03.0 -> ../controlC1
lrwxrwxrwx 1 root root 12 25 juin 10:27 pci-0000:00:1b.0 -> ../controlC0

et aussi :

[antoine@arch ~]$ id antoine
uid=1000(antoine) gid=1000(antoine) groupes=1000(antoine),96(scanner),991(lp),985(users),108(vboxusers),1001(sudoers)

Sinon quand je teste alsamixer, j'obtiens

[antoine@arch ~]$ alsamixer -c 0

┌────────────────────────────── AlsaMixer v1.1.9 ──────────────────────────────┐
│ Carte: HDA Intel PCH F1: Aide │
│ Puce: Realtek ALC3234 F2: Informations Système │
│ Vue: F3:[Lecture] F4: Capture F5: Tout F6: Choisir la carte son │
│ Contrôle: Master [gain dB: 0,00] Esc: Quitter │
│ │
│ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ │
│ │▒▒│ │▒▒│ │▒▒│ │ │ │ │ │▒▒│ │ │ │
│ │▒▒│ │▒▒│ │▒▒│ │ │ │ │ │▒▒│ │ │ │
│ │▒▒│ │▒▒│ │▒▒│ │ │ │ │ │▒▒│ │ │ →
│ │▒▒│ │▒▒│ │▒▒│ │ │ │ │ │▒▒│ │ │ →
│ │▒▒│ │▒▒│ │▒▒│ │ │ │ │ │▒▒│ │ │ →
│ │▒▒│ │▒▒│ │▒▒│ │ │ │ │ │▒▒│ │ │ →
│ │▒▒│ │▒▒│ │▒▒│ │ │ │ │ │▒▒│ │ │ →
│ │▒▒│ │▒▒│ │▒▒│ │ │ │ │ │▒▒│ │ │ →
│ │▒▒│ │▒▒│ │▒▒│ │ │ │ │ │▒▒│ │ │ →
│ │▒▒│ │▒▒│ │▒▒│ │ │ │ │ │▒▒│ │ │ │
│ │▒▒│ │▒▒│ │▒▒│ │ │ │ │ │▒▒│ │ │ │
│ ├──┤ ├──┤ ├──┤ └──┘ ├──┤ └──┘ Follow M ├──┤ │
│ │OO│ │OO│ │MM│ │MM│ │MM│ │
│ └──┘ └──┘ └──┘ └──┘ └──┘ │
│ 100 100<>100 100<>100 0<>0 0<>0 100<>100 0<>0 │
│ < Master >Headphon Headphon Headphon Speaker PCM Mic Mute Beep │
└──────────────────────────────────────────────────────────────────────────────┘

et

[antoine@arch ~]$ alsamixer -c 1

┌────────────────────────────── AlsaMixer v1.1.9 ──────────────────────────────┐
│ Carte: HDA Intel HDMI F1: Aide │
│ Puce: Intel Haswell HDMI F2: Informations Système │
│ Vue: F3:[Lecture] F4: Capture F5: Tout F6: Choisir la carte son │
│ Contrôle: S/PDIF Esc: Quitter │
│ │
│ │
│ │
│ │
│ │
│ │
│ │
│ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ │
│ │OO│ │OO│ │OO│ │OO│ │OO│ │
│ └──┘ └──┘ └──┘ └──┘ └──┘ │
│ < S/PDIF >S/PDIF 1 S/PDIF 2 S/PDIF 3 S/PDIF 4 │
│ │
│ │
│ │
│ │
│ │
│ │
│ │
└──────────────────────────────────────────────────────────────────────────────┘

Dernière chose : dans mon fichier alsa-base.conf, on trouve :

[antoine@arch ~]$ more /etc/modprobe.d/alsa-base.conf
options snd-hda-intel id=Generic_1 index=1 snd slots=snd-hda-intel,snd-usb-audio

Après, comme une bonne partie des retours que j'ai sonnent un peu comme des formules vaudou pour moi, il y a peut-être (sans doute) un truc tout bête...

Enfin, pour le bluetooth, je vais dans bluetoothctl, je mets le contrôleur sous tension et j'essaye de connecter ma chaîne :

[bluetooth]# connect 51:59:33:D6:05:FE
Attempting to connect to 51:59:33:D6:05:FE
[CHG] Device 51:59:33:D6:05:FE Connected: yes
Failed to connect: org.bluez.Error.Failed
[CHG] Device 51:59:33:D6:05:FE Connected: no

Et dans le journal de systemctl (dont j'ai oublié la commande) il me mettait "too many loops" (donc il doit tester, ne pas y arriver et laisser tomber).

Si quelqu'un a des idées de manips qui pourraient m'aider à m'en sortir, je vous en serais éternellement reconnaissant !

Publicité
Logicien
 Posté le 25/06/2019 à 17:13 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut Bonjour,

j'utilise Blueman pour les connections Bluetooth. C'est plus convivial que Bluetoothctl, surtout si tu dois entrer un code pin pour apparier les deux appareils, ordi et enceintes. Il est important de comprendre que les appareils audios Bluetooth peuvent s'apparier comme les autres appareils Bluetooth mais que Pulseaudio est nécessaire pour permettre à ces appareils pour se connecter à une distribution Linux.

Il faut que le paquet pulseaudio-bluetooth soit installé pour que l'audio Bluetooth fonctionne. Pour le reste il faut que le service Bluetooth soit démarré autant que Pulseaudio. Sous ma Arch, je n'ai pas de configuration specifique à faire. En général Pulseaudio est démarré automatiquement avec la session graphique de l'utilisateur mais le service Bluetooth doit être activé pour être démarré automatiquement.

Lorsque les enceintes Bluetooth sont appariées et connectées à la Arch, Pavucontrol sous l'onglet Configuration affiche les périphériques audios. Pour en choisir un plutôt qu'un autre j'éteint tous les autres périphériques sauf celui que je veux utiliser. La sortie audio utilise de force le seul qui reste activé. Il faut s'assurer que le péripĥérique utilise le bon profil et qu'il n'est pas muet.

Dbus s'insère dans le processus d'appariement et de connection et il faut parfois redémarrer le service Bluetooth et la session graphique pour que Dbus et Pulseaudio soient redémarrés correctement.

Si on veut avoir un périphérique audio qui envoi la sortie audio sur tous les périphériques physiques de sorties audios, on peut le créer avec l'interface Paprefs, paprefs en ligne de commande.

Alsa a pour tâche de piloter les périphiques audios non Bluetooth et Pulseaudio d'être le serveur de son des tous les périphériques audios. Alsamixer n'est pas nécessaire. Pavucontrol fait tout.

Un utilisateur normal n'a pas besoin d'être dans un groupe spécifique pour que l'audio fonctionne, même pas dans le groupe audio ou lp. C'est déconseillé. J'ai des écouteurs et un clavier Bluetooth. Je réussi à les utiliser mais je ne sais pas si le microphone Bluetooth des écouteurs fonctionne. Je n'ai pas essayé de les utiliser.



Modifié par Logicien le 25/06/2019 17:35
rodak
 Posté le 25/06/2019 à 19:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Merci pour ta réponse. Je ne sais pas si tu as compris (c'est vrai que mon message ne le précise pas, du coup ça pourrait paraître ambigu), mais le problème de bluetooth et le problème d'écouteurs sont deux problèmes distincts (qui me paraissent liés, mais c'est juste une intuition). Les écouteurs sont branchés physiquement à l'ordi, avec un fil, sont reconnus mais aucun son n'en sort. Sinon pour répondre à ton message :

- pulseaudio-bluetooth est bien installé

- le service bluetooth est bien démarré. Voilà ce que donne un appel à systemctl :

[root@arch antoine]# systemctl status bluetooth

● bluetooth.service - Bluetooth service
Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
Active: active (running) since Tue 2019-06-25 16:19:01 CEST; 3h 17min ago
Docs: man:bluetoothd(8)
Main PID: 517 (bluetoothd)
Status: "Running"
Tasks: 1 (limit: 4612)
Memory: 2.2M
CGroup: /system.slice/bluetooth.service
└─517 /usr/lib/bluetooth/bluetoothd

juin 25 16:19:28 arch bluetoothd[517]: Endpoint registered: sender=:1.76 path=/MediaEndpoint/A2DPSource
juin 25 16:19:28 arch bluetoothd[517]: Endpoint registered: sender=:1.76 path=/MediaEndpoint/A2DPSink
juin 25 17:56:06 arch bluetoothd[517]: connect error: Permission denied (13)
juin 25 17:56:12 arch bluetoothd[517]: connect error: Permission denied (13)
juin 25 17:58:06 arch bluetoothd[517]: connect error: Permission denied (13)
juin 25 17:58:11 arch bluetoothd[517]: connect error: Too many levels of symbolic links (40)
juin 25 17:58:18 arch bluetoothd[517]: connect error: Permission denied (13)
juin 25 17:58:24 arch bluetoothd[517]: connect error: Too many levels of symbolic links (40)
juin 25 17:59:08 arch bluetoothd[517]: connect error: Permission denied (13)
juin 25 17:59:13 arch bluetoothd[517]: connect error: Too many levels of symbolic links (40)

et blueman ne fonctionne pas mieux que bluetoothctl (malgré la plus grande facilité d'utilisation). Quand j'essaye d'installer mon enceinte, il me répond "Périphérique ajouté, mais échec de la connexion". Donc pavucontrol ne m'y donne même pas accès (sinon, me connaissant, je pense que j'aurais bidouillé pour le faire fonctionner comme je l'ai fait sous Debian). Et quand je branche les écouteurs, pavucontrol bascule sur la sortie écouteurs qui semble fonctionner normalement... sauf qu'aucun son n'en sort.

Logicien
 Posté le 25/06/2019 à 21:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Il y a des périphériques Bluetooth sous Linux qui demandent des fichiers microcodes (firmwares) au démarrage pour fonctionner. Connais-tu la marque et le modèle du Bluetooth de ta Arch? Si ça fonctionne sous Debian, ça devrait fonctionner sous la Arch.

Le problème ne semble pas être là mais le service Bluetooth dit qu'il y a problème de permissions. Avec une distribution Linux dont j'ai oublié le nom j'ai été obligé de mettre mon utilisateur dans le groupe lp pour qu'il puisse utiliser le Bluetooth. Dbus permet à ceux qui sont dans le groupe lp d'utiliser les imprimantes Bluetooth.

Tu peux essayer ça et essayer de te connecter en root pour le Bluetooth. Pulseaudio ne prend en charge les périphériques audio Bluetooth qu'après qu'ils soient appariés et connectés à la Arch. Le service Bluetooth pointe clairement un problème de connection et non pas d'appariement. C'est une information importante. Tu peux aussi examiner les logs de Pulseaudio voir ceux du noyau Linux (dmesg) et du journal de Systemd (journalctl -b).

Quel est le type d'ordinateur sur lequel tourne la Arch? Je part pour plusieurs heures.



Modifié par Logicien le 25/06/2019 22:02
rodak
 Posté le 27/06/2019 à 11:52 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Pas de problème, je n'ai moi-même pas toujours beaucoup de temps et c'est le cas en ce moment...

J'ai vu sur le wiki d'archlinux qu'il était possible d'apparier le bluetooth audio avec le paquet bluez-alsa, qui se trouve dans AUR. Or (!) il se trouve que j'ai jusqu'ici réussi à installer une arch qui me convient sans installer le moindre paquet AUR. Il va donc falloir que je me penche sur l'utilisation de AUR avant d'aller plus loin (ça ne doit pas être bien compliqué, je ne te demande pas d'aide là-dessus, c'est juste un rapport d'étape).

Les deux commandes que tu m'as indiqué donnent respectivement (j'ai enlevé des lignes qu me paraissaient n'avoir clairement aucun rapport avec le schmilblik) :

[root@arch antoine]# dmesg
[ 0.678523] pci 0000:00:1c.0: bridge window [io 0x1000-0x0fff] to [bus 04] add_size 1000
[ 0.678527] pci 0000:00:1c.0: bridge window [mem 0x00100000-0x000fffff 64bit pref] to [bus 04] add_size 200000 add_align 100000
[ 0.678529] pci 0000:00:1c.0: bridge window [mem 0x00100000-0x000fffff] to [bus 04] add_size 200000 add_align 100000
[ 0.678538] pci 0000:00:1c.0: BAR 14: assigned [mem 0xdf200000-0xdf3fffff]
[ 0.678543] pci 0000:00:1c.0: BAR 15: assigned [mem 0xdf400000-0xdf5fffff 64bit pref]
[ 0.678546] pci 0000:00:1c.0: BAR 13: assigned [io 0x2000-0x2fff]
[ 0.678549] pci 0000:00:1c.0: PCI bridge to [bus 04]
[ 0.678552] pci 0000:00:1c.0: bridge window [io 0x2000-0x2fff]
[ 0.678556] pci 0000:00:1c.0: bridge window [mem 0xdf200000-0xdf3fffff]
[ 0.678560] pci 0000:00:1c.0: bridge window [mem 0xdf400000-0xdf5fffff 64bit pref]
[ 0.678565] pci 0000:00:1c.2: PCI bridge to [bus 06]
[ 0.678569] pci 0000:00:1c.2: bridge window [mem 0xf7d00000-0xf7dfffff]
[ 0.678577] pci 0000:00:1c.3: PCI bridge to [bus 07]
[ 0.678579] pci 0000:00:1c.3: bridge window [io 0xe000-0xefff]
[ 0.678583] pci 0000:00:1c.3: bridge window [mem 0xf7c00000-0xf7cfffff]
[ 0.678586] pci 0000:00:1c.3: bridge window [mem 0xf0000000-0xf00fffff 64bit pref]
[ 0.678591] pci 0000:00:1c.4: PCI bridge to [bus 08]
[ 0.678604] pci_bus 0000:00: resource 4 [io 0x0000-0x0cf7 window]
[ 0.678605] pci_bus 0000:00: resource 5 [io 0x0d00-0xffff window]
[ 0.678607] pci_bus 0000:00: resource 6 [mem 0x000a0000-0x000bffff window]
[ 0.678608] pci_bus 0000:00: resource 7 [mem 0xdf200000-0xfeafffff window]
[ 0.678610] pci_bus 0000:04: resource 0 [io 0x2000-0x2fff]
[ 0.678611] pci_bus 0000:04: resource 1 [mem 0xdf200000-0xdf3fffff]
[ 0.678612] pci_bus 0000:04: resource 2 [mem 0xdf400000-0xdf5fffff 64bit pref]
[ 0.678614] pci_bus 0000:06: resource 1 [mem 0xf7d00000-0xf7dfffff]
[ 0.678615] pci_bus 0000:07: resource 0 [io 0xe000-0xefff]
[ 0.678617] pci_bus 0000:07: resource 1 [mem 0xf7c00000-0xf7cfffff]
[ 0.678618] pci_bus 0000:07: resource 2 [mem 0xf0000000-0xf00fffff 64bit pref]
[ 0.953447] fbcon: Deferring console take-over
[ 0.953448] fb0: EFI VGA frame buffer device
[ 0.953458] intel_idle: MWAIT substates: 0x11142120
[ 0.953459] intel_idle: v0.4.1 model 0x45
[ 0.953770] intel_idle: lapic_timer_reliable_states 0xffffffff
[ 0.966359] intel_pstate: Intel P-state driver initializing
[ 0.966561] ledtrig-cpu: registered to indicate activity on CPUs
[ 0.967106] NET: Registered protocol family 10
[ 0.983792] Segment Routing with IPv6
[ 0.983829] NET: Registered protocol family 17
[ 0.984243] mce: Using 7 MCE banks
[ 0.984269] RAS: Correctable Errors collector initialized.
[ 0.984333] microcode: sig=0x40651, pf=0x40, revision=0x25
[ 0.984466] microcode: Microcode Update Driver: v2.2.
[ 0.984482] sched_clock: Marking stable (984069625, 389471)->(992889520, -8430424)
[ 5.851187] systemd[1]: systemd 242.29-1-arch running in system mode. (+PAM +AUDIT -SELINUX -IMA -APPARMOR +SMACK -SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD +IDN2 -IDN +PCRE2 default-hierarchy=hybrid)
[ 5.865997] systemd[1]: Detected architecture x86-64.
[ 5.887577] systemd[1]: Set hostname to <arch>.
[ 7.888969] systemd[1]: Listening on Journal Socket.
[ 7.889189] systemd[1]: Condition check resulted in File System Check on Root Device being skipped.
[ 7.889481] systemd[1]: Listening on Journal Audit Socket.
[ 7.889610] systemd[1]: Listening on initctl Compatibility Named Pipe.
[ 7.889769] systemd[1]: Listening on udev Kernel Socket.
[ 7.894203] systemd[1]: Mounting POSIX Message Queue File System...
[ 7.896612] systemd[1]: Mounting Kernel Debug File System...
[ 9.274142] audit: type=1130 audit(1561613829.758:4): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-modules-load comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 9.354458] audit: type=1130 audit(1561613829.838:5): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-tmpfiles-setup-dev comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 9.530431] audit: type=1130 audit(1561613830.015:6): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-sysctl comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 10.812211] audit: type=1130 audit(1561613831.295:7): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-udevd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 12.794518] snd_hda_intel: unknown parameter 'snd' ignored
[ 12.794520] snd_hda_intel: unknown parameter 'slots' ignored
[ 12.794633] snd_hda_intel 0000:00:03.0: enabling device (0000 -> 0002)
[ 12.794873] snd_hda_intel 0000:00:1b.0: enabling device (0000 -> 0002)
[ 12.904512] r8169 0000:07:00.0 enp7s0: renamed from eth0
[ 12.917082] audit: type=1130 audit(1561613833.401:8): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-backlight@leds:dell::kbd_backlight comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 13.042744] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC3234: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[ 13.042751] snd_hda_codec_realtek hdaudioC0D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 13.042755] snd_hda_codec_realtek hdaudioC0D0: hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[ 13.042758] snd_hda_codec_realtek hdaudioC0D0: mono: mono_out=0x0
[ 13.042760] snd_hda_codec_realtek hdaudioC0D0: inputs:
[ 13.042764] snd_hda_codec_realtek hdaudioC0D0: Headset Mic=0x19
[ 13.042768] snd_hda_codec_realtek hdaudioC0D0: Headphone Mic=0x1a
[ 13.042770] snd_hda_codec_realtek hdaudioC0D0: Internal Mic=0x12
[ 13.091302] input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:1b.0/sound/card0/input17
[ 13.091416] input: HDA Intel PCH Headphone Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input18
[ 13.296087] media: Linux media interface: v0.10
[ 13.304850] Intel(R) Wireless WiFi driver for Linux
[ 13.304852] Copyright(c) 2003- 2015 Intel Corporation
[ 13.304974] iwlwifi 0000:06:00.0: enabling device (0000 -> 0002)
[ 13.678043] iwlwifi 0000:06:00.0: loaded firmware version 17.3216344376.0 op_mode iwlmvm
[ 13.787107] Bluetooth: Core ver 2.22
[ 13.787132] NET: Registered protocol family 31
[ 13.787133] Bluetooth: HCI device and connection manager initialized
[ 13.787137] Bluetooth: HCI socket layer initialized
[ 13.787140] Bluetooth: L2CAP socket layer initialized
[ 13.787143] Bluetooth: SCO socket layer initialized
[ 13.919072] Console: switching to colour frame buffer device 170x48
[ 13.919196] snd_hda_intel 0000:00:03.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[ 13.939399] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[ 14.005292] audit: type=1130 audit(1561613834.488:9): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-backlight@backlight:intel_backlight comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 14.158420] intel_rapl: Found RAPL domain package
[ 14.158425] intel_rapl: Found RAPL domain core
[ 14.158433] intel_rapl: Found RAPL domain uncore
[ 14.158436] intel_rapl: Found RAPL domain dram
[ 14.158442] intel_rapl: RAPL package 0 domain package locked by BIOS
[ 14.158454] intel_rapl: RAPL package 0 domain dram locked by BIOS
[ 14.171965] input: HDA Intel HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:03.0/sound/card1/input19
[ 14.172075] input: HDA Intel HDMI HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:03.0/sound/card1/input20
[ 14.172176] input: HDA Intel HDMI HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:03.0/sound/card1/input21
[ 14.172274] input: HDA Intel HDMI HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:03.0/sound/card1/input22
[ 14.172404] input: HDA Intel HDMI HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:03.0/sound/card1/input23
[ 14.173266] videodev: Linux video capture interface: v2.00
[ 14.741502] usbcore: registered new interface driver btusb
[ 14.761221] Bluetooth: hci0: read Intel version: 3707100100012d0d00
[ 14.857880] iwlwifi 0000:06:00.0: Detected Intel(R) Dual Band Wireless AC 3160, REV=0x164
[ 14.877854] iwlwifi 0000:06:00.0: base HW address: 78:0c:b8:67:f3:54
[ 14.902495] Bluetooth: hci0: Intel Bluetooth firmware file: intel/ibt-hw-37.7.10-fw-1.0.1.2d.d.bseq
[ 14.944376] uvcvideo: Found UVC 1.00 device Integrated_Webcam_HD (0c45:6712)
[ 14.963226] audit: type=1130 audit(1561613835.448:10): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-rfkill comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 14.996458] uvcvideo 2-5:1.0: Entity type for entity Extension 4 was not initialized!
[ 14.996467] uvcvideo 2-5:1.0: Entity type for entity Extension 3 was not initialized!
[ 14.996472] uvcvideo 2-5:1.0: Entity type for entity Processing 2 was not initialized!
[ 14.996477] uvcvideo 2-5:1.0: Entity type for entity Camera 1 was not initialized!
[ 14.996721] input: Integrated_Webcam_HD: Integrate as /devices/pci0000:00/0000:00:14.0/usb2/2-5/2-5:1.0/input/input24
[ 14.996952] usbcore: registered new interface driver uvcvideo
[ 14.996956] USB Video Class driver (1.1.1)
[ 15.069479] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[ 15.074213] Bluetooth: hci0: unexpected event for opcode 0xfc2f
[ 15.089317] Bluetooth: hci0: Intel firmware patch completed and activated
[ 15.134711] iwlwifi 0000:06:00.0 wlp6s0: renamed from wlan0
[ 16.025071] Adding 2562044k swap on /dev/sda9. Priority:-2 extents:1 across:2562044k FS
[ 16.682312] audit: type=1130 audit(1561613837.165:11): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=lvm2-monitor comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 17.630658] audit: type=1130 audit(1561613838.115:12): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-fsck@dev-disk-by\x2duuid-c6f5f38c\x2dcd09\x2d4935\x2db74a\x2d0414e7aa664b comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 17.894495] EXT4-fs (sda6): mounted filesystem with ordered data mode. Opts: stripe=32748,data=ordered
[ 18.081179] audit: type=1130 audit(1561613838.565:13): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-fsck@dev-disk-by\x2duuid-C85E\x2d8AE8 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 18.579470] audit: type=1130 audit(1561613839.065:14): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-fsck@dev-disk-by\x2duuid-8fdfb62e\x2d7acb\x2d4e3a\x2db2f4\x2d38a8c274a8d4 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 18.895865] EXT4-fs (sda7): mounted filesystem with ordered data mode. Opts: stripe=32742,data=ordered
[ 20.113031] audit: type=1131 audit(1561613840.598:15): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-rfkill comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 24.920140] audit: type=1130 audit(1561613845.405:16): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-journal-flush comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 25.252178] audit: type=1130 audit(1561613845.735:17): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-tmpfiles-setup comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 25.300439] audit: type=1127 audit(1561613845.785:18): pid=498 uid=0 auid=4294967295 ses=4294967295 msg=' comm="systemd-update-utmp" exe="/usr/lib/systemd/systemd-update-utmp" hostname=? addr=? terminal=? res=success'
[ 25.348775] audit: type=1130 audit(1561613845.831:19): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-update-utmp comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 25.437188] audit: type=1130 audit(1561613845.921:20): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=dbus comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 25.573651] audit: type=1130 audit(1561613846.058:21): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=alsa-restore comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 25.583020] audit: type=1130 audit(1561613846.068:22): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=shadow comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 26.727291] audit: type=1131 audit(1561613847.211:23): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=shadow comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 27.291002] audit: type=1130 audit(1561613847.775:24): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=bluetooth comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 27.464770] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 27.464774] Bluetooth: BNEP filters: protocol multicast
[ 27.464782] Bluetooth: BNEP socket layer initialized
[ 27.761273] audit: type=1130 audit(1561613848.245:25): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-logind comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 28.034884] audit: type=1130 audit(1561613848.518:26): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-hostnamed comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 32.349563] Generic PHY r8169-700:00: attached PHY driver [Generic PHY] (mii_bus:phy_addr=r8169-700:00, irq=IGNORE)
[ 32.497263] kauditd_printk_skb: 4 callbacks suppressed
[ 32.497266] audit: type=1130 audit(1561613852.981:31): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=colord comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 32.600310] r8169 0000:07:00.0 enp7s0: Link is Down
[ 33.809314] audit: type=1130 audit(1561613854.291:32): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=wpa_supplicant comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 33.824712] audit: type=1130 audit(1561613854.308:33): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=org.cups.cupsd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 35.935355] audit: type=1130 audit(1561613856.418:34): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=polkit comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 37.500817] audit: type=1130 audit(1561613857.985:35): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=user-runtime-dir@620 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 37.538261] audit: type=1006 audit(1561613858.021:36): pid=568 uid=0 old-auid=4294967295 auid=620 tty=(none) old-ses=4294967295 ses=1 res=1
[ 37.942273] audit: type=1130 audit(1561613858.425:37): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=user@620 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 40.232656] audit: type=1131 audit(1561613860.718:38): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 42.811421] fuse init (API version 7.29)
[ 59.158446] audit: type=1131 audit(1561613879.641:39): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-hostnamed comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 83.718176] audit: type=1006 audit(1561613904.201:40): pid=613 uid=0 old-auid=4294967295 auid=1000 tty=(none) old-ses=4294967295 ses=2 res=1
[ 83.764460] audit: type=1130 audit(1561613904.248:41): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=user-runtime-dir@1000 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 83.774403] audit: type=1006 audit(1561613904.258:42): pid=632 uid=0 old-auid=4294967295 auid=1000 tty=(none) old-ses=4294967295 ses=3 res=1
[ 83.909190] audit: type=1130 audit(1561613904.395:43): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=user@1000 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 84.257838] audit: type=1112 audit(1561613904.741:44): pid=613 uid=0 auid=1000 ses=2 msg='op=login id=1000 exe="/usr/bin/lightdm" hostname=arch addr=? terminal=/dev/tty7 res=success'
[ 86.617006] wlp6s0: authenticate with 24:95:04:e6:21:cc
[ 86.619736] wlp6s0: send auth to 24:95:04:e6:21:cc (try 1/3)
[ 86.621833] wlp6s0: authenticated
[ 86.622336] wlp6s0: associate with 24:95:04:e6:21:cc (try 1/3)
[ 86.626988] wlp6s0: RX AssocResp from 24:95:04:e6:21:cc (capab=0x411 status=0 aid=1)
[ 86.628591] wlp6s0: associated
[ 87.699219] IPv6: ADDRCONF(NETDEV_CHANGE): wlp6s0: link becomes ready
[ 87.970409] audit: type=1130 audit(1561613908.455:45): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 88.705709] audit: type=1130 audit(1561613909.188:46): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=rtkit-daemon comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 89.818814] Bluetooth: RFCOMM TTY layer initialized
[ 89.818826] Bluetooth: RFCOMM socket layer initialized
[ 89.818836] Bluetooth: RFCOMM ver 1.11
[ 94.336172] audit: type=1131 audit(1561613914.818:47): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=user@620 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 94.350010] audit: type=1131 audit(1561613914.835:48): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=user-runtime-dir@620 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 94.576130] audit: type=1130 audit(1561613915.061:49): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=upower comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 98.012199] audit: type=1131 audit(1561613918.495:50): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 104.168166] audit: type=1130 audit(1561613924.651:51): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=udisks2 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 902.303344] audit: type=1130 audit(1561614722.788:52): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-tmpfiles-clean comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 902.303358] audit: type=1131 audit(1561614722.788:53): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-tmpfiles-clean comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'

et (je ne mets que les lignes post-tentative de connexion bluetooth)

juin 27 08:37:46 arch su[2366]: (to root) antoine on pts/0
juin 27 08:37:46 arch su[2366]: pam_unix(su:session): session opened for user root by (uid=1000)
juin 27 08:38:34 arch bluetoothd[499]: connect error: Permission denied (13)
juin 27 08:38:40 arch bluetoothd[499]: connect error: Permission denied (13)
juin 27 08:39:28 arch kernel: usb 2-3: new low-speed USB device number 5 using xhci_hcd
juin 27 08:39:28 arch kernel: usb 2-3: New USB device found, idVendor=046d, idProduct=c062, bcdDevice=31.00
juin 27 08:39:28 arch kernel: usb 2-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
juin 27 08:39:28 arch kernel: usb 2-3: Product: USB Laser Mouse
juin 27 08:39:28 arch kernel: usb 2-3: Manufacturer: Logitech
juin 27 08:39:28 arch Thunar[878]: Failed to launch the volume manager (L’exécution du processus fils « thunar-volman » a échoué (Aucun >
juin 27 08:39:28 arch kernel: input: Logitech USB Laser Mouse as /devices/pci0000:00/0000:00:14.0/usb2/2-3/2-3:1.0/0003:046D:C062.0002/i>
juin 27 08:39:28 arch kernel: hid-generic 0003:046D:C062.0002: input,hidraw1: USB HID v1.10 Mouse [Logitech USB Laser Mouse] on usb-0000>
juin 27 08:39:28 arch kernel: usbcore: registered new interface driver usbhid
juin 27 08:39:28 arch kernel: usbhid: USB HID core driver
juin 27 08:39:28 arch Thunar[878]: Failed to launch the volume manager (L’exécution du processus fils « thunar-volman » a échoué (Aucun >
juin 27 08:39:28 arch Thunar[878]: Failed to launch the volume manager (L’exécution du processus fils « thunar-volman » a échoué (Aucun >
juin 27 08:39:28 arch Thunar[878]: Failed to launch the volume manager (L’exécution du processus fils « thunar-volman » a échoué (Aucun >
juin 27 08:39:28 arch Thunar[878]: Failed to launch the volume manager (L’exécution du processus fils « thunar-volman » a échoué (Aucun >
juin 27 08:39:30 arch dbus-daemon[500]: [system] Activating via systemd: service name='org.freedesktop.Avahi' unit='dbus-org.freedesktop>
juin 27 08:39:30 arch dbus-daemon[500]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.Avahi.service': Unit dbus->
juin 27 08:39:32 arch dbus-daemon[500]: [system] Activating via systemd: service name='org.freedesktop.Avahi' unit='dbus-org.freedesktop>
juin 27 08:39:32 arch dbus-daemon[500]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.Avahi.service': Unit dbus-

et ça aussi :

[root@arch antoine]# journalctl -b | grep "bluetooth"
juin 27 07:37:27 arch bluetoothd[499]: Bluetooth daemon 5.50
juin 27 07:37:27 arch kernel: audit: type=1130 audit(1561613847.775:24): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=bluetooth comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
juin 27 07:37:27 arch audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=bluetooth comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
juin 27 07:37:27 arch bluetoothd[499]: Starting SDP server
juin 27 07:37:27 arch bluetoothd[499]: Bluetooth management interface 1.14 initialized
juin 27 07:37:27 arch dbus-daemon[500]: [system] Activating via systemd: service name='org.freedesktop.hostname1' unit='dbus-org.freedesktop.hostname1.service' requested by ':1.1' (uid=0 pid=499 comm="/usr/lib/bluetooth/bluetoothd ")
juin 27 07:37:31 arch NetworkManager[501]: <info> [1561613851.8901] Loaded device plugin: NMBluezManager (/usr/lib/NetworkManager/1.18.0-1/libnm-device-plugin-bluetooth.so)
juin 27 07:38:30 arch bluetoothd[499]: Endpoint registered: sender=:1.83 path=/MediaEndpoint/A2DPSource
juin 27 07:38:30 arch bluetoothd[499]: Endpoint registered: sender=:1.83 path=/MediaEndpoint/A2DPSink
juin 27 08:38:34 arch bluetoothd[499]: connect error: Permission denied (13)
juin 27 08:38:40 arch bluetoothd[499]: connect error: Permission denied (13)

J'ai une connaissance insuffisante de linux, où puis-je trouver les logs de pulseaudio ?

Ah et sinon mon ordi est un Dell Inspiron (dans la gamme des 5000 je crois), un portable.

Le modèle du bluetooth de ma arch ? Tu ne veux pas dire de ma chaîne hifi plutôt ?

Logicien
 Posté le 27/06/2019 à 23:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Je n'ai pas le paquet bluez-firmware d'installé et mes écouteurs bluetooth fonctionnent. Je n'ai même pas le paquet alsa-firmware d'installé. Par contre j'ai le paquet linux-firmware d'installé. Il est utilise pour les cartes réseaux avec et sans fil. Le Bluetooth est réseau et sans fil. Assure-toi qu'il est bien installé, ça devrait et installe alsa-firmware.

Pour le paquet bluez-firmware si tu veux le compiler tu dois le faire en utilisateur normal avec yaourt ou packer. Tu dois être dans le group wheel. Compiler en root est décommandé.

Je pense que ton problème est de permission. Tant que tu as le message

"connect error: Permission denied (13)"

c'est soit qu'il y a un problème logiciel ou matériel ou que l'utilisateur qui veut se connecter en Bluetooth n'a pas les permissions pour le faire.

Assai avec une clé Bluetooth sur port Usb. Si tu y arrives, sans rien changer d'autre que le contrôleur Bluetooth c'est que ton contrôleur Bluetooth intégré a un problème.

Met ton utilisateur normal qui veut se connecter en Bluetooth dans le groupe lp. Avec le droits root:

usermod -a -G lp utilisateur

où utilisateur est le nom d'utilisateur de celui qui travaille en bluetooth. Redémarre ta session et essai encore.



Modifié par Logicien le 27/06/2019 23:41
rodak
 Posté le 06/08/2019 à 23:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bon, ça fait plus d'un mois que tu m'as répondu et que je n'avais pas fait de retour, essentiellement parce que je n'avais pas significativement avancé ; je n'avais pas de clé bluetooth sous la main, mon utilisateur était déjà dans le groupe lp et je me refusais à installer un paquet de AUR avant d'avoir tout essayé.

Bref, juste avant de partir en vacances il y a trois semaines, j'ai essayé, un peu pour m'amuser, de connecter mon téléphone portable à mon ordi en bluetooth. Je l'ai apparié avec un mot de passe affiché sur l'écran de mon téléphone, et j'ai réussi sans problème à le connecter et à faire transiter des fichiers entre ordi et téléphone. De là m'est venue l'idée que j'avais peut-être mal apparié ma chaîne audio, pour une raison inconnue (un mot de passe, peut-être ?)... Bref, je viens de tester, désapparier, réapparier puis connecter ma chaîne avec Blueman et ce coup-ci, pas de problème, ça marche parfaitement.

Je te dois un grand merci, car je ne crois pas que j'y aurais pensé si tu n'avais pas pointé le problème de permissions !

Comme j'ai dû faire un petit réglage après avoir connecté la chaîne sur Pavucontrol, il y a peut-être le même réglage à faire avec les écouteurs, il se pourrait que je ne l'aie pas vu... je testerai demain (là maintenant il est tard, je ne sais pas où ils sont et je ne veux réveiller personne chez moi) et je referai un retour.

Encore merci !

rodak
 Posté le 07/08/2019 à 09:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Suite et fin de mon problème : j'ai branché les écouteurs ce matin... et ça marche, sans problème, et sans aucun réglage.

Mon intuition sur le lien entre les deux problèmes était bonne, je ne comprends juste pas trop comment ni pourquoi !

Encore merci à toi.

rodak
 Posté le 16/09/2019 à 20:17 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bon, je reviens ici parce que mon problème initial est revenu (pas celui du bluetooth, mais celui des écouteurs).

En réfléchissant, je m'étais dit que les écouteurs avaient remarché parce que, quand j'avais réussi à me connecter en bluetooth, j'avais dû déactiver le son des enceintes de mon ordi via Pavucontrol pour que le son sorte sur ma chaîne hi-fi, et les écouteurs avaient fonctionné dans la foulée. Je pense que c'était pour ça (et que c'est pour ça à nouveau) qu'ils ne fonctionnaient pas : il y avait un conflit entre le son des enceintes et le son des écouteurs. Or, quand je branche les écouteurs, je n'ai pas accès au son des enceintes de l'ordi dans les réglages (c'est peut-être un bug ?). Pour une raison mystérieuse, ça s'était mis à fonctionner et ça ne fonctionne plus alors que je n'ai pas changé les réglages (mais j'ai dû déconnecter et reconnecter le bluetooth plusieurs fois parce que ça ne fonctionne pas toujours). Ça me paraît être davantage un problème Pavucontrol qu'un problème Archlinux, n'y a-t-il pas un moyen de contrôler ces fameux réglages en ligne de commande ?

Merci d'avance pour vos éclairages !



Modifié par rodak le 16/09/2019 20:19
Publicité
Logicien
 Posté le 16/09/2019 à 23:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut,

tu peux te servir de paprefs sous l'onglet Simultaneous Output et activer le périphérique virtuel de Pulseaudio qui te permet d'associer toutes tes sorties audios à ce périphérique et faire en sorte que ces sorties soient audibles depuis tes écouteurs, tes enceintes et tous les périphériques audios reconnus par Pulseaudio. Il ne faut pas éteindre ces périphériques si tu veux entendre le son mais les configurer comme il se doit chacun depuis Pavucontrol sous l'onglet Configuration et au moment de l'exécution du son sous l'onglet Lecture.

Peut-être cela peut-il régler ton problème.



Modifié par Logicien le 16/09/2019 23:56
rodak
 Posté le 28/09/2019 à 20:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Merci !

Mais ça ne marche pas... et c'est très énervant.

J'ai fait des captures d'écran des menus Pavucontrol pour que tu puisses voir... le casque apparaît bien dans la liste et produit théoriquement du son mais... je n'entends rien.

Logicien
 Posté le 29/09/2019 à 02:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut,

honnêtement, j'ai perdu le fil de la discussion. Es-tu certain que ton casque fonctionne? Quel type d'écouteurs utilises-tu déjà, Bluetooth, USB ou analogique depuis la carte de son? As-tu plusieurs prises de sortie audio? Il arrive qu'une prise de sortie audio ne fonctionne pas et une autre oui sur une tour par exemple.

As-tu le fichier /etc/asound.conf dont le contenu redirige les appels Alsa vers Pulseaudio? Comme ceci par exemple:

pcm.pulse {
type pulse
}

ctl.pulse {
type pulse
}

pcm.!default {
type pulse
}

ctl.!default {
type pulse
}

Assure-toi aussi que tu n'as pas de fichier $HOME/.asoundrc qui as preséance sur /etc/asound.conf et qui serait configuré différemment.



Modifié par Logicien le 29/09/2019 02:35
rodak
 Posté le 29/09/2019 à 17:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Oui, c'est un peu de ma faute, j'ai quinze fers au feu je mets beaucoup trop de temps à te répondre, désolé...

Mon fichier /etc/asound.conf dit ceci :

# Use PulseAudio by default
pcm.!default {
type pulse
fallback "sysdefault"
hint {
show on
description "Default ALSA Output (currently PulseAudio Sound Server)"
}
}

ctl.!default {
type pulse
fallback "sysdefault"
}

# vim:set ft=alsaconf:

et ~/.asoundrc dit cela :

# réglage de la carte son par défaut, selon la commande « aplay -l », card = car
te et device = périphérique
defaults.pcm.card 0
defaults.pcm.device 0
defaults.ctl.card 0
#
# # fréquence d'échantillonnage
defaults.pcm.dmix.rate 44100
#
# # algorithme de re-échantillonnage
defaults.pcm.rate_converter "samplerate_best"

Est-ce que les deux sont incompatibles ? En tout cas j'ai relancé ma session après avoir modifié ~/.asoundrc en ~/.asoundrc.old, et ça n'a pas résolu mon problème.

Sinon j'ai des écouteurs analogiques qui sont branchés sur la seule sortie son de mon ordi. Ils fonctionnent dans l'absolu, ils ont produit du son sur ma Arch pendant les quelques jours qui ont suivi le règlement de mon problème de Bluetooth (celui pour lequel tu m'as apporté ton aide précieuse au début de ce fil), avant de ne plus fonctionner à nouveau. Donc... ça devrait marcher, je pense que c'est un problème de configuration, mais je ne vois pas à quel niveau.



Modifié par rodak le 29/09/2019 17:15
Logicien
 Posté le 29/09/2019 à 20:39 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Ce que je ferais à ce stade-ci, c'est de fermer toute session utilisateur normal graphique et au terminal pour retourner au gestionnaire d'affichage. J'ouvrirais une session root (sans sudo) dans un terminal Linux (Ctrl+Alt+F2). Après avoir eu l'invite de commandes root, je m'assurerais que tous les processus non root sont terminés. Par exemple si l'utilisateur antoine est le seul utilisateur non root à pouvoir ouvrir une session graphique et au terminal, je ferais

killall -u antoine

Ensuite je déplacerais le fichier /etc/asound.conf pour que les requêtes Alsa ne soit pas redirigées vers Pulseaudio qui est actif seulement pour un utilisateur en session graphique:

mv /etc/asound.conf /etc/asound.conf.sauve

Je vérifierais aussi qu'il n'y a pas de fichier .asoundrc à la racine du répertoire /root. Ensuite, j'ouvrirais alsamixer

alsamixer

pour m'assurer que la carte de son par défaut est celle où tu branches tes écouteurs, qu'elle n'est pas muète et que la volume permet d'entendre une sortie audio.

Supprime le répertoire /root/.mplayer s'il existe

rm -fr /root/.mplayer

Ensuite je metterais mes écouteurs analogiques et ferais jouer un fichier audio reconnu par Mplayer, ogg par exemple:

mplayer -ao alsa /chemin/vers/fichier.ogg

Normalement ça devrait jouer si tout est en état de fonctionner à moins que Pulseaudio se lance en même temps grâce à l'option autospawn=yes activée dans ses fichiers de configurations dans /etc/pulse/.

Comme les vrais pilotes audios sont ceux d'Alsa et non pas le serveur de son Pulseaudio, sans Pulseaudio activé et avec le compte root comme client audio rien ne peut barrer la route à une requête audio root vers Alsa via Mplayer.

Si ça ne marche toujours pas, c'est peut-être que les pilotes Alsa ont eux-mêmes besoin d'une configuration spéciale pour ta carte de son.



Modifié par Logicien le 29/09/2019 21:20
rodak
 Posté le 30/09/2019 à 01:14 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Merci ! Eh bien, ça fonctionne... mais ça fonctionne bizarrement, c'est comme s'il y avait un faux contact, il faut que j'enclenche la fiche à moitié pour avoir du son (alors que sous ma Debian, il n'y a pas ce faux contact).

Mais maintenant, comment reconnecter tout ça ?

Logicien
 Posté le 30/09/2019 à 04:21 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

La seule chose à faire si tu veux revenir en arrière c'est dans une session root

mv /etc/asound.conf.sauve /etc/asound.conf

pour que les requêtes Alsa soient redirigées vers Pulseaudio.

Le compte root ne sert que pour faire des tests et sans Pulseaudio. Pulseaudio ne lui est pas accessible par défaut. Seul l'utilisateur en cours de session graphique peut accéder à Pulseaudio.

Peut-être qu'en changeant d'écouteurs la fiche sera meilleure et le contact aussi. Ça arrive souvent qu'une fiche ne fonctionne pas bien surtout quand le câble est long.

Une autre chose que tu peux faire c'est de comparer la sortie suivante entre Debian et ArchLinux

lsmod | grep snd

pour voir si tous les modules Alsa sont identiques entre les deux distributions. Aussi la sortie

ls -aR /etc/modprobe.d

dans chaque distribution va te donner une idée s'il y a des fichiers de configurations des modules qui diffèrent entre les deux distributions. Habituellement oui mais sans conséquences en ce qui me concerne. C'est surtout le module Alsa principal snd-hda-intel qui peut recevoir plusieurs paramètres spécifiques. Il est parfois nécessaire de lui en passer avec certaines cartes de sons.

lspci -nn | grep -i audio

dit de quelle carte de son il est question.



Modifié par Logicien le 30/09/2019 04:29
rodak
 Posté le 23/10/2019 à 14:42 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

À nouveau, je m'excuse pour mon temps de réponse. Ce problème m'agace, mais ne m'empêche pas de fonctionner au quotidien, donc je m'y attelle un peu quand je peux...

J'écarte a priori le problème de faux contact : sous Debian, ça fonctionne parfaitement. Et encore une fois, les écouteurs sont reconnus (et émettent le petit son caractéristique au moment du branchement, qu'émettent tous les écouteurs du monde quand on les branche dans une fiche). (Pour rappel, au départ, c'est à la suite d'une mise à jour des paquets de gestion du son que les écouteurs se sont éteints.)

Voilà le comparatif de lsmod | grep snd, sous Arch :

snd_hda_codec_hdmi 69632 1
snd_hda_codec_realtek 126976 1
snd_hda_codec_generic 94208 1 snd_hda_codec_realtek
snd_hda_intel 53248 3
snd_hda_codec 159744 4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
snd_hda_core 102400 5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
snd_hwdep 20480 1 snd_hda_codec
snd_pcm 135168 4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_core
snd_timer 40960 1 snd_pcm
ledtrig_audio 16384 3 snd_hda_codec_generic,snd_hda_codec_realtek,dell_laptop
snd 110592 14 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_pcm
soundcore 16384 1 snd

et sous Debian :

snd_hda_codec_realtek 122880 1
snd_hda_codec_generic 86016 1 snd_hda_codec_realtek
snd_hda_codec_hdmi 57344 1
snd_hda_intel 45056 6
snd_hda_codec 151552 4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
snd_hda_core 94208 5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
snd_hwdep 16384 1 snd_hda_codec
snd_pcm 114688 4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_core
snd_timer 36864 1 snd_pcm
snd 94208 20 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_pcm
soundcore 16384 1 snd

Comme tu peux le voir, c'est pareil sans être pareil, le diable se niche sans doute dans les détails...

Les fichiers de /etc/modprobe.d/ ne sont pas mes mêmes sous Debian et sous Arch. Sous Arch j'en ai deux, alsa-base.conf qui contient le texte suivant :

options snd-hda-intel id=Generic_1 index=1 snd slots=snd-hda-intel,snd-usb-audio

et modprobe.conf, dans laquelle j'ai mis deux lignes commentées, que voici :

# options snd_hda_intel index=0
# options snd_hda_codec_atihdmi index=1

De mémoire, je les avais moi-même créé en ma basant sur des recherches dans le wiki d'Archlinux, mais sans vraiment comprendre ce que je faisais.

Sous Debian, il y a a trois fichiers dans /etc/modprobe.conf : dkms.conf (qui est vide), intel-microcode-blacklist.conf, qui contient le message suivant (si on fait abstraction des commentaires) :

blacklist microcode

et modessetting.conf, qui lui contient ceci :

options cirrus modeset=1
options mgag200 modeset=1

J'ai essayé de remplacer les fichiers Arch de /etc/modprobe.d/ par ceux de Debian, sans succès.

Un appel de lspci -nn | grep -i audio donne :

00:03.0 Audio device [0403]: Intel Corporation Haswell-ULT HD Audio Controller [8086:0a0c] (rev 0b)
00:1b.0 Audio device [0403]: Intel Corporation 8 Series HD Audio Controller [8086:9c20] (rev 04)

Je suppose que c'est ça qui doit être passé comme arguments dans modprobe.conf, mais comment ?

Je t'avoue que je suis un peu perdu...

Publicité
Logicien
 Posté le 24/10/2019 à 00:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Je mettrais les lignes en commentaires dans le fichier /etc/modprobe.d/alsa-base.conf. De plus je ferais

mkinitcpio -p linux

pour que les fichiers dans /etc/modprobe.d/ soient inclus dans l'initramfs. Aucun module son n'est paramètré sous Debian et ça fonctionne. Ça doit être de même sous la Arch. Alternativement je supprimerais carrément les fichiers

rm -f /etc/modprobe.d/alsa-base.conf /etc/modprobe.d/modules.conf

avant de faire

mkinitcpio -p linux

Je ne vois pas leurs utilités. J'ai un fichier de configuration personnalisé des modules Linux qui est le même pour Arch et Debian. Il ne contient rien pour les modules sons et ça fonctionne sous les deux distributions. Je dois dire toutefois que la carte de son Intel Haswell-ULT HD Audio Controller m'est inconnue. C'est peut-être une carte qui nécessite des paramètres spéciaux mais alors pourquoi ça fonctionne sous Debian sans aucune option pour les modules sons? Essai la Arch de la même manière que Debian pour voir si ça fonctionne.



Modifié par Logicien le 24/10/2019 00:31
rodak
 Posté le 28/10/2019 à 15:56 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Si j'ai bien compris, la commande mkinitcpio -p linux recompile le noyau linux, c'est bien ça ?

J'ai tout essayé, commenter, décommenter les lignes de mes fichiers de configuration, virer les fichiers de configuration arch et mettre ceux de debian à la place, j'ai même essayé de virer les fichiers de configuration de Debian, les remplacer par ceux de Arch et lancer ma Debian. Même ainsi, les écouteurs fonctionnent parfaitement.

Dans tous les cas, les écouteurs sont reconnus, Pavucontrol détecte du son, mais rien ne sort.

À tout hasard, j'ai tapé le nom de ma carte son dans un moteur de recherche, et je suis tombé sur ça : https://darmawan-salihun.blogspot.com/2015/02/intel-pch-haswell-sound-alsa-problem.html . Mon anglais défaillant m'a fait penser un instant que je tenais la solution, mais ça ne marche pas non plus

Logicien
 Posté le 29/10/2019 à 14:12 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

mkinitcpio ne recompile pas Linux ce serait vraiment très court, il y a pleins d'options à compiler dans les sources. mkinitcpio crée un initramfs, un initrd à l'aide de cpio et remplace l'ancien /boot/initramfs-linux.img par celui créé. Il faut redémarrer après cette commande. C'est au démarrage que l'initramfs est utilisé.

C'est un mini systèmes de fichiers racine avec tout ce dont le noyau Linux a de besoin pour démarrer avant que la vraie racine du système de fichiers sur le disque dur soit dispinible. C'est avec l'initramfs que la première détection matérielle se fait. Il est donc important que tout y soit. On peut ajouter des modules à l'initramfs dans le fichier /etc/mkinitcpio.conf avant d'exécuter la commande mkinitcpio -p linux. Dans ton cas peut-être que mettre les principaux modules audios dans l'initramfs pourrait aider, j'en doute.

Je ne me souviens plus de ta configuration audio matérielle ni de l'ordinateur que tu as et du problème audio que tu rencontres sur celui-ci avec la Arch.

As-tu essayé un live cd/dvd/sd/usb basé sur la Arch pour voir si ton problème est récurrent sur la Arch?

La dernière version de la Arch, celle du mois d'octobre est disponible ici. Tu es en lignes de commandes avec l'interpréteur zsh. Bash est aussi disponible. C'est assez pour voir si le son fonctionne et installer des paquets pour faire des tests si tu as Internet. J'y arrive par Ethernet câblé et avec le sans fil aussi. Je peux faire tout avec ce live iso9660 64 bits hybride sans interface graphique.

http://mirror.csclub.uwaterloo.ca/archlinux/iso/latest/

C'est quand même plus simple d'utiliser Manjaro pour le bluetooth audio et tout le reste qui est déjà installé.



Modifié par Logicien le 29/10/2019 14:55
rodak
 Posté le 30/10/2019 à 18:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Merci pour ce petit cours

Le problème reste celui des écouteurs, qui, bien que reconnus, ne produisent aucun son. Je suis allé vérifier sur un live-cd de Manjaro, pas de problème, il y a du son.

Mais je me disais que c'était tricher de faire ça, et archlinux est fait pour apprendre (d'ailleurs ce satané problème m'a fait apprendre des choses, notamment grâce à toi) alors je me suis relancé dans une installation d'arch (par chroot). J'ai déjà pu voir que le fichier alsa-base.conf dont je t'ai parlé, qui contient les lignes suivantes :

# Intel PCH
options snd-hda-intel index=0 model=auto vid=8086 pid=9c20
# Intel HDMI
options snd-hda-intel index=1 model=auto vid=8086 pid=0a0c

est nécessaire, car si je ne le mets pas, c'est le HDMI qui est pris en compte en premier, au lieu du PCH, et du coup je n'ai pas de son du tout.

Dès que j'aurai pris le temps de faire mes réglages, je te ferai un retour plus complet.

rodak
 Posté le 30/10/2019 à 23:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Eh bien, à peine avais-je installé Alsa sur mon "nouveau" système que j'ai vu que je tenais ma solution : il n'y avait aucun problème pour le son, ni sur les petits haut-parleurs de mon portable, ni sur les écouteurs. Et une installation minimale de pulseaudio et pavucontrol ne changeait rien à la donne.

J'en ai déduit que parmi tous mes paquets audio installés, il devait y en avoir un qui provoquait un conflit quelconque ; je me souviens que j'avais eu du mal à obtenir du son quand j'avais installé ma Arch (finalement obtenu par la présence de mon fichier alsa-base.conf) et j'avais installé pas mal de paquets inutiles. J'ai donc frappé à l'aveugle : j'ai désinstallé tous mes paquets qui faisaient mention à Pulseaudio et à Alsa (paprefs, pavucontrol, pulseaudio, pulseaudio-alsa, pulseaudio-bluetooth, pulseaudio-jack, xfce4-pulseaudio-plugin, alsa-firmware, alsa-oss, alsa-plugins, alsa-utils et zita-alsa-pcmi !) et j'ai réinstallé la petite fraction nécessaire à mes modestes besoin pour l'obtention du son (pavucontrol, pulseaudio, pulseaudio-bluetooth, pulseaudio-alsa, xfce4-pulseaudio-plugin). Et maintenant, ça marche

Il y a quand même un hic : quand je lance Audacious et Audacity en même temps, le son se coupe dans les écouteurs. Et ne revient pas ensuite : c'est le même bug. On dirait qu'il y a un conflit entre les deux (qui n'apparaît pas sur ma "nouvelle" Arch, que je n'ai pas encore enlevée). Mais enfin c'est déjà une énorme avancée, et je te dois un grand merci !

Edit : C'est quand même fragile. Après avoir comparé les paquets de son installés sur mes deux "Arch", j'ai voulu réinstaller alsa-utils. Retour du problème, plus de son. Je désinstalle alsa-utils, Le son revient. Mon problème, bien que presque entièrement résolu, garde une composante incompréhensible.



Modifié par rodak le 31/10/2019 11:56
Logicien
 Posté le 05/11/2019 à 12:28 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut,

le paquet zita-alsa-pcmi je ne me souviens pas de l'avoir déjà installé mais il l'est comme dépendance de Jack et donc de pulseaudio-jack. Comme je n'utilise pas Jack je me passe d'installer pulseaudio-jack. Quand Pulseaudio contrôle la carte de son on peut se passer du paquet alsa-utils mais aucun des paquets dont tu fais mention ne m'a posé de problème.

En ce qui concerne Audacious et Audacity, si chaque logiciel utilise le micro, le premier lancé doit bloquer l'accès à la carte de son puisque le micro en entrée ne peut servir qu'à un logiciel à la fois. En sortie Pulseaudio a un bon mixer.

Le paquet alsa-utils installe un service qui sauvegarde et restaure le volume des cartes de sons. Peut-être que le son devient muet. Tout ceci est hypothèses et spéculations de ma part. En tout cas, je suis content de voir que tu progresses.



Modifié par Logicien le 05/11/2019 13:49
Publicité
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
.XCompose non pris en compte dans Mint
je vais me lancer dans linux
( Résolu ) Debian 9 Cinnamon et pas d'imprimantes vues dans les paramètres
Créer/déposer un fichier dans W10 depuis Ubuntu 18.04 impossible
Est-ce que Ubuntu achète de la publicité dans les moteurs de recherche?
Archlinux : paquets orphelins : que faut-il en faire ?
apturl-kde manquant dans 18.04 LTS
Les consignes de base pour administrer une Archlinux. - YouTube
Archlinux : série de messages d'erreurs à la fermeture
[messages inquiétants à la fermeture d'Archlinux]
Plus de sujets relatifs à Archlinux : Plus de son dans les écouteurs
 > Tous les forums > Forum Linux