> Tous les forums > Forum Linux
 Archlinux : résolution de la police du bootSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Mimile
  Posté le 30/11/2013 @ 11:33 
Aller en bas de la page 
Astucien

Bonjour,

Je suis sous Archlinux 64 bits. J'ai une carte nVidia qui est gérée par les pilotes nouveau et nouveau-dri (et non par les pilotes propriétaires qui sont déconseillés sur les Wiki ad hoc d'Arch).

Quand je lance le boot, dans un premier temps, la résolution de l'écran est - je suppose - 800x600, ce qui affiche les lignes du boot en très gros caractères un peu flous et peu esthétiques.

Après une vingtaines de lignes, l'écran passe au noir pendant une à deux secondes après quoi l'affichage des lignes est ramené à une taille "normale", bien nette et visiblement en liaison avec la résolution de mon écran (1440x900).

Sur mon ancien PC, l'affichage des lignes était d'emblée normal.

Que faut-il faire pour que les premières lignes soient d'emblée affichées à un format normal ?

Merci d'avance.

Publicité
Logicien
 Posté le 30/11/2013 à 21:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Je n'ai plus Archlinux d'installée Mimile. Peut-être te souviens-tu de la procédure. Tu crées un fichier /etc/modprobe.d/modprobe.conf dans lequel tu ajoutes la ligne

options nouveau modeset=1

Tu sauvegardes. Tu édites le fichier /etc/mkinitcpio.conf, tu décommentes la ligne MODULES et tu lui ajoutes le module nouveau .Tu décommentes aussi la ligne qui ajoute le fichier /etc/modprobe.d/modprobe.conf à l'initramfs. Tu sauvegardes, puis tu exécutes la commande

mkinitcpio -p linux

Puis, tu redémarres. La résolution native de ton écran devrait être prise en charge dès que le noyau Linux est en mémoire. Sans cela, il faut qu'ArchLinux déduise d'elle-même que le module nouveau doit être ajouté à l'initramfs, ce qui n'est pas toujours le cas.

Sans ton intervention, le module nouveau n'est probablement pas dans l'initramfs et n'est accessible qu'après que la partition racine soit montée, cela retarde la prise en charge de la résolution native de l'écran par le pilote nouveau. Entre temps c'est le framebuffer Vesafb du noyau qui gère l'affichage. Il ne prend pas en charge toutes les résolutions natives des écrans, mais seulement un certain nombre de résolutions fixes.



Modifié par Logicien le 30/11/2013 21:24
Mimile
 Posté le 30/11/2013 à 23:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour Paul

Merci pour ta réponse qui est, une fois de plus, exactement celle qui convenait.

Question réglée.

Avec mes sentiments les plus cordiaux.

Mimile

EDIT : je n'ai pas trouvé de ligne faisant référence à /etc/modprobe.d/modprobe.conf dans /etc/mkinitcpio.conf



Modifié par Mimile le 01/12/2013 00:02
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Archlinux : le boot s'arrête plusieurs secondes
Archlinux Problème au boot avec systemd
Problème de boot avec handy linux
Créer un dual boot entre LinuxMint et Windows10
Archlinux : l'activation du pavé numérique ne se fait plus
Archlinux : mise à jour foireuse - merci chroot !
Perte de résolution d'affichage
impossible de booter sur linux, l'ordi boot que sur win 7
resolution ecran
Dual-boot avec XP - Navigation Internet uniquement sur LINUX
Plus de sujets relatifs à Archlinux : résolution de la police du boot
 > Tous les forums > Forum Linux