> Tous les forums > Forum Linux
 Avatar de l'écran de démarrage de Lightdm - wiki persoSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Mimile
  Posté le 08/10/2017 @ 16:13 
Aller en bas de la page 
Astucien

Bonjour,

Contexte : Archlinux 64 bits - WM : Lightdm

Depuis quelques semaines, quand mon écran d'ouverture de Lightdm s'ouvrait, mon avatar (en fait mon visage) était aplati, évidemment dû au mauvais format de l'image (idéalement 96x96 pixels).

J'ai essayé de modifier cela en modifiant /etc/lightdm/lightdm-gtk-greeter.conf qui ne permet de modifier que l'option default-user-image, ce qui ne produisait aucun effet.

A force d'à force, j'ai finalement compris que l'avatar affiché au lancement de l'écran de connexion lightdm se trouvait en fait dans /var/lib/AccountsService/icons.

J'ai donc repris mon image et comme gimp ne me permettait pas de la structurer en 96x96 sans déformation (peut-être de ma faute car je dois avouer que gimp est d'une complexité qui me dépasse), j'ai fait un tour sous W7 où je possède un logiciel nickel (Snagit) qui permet un nombre incalculable de modifications et surtout de modifier une image en lui donnant les bonnes mesures, sans déformation.

Résultat, j'ai pu mettre mon portrait dans une image au bon format et je l'ai balancée dans /var/lib/AccountsService/icons.

Redémarrage d'Arch et au lancement de lightdm, c'est enfin mon visage qui apparaît normalement.

Ceci est ma petite contribution pour ceux qui se heurtent au même problème maintenant résolu.

Cordialement,



Modifié par Mimile le 08/10/2017 16:18
Publicité
m_n
 Posté le 08/10/2017 à 17:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Moi, j'aime bien le logiciel (( Kolourpaint )) ..

Logicien
 Posté le 08/10/2017 à 19:12 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Chez moi l'avatar de mon utilisateur principal apparaît sous Ligntdm. À propos du fichier /etc/lightdm/lightdm-gtk-greeter.conf et de l'option default-user-image, l'option apparaît après les crochets [greeter] comme ceci:

[greeter]

default-user-image=/mnt/sauve/Images/harfang-100x100.png

Sans les crochets [greeter] je pense qu'aucune option ne fonctionne.



Modifié par Logicien le 08/10/2017 19:18
Mimile
 Posté le 08/10/2017 à 20:06 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

hello Paul

J'avais exactement ce que tu indiques mais bizarrement, à chaque affichage de l'écran de connexion, c'était un autre avatar (aplati) que celui que j'indiquais dans default-user-image qui apparaissait.

[greeter]
keyboard = fr_BE.UTF-8
theme-name = Adwaita
icon-theme-name = Adwaita
background = /media/Stock0/Mes_Images/images diverses/cielbleu.jpg
default-user-image = /usr/share/pixmaps/Ego52.jpg
a11y-states = +keyboard
indicators = ~host;~spacer;~clock;~spacer;~language;~session;~a11y;~layout
xft-dpi =
xft-rgba = none

J'ai passé beaucoup de temps à chercher d'où venait cet autre avatar déplaisant.

J'avais beau modifier default-user-image, rien à faire : toujours mon visage aplati.

Je crois que default-user-image affiche une image par défaut, lorsque, précisément, il n'y en a pas dans /var/lib/AccountsService/icons.

Or, chez moi, dans ce fichier, il y avait une image de ma figure qui avait un calibre inadapté, ce qui m'a fait comprendre qu'à l'arrivée, la zone de Lightdm affichant l'avatar écrasait l'image (calibre 96x96), d'où ma figure aplatie.

[okapi@archie ~]$ cd /var/lib/AccountsService/icons
[okapi@archie icons]$ ls -l
total 72
-rw-r--r-- 1 okapi okapi 2117 8 oct 12:35 okapi

J'ai donné la bonne réponse dans mon premier message, preuve en est que maintenant, mon avatar est correct.

Tu devrais peut-être jeter un coup d’œil dans /var/lib/AccountsService/icons pour voir ce qui s'y trouve.

Je parierais que c'est la même image que celle que tu as indiquée dans /etc/lightdm/lightdm-gtk-greeter.conf.

Cordialement,

Mimile



Modifié par Mimile le 08/10/2017 20:16
Logicien
 Posté le 08/10/2017 à 21:18 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Je n'ai aucune image dans le répertoire /var/lib/AccountsService/icons. Si tu veux faire une expérience, converti l'image que tu veux utiliser comme avatar au format png avec Gimp. Configure lightdm-gtk-greeter.conf pour utiliser cette image. Enlève l'image dans /var/lib/AccountsService/icons, ferme ta session et retourne à Lightdm. Peut-être que ton image apparaîtra. Peut-être que le format de l'image est important.

Spéculatif, mais mon image au format png est reconnue par Lightdm depuis son fichier de configuration lightdm-gtk-greeter.conf.



Modifié par Logicien le 08/10/2017 21:19
Mimile
 Posté le 09/10/2017 à 14:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Paul,

Ce que tu énonces dans ton message (Je n'ai aucune image dans le répertoire /var/lib/AccountsService/icons) me conforte dans ce que j'ai écrit juste auparavant, savoir que l'avatar indiqué dans le paramètre "default-user-image" (lightdm-gtk-greeter.conf) ne s'affiche que si /var/lib/AccountsService/icons est vide, ce qui est précisément ton cas.

On pourrait d'ailleurs traduire "default-user-image" par "image par défaut de l'utilisateur" et dans ma logique, j'en déduis qu'elle ne s'affiche qu'en l'absence d'image dans /var/lib/AccountsService/icons

Pour préciser, avant de trouver l'existence de /var/lib/AccountService/icons, j'avais effectivement formaté l'image indiquée dans default-user-image en 96x96 (le bon format) mais c'était toujours l'image se trouvant dans /var/lib/AccountService/icons qui apparaissait, avec mon visage aplati.

Quand j'ai ouvert ce répertoire, j'y ai effectivement trouvé la photo de mon visage mais dans un format rectangulaire et dépassant largement les 96x96 (195x255), ce qui expliquait l'aplatissement de mon visage sur l'écran de connexion (qui de toute évidence exige une image carrée).

Après avoir compris cela, je lui ai donné le bon format (avec Snagit sous W7 - gimp étant trop compliqué pour moi).

J'ai trouvé la solution que je décris dans le ArchWiki de lightdm https://wiki.archlinux.org/index.php/LightDM où il est dit :

Changing your avatar

Tip: If you are using KDE, you can change your avatar in KDE System Settings.

First, make sure the accountsservice package from the official repositories is installed, then set it up as follows, replacing username with the desired user's login name. The .png file extension should not be included in the filename.

  • Edit or create the file /var/lib/AccountsService/users/username, and add the lines
[User]
Icon=/var/lib/AccountsService/icons/username
  • Create the file /var/lib/AccountsService/icons/username using a 96x96 PNG image file.
Note: Make sure that both created files have 644 permissions, use chmod to correct them.

Je n'ai pas tout-à-fait pratiqué comme dit ci-dessus puisque j'avais déjà un répertoire /var/lib/AccountsService/icons (venu de je-ne-sais-où - peut-être que Lighdm le crée lui-même lors de son installation) mais ça m'a donné l'idée d'aller voir ce qu'il contenait et j'y ai constaté la présence de cette photo inadaptée. (Comment s'est-elle retrouvée là ? mystère ...)

Tu connais la suite.

Comme ça marche bien comme ça, et sans vouloir te peiner, je m'abstiendrai de procéder à l'expérience que tu suggères.

En revanche, à mon tour de te faire une suggestion : place une autre image (au bon format) dans /var/lib/AccountsService/icons, supprime son extension (*.png) puis relance Lightdm.

On verra alors si c'est cette autre image qui s'affiche ou ton image habituelle.

Pour ma part, je vais me remettre à la recherche de la solution qui permettra à mon PC de s'éteindre totalement sans intervention manuelle de ma part.

Amicalement,

Mimile



Modifié par Mimile le 09/10/2017 18:54
Mimile
 Posté le 13/10/2017 à 16:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Je reviens faire amende honorable.

J'ai modifié /etc/lightdm/lightdm-gtk-greeter.conf qui se présente maintenant comme ceci :

[greeter]
keyboard = fr_BE.UTF-8
theme-name = Adwaita
icon-theme-name = Adwaita
background = /media/Stock0/Mes_Images/images diverses/cielbleu.jpg
default-user-image = /usr/share/pixmaps/ed-mini-1.jpg
a11y-states = +keyboard
indicators = ~host;~spacer;~clock;~spacer;~language;~session;~a11y;~layout
xft-dpi =
xft-rgba = none
#font-name = ter-v18b

Comme on le voit, j'ai installé mon avatar calibré à 96x96 (ed-mini-1.jpg)) dans /usr/share/pixmaps.

C'est lui qui s'affiche maintenant dans l'écran de connexion de lightDM.

Par contre, quand mon PC passe en pause quand il reste inutilisé pendant quelques minutes, mon avatar n'apparaît plus quand je réanime mon PC alors qu'auparavant, c'était ma tête en grand format qui s'affichait au dessus de la prise de mot de passe.

Je cherche à résoudre de ce petit désagrément.

Mimile
 Posté le 21/10/2017 à 14:42 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut

Pour je ne sais quelle raison, mon avatar qui s'affichait en sortie de pause et qui ne s'affichait plus depuis quelque temps (voir texte ci-dessus), s'affiche maintenant comme avant.

Sujet clôturé donc.



Modifié par Mimile le 21/10/2017 14:43
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Démarrage avec écran noir
démarrage de backtrack v5 ecran noir led maj clign
Ecran noir après le démarrage d' Ubuntu 11.10
Problème affichage écran au démarrage avec 10.10
Ecran de démarrage
Ecran noir au démarrage
splashscreen/ecran de demarrage kde
Retirer ecran de demarrage apres desintallation
Ecran ou carte graphique non reconnue + Pas de son
Ecran noir au début de l'installation
Plus de sujets relatifs à Avatar de l''écran de démarrage de Lightdm - wiki perso
 > Tous les forums > Forum Linux