> Tous les forums > Forum Linux
 Besoin de conseils pour mise à jour Debian TestingSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
milou32
  Posté le 06/01/2015 @ 23:02 
Aller en bas de la page 
Astucienne

Bonjour les Linuxiens

J'ai besoin des conseils des spécialistes Debian Testing

Je viens de lancer la mise à jour de ma Debian Testing, mais j’ai une hésitation....
Sur les conseils de Logicien et de Hido, j’avais installé les paquets apt-listbugs et apt-listchanges pour avoir les rapports de bugs.

après avoir fait apt-get update

J’ai ce retour avec apt-get upgrade

Analyse des informations Trouvé/Corrigé… Fait
bogues de gravité critical sur systemd (215-7 → 215-8) <En attente de traitement>
b1 - #774020 - systemd: black screen with backlight on start. rescue mode plus Ctrl-D allows normal boot
bogues de gravité serious sur systemd-sysv (215-7 → 215-8) <Transférés>
b2 - #774335 - Provides: in SysV init scripts are not handled correctly, leading to wrong orderings
bogues de gravité serious sur ifupdown (0.7.50 → 0.7.51) <Résolus dans une version donnée>
b3 - #774212 - ifupdown: segfault when misssing read access on /etc/network/interfaces (Corrigé : ifupdown/0.7.52)
Résumé :
systemd(1 bogue), systemd-sysv(1 bogue), ifupdown(1 bogue)
Êtes-vous certain de vouloir installer/mettre à jour les paquets ci-dessus ? [Y/n/?/...] n
****************************************************************
****** Sortie sur erreur pour interrompre l'installation. ******
****************************************************************
E: Le sous-processus /usr/sbin/apt-listbugs apt a renvoyé un code d'erreur (10)
E: Failure running script /usr/sbin/apt-listbugs apt


Bien sûr, comme ça concerne systemd, j’ai dit non pour l'installation en attendant vos avis

Ce que je voudrais savoir aussi, c’est quand je refuse l’installation de paquets bogués, est-ce que ça bloque les autres mises à jour ?
Parce que mon gestionnaire de mises à jour continue à m’en proposer (264 exactement ) malgré que j’ai fait apt-get update dans un terminal.
Est-ce que je suis obligée de passer par le gestionnaire pour faire mes mises à jour dans ce cas là ?
J’ai trouvé les trois paquets signalés comme comportant des bugs et je les ai décochés.

Je sais, ça fait beaucoup de questions, comme d'habitude

J’attends vos conseils avant de les lancer



Modifié par milou32 le 06/01/2015 23:26
Publicité
m_n
 Posté le 07/01/2015 à 02:56 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Message original par milou32

Bonjour les Linuxiens

J'ai besoin des conseils des spécialistes Debian Testing

https://www.debian-fr.org/

Slyvester
 Posté le 07/01/2015 à 11:17 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour Milou,

Je te conseille de lire, et même de relire ce "post" extrêmement intéressant : https://forum.pcastuces.com/debian_et_derivees___questions_diverses-f8s14369.htm . Notre ami Québecquois Logicien y précisait notamment : " ...

sudo apt-get update met à jour la liste des paquets disponibles dans les dépôts distants configurés.

sudo apt-get upgrade
met à jour le système Debian avec les nouvelles versions disponibles des paquets installés. Cette commande ne désinstalle aucun paquet.

sudo apt-get dist-upgrade met à jour le système Debian avec les nouvelles versions disponibles des paquets installés. Cette commande peut désinstaller des paquets. À utiliser seulement si on sait ce que l'on fait, par exemple, une mise-à-jour d'une version majeure de Debian vers la suivante.La première commande doit précéder la seconde quand on fait une mise-à-jour. Les paquets suggérés ne sont pas essentiels au bon fonctionnement du système Debian et des applications, mais ajoutent des fonctionnalités supplémentaires. Ils sont optionnels".

Fort de ce qui précède, sur ma Debian Jessie testing" & sur ma Debian Wheezy stable", je fais toujours les mises-à-jour (et mises-à-niveau) via terminal de la façon suivante : "sudo apt-get update &"depuis plus de quatre mois en procédant de cette manière.

Lors de messages gênants, j'utilise les commandes : "sudo sudo dpkg --configure - a" & "sudo apt-get install -f". Jamais rencontré de problèmes majeurs sur ma "SparkyLinux testing" ni sur ma "WattOS R8 stable".

hido
 Posté le 07/01/2015 à 11:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

bonjour

Ce que je voudrais savoir aussi, c’est quand je refuse l’installation de paquets bogués, est-ce que ça bloque les autres mises à jour ?

non

jette un œil sur cette page http://www.isalo.org/wiki.debian-fr/Apt-listbugs

milou32
 Posté le 07/01/2015 à 12:37 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucienne

Bonjour Slyvester,

C'est la méthode que j'applique pour faire mes mises à jour pour Debian

Bonjour Hido,

Merci pour ton lien. Si j'ai bien tout compris à cette question

Êtes-vous certain de vouloir installer/mettre à jour les paquets ci-dessus ? [Y/n/?/...]

Je dois répondre a pour que les paquets bogués soient ignorés, mais que l'installation des autres mises à jour se poursuivent ?

Ou je dois choisir p pour que ces paquets ne me soient plus proposés à l'installation tant qu'il sont bogués ?



Modifié par milou32 le 07/01/2015 12:41
hido
 Posté le 07/01/2015 à 12:46 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

non

il faut mettre p pour figer le paquet, il sera mis à jour quand le bug aura été corrigé

Relis bien c'est bien expliqué



Modifié par hido le 07/01/2015 12:52
milou32
 Posté le 07/01/2015 à 12:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucienne

Oui, c'est ce que j'avais compris en relisant c'est pour ça que j'ai modifié mon message

Avec a, il ne sera pas installé, mais me sera reproposé à la prochaine mise à jour

alors qu'avec p, il ne me sera plus proposé tant qu'il n'aura pas été corrigé.

Merci Hido, je fais les mises à jour

hido
 Posté le 07/01/2015 à 12:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

en fait je pense avoir mal compris du coup j'ai édité mon post.

ignorer je pense que ça veut dire qu'il va quand même installer les paquets buggés

milou32
 Posté le 07/01/2015 à 12:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucienne

ça me fait plaisir, car j'ai relu plusieurs fois et j'ai le même doute que toi

Dans le doute, je choisis p c'est plus sûr

Publicité
milou32
 Posté le 07/01/2015 à 13:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucienne

ça m'aurait étonné que tout se passe normalement

Je te mets le retour

Récupération des rapports de bogue… Fait
Analyse des informations Trouvé/Corrigé… Fait
bogues de gravité critical sur systemd (215-7 → 215-8)
b1 - #774020 - systemd: black screen with backlight on start. rescue mode plus Ctrl-D allows normal boot
bogues de gravité serious sur systemd-sysv (215-7 → 215-8) <Transférés>
b2 - #774335 - Provides: in SysV init scripts are not handled correctly, leading to wrong orderings
bogues de gravité serious sur ifupdown (0.7.50 → 0.7.51) <Résolus dans une version donnée>
b3 - #774212 - ifupdown: segfault when misssing read access on /etc/network/interfaces (Corrigé : ifupdown/0.7.52)
Résumé :
systemd(1 bogue), systemd-sysv(1 bogue), ifupdown(1 bogue)
Êtes-vous certain de vouloir installer/mettre à jour les paquets ci-dessus ? [Y/n/?/...] p
Les 3 paquets suivants seront figés ou mis en attente :
ifupdown, systemd, systemd-sysv
Confirmez-vous cette action ? [Y/n]
ifupdown systemd systemd-sysv épinglé par ajout de préférences « Pin » dans /etc/apt/preferences.d/apt-listbugs.
APT devra être relancé pour activer cette option
Êtes-vous certain de vouloir installer/mettre à jour les paquets ci-dessus ? [N/?/...] n
****************************************************************
****** Sortie sur erreur pour interrompre l'installation. ******
****************************************************************
E: Le sous-processus /usr/sbin/apt-listbugs apt a renvoyé un code d'erreur (10)
E: Failure running script /usr/sbin/apt-listbugs apt

Quand je fait cat pour vérifier l'état du fichier /etc/apt/preferences, j'ai ce retour

root@testing:~# cat /etc/apt/preferences
cat: /etc/apt/preferences: Aucun fichier ou dossier de ce type

Par contre à la commande

root@testing:~# cat /etc/apt/preferences.d/apt-listbugs

Explanation: Pinned by apt-listbugs at 2015-01-07 12:58:29 +0100
Explanation: #774212: ifupdown: segfault when misssing read access on /etc/network/interfaces
Package: ifupdown
Pin: version 0.7.50
Pin-Priority: 1000

Explanation: Pinned by apt-listbugs at 2015-01-07 12:58:29 +0100
Explanation: #774020: systemd: black screen with backlight on start. rescue mode plus Ctrl-D allows normal boot
Package: systemd
Pin: version 215-7
Pin-Priority: 1000

Explanation: Pinned by apt-listbugs at 2015-01-07 12:58:29 +0100
Explanation: #774335: Provides: in SysV init scripts are not handled correctly, leading to wrong orderings
Package: systemd-sysv
Pin: version 215-7
Pin-Priority: 1000

Je relance la mise à jour ? Les paquets bogués sont bien fixés ?



Modifié par milou32 le 07/01/2015 13:11
milou32
 Posté le 07/01/2015 à 13:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucienne

J'ai relancé les mises à jour, plus de rapport de bogues, donc je suppose que les paquets ont bien été fixés.

Les mises à jour sont faîtes.
Comme j'aime voir ces lignes défiler, voir ce qui se passe en direct dans le système

Merci Hido , je passe en résolu

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Carte wifi plus reconnue après mise à jour Debian Testing
Mise-à-jour Debian Testing/Sid: Améliorations !
Mise à jour de ma Debian Wheezy vers Jessie
installer debian testing pour tester quelque chose.....
Debian Wheezy HS après mise à jour
Prévenir la mise-à-jour d'un paquet sous Debian et dérivées
Pas de connection pour mise à jour
Miroir de mise a jour pour mdk / amd64
mise a jour adobe
Archlinux : mise à jour foireuse - merci chroot !
Plus de sujets relatifs à Besoin de conseils pour mise à jour Debian Testing
 > Tous les forums > Forum Linux