> Tous les forums > Forum Linux
 bureau XFCE4 rempli d'icônes GNOME (Slim)
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Mimile
  Posté le 11/06/2012 @ 11:14 
Aller en bas de la page 
Astucien

Bonjour;

J'ai installé Arch avec Gnome (restreint) lancé par GDM.

Sous Virtualbox, j'ai testé Slim qui démarre au choix Gnome ou XFCE4 et tout fonctionne bien : pas d'interaction entre les deux.

J'ai donc installé Slim sur ma Arch en dur, fait les modifications nécessaires (.xinitrc, slim.conf et inittab) et dans un premier temps, j'ai vérifié que Gnome démarrait bien au départ de Slim.

J'ai alors installé XFCE4 (+ses annexes : goodies, etc...) sans problème puis j'ai lancé XFCE4 au démarrage de Slim.

Le petit message d'accueil s'est affiché (choix entre un bureau normal ou vide - ou quelque chose comme ça) et j'ai choisi le nureau normal.

Les barres de tâches typiques de XFCE4 sont apparues mais aussi une kyrielle d'icônes qui proviennent inévitablement de Gnome : j'y retrouve les icônes de mon bureau Gnome y compris la poubelle, et divers fichiers venus de je ne sais où.

Bref, ce bureau est un vrai foutoir ...

Quelqu'un pourrait-il me dire ce qui justifie la présence de ces icônes du bureau gnome et comment faire en sorte qu'elles n'apparaissent plus ?

Je lui en serais infiniment reconnaissant.

Publicité
Mori
 Posté le 11/06/2012 à 16:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

c'est l'un des problèmes de xfce : il aspire tout ce qui passe des autres bureaux. il est en outre juste un peu moins gourmand que gnome-panel. et ce n'est pas évident de modifier les menus sous xfce. bref, je lui ai préféré (étant un gnomien de la première heure), à force de quête de simplicication, un wm comme fluxbox, facilement configurable pour les applications à lancer.

Logicien
 Posté le 12/06/2012 à 21:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

ton problème Mimile n'est pas lié à Slim ou à un quelconque gestionnaire d'affichage à ce que je sache. Il est lié au fait que le répertoire $HOME/Desktop, par défaut, sert de dossier pour le bureau à Gnome2 ou 3 restreint (?), Lxde et Xfce.

J'avais remarqué que Kde3 et Gnome2 utilisaient par défaut $HOME/Desktop comme dossier pour le bureau et qu'une icône placée sur le bureau de Kde3 se voyait aussi depuis le bureau de Gnome2 et vice-versa. Heureusement, Kde3 permettait de changer le dossier du bureau. Je lui donnait $HOME/Bureau. Comme ceci, les icônes de chaque environnement de bureau étaient séparées. Gnome2 permet aussi d'utiliser le répertoire personnel $HOME comme dossier du bureau. Sans intérêt pour moi.

Avec Kde4, le répertoire par défaut du bureau de Kde a changé et n'est plus partagé avec les autres bureaux. Gnome3 permet d'utiliser $HOME/Desktop grâce à une option de Gnome-tweak-tool. Sinon, l'arrière plan du bureau est libre d'icônes parce-que par défaut $HOME/Desktop n'est plus utilisé comme dossier du bureau.

L'idéal serait que chaque environnement de bureau ait une option de configuration qui permette de lui attribuer un dossier unique pour le bureau afin de ne pas mélanger les icônes. Peut-être est-ce déjà possible. Je n'ai trouvé aucune variable d'environnement configurable pour le répertoire du bureau après recherche dans les répertoires $HOME/.config, $HOME/.local, /etc/xdg et lecture de pages de manuels d'Xfce. J'espère qu'un jour ce le sera.

En attendant, j'ai modifié $HOME/.xinitrc sous Debian afin qu'il n'installe dans $HOME/Desktop que les icônes de l'environnement de bureau démarré avec X, que ce soit Lxde ou Xfce. J'utilise présentement Gnome mais seulement en version 3 et Kde en version 4. Pour Gnome3 et Kde4 le problème ne se pose plus si on garde la configuration par défaut de ces bureaux.



Modifié par Logicien le 13/06/2012 10:34
Mimile
 Posté le 14/06/2012 à 09:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Effectivement Gnome (restreint), XFCE et lxde (que je viens d'ajouter) utilisent le même $HOME/Desktop.

Cela dit, je trouve lxde plutôt agréable (démarrage ultra-rapide) et pas trop gourmand en ressources, ce qui convient bien à mon vieux PC.

Dommage que je n'ai pas encore trouvé le moyen d'ajouter des lanceurs dans la barre des tâches ....

Mori
 Posté le 14/06/2012 à 11:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Mimile
 Posté le 14/06/2012 à 12:42 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Merci pour le lien mais je n'arrive pas à mes fins.

Sous Gnome, il y a une ligne de commande similaire qui permet de créer un lanceur que l'on peut ensuite transférer sur le bureau ou dans la barre des tâches.

Ici, il est indiqué que le lanceur (il s'agit de lancer un petit script perl) est lancé par ... gedit !

J'ai beau modifier en indiquant la ligne de commande correcte, on en revient toujours à gedit bien que j'aie indiqué que le script était exécutable.

Je dois rater une étape mais je ne vois pas laquelle ...

Résumé : je crée mon lanceur :

Je me rends dans le dossier .local/share/application et j'y trouve mon raccourci :

Quand j'affiche les propriétés :

S'ouvre avec gedit !!!

J'ai beau modifier pour indiquer la ligne de commande correcte, ça échoue :

Raaaah



Modifié par Mimile le 14/06/2012 12:56
Mori
 Posté le 14/06/2012 à 15:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

l'application doit être un *.desktop (avec sa structure) pour que lxde le reconnaisse.

http://linux.koolsolutions.com/2009/09/11/howto-place-programs-on-lxde-desktop/

c'est un peu casse-noisette lxde de ce côté-là. rien à voir avec fluxbox, qui est plus simple.

Logicien
 Posté le 14/06/2012 à 19:06 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Vous vérifierez par vous-mêmes. J'ai remarqué au moins deux comportements bizarres avec Lxde.

Si j'édite une icône placée sur le bureau avec l'option du menu contextuel donné par le clic droit sur l'icône, que je modifie la commande à exécuter et que je sauvegarde, cela peut faire paniquer PCManFM, le gestionnaire de fichiers qui gère le bureau sous d'Lxde. L'icône modifiée se positionne ailleurs sur le bureau et il arrive qu'il ne soit plus possible de cliquer sur les icônes du bureau. Elles ne se mettent plus en surbrillances. Impossible de démarrer une application depuis les icônes du bureau. Je dois redémarrer la session pour corriger le problème.

Si je déroule le menu de la barre des tâches et que le pointeur de la souris est ailleurs que sur le menu, le menu reste ouvert peu importe où je clique gauche hors du menu pour le fermer. Il faut que le pointeur soit sur le menu pour fermer le menu, le plus souvent avec des Esc successifs correspondants au nombre de sous-menus déroulés.

Je dois dire que j'utilise presque toujours Compiz comme gestionnaire de fenêtres avec Lxde. Cela peut changer des choses vu qu'Openbox est le gestionnaire de fenêtres par défaut d'Lxde.



Modifié par Logicien le 14/06/2012 19:18
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
aligner icones sur bureau gnome [resolu]
Icônes énormes après installation de Gnome 3.16.0
Bouger les icones du bureau avec KDE
Archlinux + Gnome + slim : 2 messages inquiétants
Barre en bas sous bureau Gnome
raccoucis (icones ) de programmes en haut bureau
disparition icones du bureau
UBUNTU passer de gnome à XFCE4.2 ? [RESOLUT]
Actualisation bureau gnome
icones du bureau : ouvrir avec krusader
Plus de sujets relatifs à bureau XFCE4 rempli d''icônes GNOME (Slim)
 > Tous les forums > Forum Linux