> Tous les forums > Forum Bureautique
 Calcul de durées dans ExcelSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Jaruska
  Posté le 08/04/2011 @ 15:55 
Aller en bas de la page 
Petit astucien

Bonjours,

J'ai un problème de calcul de durée entre une dates départ et une date actuelle. J'ai formaté: j" jours" h" h" mm et cela fonctionne très bien jusqu'à une durée inférieure à 1 mois entre les deux dates, après le nombre de jours recommencent à 1.

Ex. de: 02 mars à 20 h 40 à 02 avr à 15 h 30 = 30 jours 18 h 50

02 mars à 20 h 40 à 08 avr à 15 h 30 = 5 jours 18 h 50

http://www.cijoint.fr/cjlink.php?file=cj201104/cijQpTdsVi.xlsx

Merci pour la (les) réponse(s).

Publicité
ferrand
 Posté le 08/04/2011 à 17:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonsoir,

Pour l'instant je ne vois que cette transformation de ta formule pour obtenir le résultat souhaité:

=SI(OU($A2="";$B2<$A2);"";ENT($B2-$A2)&" jours "&TEXTE($B2-$A2;"h"" h ""mm"))

Le format de cellule n'a plus d'effet puisque le résultat est du texte. Attention si ce résultat doit intervenir dans des calculs ultérieurs, il faudra reconvertir le texte en nombre ou (plus aisément) repartir des cellules initiales.

http://cjoint.com/?1eirERF586U

Bonne continuation.

Jaruska
 Posté le 09/04/2011 à 13:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Merci beaucoup, ça fonctionne très bien. Pour la suite des calculs se référant à la cellule "C2", j'ai remplacé C2 par ($B2-$A2) dans les formules et tout est parfait.

Cordialement

ferrand
 Posté le 09/04/2011 à 13:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

La formule ci-dessous, reconvertit la chaîne en nombre (pour le plaisir...):

=SI($C2<>"";CNUM(GAUCHE($C2;TROUVE(" jours";$C2)-1))+TEMPS(CNUM(STXT($C2;TROUVE(" h";$C2)-2;2));CNUM(DROITE($C2;2));0);"")

Mais repartir de A et B reste plus pratique à mettre en oeuvre.

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
1199,99 €PC portable 14'' Asus Vivobook Pro (OLED QHD+, R7 5800H, 16 Go, SSD 1 To, RTX 3050 Ti) à 1199,99 €
Valable jusqu'au 23 Mai

RueDuCommerce fait une promotion sur le PC portable Asus Vivobook Pro 14 N7400QE-KM008T qui passe à 1199,99 € au lieu de 1549 €. Cet ordinateur dispose d'un superbe écran 14 pouces OLED QHD+ (2880x1800p), d'un processeur AMD Ryzen 7 5800H (8 coeurs) avec chip Radeon Vega 8 intégré, 16 Go de RAM, un SSD NVMe de 1 To, d'une carte graphique Nvidia RTX 3050 Ti et tourne sous Windows 10 que vous pouvez mettre à jour vers Windows 11.

Un super PC pour les créateurs qui ont besoin de mobilité.


> Voir l'offre
55,99 €Alimentation semi modulaire Corsair TX550M Gold à 55,99 €
Valable jusqu'au 24 Mai

RueDuCommerce propose actuellement l'alimentation semi modulaire Corsair TX550M à 55,99 €. Cette alimentation de 550 W est certifiée 80+ Gold et est garantie 7 ans. On la trouve ailleurs à partir de 85 €. Semi-modulaire, elle permet d'utiliser uniquement les câbles nécessaires, pour un assemblage épuré et une circulation de l'air plus efficace.


> Voir l'offre
247,46 €Casque sans fil à réduction de bruit Sony WH-1000XM4 (Hi-Res Audio, Bluetooth/NFC) à 247,46 € livré
Valable jusqu'au 24 Mai

Amazon Italie propose actuellement l'excellent casque sans fil à réduction de bruit et Hi-Res Audio Sony WH-1000XM4 à 241,76 € (avec la TVA ajustée). Comptez 5,70 € pour la livraison en France soit un total de 247,46 € livré. On le trouve ailleurs à partir de 291 €. Equipé de l'annulation de bruit active, d'une connexion sans fil Bluetooth et NFC, d'un confort supérieur et d'une autonomie longue durée (30 heures), ce modèle vous accompagnera idéalement dans tous vos déplacements. Profitez d'une qualité acoustique Hi-Res Audio, de commandes tactiles intuitives et des assistants vocaux intégrés. Laissez-vous transporter au coeur des émotions de vos morceaux préférés et révolutionnez votre manière d'écouter la musique.


> Voir l'offre

Sujets relatifs
Comment insérer un tableau Excel de calcul dans un site?
Excel: valeur cellule impliquée dans calcul ailleurs -> connexions
Problème de calcul dans Excel 2010
Excel reporter détail de calcul dans formule
Calcul dans excel
une erreur dans la formule de calcul avec excel
calcul de l'âge dans excel 2003
calcul de durées et décompte sous Excel
CALCUL DANS EXCEL
créer un calcul en boucle dans excel
Plus de sujets relatifs à Calcul de durées dans Excel
 > Tous les forums > Forum Bureautique