> Tous les forums > Forum Bureautique
 calcul de nombre de celluleSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
ed
  Posté le 02/10/2010 @ 16:12 
Aller en bas de la page 
Petit astucien

Bonour a tous

voilà mon petit soucis

j'ai un tableau A1: Q33

ce qui m'interresse c'est la colonne K et L

sur la colonne k j'ai K1=3: k2=200: k3=200 les autres ne sont pas encore remplis

sur la colonne L j'ai L1=4: L2:150:L3=7 les autres ne sont pas encore remplis

dans la cellule quelconque pour mon exemple ce sera V1. je souhaiterai compter le nombre de cellule avec ces conditions si K1>L1 + K2>L2 + K3>L3

je peux le faire avec la formule NBSI mais le probleme que si je rempli K4 et L4 je suis obligé de rajouter la formule dans V1 et c'est ce que je voudrais eviter.

ce que je voudrais je selectionne le plage K1 à K33 et L1 à L33 et le resultat me donne ce que j'ai rempli dans les cellules.

exemple pour mon cas : en sélectionnant la plage complète : le resultat me donne "2" et si je rajoute K4=200 et L4=8 dans le tableau. le resultat en V1 est "3" sans que je puisse modifier la formule.

Est ce possible ?

j'espere que j'étais clair

merci de vos reponses

cordialement

Publicité
gr42
 Posté le 02/10/2010 à 16:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

bonjour,

En général, pour ce type de problème , le mieux est de pouvoir visualiser le tableau.

Donc permettre de le charger sur dl.free.fr par ex

ce sera + facile de répondre et d etrouver la bonne formule

papouclo
 Posté le 02/10/2010 à 16:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour

Essayer dans V1 (mais surtout pas dans une cellule des colonnes K et L) la formule matricielle :

{=SOMME(1*(K:K>L:L))}

Rappel : Pour obtenir une formule matricielle, on tape la formule =SOMME(1*(K:K>L:L)) et on valide avec les trois touches
simultanées Ctrl , Shift, Enter. Les accolades en début et en fin de formule se placent alors automatiquement.

Cordialement.

ed
 Posté le 02/10/2010 à 16:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

http://dl.free.fr/tJ9pG6HNp'); return false;" href="http://dl.free.fr/tJ9pG6HNp">http://dl.free.fr/tJ9pG6HNp

comme vous voyez c'est une patie d'un tableau mais c'est ses 2 colonnes qui m'interre. En E3 j'ai mis cette formule =NB(A3<B3;A4<A5;A5<B5)

mais le probleme c'est que ces colonnes vont être alimentées et je voudrais que le resultat se met a jour sans modifier la formule

et encore merci

ed
 Posté le 02/10/2010 à 17:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

bonjour

merci papouclo d'essayer de m'aider mais cela ne marche pas.

est ce que le lien fonctionne.

j'ai oublié de vous dire , je suis sur excell2007

papouclo
 Posté le 02/10/2010 à 17:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Rebonjour,

Le lien fonctionne mais j'ai toujours des problèmes pour récupérer les fichiers Excel 2007 après que le site
d'accueil les aient compressés sous format .rar

Serait-il possible de sauvegarder l'exemple sous le format 2003 (au moment d'enregistrer sous...) et de
renvoyer ce fichier sur le site d'accueil ?

Cordialement

ed
 Posté le 02/10/2010 à 18:15 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Ok le fichier est converti. voila le lien

http://dl.free.fr/cWybzLwiq'); return false;" href="http://dl.free.fr/cWybzLwiq">http://dl.free.fr/cWybzLwiq

la formule est bien interactif, il incremente quand je saisi une ligne mais elle ne fait pas la différence si A1>B1, A2>B2 etc....

merci quand même

papouclo
 Posté le 02/10/2010 à 18:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

Le problème vient de la ligne 1 qui contient des titres ce que votre demande initiale ne mentionnait pas.
Il me semblait que les valeurs à comparer commencaient en ligne 1 et j'ai compris avec votre fichier.

EN A1, on a "Place payée" et en B1 "Classement" ; or par ordre alphabétique, Place Payée vient après Classement,
d'où, pour Excel : A1 > B1 ce qui explique le total 4 lorsque vous attendez 3.

Pour éviter cette ligne de titre, on peut utiliser la formule :

{=SOMME(1*(DECALER(A2;0;0;NBVAL(A:A);1)>(DECALER(B2;0;0;NBVAL(B:B);1))))}

ou encore beaucoup plus simplement :

{=SOMME(1*(A:A>B:B))-1}

Cordialement

rj390111
 Posté le 02/10/2010 à 18:37 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

En V1 mettre

=SOMMEPROD(($K$1:$K$33>$L$1:$L$33)*1)

ed
 Posté le 02/10/2010 à 19:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

c'est vrai que je n'ai pas ditqu'il y avait un titre et la premiere ligne vide, je n'y avais pas pensé (rien ne vaux un exemple en fichier joint :-))

j'ai essayé en supprimant la ligne vide et ca a l'air de fonctionné, j'essayerai plus profondément demain et je vous tiendrai au courant.

merci beaucoup

A+

Cordialement

ferrand
 Posté le 02/10/2010 à 20:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

rj390111 a écrit :

Bonjour,

En V1 mettre

=SOMMEPROD(($K$1:$K$33>$L$1:$L$33)*1)

Parfait ! Cela évite d'avoir à saisir une formule matricielle [SOMMEPROD l'étant directement] et elle peut aussi être écrite sous la forme =SOMMEPROD((K:K>L:L)*1) ou =SOMMEPROD((A:A>B:B)*1) [pour prendre les références du classeur exemple] ; dans ce cas, pour éviter la comptabilisation des cellules contenant du texte :

=SOMMEPROD((A:A>B:B)*1;(A:A)<"")*1)

ed
 Posté le 05/10/2010 à 19:24 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

bonjour a tous

c'est pour vous dire merci a tous qui m'ont aidé.

j'ai pris cette formule qui fonctionne: =SOMMEPROD((Everest!$K$5:$K$33>Everest!$L$5:$L$33)*1) de rj390111 et papoucho . c'est plus facile pour moi. avec un peu de mal pour mettre le nom de la feuille et il me donnait une erreur de 1 et j'ai compris qu'il comptais le titre "Merci papoucho"

=SOMME(1*(DECALER(A2;0;0;NBVAL(A:A);1)>(DECALER(B2;0;0;NBVAL(B:B);1))))} fonctionne mais quand la formule est sur la même feuille mais elle se trouve ailleurs et j'ai un peu de mal. cela ne vient pas de la formule mais de moi

=SOMMEPROD((A:A>B:B)*1;(A:A)<"")*1), je n'arrive pas a la faire fonctionné mais cela vient surement de moi.

toutes les formules que vous m'avez donné sont interressantes et je les mets de coté (je comprend comment fonctionne les matriciels)

je vais bucher un peu les autres formules pour comprendre

et encore merci

A+ cordialement

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
-6 €6 € offerts pour toute recharge de son compte Amazon de 70 €
Valable jusqu'au 07 Août

Amazon remet en avant son offre pour obtenir un bon d'achat de 6 € sur Amazon. Pour toute recharge de son compte Amazon d'au moins 70 €, Amazon vous offre un bon d'achat de 6 € utilisable jusqu'au 31 Octobre 2022. Vous pouvez utiliser le solde de votre compte Amazon pour tous vos achats.

Notez que cette offre n'est pas disponible si vous avez déjà rechargé votre compte Amazon dans les 36 derniers mois.


> Voir l'offre
32,24 €Outil rotatif sans fil multifonction POPOMAN + 58 accessoires à 32,24 €
Valable jusqu'au 27 Mai

Amazon fait une promotion sur l'outil rotatif multifonction sans fil POPOMAN avec ses 58 accessoires qui passe à 32,24 € avec un coupon de réduction de 25% à activer sur la page du produit. On le trouve habituellement autour de 42,99 €. Cet outil va vous permettre de découper, poncer, percer, nettoyer. Il est compatible avec tous les outils de Dremel. Il est sans fil et rechargeable via USB-C.


> Voir l'offre
30,49 €Clavier sans fil Microsoft All in One avec pad intégré à 30,49 €
Valable jusqu'au 27 Mai

Amazon fait une promotion sur le clavier Microsoft All in One qui passe à 30,49 € au lieu de 39 €. Ce clavier sans fil (jusqu'à 9 mètres) est idéal pour piloter un ordinateur à distance puisqu'il intègre un touchpad pour contrôler également la souris. Léger, solide et résistant aux éclaboussures, il comporte de nombreuses touches multimédia personnalisables. Il est garanti 3 ans.


> Voir l'offre

Sujets relatifs
Excel: valeur cellule impliquée dans calcul ailleurs -> connexions
afficher le calcul d'une cellule
Calcul d'un coef suivant le % et du nombre d'éléme
Nombre de mots répétés dans une même cellule
OPEN OFFICE CALC - CALCUL NOMBRE CELLULES
calcul nombre de fois valeur max
Calcul nombre jours
Compter le nombre cellule de telle annee
Format de cellule texte vers nombre
calcul du nombre de jours
Plus de sujets relatifs à calcul de nombre de cellule
 > Tous les forums > Forum Bureautique