> Tous les forums > Forum Bureautique
 calcul nombre de fois valeur maxSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
dlxpat
  Posté le 15/01/2010 @ 16:15 
Aller en bas de la page 
Astucien

Bonjour et bonne année à tous. Qui peut me dire SVP quelle formule inscrire dans un tableau pour qu'apparaisse automatiquement le nombre de fois où la valeur d'une cellule est égale au max de la ligne dans laquelle elle se trouve ?

J'aimerais joindre le fichier mais je ne connais plus le lien !!!

JOUR A B C D E

01.01 1 1 2 3 3

02.01 1 4 1 3 3

03.01 5 5 4 0 2

Nombre de max (c'est ci-dessous que j'aimerai inscrire la formule !!)

1 2 0 1 1

Publicité
ferrand
 Posté le 15/01/2010 à 16:52 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

Tu as intérêt à mettre ta formule dans une cellule de la ligne où tu recherches le nombre de max, tu pourras ainsi la tirer vers le bas pour les lignes suivantes.

Si les jours en col. A, tes valeurs en col. B à F, à partir de la ligne 2 (comme ton schéma) :

=NB.SI(B2:F2;MAX(B2:F2))

à placer sur la ligne 2 et étendre vers le bas dans la même colonne.

dlxpat
 Posté le 17/01/2010 à 10:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Merci pour cette réponse qui est dèjà une trés bonne première étape, mais comment faire apparaitre le total des max par nom (A, B, C.....)

Merci d'avance

ferrand
 Posté le 17/01/2010 à 20:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Excuses, j'ai lu trop vite, je pensais que tu le voulais par ligne.

Je n'ai pas le temps de chercher si on peut construire une formule directe, mais indirectement on peut: tu ajoutes une colonne à ton tableau, en H par exemple, en H2, tu mets: =MAX(B2:F2), tu tires ça sur la colonne (sur ton exemple jusqu'à la ligne 4, tu auras une colonne de max).

A partir de là, la formule tapée en colonne B sur une ligne en dessous:

=SOMMEPROD((B2:B4=$H$2:$H$4)*1)

tirée sur la ligne jusqu'à la colonne F, te donnera ton résultat.

dlxpat
 Posté le 18/01/2010 à 07:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Génial ça marche !! merci et bonne journée

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
449,99 €Ultraportable MSI Modern 14 (Core i3, 8 Go RAM, SSD 256 Go) à 449,99 €
Valable jusqu'au 25 Janvier

RueDuCommerce fait une promotion sur l'ultraportable MSI Modern 14 B10MW-634XFR qui passe à 449,99 € au lieu de 549,99 €. Cet ordinateur possède une dalle 14 pouces Full HD, est équipé d'un processeur Intel Core i3-10110U, de 8 Go de RAM et d'un SSD NVME de 256 Go. Il ne pèse que 1,18 kg et offre une autonomie d'une dizaine d'heures. 

 L'ordinateur est livré sans OS mais vous pouvez facilement installer Windows 10.


> Voir l'offre
39,99 €SSD PNY CS900 480 Go à 39,99 €
Valable jusqu'au 21 Janvier

Cdiscount fait une promotion sur le SSD PNY CS900 480 Go qui passe à 39,99 €. Ce SSD offre des vitesses d'écriture de 515 Mo/s et de lecture à 550 Mo/s. Il est garanti 3 ans.


> Voir l'offre
199,99 €Smartphone 6.67 pouces Xiaomi Redmi Note 9 Pro (FHD+, 6Go/128Go) à 199,99 €
Valable jusqu'au 21 Janvier

Darty fait une promotion sur le smartphone 6.53 pouces Xiaomi Redmi Note 9 Pro qui passe à 199,99 € au lieu de 300 €. Ce smartphone dispose d'un écran 6.67 pouces FHD+ (2400x1080 pixels), un processeur 8 coeurs Snapdragon 720, 6 Go de mémoire, de 128 Go d'espace de stockage extensible par microSD, d'un APN 64 +8 +2 + 2 MPixels et d'un APN 32 MP avant, du bluetooh, du Wifi, d'un lecteur d'empreintes digitales. Il est compatible avec les fréquences 2G, 3G et 4G. Le tout tourne sous Android 10 avec une surcouche Xiaomi. La batterie est de haute capacité 5020 mAh et est compatible charge rapide. Un bracelet sportif Xiaomi Mi Band 5.0 vous est également offert (valeur 30 €).


> Voir l'offre

Sujets relatifs
calcul plus grande valeur d'une colonne
Excel: valeur cellule impliquée dans calcul ailleurs -> connexions
Calcul d'un coef suivant le % et du nombre d'éléme
OPEN OFFICE CALC - CALCUL NOMBRE CELLULES
calcul de nombre de cellule
Calcul nombre jours
calcul du nombre de jours
calcul sur nombre d'heures
combien de fois la même valeur
Calcul d'heures sur période de 28 jours
Plus de sujets relatifs à calcul nombre de fois valeur max
 > Tous les forums > Forum Bureautique