> Tous les forums > Forum Bureautique
 calcul nombre de fois valeur maxSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
dlxpat
  Posté le 15/01/2010 @ 16:15 
Aller en bas de la page 
Astucien

Bonjour et bonne année à tous. Qui peut me dire SVP quelle formule inscrire dans un tableau pour qu'apparaisse automatiquement le nombre de fois où la valeur d'une cellule est égale au max de la ligne dans laquelle elle se trouve ?

J'aimerais joindre le fichier mais je ne connais plus le lien !!!

JOUR A B C D E

01.01 1 1 2 3 3

02.01 1 4 1 3 3

03.01 5 5 4 0 2

Nombre de max (c'est ci-dessous que j'aimerai inscrire la formule !!)

1 2 0 1 1

Publicité
ferrand
 Posté le 15/01/2010 à 16:52 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

Tu as intérêt à mettre ta formule dans une cellule de la ligne où tu recherches le nombre de max, tu pourras ainsi la tirer vers le bas pour les lignes suivantes.

Si les jours en col. A, tes valeurs en col. B à F, à partir de la ligne 2 (comme ton schéma) :

=NB.SI(B2:F2;MAX(B2:F2))

à placer sur la ligne 2 et étendre vers le bas dans la même colonne.

dlxpat
 Posté le 17/01/2010 à 10:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Merci pour cette réponse qui est dèjà une trés bonne première étape, mais comment faire apparaitre le total des max par nom (A, B, C.....)

Merci d'avance

ferrand
 Posté le 17/01/2010 à 20:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Excuses, j'ai lu trop vite, je pensais que tu le voulais par ligne.

Je n'ai pas le temps de chercher si on peut construire une formule directe, mais indirectement on peut: tu ajoutes une colonne à ton tableau, en H par exemple, en H2, tu mets: =MAX(B2:F2), tu tires ça sur la colonne (sur ton exemple jusqu'à la ligne 4, tu auras une colonne de max).

A partir de là, la formule tapée en colonne B sur une ligne en dessous:

=SOMMEPROD((B2:B4=$H$2:$H$4)*1)

tirée sur la ligne jusqu'à la colonne F, te donnera ton résultat.

dlxpat
 Posté le 18/01/2010 à 07:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Génial ça marche !! merci et bonne journée

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
25,70 €Lot de 2 switchs Gigabit D-Link 5 ports en métal à 25,70 €
Valable jusqu'au 06 Décembre

Cdiscount propose actuellement le lot de 2 switchs Gigabit D-Link DGS105 5 ports (10/100/1000) avec boîtier métal à 25,70 €. On les trouve habituellement autour de 17 € l'unité.


> Voir l'offre
264,99 €Ecran PC 32 pouces incurvé Samsung Odyssey G5 (WQHD, 144 Hz, 1 ms) à 264,99 €
Valable jusqu'au 07 Décembre

Cdiscount fait une promotion sur l'écran PC 32 pouces incurvé Samsung Odyssey G5 à 264,99 € avec le code promo MOINS25EUROS alors qu'on le trouve ailleurs à partir de 339 €. Cet écran incurvé de 32 pouces offre une définition WQHD de 2560x1440 pixels et est compatible FreeSync Premium avec un taux de réponse de 1 ms et un rafraichissement de 144 Hz.


> Voir l'offre
69,90 €Casque gamer Logitech G635 (DTS Headphone : X v2.0) pour PC, Mac, XBox, PS4, PS5, Switch à 69,90 €
Valable jusqu'au 07 Décembre

Amazon fait une belle promotion sur le casque gamer Logitech G635 qui passe à à 69,99 € livré gratuitement alors qu'on le trouve ailleurs à partir de 120 €. Ce casque est compatible PC, Mac, Xbox One, PS4 et Nintendo Switch. Plongez au coeur de l'action avec le casque Logitech G635 et son son surround DTS Headphone:X 2.0. Ce dernier crée une précision positionnelle exceptionnelle en jeu pour que vous puissiez entendre vos ennemis se faufiler derrière vous et ainsi anticipez leurs attaques. Équipé de transducteurs Pro-G 50 mm en maillage hybride vous allez entendre encore plus de détails avec un son d'une grande profondeur et d'une clarté incroyable. De plus, il est équipé d'un microphone unidirectionnel avec fonction de sourdine ! Quant au rétro-éclairage Lightsync RGB entièrement personnalisable, il réagira aux actions se passant dans votre jeu pour une immersion encore plus grande.


> Voir l'offre

Sujets relatifs
calcul plus grande valeur d'une colonne
Excel: valeur cellule impliquée dans calcul ailleurs -> connexions
Calcul d'un coef suivant le % et du nombre d'éléme
OPEN OFFICE CALC - CALCUL NOMBRE CELLULES
calcul de nombre de cellule
Calcul nombre jours
calcul du nombre de jours
calcul sur nombre d'heures
combien de fois la même valeur
Calcul d'heures sur période de 28 jours
Plus de sujets relatifs à calcul nombre de fois valeur max
 > Tous les forums > Forum Bureautique