> Tous les forums > Forum Linux
 Comment activer mon lecteur de carte SD ?
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
noisette7155
  Posté le 30/06/2010 @ 19:36 
Aller en bas de la page 
Astucien

a tous

-J'ai introduit la carte SD de mon appareil photo numérique Sony ,mais mon pc ne
détecte rien!Comment je dois faire pour pouvoir regarder mes photos?sous ubuntu.

-Sous windows,pas de probléme!

merci de me répondrea bientot.

Publicité
hido
 Posté le 30/06/2010 à 21:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour

Tu peux laisser la carte SD dans l'appareil, et brancher l'appareil en USB

Logicien
 Posté le 30/06/2010 à 23:37 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut,

que tu laisses ta carte sd dans ton appareil photo et que tu le branches dans port USB ou que tu insères ta carte sd dans le lecteur sd, tout dans les systèmes de type Unix est fichier. À moins que tout ne se monte automatiquement, tu devras savoir à quel fichier de périphérique est associé ton lecteur sd ou ton appareil photo afin d'y accéder. Quand tu branches quelque chose à ton ordinateur surveille les messages du noyau

dmesg | tail

Le noyau décrit de qui s'est passé et comment accéder au matériel "branche et aide-toi". Enfin peut-être une nouvelle icône apparaîtra d'elle-même sur le bureau.



Modifié par Logicien le 30/06/2010 23:39
mic50
 Posté le 01/07/2010 à 19:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

bonjour,

Redemmare ton pc avec la carte dans le lecteur il devrait la reconnaitre.

amicalement

noisette7155
 Posté le 01/07/2010 à 20:21 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

a tous

merci de vos réponses

mic50 -j'ai redémarrer mais malheureusement rien

hido-C'est vrai je me creuse la tete pour rien ta solution est radicalemais bon comme ca marche sous windows,cela devrais

fonctionner sous linux!

Logicien-Excuse moi mais je débute sous linux,et j'ai essayer de comprendre ton message mais en vain

a bientot.

yolette
 Posté le 01/07/2010 à 22:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

ça doit être détecté mais comme moi au début, tu dois pas savoir trouver l'emplacement et reconnaître l'icône.

Je sais, ma réponse n'aide pas {#}, je repars donc de ce pas.



Modifié par yolette le 01/07/2010 22:08
rumoko
 Posté le 02/07/2010 à 15:38 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

Pour lister les disques meme ceux qui ne sont pas montés :

en root : fdisk -l



Modifié par rumoko le 02/07/2010 15:39
Mimile
 Posté le 06/07/2010 à 09:56 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour

J'avais le même problème que toi sous Debian Lenny : aucune réaction (apparente) du PC au branchement de mon lecteur de carte.

Voici comment j'ai réglé le problème :

- tu branches sur une prise USB ton lecteur de carte SD avec une carte SD insérée dedans (le mien comporte 4 entrées) pour 4 types de cartes différentes.

- tu ouvres une console et tu tapes: sudo fdisk -l (la dernière lettre est un L minuscule pas un 1)

Tu vas voir quelque chose qui ressemble à ceci :

Tout en dessous, tu vois qu'il y a un élément qui s'appelle (chez moi) /dev/sdc1 et qui est formaté en FAT16.

Cela correspond à la carte sd insérée dans le lecteur.

Si Ubuntu ne l'ouvre pas spontanément, il faut procéder comme ceci :

1°) d'abord créer un point de montage dans le dossier /media : sudo mkdir /media/lecteur_sd (cette opération ne doit être exécutée qu'une seule fois)

2°) ensuite, il faut monter /dev/sdc1 sur ce point de montage : sudo mount /dev/sdc1 /media/lecteur_sd (cette opération devra être répétée chaque fois que tu inséreras ton lecteur de carte)

Avec l'explorateur, tu navigues jusqu'au dossier /media/lecteur_sd et tu y trouveras tes photos dans un des dossiers présents :

Seul inconvénient sous Debian et KDE : le contenu est en lecture seule. Donc pas de possibilité de supprimer un élément indésirable.

Le répertoire /media/lecteur_sd appartient à root et au groupe root ; La commande chown même en root ne me permet pas de m'attribuer la propriété du dossier et la commande chmod (pour me donner les droits d'écriture) n'a aucun effet.

Si quelqu'un avait un avis sur ce point ...

En revanche, sous Linux Mint 7 (extrapolée d'Ubuntu 8.10), au branchement de mon lecteur de carte, j'ai vu apparaître ceci :

En exécutant la commande sudo fdisk -l, j'ai observé que sous Mint, le lecteur était identifié /dev/sde1.

J'ai procédé comme ci-dessus (en remplaçant /dev/sdc1 par /dev/sde1) et j'ai pu accéder à mes photos en lecture et en écriture (autrement dit avec possibilité de supprimer une photo et de la restaurer).

Décidément, cette distribution Mint ne cessera de m'étonner.

@+



Modifié par Mimile le 06/07/2010 10:46
Logicien
 Posté le 06/07/2010 à 21:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Mimile,

est-ce que mount te demande parfois de préciser le système de fichiers quand tu exécutes la commande

sudo mount /dev/sdc1 /media/lecteur_sd

ou bien il trouve toujours le type lui-même comme un grand?

J'ai une préférence pour une session root plutôt que sudo pour changer les permissions. C'est plus convainquant:

chmod -R 777 /media/lecteur_sd

devrait être suffisant pour qu'un utilisateur non-root puisse ajouter/modifier/supprimer des éléments dans le répertoire. Comment as-tu exécuté les commandes chown et chmod sur le répertoire. Il se peut qu'il faille que l'utilisateur non-root soit dans le groupe disk ou au groupe correspondant à la sortie de la commande

ls -l /dev/sdc*

Personnellement, je ne met jamais mes utilisateurs dans le groupe disk et encore moins dans le groupe root. Une entrée dans /etcfstab qui préciserait le propriétaire, le groupe et les permissions sur le répertoire de montage du lecteur sd me semble supérieure à sa manipulation directe avec les commandes mount, chown et chmod.

Amicalement (qui dit ça? )



Modifié par Logicien le 06/07/2010 21:19
Mimile
 Posté le 06/07/2010 à 22:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Qui dit "amicalement" ? euh ... je ne vois pas

Pour ce qui concerne la commande "mount", le résultat est indifférent.

J'ai essayé mount avec et sans "t -vfat" et ça ne change rien.

SI dans ma réponse, j'ai indiqué : sudo mount ... c'est simplement parce que je supposais que notre amie Noisette7155 utilisais une distrbution genre Ubuntu ou autre.

Personnellement, j'ai essayé aussi (chmod et chown) en ouvrant une "vraie" console root (donc sans devoir faire appel à sudo) et je n'ai obtenu aucun résultat (même # chmod -R 777 ...).

A noter que pour éviter de devoir fournir mon passwd root à chaque commande sudo, je me suis inclus dans le groupe sudo et j'ai modifié sudoers pour dispenser ce groupe de fournir le mot de passe (pas prudent, d'accord, mais bof - voir ici).

Malgré tout, pas moyen d'obtenir les droits d'écriture.

Je suppose qu'effectivement le problème pourrait se régler en intervenant au niveau de /etc/fstab mais bon, je n'ai fait ces manip que pour essayer d'aider notre amie noisette7155 vu que l'appareil photo est celui de mon épouse qui n'utilise que WinXP avec les logiciels fournis avec l'appareil (Canon).

Moi, j'utilise encore mon bon vieil appareil argentique reflex Ricoh TLS401 que j'ai reçu en cadeau de mon père quand j'ai terminé mes études secondaires supérieures... en 1971/72 ... (avec une électronique à l'époque très évoluée et objectif amovible (à pas de vis) 55 mm et télé 400 mm)

Les photos que je fais encore aujourd'hui avec cet appareil restent de qualité nettement supérieure avec un pellicule genre 100 ASA ou moins (un piqué incroyable) et quand je les scanne avec un bon niveau de résolution, elles restent splendides, quoi qu'un peu pesante (quelques mo !).

Juste comme ça, pour dire qu'on fabriquait de la qualité à l'époque, mon PC est raccordé en audio à un ampli Sansui AU 505 (et ses diffuseurs) increvables que j'ai reçus en cadeau quand j'ai terminé mes études secondaires inférieures en 1969/70 et qui a fonctionné je ne sais combien de milliers d'heures notamment pour animer des soirées.

Amical... euh non, je voulais dire : cordialement

Logicien
 Posté le 07/07/2010 à 10:24 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Ça semble être un beau parcours que le tien Mimile. En tous cas, j'en profite pour te féliciter pour tes succès aux études. je suis le plus jeune d'une famille de cinq enfants. Seuls les deux ainé(e)s, garçon et fille se sont mariés et pour eux ça tient toujours. Alors félicitations aussi pour ton mariage Mimile.

Je ne comprend pas encore pourquoi une carte sd puisse n'être accessible qu'en lecture à root, le plus puissant après Richard Stallman. (humour )

Comme je n'en ai jamais eu, seulement un lecteur de cartes sd, je ne sais qu'à demi de quoi je parle. Je me demande si c'est possible que seuls certains appareils puissent écrire sur certains types de cartes sd. Y a-t-il, comme sur une disquette, possibilité de bloquer une carte sd en écriture? Peut-être ferais-je mieux de faire une recherche?



Modifié par Logicien le 07/07/2010 10:31
Mimile
 Posté le 07/07/2010 à 13:54 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut Paul,

Merci pour ton gentil message dont j'ai fait part à mon épouse qui te remercie aussi (33 ans de mariage !).

Pour en revenir au sujet, ce qui m'étonne vraiment, c'est que sous Linux Mint 7 (dérivée d'Ubuntu 8.04 je crois) le lecteur de carte est détecté dès son branchement (voir ma capture d'écran) mais ne propose aucune action à associer.

Mais, une fois le lecteur monté, il est tout-à-fait possible d'accéder au contenu de la carte en lecture et écriture en simple utilisateur sans qu'il soit besoin de modifier quoi que ce soit avec chmod ou chown.

Sous Windows, le lecteur qui comporte en fait 4 fentes permettant d'insérer des cartes de modèles différents (sm/xd, sd/mmc, ms/ms pro, cf i/ii/md/mstore) apparaît dans l'explorateur qui affiche alors 4 lecteurs amovibles (chacun avec sa lettre d'identification).

Reste à identifier celui qui contient la carte mais dès cet instant, son contenu devient accessible en lecture et écriture.

Il n'y a que Debian qui fasse sa mavaise tête : rien à faire : pas moyen de modifier, ni les droits (même en ciblant une photo en particulier), ni l'utilisateur et même en root, on a qu'un accès en lecture.

A n'y rien comprendre.

Tant pis.

Mais en ce qui concerne le sujet initial, si Noisette7155 (qui, je suppose est sous Ubuntu) se contente d'appliquer la méthode que j'ai indiquée, elle aura accès à ses photos.

Cordialement,



Modifié par Mimile le 07/07/2010 13:55
Tasgarth
 Posté le 07/07/2010 à 17:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour Logicien et Mimile,

Peut-être avec , plus en amont, la commande umask ?

Les autres commandes (chmod et chown) ne peuvent faire que ce qui est permis par umask ?

Mint doit faire qqch comme cela.

Il existe d'autres commandes plus 'fines', similaires à umask, mais là j'ai oublié



Modifié par Tasgarth le 07/07/2010 17:40
noisette7155
 Posté le 07/07/2010 à 19:13 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

a tous

Mimile,voici ce que j'obtiens dans ma console!

Peut-etre parce que mon lecteur de carte est intégré a mon pc c'est un portable.

a bientot.

Logicien
 Posté le 07/07/2010 à 21:06 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour à tous,

Tasgarth, je vais dans le même sens que toi.

noisette7155, en lisant quelque-peu, il serait important que tu insères une carte sd dans ton lecteur avant même de démarrer l'ordinateur et Ubuntu, question de s'assurer d'une meilleure reconnaissance du lecteur sd. Il se peut que des modules essentiels du noyau Linux ne soient pas chargés automatiquement pour que le lecteur sd soit reconnu et qu'il te faille les charger en mémoire vive toi-même. On y reviendra.

Il est important se savoir quel est la marque du lecteur sd. Exécute la commande

sudo lspci

dans un terminal et affiche le résultat ici. D'autres informations importantes peuvent venir du noyau Linux lui-même grâce aux commandes

dmesg | grep -i sd

dmesg | grep -i mmc

Pour l'instant seul ton disque dur principal /dev/sda est affiché par la commande

sudo fdisk -l

Lorsque ton lecteur sd sera reconnu il devrait s'ajouter éventuellement /dev/sdb

Mimile
 Posté le 08/07/2010 à 12:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

Puisque le lecteur de carte de notre amie est interne, je fais une analogie avec mon lecteur de disquettes qui s'identifie /dev/fd0 (planqué dans le dossier /dev évidemment) :

Quand j'insère une disquette, il ne se passe rien.

J'ai contourné le problème en écrivant un petit script rudimentaire montage/démontage activé par une icône sur mon bureau KDE :

#!/bin/bash
mount > ps.txt
if grep "floppy" ps.txt
then
sudo umount /dev/fd0
killall konqueror
else
sudo mount /dev/fd0 /media/floppy
konqueror /media/floppy
fi

Quand fd0 est monté, konqueror affiche le contenu de la disquette.

Si, à ce moment, j'exécute sudo fdisk -l, /dev/fd0 n'est pas repris dans la liste des disques. De plus, sudo lspci ne fait aucune allusion à ce lecteur de disquette.

S'il en est de même avec le lecteur de carte (assez comparable à un lecteur de disquette vu le système de fichier utilisé FAT16 ou FAT32), rien d'étonnant à ce qu'il ne se passe rien à l'insertion de la carte et que fdisk ne fasse pas état du lecteur.

Reste donc à identifier celui-ci dans le dossier /dev : /dev/sd0 peut-être ? et une fois identifié de le monter pour y avoir accès.

Mais j'ai peut-être faux sur toute la ligne

Superlativement (juste pour varier un peu - private joke pour Logicien )

P.S. peut-être qu'on en apprendrait un peu plus si notre amie exécutait sudo tail -f /var/log/message et observait ce qui se passe quand elle insère sa carte sd ?



Modifié par Mimile le 08/07/2010 12:17
rumoko
 Posté le 08/07/2010 à 14:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

{#}

Effectivement fdisk et sfdisk ne gèrent que les disques durs !!!

Pour tout faire apparaitre toujours en root tu peux essayer :

parted -l


{#} {#}


Mimile
 Posté le 09/07/2010 à 00:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Effectivement, parted -l détecte le floppy :

Bon, les commentaires relatifs à /dev/fd0 sont un peu alarmistes mais il suffirait probablement que je modifie mon script de montage pour obtenir un accès en lecture/écriture.

Au passage, je trouve que l'affichage des spécificités des différentes partitions est bien plus clair que celui de fdisk (sauf que la dénomination des partitions n'est pas présente (/dev/sda1, /dev/sdb3, etc...). Il y a peut-être un autre paramètre que -l à fournir ?).

Subjectivement,



Modifié par Mimile le 09/07/2010 13:10
Logicien
 Posté le 09/07/2010 à 00:46 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Fdisk ne découvre pas tous les périphériques de type blocs automatiquement. On peut quand-même le faire travailler sur tout ce qui se partitionne:

fdisk /dev/fd0 (disquette)

fdisk /dev/sdb (disque IDE, Sata, clé USB ou autres)

fdisk fichier-image.disque (USB ou autres)



Modifié par Logicien le 09/07/2010 01:10
Mimile
 Posté le 09/07/2010 à 13:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut

J'ai rectifié mon message précédent car la capture d'écran ne s'affichait à cause du # que j'avais mentionné devant parted.

Cela dit, chez moi :# fdisk /dev/fd0 me renvoie : unable to open /dev/fd0 lorsqu'il n'y a pas de disquette insérée.

Quand il y a une disquette insérée et dont le contenu est affiché par konqueror, la même commande renvoie :

Command (m for help): m
Command action
a toggle a bootable flag
b edit bsd disklabel
c toggle the dos compatibility flag
d delete a partition
l list known partition types
m print this menu
n add a new partition
o create a new empty DOS partition table
p print the partition table
q quit without saving changes
s create a new empty Sun disklabel
t change a partition's system id
u change display/entry units
v verify the partition table
w write table to disk and exit
x extra functionality (experts only)

Reste à trouver sous quel nom se cache le lecteur de carte interne de notre amie.

noisette7155
 Posté le 10/07/2010 à 22:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

a tous.

-Encore un grand merci pour vos réponses j'ai lu et relu plusieurs fois vos réponses,mais

j'avoue que je débute sous linux,et la franchement je nage dans vos manipulations,alors,pour l'instant,

je pense que je vais faire ceci : laisser la carte SD dans l'appareil, et brancher l'appareil en USB.

a bientot.

Publicité
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
Ecran PC 27 pouces KTC H27V13 (VA, Full HD, 100 Hz) à 99,99 €
99,99 € 149 € -33%
@Geekbuying
SSD PNY CS900 250 Go à 17,99 €
17,99 € 25,99 € -31%
@Amazon
Prise connectée Wi-Fi TP-Link Tapo P100 à 6,55 €
6,55 € 9,99 € -34%
@Amazon
Casque de VR Meta Quest 3 128 Go à 424,99 €
424,99 € 549,99 € -23%
@Rakuten
Ecran 27 pouces LG Ultragear 27GP850P-B (IPS, WQHD, 165Hz, HDR10, G-sync/FreeSync) à 219,99 €
219,99 € 320 € -31%
@Amazon
Adaptateur Bluetooth 5.0 USB Ugreen à 6,99 €
6,99 € 11,99 € -42%
@Amazon

Sujets relatifs
comment activer la carte reseau
comment activer ma carte reseau sous mandrake 9.0
Comment activer le simple clic - Mint 17 Cinnamon
comment mettre a jour les pilotes d'une carte mère sous Linux ?
Comment activer mon clavier durant le Grub ?
[réglé]debian squeze comment activer effets bureau
Comment rediriger mon lecteur de CD ?
Lecteur carte SD
comment copier une carte compact flash avec slax
Comment activer les dépots ?
Plus de sujets relatifs à Comment activer mon lecteur de carte SD ?
 > Tous les forums > Forum Linux