> Tous les forums > Forum Bureautique
 Comment copier une formule Excel sur une colonne
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Cetelle
  Posté le 25/07/2018 @ 17:14 
Aller en bas de la page 

Bonjour,

Dans un tableau Excel 2010 comprenant 560 000 lignes je voudrais copier une formule de la cellule A1 à la cellule A560000. En déroulant avec la poignée de recopie c'est beaucoup trop long. La méthode du double-clic sur cette poignée de recopie ne fonctionne pas -rien ne se passe- (mais je ne le fais peut-être pas de la bonne manière). J'ai essayé CTRL+B mais le résultat rendu est faux. Donc je suis preneuse de toute autre solution. Je précise que ma formule a pour résultat l'affichage de numéros de 6 à 10 chiffres. Par avance merci pour votre aide (j'espère).

Publicité
galopin01
 Posté le 25/07/2018 à 21:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonsoir,

Fais Copier [Ctrl + C]

A partir de la cellule A2

Faire [Ctrl + Shift + Down] : => La sélection va s'étendre jusqu'à la dernière ligne.

Faire [Ctrl + V] pour Coller

Nota : Shift = Touche Majuscule juste à coté de Ctrl

A+

E-L
 Posté le 26/07/2018 à 07:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

salut,

Exact c'est cela ou la macro. La méthode citée ci-dessus est la plus pratique.

Cetelle
 Posté le 26/07/2018 à 12:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page

galopin01 a écrit :

Bonsoir,

Fais Copier [Ctrl + C]

A partir de la cellule A2

Faire [Ctrl + Shift + Down] : => La sélection va s'étendre jusqu'à la dernière ligne.

Faire [Ctrl + V] pour Coller

Nota : Shift = Touche Majuscule juste à coté de Ctrl

A+

Bonjour,

Merci pour votre réponse mais malheureusement cela ne fonctionne pas dans mon cas précis.

J'utilise la fonction RECHERCHEV pour faire apparaître les données (il s'agit de numéros d'identification) qui se trouvent à la fois dans la colonne A et la colonne B (=RECHERCHEV(A1;$B$1:$B$734;1;0). Ma colonne B ne comprend que 734 lignes, classées par ordre croissant. Je me suis placée en colonne D pour l'affichage du résultat. Lorsque la fonction ne trouve pas, #NA (non applicable) s'affiche dans la cellule. Lorsque le doublon est trouvé, le numéro d'identification en double s'affiche dans la cellule. La cellule A1 affiche #NA. En utilisant votre méthode, c'est #NA qui est dupliqué dans toutes les cellules jusqu'au bout alors qu'il devrait y avoir l'affichage d'un numéro d'identification dans 734 d'entres-elles. J'espère que mon exposé est suffisamment clair pour que peut-être vous puissiez m'apporter une autre solution.

Merci d'avance.

Cetelle
 Posté le 26/07/2018 à 13:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page

E-L a écrit :

salut,

Exact c'est cela ou la macro. La méthode citée ci-dessus est la plus pratique.

Bonjour,

Cela ne fonctionne pas comme je l'explique à la personne qui a proposé cette solution.

galopin01
 Posté le 26/07/2018 à 14:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

Au lieu de Ctrl + V

Choisissez dans le menu Accueil :

Coller des Valeurs

ou Collage Spécial : Valeurs

fs.md_pca
 Posté le 27/07/2018 à 15:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

Bonjour,

suggestion :

si la colonne A contient les 560000 infos

et que la colonne B en contient 734 (base sur laquelle on cherche la correspondance)

1. insérer une colonne après la colonne A

2. dans la case B1 de cette nouvelle colonne, insérer la formule =RECHERCHEV(A1;$C$1:$C$734;1;0)

3. la valuer devrait maintenant figurer en case B1

4. propager la formule :

sélectionner la cellule B1

passer le cursuer dans le coin inférieur droit : un petit plus noir devrait aparaitre

double clic sur cette petite croix noire.

5. résultat ?

sinon : mieux expliquer ton problème.

(;-)

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Comment modifier une formule dans un TCD excel ?
Comment afficher la dernière information d'une colonne Excel
comment copier formule d'1 class à l'autre sans li
comment copier un graphique depuis excel
Copier la valeur d'une colonne et non la formule
Comment creer une formule excel ? RESOLU
comment appliquer une formule à toute une colonne
Comment faire un copier/coller Word sur un formulaire de site?
Copier une plage excel vers une autre feuille
Comment inserer en auto la date en complément d'une autre colonne?
Plus de sujets relatifs à Comment copier une formule Excel sur une colonne
 > Tous les forums > Forum Bureautique