> Tous les forums > Forum Bureautique
 Comptage de nombres pairs dans plusieurs colonnesSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Yéti du 38
  Posté le 15/04/2010 @ 18:34 
Aller en bas de la page 
Petit astucien

Bonjour,

J'ai un pb de comptage de nombres qui peuvent être Pairs ou Impairs. Là où ça se corse un peu c'est que mes colonnes ne sont pas consécutives d'une part et d'autre part que le même comptage peut s'effectuer sur plusieurs feuilles à la fois.

Quelqu'un a une petite idée?

Publicité
qmike549
 Posté le 15/04/2010 à 19:15 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

bonjour

une piste ici

- Totaliser les nombres pairs ou les nombres impairs

Soit le tableau suivant :

Totaliser les nombres pairs :

  1. Tapez la formule suivante : =SOMMEPROD((MOD(A1:A10;2)=0)*(A1:A10))

    Résultat :

Totaliser les nombres impairs :

  1. Tapez la formule suivante : =SOMMEPROD((MOD(A1:A10;2)=1)*(A1:A10))

    Résultat :

Yéti du 38
 Posté le 15/04/2010 à 19:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Je vais essayer ça.

Merci

Yéti du 38
 Posté le 16/04/2010 à 09:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour tlm,

Pour qmike549, j'ai essayé et je pense que je dois me planter quelque part parce que j'arrive à un résultat farfelu. J'explique: les chiffres de ma colonne vont de H22 à H725, soit 703 résultats. Ce sont des nombres à 3 digits (centaines). Normalement, sauf erreur de ma part, si je ne teste que le digit le plus à droite, cela devrait me suffire pour déterminer si l'ensemble de mes 3 digits composant mon nombre est Pair ou Impair. Or là, j'ai l'impression qu'il teste tous les digits en les prenant un par un. Mais même ça, ça ne fait toujours pas un bon résultat en multipliant 700 x 3

Et là je me retrouve avec un résultat dans les 80.000 qui ne rime à rien Normalement (je dis bien "grosso-merdo") mon résultat attendu devrait se situer proche de la moitié de 700. Je suis loin du compte de 80.000.

Où est-ce que je fais une connerie?

Mytå
 Posté le 16/04/2010 à 13:05 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Salut le forum

La formule de Qmike fait la somme des nombres impairs ou pairs selon la condition du MOD (0 ou 1)

Pour avoir la quantité de nombre impairs d'une plage

=SOMMEPROD((MOD(A1:A10;2)=1)*1)

Pour avoir la quantité de nombre pairs d'une plage

=SOMMEPROD((MOD(A1:A10;2)=0)*1)

Mytå



Modifié par Mytå le 16/04/2010 13:09
Yéti du 38
 Posté le 16/04/2010 à 15:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Merci Myta, je vais essayer.

Yéti du 38
 Posté le 17/04/2010 à 10:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour tlm

Pour Myta, Bon, ça marche impeccable. Ce sont les résultats que j'attendais. Mais comme je ne connais rien au calcul matriciel, je suis incapable d'additionner plusieurs matrices pour plusieurs colonnes. Tu peux me renseigner s'il te plaît?

NB: Mon fichier est assez gros (pour l'instant il ne fait que 750 Mo environ, dont certaines données font plusieurs feuilles, vu la limite des colonnes d'une feuille).

Dans l'exemple que j'avais donné (725 enregistrements), j'aimerai exclure du comptage certaines cell qui ont un fond de couleur, par rapport aux autres qui n'en ont pas.

1) Je ne sais pas si c'est possible de le faire

2) Dans l'affirmative, je ne sais pas comment le faire.

qmike549
 Posté le 17/04/2010 à 10:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

bonjour

pour exclure les cellules contenant certaines couleurs

excel n'offre pas en standard de formule magique

en revanche, ce résultat peut être obtenu via la vba

Yéti du 38
 Posté le 17/04/2010 à 11:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Merci pour le tuyau qmike

Publicité
Mytå
 Posté le 17/04/2010 à 20:42 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Re le forum

Yéti pour additionner des matrices utilise le OU (+) au-lieu du ET (*)

SOMMEPROD((MOD(A1:A10;2)=1)+(MOD(B1:B10;2)=1))

Mytå

Yéti du 38
 Posté le 18/04/2010 à 17:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour tlm

Pour Myta: Bon, je viens d'essayer ta formule, pour faire le comptage de la quantité de nombres impairs que je peux avoir dans 2 colonnes. Elle ne convient pas. A sa lecture, il me semblait bien qu'il manquait les opérands logiques, mais j'ai quand même voulu essayer. Comme je n'y connais pas grand'chose, je me suis dit que ça ne coûtait rien d'essayer.

C'est pas grave, je me suis dit qu'en rajoutant ce que je pensais qu'il manquait j'allais avoir ce que je cherchais. Ben rien du tout. Comme formule, j'ai tapé: =sommeprod(((mod(AG688:AG61186;2)=0)+1)+((mod(aj22:AJ12671;2)=0)+1)) pour faire le compte de mes nombres impairs et comme résultat j'ai eu dans ma cell de destination #N/A.

Où est-ce que je me plante?

Yéti du 38
 Posté le 18/04/2010 à 17:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Dans ma formule c'était pour faire le compte des nombres Pairs et j'ai écris Impairs.

Mytå
 Posté le 18/04/2010 à 18:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Re le forum

Yéti ma formule est bonne regarde dans le fichier : Pair_Impair.xls

Mytå

Yéti du 38
 Posté le 18/04/2010 à 18:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Oui Myta, j'avais pensé à cette solution d'additionner les sommes colonne par colonne et dans faire le total. Mais j'espérais trouver une solution plus... élégante en tapant une formule qui m'aurait évité de faire des tas de manip.

Faut pas croire, mais un fichier de 750 Mo... ça en fait des colonnes et des feuilles!

Merci de m'avoir répondu. Je coche le sujet comme résolu et vais me brasser mon fichier "à l'artisanal".

Mytå
 Posté le 18/04/2010 à 19:00 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Re le forum

Yéti, as-tu regardé la formule total sur le fichier ?

=SOMMEPROD((MOD(B$2:B$11;2)=0)+(MOD(C$2:C$11;2)=0)+(MOD(D$2:D$11;2)=0))

Tu peux la remplacer par

=SOMMEPROD((MOD($B$2:$D$11;2)=0)*1)

Mytå



Modifié par Mytå le 18/04/2010 19:04
Yéti du 38
 Posté le 19/04/2010 à 08:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour tlm

Merci Myta. ça c'est un tuyau qui me convient parfaitement bien. Mettre les cellules de début et de fin en valeur absolue, je n'y avais pas pensé. Il y a juste un os, c'est qu'il va falloir que j'adapte cette formule car mes colonnes de chiffres ne sont pas jointives. Entre chaque colonne de chiffres, j'ai des colonnes de lettres auxquelles correspond chaque chiffre des colonnes que je veux compter.

Bon, j'ai encore de la bidouille à faire. Merci encore.

Nbr Ventral Pair Impair Nbr Ventral Pair
6 0P/0G/0P 7 0P/0G/0P
5 0P/1G/0P 6 0P/1G/0P
4 0P/2G/0P 5 0P/2G/0P
3 0P/3G/0P 4 0P/3G/0P
5 1P/0G/1P 6 1P/0G/1P
4 1P/1G/1P #N/A #N/A 5 1P/1G/1P
3 1P/2G/1P 4 1P/2G/1P
2 1P/3G/1P 3 1P/3G/1P
ZzxM <--- dern. vzxM <--- dern.
0 <--err. 0 <--err.
73815 4 1 4
61165 4,01 12650 4,02
GOPQ 323 abcd 459
GOPR 323 abce 462
GOPS 323 abcf 462
GOPT 324 abcg 462
GOPU 325 abch 463
GOPV 325 abci 463
GOPW 326 abcj 464
GOPX 327 abck 464
GOPY 329 abcl 465
GOPZ 330 abcm 465
GOPa 330 abcn 465
Mytå
 Posté le 19/04/2010 à 13:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Re le forum

Yéti, avec une vérification des colonnes...

Nombre pair des colonnes pair (B et D)

=SOMMEPROD((MOD($B$2:$E$11;2)=0)*(MOD(COLONNE($B$2:$E$11);2)=0))

Mytå



Modifié par Mytå le 19/04/2010 13:06
Publicité
Yéti du 38
 Posté le 19/04/2010 à 18:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Je vais essayer. Merci.

Yéti du 38
 Posté le 02/05/2010 à 19:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Myta,

Je travaille avec Excel 2003. Pour info, je te dis ce que j'ai remarqué.

Lorsque je modifie plus de 12 cellules matricielles, le pgm bloque et ne répond plus. Tout le boulot est perdu et je suis bon pour recommencer. Mais jusqu'à 12 calculs simultanés, ça va.

ça ne nous amène rien de plus, c'est juste un truc que j'ai remarqué. Alors pour le comptage de mes colonnes, c'est 12 par 12 et basta. Quand tu penses que j'ai environ 160 colonnes... tu vois ma galère.

Bonne journée.

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
trier numéros dans plusieurs colonnes
RechercheV dans plusieurs colonnes
Insérer un texte dans plusieurs champs avec Word
Largeur Hauteur colonnes en mm dans Excel
chercher chaîne de caractères VBA dans plusieurs fichiers XL
Bloquer et débloquer colonnes dans excell
Passer plusieurs variables dans une autre macro excel VBA
Supprimer des colonnes dans Excel
Somme si sur plusieurs colonnes
fusionner des colonnes de 10000 lignes dans excel
Plus de sujets relatifs à Comptage de nombres pairs dans plusieurs colonnes
 > Tous les forums > Forum Bureautique