> Tous les forums > Forum Bureautique
 Compter jour/sem=nombre de mardi par ex sur 1 moisSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
aubertot2000
  Posté le 18/02/2011 @ 09:03 
Aller en bas de la page 
Petit astucien

Bonjour à tous, j'aimerai savoir s'il est possible de compter des jours de la semaine sur 1 mois complet. Par exemple

Dans cette exemple j'aimerai compter le nombre de mardi et de mercredi qui symbolise des jours de présence sur certains lieux et donc je souhaiterai avoir un récapitulatif par mois puis par année. Merci d'avance pour votre aide.

Publicité
galopin01
 Posté le 18/02/2011 à 09:28 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

la formule pour une plage A1:A31 :

=SOMMEPROD(--(JOURSEM(A1:A31;2)=1))

ou 1 est lundi, 2 mardi, 3 mercredi...

A+

aubertot2000
 Posté le 18/02/2011 à 09:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

galopin01 a écrit :

Bonjour,

la formule pour une plage A1:A31 :

=SOMMEPROD(--(JOURSEM(A1:A31;2)=1))

ou 1 est lundi, 2 mardi, 3 mercredi...

A+

Peux tu me donner un peu plus de précision parce que chez moi en mettant ta formule tel que tu me la donné et l'adaptant à mon tableau ça me donne ceci =SOMMEPROD(--(JOURSEM(B3:B11;2)=2)) enfin si j'ai tout bien compris hors ça me met un erreur #valeur!

galopin01
 Posté le 18/02/2011 à 11:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Ben... il faut que B3:B11 contienne des dates dans un format de date :

ta formule doit alors renvoyer le nombre de mardi

Ok ?

aubertot2000
 Posté le 18/02/2011 à 12:15 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Ca y est c'est bon ça marche, c'est moi qui est nul, j'ai pris une cellule de trop, fallait juste commencer à B4 au lieu de B3. Merci beaucoup pour ton coup de main si rapide.

@+

galopin01
 Posté le 18/02/2011 à 12:54 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Evidemment !

Il est possible d'inclure dans la formule des cellules vides, ce qui est bien pratique : Tu peux faire comme s'il y avait 31 jours tous les mois : les mois de 30 jours ou de 28 jours ne perturbent pas le calcul...

A+

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Compter le nombre de jour ouvrable du mois
Nombre jour suivant mois
Comment compter le nombre de finales distinctes ??
Excel 2013 Renvoyer le jour de la semaine "lundi, mardi etc..."
afficher "jour/mois" d'une date ACCESS 2010
Aide Excel 2003 - Compter le nombre d'occurences
afficher le 1er jour du mois suivant
afficher le 1er jour du mois courant
la date du 1er jour du mois qui suit ?
Compter le nombre de mots
Plus de sujets relatifs à Compter jour/sem=nombre de mardi par ex sur 1 mois
 > Tous les forums > Forum Bureautique