> Tous les forums > Forum Bureautique
 Compter le nombre cellule de telle anneeSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
williamsss
  Posté le 26/02/2008 @ 17:35 
Aller en bas de la page 
Petit astucien

Bonjour,

Si dans la colonne A de la ligne 1 a 100 on a des dates avec differentes annees mais qu'on retrouve plusieur fois la meme année, comment peut on calculer le nombre de cellules d'où la date est de l'année 2007 (soit du 01/01/2007 a 31/12/2007) ?

Merci

Williams

Publicité
g
 Posté le 26/02/2008 à 17:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

B1=ANNEE(A1) à recopier vers le bas

cellule quelconque =NB.SI(B1:B100;2007)

Bonne soirée.

williamsss
 Posté le 26/02/2008 à 18:42 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

j'aurais cru que sans faire une colonne de plus qu'on aurait pu pouvoir calculer ceci.

merci

Williams

sourisdeservice
 Posté le 26/02/2008 à 19:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grande Maîtresse astucienne

Bonjour,

Tu peux masquer cette colonne ou la placer dans un endroit éloigné de ta feuille

Bérylion
 Posté le 26/02/2008 à 19:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

williamsss a écrit :

j'aurais cru que sans faire une colonne de plus qu'on aurait pu pouvoir calculer ceci.

merci

Williams



=NB.SI(A1:A100;">31/01/06")-NB.SI(A1:A100;">31/12/07")





fth
 Posté le 26/02/2008 à 19:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir,

Eventuellement une autre possibilité via une petite macro qui affichera le résultat dans un message

Sub test_annee()
Dim i%, x%
x = 0
For i = 1 To Range("A65535").End(xlUp).Row
If Year(Cells(i, 1)) = 2007 Then
x = x + 1
End If
Next
MsgBox x & " cellules concernent l'année 2007"
End Sub

williamsss
 Posté le 26/02/2008 à 21:38 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
Bérylion a écrit :

williamsss a écrit :

j'aurais cru que sans faire une colonne de plus qu'on aurait pu pouvoir calculer ceci.

merci

Williams



=NB.SI(A1:A100;">31/01/06")-NB.SI(A1:A100;">31/12/07")





Merci BP Bérylion c'est ce dont je cherchais à faire comme il est pas obligé de mettre d'autre colonnes.

Williams

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Comment compter le nombre de finales distinctes ??
Nombre de mots répétés dans une même cellule
Compter le nombre de jour ouvrable du mois
Aide Excel 2003 - Compter le nombre d'occurences
Compter jour/sem=nombre de mardi par ex sur 1 mois
calcul de nombre de cellule
Compter les caractères dans une cellule
Compter le nombre de mots
compter nombre de paragraphe
Compter le nombre de mots sur word
Plus de sujets relatifs à Compter le nombre cellule de telle annee
 > Tous les forums > Forum Bureautique