> Tous les forums > Forum Bureautique
 Compter les lignes non vides (Excel 2010)Sujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
LRD95
  Posté le 30/09/2010 @ 11:14 
Aller en bas de la page 
Petit astucien

Bonjour

Je suis sous excel 2010

J’ai trouvé sur internet la formule pour compter les cellules vide dans une colonne.

=NB.SI(B6:B31;"")&" opérations"

C’est le contraire que je voudrais, compter les cellules non vides.

Merci de bien vouloir m’aider.

Publicité
LRD95
 Posté le 30/09/2010 à 11:54 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Merci Anonyme, ça fonctionne.

=NBVAL(B6:B31)&" opérations"

A+

ferrand
 Posté le 30/09/2010 à 12:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut,

...et si tu veux conserver NB.SI, tu peux faire: =NB.SI(plage;"<>")

pour compter les cellules qui contiennent du texte: =NB.SI(plage;"*")

Et pour les cellules vides, tu as aussi NB.VIDE à ta disposition.

LRD95
 Posté le 30/09/2010 à 12:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour ferrand

Merci pour ta deuxième solution, mais je vais conserver NBVAL.

Ça m’intéresse quand même, je l’essayerai dans un autre fichier surtout la deuxième pour compter les cellules avec du teste.

Bonne journée

A+

qmike549
 Posté le 30/09/2010 à 15:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

bonjour

a noter que cette formule est valable sur toutes les versions d'excel

Compter les lignes non vides (Excel 2010)

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
51,99 €Office 365 Famille - 6 utilisateurs - Abonnement 1 an à 51,99 €
Valable jusqu'au 21 Mai

Amazon fait une promotion sur Office 365 Famille qui passe ainsi à 51,99 €, en téléchargement légal alors qu'on le trouve habituellement à 99 €. Vous pourrez télécharger et installer les dernières versions d'Outlook, Word, Excel, PowerPoint et OneNote sur 6 PC, Mac ou tablettes (iOS ou Android) pendant 1 an. Vous bénéficierez également d'un espace de stockage en ligne sur OneDrive de 1 To pour chaque utilisateur (6x1 To). Le code de téléchargement vous sera envoyé par email.


> Voir l'offre
13,99 €Organiseur 30 casiers Stanley à 13,99 €
Valable jusqu'au 21 Mai

Amazon fait une promotion sur l'organiseur 30 casiers Stanley 1-93-980 qui passe à 13,99 € au lieu de 23,99 €.  Grâce à ses 30 compartiments répartis sur 5 étages, il est plus simple de ranger méthodiquement et placer de manière organisée tous les outils, objets, accessoires et équipements dans son atelier.


> Voir l'offre
139,99 €Set de base sans fil Bosch Professional 18V system avec chargeur GAL et 2 batteries 4Ah à 139,99 €
Valable jusqu'au 21 Mai

Amazon fait une promotion sur le set de base sans fil Bosch Professional 18V system avec un chargeur GAL 18V-40 et 2 batteries 18V 4Ah à 139,99 € au lieu de 170 €. Tout pour bien accompagner vos appareils sans fil Bosch compatibles avec le système 18V de la marque.


> Voir l'offre

Sujets relatifs
Supprimer les lignes vides dans Excel
Excel - Macro - eliminer des lignes vides
LIGNES VIDES DANS EXCEL
Excel supprimer lignes vides???
supprimer des lignes vides sous excel 2003
Excel 2010
compter lignes d'un tableau dont toutes les cellules sont en couleur
Faire un tableau sur Excel avec des sauts de lignes
Excel 2010
Changement dans Excel 2010 ?
Plus de sujets relatifs à Compter les lignes non vides (Excel 2010)
 > Tous les forums > Forum Bureautique