> Tous les forums > Forum Bureautique
 Compter les lignes non vides (Excel 2010)Sujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
LRD95
  Posté le 30/09/2010 @ 11:14 
Aller en bas de la page 
Petit astucien

Bonjour

Je suis sous excel 2010

J’ai trouvé sur internet la formule pour compter les cellules vide dans une colonne.

=NB.SI(B6:B31;"")&" opérations"

C’est le contraire que je voudrais, compter les cellules non vides.

Merci de bien vouloir m’aider.

Publicité
LRD95
 Posté le 30/09/2010 à 11:54 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Merci Anonyme, ça fonctionne.

=NBVAL(B6:B31)&" opérations"

A+

ferrand
 Posté le 30/09/2010 à 12:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut,

...et si tu veux conserver NB.SI, tu peux faire: =NB.SI(plage;"<>")

pour compter les cellules qui contiennent du texte: =NB.SI(plage;"*")

Et pour les cellules vides, tu as aussi NB.VIDE à ta disposition.

LRD95
 Posté le 30/09/2010 à 12:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour ferrand

Merci pour ta deuxième solution, mais je vais conserver NBVAL.

Ça m’intéresse quand même, je l’essayerai dans un autre fichier surtout la deuxième pour compter les cellules avec du teste.

Bonne journée

A+

qmike549
 Posté le 30/09/2010 à 15:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

bonjour

a noter que cette formule est valable sur toutes les versions d'excel

Compter les lignes non vides (Excel 2010)

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
599 €Portable 15,6 pouces HP (FHD IPS, Ryzen 5 5500U, 16Go/512Go, Windows 11) à 599 €
699 € -14%

Leclerc fait une belle promotion sur l'ordinateur portable HP Pavilion 15-eh1029nf qui passe à 599 € au lieu de 699 €. Une bonne affaire ! Ce portable possède un écran 15.6 pouces Full HD IPS (1920x1080), un processeur AMD Ryzen 5 5500U (6 coeurs), 16 Go de RAM, un SSD NVMe de 512 Go et un chip graphique Vega 7. Le tout tourne sous Windows 11.

De quoi faire de la bureautique, surfer sur Internet, du multimédia et des petits jeux en toute tranquillité.


Voir l'offre
32,90 €Clé USB 3.1 Sandisk Ultra Luxe 256 Go à 32,90 €
45 € -27%

Cdiscount propose la clé USB Sandisk Ultra Luxe d'une capacité de 256 Go à 32,90 €. Cette clé USB 3.1 toute en métal est compatible USB 2.0 et offre de bons débits d'environ 150 Mo/s en lecture et en écriture. Elle inclut le logiciel SanDisk SecureAccess pour un cryptage et une protection par mot de passe de vos données sensibles. 


Voir l'offre
166,52 €Smartphone 6.5 pouces Xiaomi Redmi Note 10 5G (FHD+, 4Go/128Go) à 166,52 € livré
199 € -16%

Amazon Allemagne fait une promotion sur le smartphone 6.5 pouces Xiaomi Redmi Note 10 5G qui passe à 161,24 € (avec la TVA ajustée). Comptez 5,28 € pour la livraison en France soit un total de 166,52 € livré. On le trouve ailleurs autour de 199 €. 

Ce smartphone dispose d'un écran 6.5 pouces 90 Hz FHD+ (2400x1080 pixels), un processeur 8 coeurs, 4 Go de mémoire, de 128 Go d'espace de stockage extensible par microSD, d'un APN 48 MPixels + 2 + 2 MPixels et d'un APN 8 MP avant, du bluetooh, du Wifi, d'un lecteur d'empreintes digitales. Il est compatible avec les fréquences 2G, 3G, 4G et 5G. Le tout tourne sous Android 11 avec une surcouche Xiaomi. La batterie à charge rapide 18W est de haute capacité 5000 mAh.

Le téléphone sera en français dès le premier démarrage et bénéficie d'une garantie européenne de 2 ans. Vous pouvez utiliser votre compte Amazon FR sur Amazon DE. Pas de douane.


Voir l'offre
66,84 €Boîtier PC NZXT H510i (ATX, panneau en verre trempé) à 66,84 €
93 € -28%

Amazon fait une promotion sur le boîtier PC NZXT H510i ATX qui passe à 66,84 € alors qu'on le trouve ailleurs à plus de 93 €. Ce boîtier comporte un panneau en verre trempé et un cache pour votre alimentation. Fourni avec 2 ventilateurs qui assurent une circulation optimale de l'air, vous pourrez installer 2 unités en plus. Pour préserver l'élégance de votre système, l'admission d'air à l'avant et pour le bloc d’alimentation est entièrement filtrée. Au format moyen tour, le NZXT H510i est capable d'accueillir les configurations les plus puissantes : avec le support des cartes graphiques jusqu'à 381 mm.


Voir l'offre

Sujets relatifs
Supprimer les lignes vides dans Excel
Excel - Macro - eliminer des lignes vides
LIGNES VIDES DANS EXCEL
Excel supprimer lignes vides???
supprimer des lignes vides sous excel 2003
Excel 2010
compter lignes d'un tableau dont toutes les cellules sont en couleur
Faire un tableau sur Excel avec des sauts de lignes
Excel 2010
Changement dans Excel 2010 ?
Plus de sujets relatifs à Compter les lignes non vides (Excel 2010)
 > Tous les forums > Forum Bureautique