> Tous les forums > Forum Bureautique
 Compter les lignes non vides (Excel 2010)Sujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
LRD95
  Posté le 30/09/2010 @ 11:14 
Aller en bas de la page 
Petit astucien

Bonjour

Je suis sous excel 2010

J’ai trouvé sur internet la formule pour compter les cellules vide dans une colonne.

=NB.SI(B6:B31;"")&" opérations"

C’est le contraire que je voudrais, compter les cellules non vides.

Merci de bien vouloir m’aider.

Publicité
LRD95
 Posté le 30/09/2010 à 11:54 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Merci Anonyme, ça fonctionne.

=NBVAL(B6:B31)&" opérations"

A+

ferrand
 Posté le 30/09/2010 à 12:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut,

...et si tu veux conserver NB.SI, tu peux faire: =NB.SI(plage;"<>")

pour compter les cellules qui contiennent du texte: =NB.SI(plage;"*")

Et pour les cellules vides, tu as aussi NB.VIDE à ta disposition.

LRD95
 Posté le 30/09/2010 à 12:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour ferrand

Merci pour ta deuxième solution, mais je vais conserver NBVAL.

Ça m’intéresse quand même, je l’essayerai dans un autre fichier surtout la deuxième pour compter les cellules avec du teste.

Bonne journée

A+

qmike549
 Posté le 30/09/2010 à 15:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

bonjour

a noter que cette formule est valable sur toutes les versions d'excel

Compter les lignes non vides (Excel 2010)

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
-6 €6 € offerts pour toute recharge de son compte Amazon de 70 €

Amazon remet en avant son offre pour obtenir un bon d'achat de 6 € sur Amazon. Pour toute recharge de son compte Amazon d'au moins 70 €, Amazon vous offre un bon d'achat de 6 € utilisable jusqu'au 31 Octobre 2022. Vous pouvez utiliser le solde de votre compte Amazon pour tous vos achats.

Notez que cette offre n'est pas disponible si vous avez déjà rechargé votre compte Amazon dans les 36 derniers mois.


Voir l'offre
19,99 €Terminal de paiement SumUp Air à 19,99 €
29,99 € -33%

Cdiscount fait une promotion sur le terminal de paiement SumUp Air sans fil qui passe à 19,99 € au lieu de 29,99 €. Avec lui et votre smartphone (application SumUP à installer), vous allez pouvoir accepter simplement des paiements par cartes bancaires. Oubliez les frais mensuels et les obligations contractuelles : Vous ne payez qu'une commission de 1,75% par transaction. Pas de frais supplémentaires. Les fonds sont directement transférés sur votre compte bancaire.

Pratique pour les petits commerçants, les marchés, les vides greniers, etc.


Voir l'offre
36,99 €Clé USB Sandisk Luxe 256 Go à double connectique USB 3.1 Type A et C à 36,99 €
47 € -21%

Cdiscount fait une promotion sur la clé USB Sandisk Luxe 256 Go à double connectique USB 3.1 Type A et C qui passe à 36,99 €. Cette clé USB  dispose d'un connecteur USB Type C et d'un connecteur classique de type A. Grâce à elle, transférez en toute simplicité et rapidement (jusqu'à 150 Mo/s) vos fichiers entre vos smartphones, tablettes et ordinateurs. On la trouve ailleurs à plus de 47 €.


Voir l'offre
172,09 €Tablette 10.5 pouces Samsung Galaxy Tab A8 (8 coeurs, 32Go, WUXGA+, RAM 3 Go) à 172,09 € livrée
230 € -25%

Amazon Allemagne fait une promotion sur la tablette 10.5 pouces Samsung Galaxy Tab A8 qui passe à 166,39 € (avec la TVA ajustée). Comptez 5,70 € pour la livraison en France soit un total de 172,09 € livrée. On la trouve ailleurs à plus de 230 €. Cette tablette possède un écran 10.5 pouces WUXGA (1920x1200pixels), un processeur octa-core 2 GHz, 3 Go de RAM, un espace de stockage de 32 Go extensible par MicroSD, le WiFi, le bluetooth et tourne sous Android 11.

La tablette pourra être mise en français dès le premier démarrage et vous bénéficiez d'une garantie européenne de 2 ans. Vous pouvez utiliser votre compte Amazon France sur Amazon Allemagne et il n'y a pas de douane.


Voir l'offre

Sujets relatifs
Supprimer les lignes vides dans Excel
Excel - Macro - eliminer des lignes vides
LIGNES VIDES DANS EXCEL
Excel supprimer lignes vides???
supprimer des lignes vides sous excel 2003
Excel 2010
compter lignes d'un tableau dont toutes les cellules sont en couleur
Faire un tableau sur Excel avec des sauts de lignes
Excel 2010
Changement dans Excel 2010 ?
Plus de sujets relatifs à Compter les lignes non vides (Excel 2010)
 > Tous les forums > Forum Bureautique