> Tous les forums > Forum Bureautique
 Compter les lignes non vides (Excel 2010)Sujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
LRD95
  Posté le 30/09/2010 @ 11:14 
Aller en bas de la page 
Petit astucien

Bonjour

Je suis sous excel 2010

J’ai trouvé sur internet la formule pour compter les cellules vide dans une colonne.

=NB.SI(B6:B31;"")&" opérations"

C’est le contraire que je voudrais, compter les cellules non vides.

Merci de bien vouloir m’aider.

Publicité
LRD95
 Posté le 30/09/2010 à 11:54 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Merci Anonyme, ça fonctionne.

=NBVAL(B6:B31)&" opérations"

A+

ferrand
 Posté le 30/09/2010 à 12:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut,

...et si tu veux conserver NB.SI, tu peux faire: =NB.SI(plage;"<>")

pour compter les cellules qui contiennent du texte: =NB.SI(plage;"*")

Et pour les cellules vides, tu as aussi NB.VIDE à ta disposition.

LRD95
 Posté le 30/09/2010 à 12:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour ferrand

Merci pour ta deuxième solution, mais je vais conserver NBVAL.

Ça m’intéresse quand même, je l’essayerai dans un autre fichier surtout la deuxième pour compter les cellules avec du teste.

Bonne journée

A+

qmike549
 Posté le 30/09/2010 à 15:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

bonjour

a noter que cette formule est valable sur toutes les versions d'excel

Compter les lignes non vides (Excel 2010)

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
349,99 €Ecran 31.5 pouces LG Ultragear 32GP850-B (IPS, WQHD, 165Hz, HDR10, G-sync/FreeSync) à 349,99 €
400 € -13%

Amazon fait une promotion sur l'écran LG Ultragear 32GP850-B qui passe à 349,99 €. On le trouve ailleurs à partir de 400 €. Cet écran possède une dalle nano IPS 31.5 pouces WQHD (2560x1440) à 165 Hz, un temps de réponse de 1 ms. Il est compatible Adaptive Sync (FreeSync/GSync). Il est réglable en hauteur, possède un hub USB 3.0 et une connectique HDMIx2 et DPx1. 


Voir l'offre
259,99 €Ecran Lenovo 27 pouces G27Q-20 (WQHD, IPS, 165 Hz, FreeSync) à 259,99 €
379 € -31%

Fnac propose actuellement l'écran 27 pouces Lenovo G27Q-20 à 259,99 € alors qu'on le trouve ailleurs à plus de 379 €. Cet écran dispose d'une dalle QHD (2560x1440) à bords fins, avec un temps de réponse de 1 ms et un rafraichissement de 165 Hz. Il possède des entrées DP et HDMI. Il est compatible Freesync et GSync. Il est réglable en hauteur et en inclinaison et est garanti 3 ans.


Voir l'offre
769 €Robot tondeuse connectée Bosch Indego S+ 500 m² à 769 €
900 € -15%

Amazon fait une belle promotion sur le robot tondeuse connectée Bosch Indego S+ 500 m² qui passe à 769 € au lieu de 900 € ailleurs. Ce robot offre une capacité de tonte capacité de surface de tonte de 500 m² (±20%). Quand sa batterie est déchargée, la tondeuse robot va se recharger toute seule à sa station de charge. Le câble périphérique délimite la zone de tonte et est très facile à installer. Après avoir cartographié la pelouse, l’Indego propose un calendrier de tonte adapté à la taille de la pelouse. 

Un câble périphérique de 150 mètres, 200 cavaliers pour l'enterrer et une base sont fournis. Le robot tondeuse peut travailler sur des terrains pentes allant jusqu'à 27%. Enfin, grâce à l'application Bosch, vous pourrez programmer et lancer la tonte où que vous êtes.


Voir l'offre
69,99 €SSD PNY CS900 960 Go à 69,99 €
100 € -30%

Cdiscount fait une promotion sur le SSD PNY CS900 960 Go qui passe à 69,99 € alors qu'on le trouve ailleurs à partir de 100 €. Ce SSD offre des vitesses d'écriture de 515 Mo/s et de lecture à 550 Mo/s. Il est garanti 3 ans. La livraison est gratuite.


Voir l'offre

Sujets relatifs
Supprimer les lignes vides dans Excel
Excel - Macro - eliminer des lignes vides
LIGNES VIDES DANS EXCEL
Excel supprimer lignes vides???
supprimer des lignes vides sous excel 2003
Excel 2010
compter lignes d'un tableau dont toutes les cellules sont en couleur
Faire un tableau sur Excel avec des sauts de lignes
Excel 2010
Changement dans Excel 2010 ?
Plus de sujets relatifs à Compter les lignes non vides (Excel 2010)
 > Tous les forums > Forum Bureautique