> Tous les forums > Forum Bureautique
 compter nombre de villes différentes dans une colonneSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
maryloo2005
  Posté le 08/11/2019 @ 14:25 
Aller en bas de la page 
Petite astucienne

Bonjour,

Dans une base de données Excel, j'ai une colonne contenant des villes. Certaines figurent plusieurs fois, d'autres une seule fois.

Existe-t-il une fonction qui me donne le nombre de villes différentes ? Merci.

Pour l'instant, je me débrouille avec plusieurs formules =NB.SI(A2:A1000;"nomdelaville") mais c'est long et je peux en oublier !

Merci d'avance pour votre aide, bonne journée et WE.

Publicité
dlxpat
 Posté le 08/11/2019 à 14:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour; tape cette formule dans la case où tu veux compter tes villes

{=SOMME(SI(A1:A10<>"";1/NB.SI(A1:A10;A1:A10)))}

Remplace A10 par la dernière ligne de ta colonne. Attention formule matricielle il faut la valider par Ctrl++ majuscule + entrée

maryloo2005
 Posté le 08/11/2019 à 15:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Merci bcp !

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
compter le nombre de certains caractères dans une chaine de caractères
nombre de noms dans une colonne
Le minimum de fois sur tant de ligne dans une colonne... ??
Comment compter dans une colonne
Nombre de mots répétés dans une même cellule
Solde de lignes dans une colonne
nombre de mots dans 1 colonne
Manipuler une colonne de nombres dans Excel
somme de lettre dans une colonne
compter le nombre de lignes d'un texte word
Plus de sujets relatifs à compter nombre de villes différentes dans une colonne
 > Tous les forums > Forum Bureautique