> Tous les forums > Forum Bureautique
 compter nombre de villes différentes dans une colonneSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
maryloo2005
  Posté le 08/11/2019 @ 14:25 
Aller en bas de la page 
Astucienne

Bonjour,

Dans une base de données Excel, j'ai une colonne contenant des villes. Certaines figurent plusieurs fois, d'autres une seule fois.

Existe-t-il une fonction qui me donne le nombre de villes différentes ? Merci.

Pour l'instant, je me débrouille avec plusieurs formules =NB.SI(A2:A1000;"nomdelaville") mais c'est long et je peux en oublier !

Merci d'avance pour votre aide, bonne journée et WE.

Publicité
dlxpat
 Posté le 08/11/2019 à 14:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour; tape cette formule dans la case où tu veux compter tes villes

{=SOMME(SI(A1:A10<>"";1/NB.SI(A1:A10;A1:A10)))}

Remplace A10 par la dernière ligne de ta colonne. Attention formule matricielle il faut la valider par Ctrl++ majuscule + entrée

maryloo2005
 Posté le 08/11/2019 à 15:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucienne

Merci bcp !

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
84,99 €SSD PNY XLR8 CS3030 1 To (NMVe M.2, 3500 Mo/s) à 84,99 €
114,99 € -26%

Cdiscount fait une promotion sur le SSD PNY XLR8 CS3030 1 To (NMVe M.2) qui passe à 84,99 € alors qu'on le trouve ailleurs à partir de 114,99 €. Ce SSD utilise une interface M.2 NVMe PCIe Gen3 x 4 pour une connexion simple et des performances exceptionnelles : jusqu’à 3500 Mo/s en lecture séquentielle et jusqu’à 2000 Mo/s en écriture séquentielle.

Le SSD est doté de la technologie 3D TLC NAND haute densité offrant une endurance d’écriture durable et assorti d’une garantie de cinq ans.


Voir l'offre
89,99 €Alimentation modulaire Corsair RM750X 80+ Gold à 89,99 €
120 € -25%

Amazon propose actuellement l'alimentation modulaire Corsair RM750X à 89,99 €. Cette alimentation de 750 W est certifiée 80+ Gold et est garantie 7 ans. Entièrement modulaire, vous pourrez brancher uniquement les câbles (fournis) dont vous avez besoin. On la trouve ailleurs à partir de 120 €.


Voir l'offre
291,33 €SSD Interne M.2 NVMe PCIe 4.0 Samsung 980 PRO 2 To (avec dissipateur, 7000 Mo/s) à 291,33 €
350 € -17%

Amazon fait une promotion sur le SSD Interne M.2 NVMe PCIe 4.0 Samsung 980 PRO 2 To avec son dissipateur de chaleur qui passe à 291,33 €. On le trouve ailleurs à partir de 350 €. Ce SSD offre des taux de transfert de 7000 Mo /s en lecture et 5100 Mo/s en écriture. Une excellente affaire. 

Notez qu'il est compatible avec la console de jeux PS5.


Voir l'offre
49,99 €Imprimante multifonction HP DeskJet 2710e (Wifi) + 6 mois instant Ink à 49,99 €
89 € -44%

Cdiscount fait une belle promotion sur l'imprimante multifonction HP DeskJet 2710e (WiFi) qui passe à 49,99 € au lieu de 89 € ailleurs.. Cette imprimante 3 en 1 fait donc imprimante, photocopieur et scanner. Elle dispose d'un chargeur automatique de documents. Elle fonctionne avec 2 cartouches d'encre (une noire et une 3 couleurs). Connexion via USB, Bluetooth et Wifi. Vous pourrez facilement imprimer et numériser avec votre ordinateur, tablette, smartphone.


Voir l'offre

Sujets relatifs
compter le nombre de certains caractères dans une chaine de caractères
nombre de noms dans une colonne
Le minimum de fois sur tant de ligne dans une colonne... ??
Comment compter dans une colonne
Nombre de mots répétés dans une même cellule
Solde de lignes dans une colonne
nombre de mots dans 1 colonne
Manipuler une colonne de nombres dans Excel
somme de lettre dans une colonne
compter le nombre de lignes d'un texte word
Plus de sujets relatifs à compter nombre de villes différentes dans une colonne
 > Tous les forums > Forum Bureautique