> Tous les forums > Forum Bureautique
 compter nombre de villes différentes dans une colonneSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
maryloo2005
  Posté le 08/11/2019 @ 14:25 
Aller en bas de la page 
Astucienne

Bonjour,

Dans une base de données Excel, j'ai une colonne contenant des villes. Certaines figurent plusieurs fois, d'autres une seule fois.

Existe-t-il une fonction qui me donne le nombre de villes différentes ? Merci.

Pour l'instant, je me débrouille avec plusieurs formules =NB.SI(A2:A1000;"nomdelaville") mais c'est long et je peux en oublier !

Merci d'avance pour votre aide, bonne journée et WE.

Publicité
dlxpat
 Posté le 08/11/2019 à 14:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour; tape cette formule dans la case où tu veux compter tes villes

{=SOMME(SI(A1:A10<>"";1/NB.SI(A1:A10;A1:A10)))}

Remplace A10 par la dernière ligne de ta colonne. Attention formule matricielle il faut la valider par Ctrl++ majuscule + entrée

maryloo2005
 Posté le 08/11/2019 à 15:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucienne

Merci bcp !

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
249 €Smartphone 6,5 pouces Samsung Galaxy A52 (FullHD+, 8 coeurs, 6Go, 128Go, 4G) à 249 €
325 € -23%

Cdiscount fait une belle promotion sur le smartphone 6,5 pouces Samsung Galaxy A52 4G qui passe à 249 € au lieu de 325 €. Il intègre un bel écran Super AMOLED 90 Hz de 6.5" à résolution Full HD+ de 1080 x 2400 pixels qui offre une incroyable clarté lors de toutes vos utilisations.

En outre, il peut s'appuyer sur son processeur Qualcomm Snapdragon 720G Octo-Core cadencé à 2.3 GHz, ses 6 Go de RAM et sa capacité de stockage de 128 Go. Particulièrement fin, il s'arme de toutes les dernières innovations pour vous simplifier la vie et vous permettre de laisser libre cours à toutes vos envies. De plus, grâce à son quadruple capteur photo de 64+12+5+5 MP, offrez-vous la liberté de capturer encore plus largement le monde qui vous entoure.

Le tout tourne sous Android 11.


Voir l'offre
79,99 €Disque dur externe portable Seagate Expansion 4 To USB 3.0 à 79,99 €
100 € -20%

Cdiscount fait une promotion sur le disque dur externe portable Seagate Expansion d'une capacité de 4 To qui passe à 79,99 € alors qu'on le trouve ailleurs à partir de 100 €. Ce disque dur externe portable au format 2,5 pouces dispose d'une interface USB 3.0 compatible USB 2.0. Une excellente affaire pour ce disque dur qui offre des débits de 115 Mo/s. Il n'est pas soudé et est donc démontable si vous souhaitez le réutiliser ailleurs (console, NAS, PC).


Voir l'offre
259,00 €PC Ankermann (Intel Pentium Dual Core, 8Go RAM, SSD 480Go, Win 10 Pro + Office 365) à 259 € livré

Amazon fait une promotion sur l'ordinateur de bureau Ankermann Silent PC Work à 259 € livré. Le PC est équipé d'un processeur Intel Pentium dual core à 2.7 GHz, de 8 Go de RAM, d'un SSD de 480 Go, d'un disque dur de 500 Go, d'un lecteur DVD, d'un lecteur de carte mémoires et tourne sous Windows 10 Pro 64 bits FR. Un abonnement d'un an à Microsoft Office 365 est également fourni.

Ajoutez un écran et un pack clavier souris et vous avez un PC complet à l'aise en bureautique et Internet. Garantie 2 ans.


Voir l'offre
799,99 €Portable 15,6' Lenovo Legion 5 (FHD, Ryzen 5, 8Go, SSD 512Go, RTX3060) à 799,99 €
1200 € -33%

Cdiscount fait une promotion sur le PC portable Lenovo Legion 5 (15ACH6H) dédié aux joueurs qui passe à 799,99 € au lieu de 1200 €. Ce PC portable très bien équipé possède un écran 15,6 pouces LED Full HD 120 Hz, un processeur AMD Ryzen 5 5600H, 8 Go de RAM, un SSD NVMe de 512 Go et une carte graphique GeForce RTX 3060 6 Go dédiée qui avalera tous vos jeux sans broncher.

L'ordinateur est livré sans OS mais vous pouvez facilement installer Windows 10/11.


Voir l'offre

Sujets relatifs
compter le nombre de certains caractères dans une chaine de caractères
nombre de noms dans une colonne
Le minimum de fois sur tant de ligne dans une colonne... ??
Comment compter dans une colonne
Nombre de mots répétés dans une même cellule
Solde de lignes dans une colonne
nombre de mots dans 1 colonne
Manipuler une colonne de nombres dans Excel
somme de lettre dans une colonne
compter le nombre de lignes d'un texte word
Plus de sujets relatifs à compter nombre de villes différentes dans une colonne
 > Tous les forums > Forum Bureautique