> Tous les forums > Forum Bureautique
 compter nombre de villes différentes dans une colonneSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
maryloo2005
  Posté le 08/11/2019 @ 14:25 
Aller en bas de la page 
Astucienne

Bonjour,

Dans une base de données Excel, j'ai une colonne contenant des villes. Certaines figurent plusieurs fois, d'autres une seule fois.

Existe-t-il une fonction qui me donne le nombre de villes différentes ? Merci.

Pour l'instant, je me débrouille avec plusieurs formules =NB.SI(A2:A1000;"nomdelaville") mais c'est long et je peux en oublier !

Merci d'avance pour votre aide, bonne journée et WE.

Publicité
dlxpat
 Posté le 08/11/2019 à 14:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour; tape cette formule dans la case où tu veux compter tes villes

{=SOMME(SI(A1:A10<>"";1/NB.SI(A1:A10;A1:A10)))}

Remplace A10 par la dernière ligne de ta colonne. Attention formule matricielle il faut la valider par Ctrl++ majuscule + entrée

maryloo2005
 Posté le 08/11/2019 à 15:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucienne

Merci bcp !

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
94,99 €Disque dur Seagate NAS Iron Wolf 4 To à 94,99 €
Valable jusqu'au 25 Mai

Cdiscount propose le disque dur Seagate IronWolf 4 To à 94,99 €. Ce disque dur 3.5 pouces SATA III est adapté aux NAS et ordinateurs qui fonctionnent 24h/24. On le trouve ailleurs à partir de 105 €. Disque CMR.


> Voir l'offre
52,99 €Nintendo Ring Fit Adventure pour Switch à 52,99 €
Valable jusqu'au 25 Mai

Amazon fait une promotion sur le Nintendo Ring Fit Adventure pour Switch à 52,99 € au lieu de 79 €. Faites du sport tout en vous amusant avec Ring Fit Adventure ! Munis des accessoires présents dans la boite du jeu partez à l’aventure et réalisez des mouvements de sports pour avancer dans les niveaux. Poussez sur le Ring-Con et vous enverrez un choc sur vos ennemis ! A la fin de chaque exercice, mesurez même votre rythme cardiaque et découvrez le nombre de calories dépensées.


> Voir l'offre
-7 €-7 € dès 20 € pour une première livraison en point de retrait Amazon (selon éligibilité)
Valable jusqu'au 20 Juin

Amazon propose actuellement 7 euros de remise dès 20 euros d'achats avec le code 7RETRAIT pour une première livraison en point de retrait Amazon. Vous pouvez vérifier votre éligibilité à cette offre en vous rendant sur cette page. Vous trouverez la liste des points de retrait sur cette page.


> Voir l'offre

Sujets relatifs
compter le nombre de certains caractères dans une chaine de caractères
nombre de noms dans une colonne
Le minimum de fois sur tant de ligne dans une colonne... ??
Comment compter dans une colonne
Nombre de mots répétés dans une même cellule
Solde de lignes dans une colonne
nombre de mots dans 1 colonne
Manipuler une colonne de nombres dans Excel
somme de lettre dans une colonne
compter le nombre de lignes d'un texte word
Plus de sujets relatifs à compter nombre de villes différentes dans une colonne
 > Tous les forums > Forum Bureautique