> Tous les forums > Forum Bureautique
 compter nombre de villes différentes dans une colonneSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
maryloo2005
  Posté le 08/11/2019 @ 14:25 
Aller en bas de la page 
Astucienne

Bonjour,

Dans une base de données Excel, j'ai une colonne contenant des villes. Certaines figurent plusieurs fois, d'autres une seule fois.

Existe-t-il une fonction qui me donne le nombre de villes différentes ? Merci.

Pour l'instant, je me débrouille avec plusieurs formules =NB.SI(A2:A1000;"nomdelaville") mais c'est long et je peux en oublier !

Merci d'avance pour votre aide, bonne journée et WE.

Publicité
dlxpat
 Posté le 08/11/2019 à 14:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour; tape cette formule dans la case où tu veux compter tes villes

{=SOMME(SI(A1:A10<>"";1/NB.SI(A1:A10;A1:A10)))}

Remplace A10 par la dernière ligne de ta colonne. Attention formule matricielle il faut la valider par Ctrl++ majuscule + entrée

maryloo2005
 Posté le 08/11/2019 à 15:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucienne

Merci bcp !

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
259,99 €TV 43 pouces Continental Edison QLED, 4K UHD, Android TV à 259,99 €
Valable jusqu'au 26 Mai

Cdiscount propose la TV 43 pouces Continental Edison QLED, 4K UHD à 259,99 €. Cette TV 4K de 43 pouces (108 cm) dispose d'un contour sans bordure, du HDR, du WiFi, du bluetooth, d'Android TV, de 4 ports HDMI et 3 ports USB.


> Voir l'offre
11,99 €Micro clé USB 3.1 Sandisk Ultra Fit 64 Go à 11,99 €
Valable jusqu'au 25 Mai

Cdiscount fait une promotion sur la micro clé USB Sandisk Ultra Fit d'une capacité de 64 Go qui passe à 11,99 €. La minuscule taille de cette clé USB va vous permettre de la laisser brancher en permanence sur votre portable, votre TV ou votre autoradio sans qu'elle dépasse de manière disgracieuse. Sa compatibilité USB 3.1 lui permet d'atteindre des débits jusqu'à 130 Mo/s. 


> Voir l'offre
22,88 €Lecteur/graveur de CD/DVD externe USB 3.0 slim à 22,88 €
Valable jusqu'au 25 Mai

Cdiscount fait une promotion sur le lecteur/graveur de CD/DVD externe USB 3.0 slim qui passe à 22,88 €. Ce graveur vous permettra de lire et graver les CD et DVD sur votre ordinateur qui ne dispose pas de lecteur optique (soit la plupart des portables du marché). Branchez-le simplement sur un port USB de votre PC portable grâce à son câble intégré.


> Voir l'offre

Sujets relatifs
compter le nombre de certains caractères dans une chaine de caractères
nombre de noms dans une colonne
Le minimum de fois sur tant de ligne dans une colonne... ??
Comment compter dans une colonne
Nombre de mots répétés dans une même cellule
Solde de lignes dans une colonne
nombre de mots dans 1 colonne
Manipuler une colonne de nombres dans Excel
somme de lettre dans une colonne
compter le nombre de lignes d'un texte word
Plus de sujets relatifs à compter nombre de villes différentes dans une colonne
 > Tous les forums > Forum Bureautique