> Tous les forums > Forum Linux
 connexion automatique au web
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Kaora
  Posté le 25/11/2006 @ 17:05 
Aller en bas de la page 
Petit astucien

Bonjour,

Avec un modem-routeur, ubuntu ne peut se connecter qu'en deconnectant / reconnectant l'interface ethernet 0.

Je joins la fin du "dmesg" qui pourrait peut-être donner une piste ?

[17179605.640000] NET: Registered protocol family 10
[17179605.640000] lo: Disabled Privacy Extensions
[17179605.640000] IPv6 over IPv4 tunneling driver
[17179616.072000] eth0: no IPv6 routers present
[17179714.540000] eth0: no IPv6 routers present

A la limite je pourrais m'en accomoder mes des amis seraient intéressés par une migration à partir de windows, cette gymnastique risquerait de les rebuter !

Je suis très enthousiaste vis à vis de cette distribution. Ce serait parfait s'il n'y avait pas cette manip à faire.

merci d'avance pour votre aide

cordialement

Publicité
Taras_Boulba
 Posté le 25/11/2006 à 17:12 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

salut

tu veux dire que les commandes "pon dsl-provider" et "poff" sont sans effets?

Kaora
 Posté le 25/11/2006 à 17:21 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir,

merci beaucoup Taras-Boulba de venir à mon aide.

Je devrais essayer cette commande "pon...." pour me connecter ? Ce ne serait toujours pas automatique ? Pourrais-tu me documenter un petit plus cette manip ?

Merci

a+

Kaora
 Posté le 25/11/2006 à 17:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Re

Je joins "route" si ça peut aider ?

moroe@ubuntu-g:~$ route
Table de routage IP du noyau
Destination Passerelle Genmask Indic Metric Ref Use Iface
192.168.0.0 * 255.255.255.0 U 0 0 0 eth0
default www.routerlogin 0.0.0.0 UG 0 0 0 eth0
moroe@ubuntu-g:~$

Taras_Boulba
 Posté le 25/11/2006 à 17:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Kaora a écrit :

Bonsoir,

merci beaucoup Taras-Boulba de venir à mon aide.

Je devrais essayer cette commande "pon...." pour me connecter ? Ce ne serait toujours pas automatique ? Pourrais-tu me documenter un petit plus cette manip ?

Merci

a+


oui, si tu as paramétré ta connexion avec pppoeconf, sans demander de connexion auto au démarrage, pour te connecter tu dois taper dans un terminal "sudo pon dsl-provider" et pour te déconnecter "sudo poff" (sans les guillemets)

titi6852
 Posté le 25/11/2006 à 17:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

bonjour,

pour lancer automatiquement la connexion au démarrage:

sudo ln -s /etc/ppp/pppoe_on_boot /etc/ppp/ppp_on_boot

http://doc.ubuntu-fr.org/materiel/modem

à vous lire

Yves

Kaora
 Posté le 25/11/2006 à 18:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir,

J'ai lu la manip d'ubuntu et voudrais demander s'il n'est pas possible d'utiliser "gedit" comme editeur de texte car je ne voudrais pas me planter un peu plus.

merci beaucoup pour l'aide.

A+

Kaora
 Posté le 25/11/2006 à 18:08 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Je voulais dire aussi que ma connexion à lieu avecun modem-routeur (configuré avec pppoa).

La configuration a été faite dans l'interface du modem-routeur. Est-ce que la manip indiquée dans le lien me concerne aussi ?

Sympa de me consacrer votre temps pour ce cas



Modifié par Kaora le 25/11/2006 18:16
Taras_Boulba
 Posté le 25/11/2006 à 19:39 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

oui tu peux utiliser gedit mais remplace sudo par gksudo (pour lancer une application graphique en root).

pour le reste, vu que le tuto est pour du pppoe, tu dois pouvoir l'adapter au pppoa en cherchant des fichiers équivalents.



Modifié par Taras_Boulba le 25/11/2006 20:13
Publicité
Kaora
 Posté le 25/11/2006 à 21:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir,

Je m'excuse d'insister mais pour moi il s'agit d'un modem-routeur et dans des précédents post, toujours pour ce même problème, on m'a fait éliminer dans "$ sudo /etc/network/interfaces", tout ce qui avait trait à pppoe.....

Donc je peux quand même lancer ces manips ?

Merci pour ta patience



Modifié par Kaora le 25/11/2006 21:07
Taras_Boulba
 Posté le 25/11/2006 à 21:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Kaora a écrit :

Bonsoir,

Je m'excuse d'insister mais pour moi il s'agit d'un modem-routeur et dans des précédents post, toujours pour ce même problème, on m'a fait éliminer dans "$ sudo /etc/network/interfaces", tout ce qui avait trait à pppoe.....

Donc je peux quand même lancer ces manips ?

Merci pour ta patience


a priori ça n'a pas d'importance qu'on t'es fait éliminer tout ce qui concerne pppoe puisque tu utilises le protocoles pppoa... je ne connais pas pppoa, je ne sais pas quels sont les fichiers de configuration mais il te suffit de regarder, puisque toi tu utilises ce protocole, si tu as l'équivalent pppoa des fichiers traités dans le tuto pour pppoe. si tu trouves des fichiers équivalents, tente la manip décrite en l'adaptant.

Kaora
 Posté le 25/11/2006 à 22:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir,

Je vais essayer cette manip et te tiens au courant des résultats.

merci encore

bien cordialement

Koss
 Posté le 26/11/2006 à 09:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Salut,

regarde ici:

http://doc.ubuntu-fr.org/materiel#modem

peut-être ton bonheur.

Taras_Boulba
 Posté le 26/11/2006 à 11:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

re,

si tu n'arrives pas à modifier les fichiers de configuration de pppoa pour avoir une connexion au démarrage, le plus simple c'est que tu recommences la configuration avec pppoaconf et que tu choisisses une connexion auto au démarrage. si c'est comme avec pppoeconf, tu as une option qui t'es proposée. et toujours si c'est comme avec pppoeconf, tu as un message à la fin de la configuration qui t'indique comment se déconnecter et se reconnecter à volonté en console.

titi6852
 Posté le 26/11/2006 à 11:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

bonjour,

comme tu ne précises ni le nom de ton FAI ni la marque de ton modem, vas faire un tour à cette adresse tu y trouveras bons nombres de modems: http://www.google.fr/search?hl=fr&q=pppoa+site%3Adoc.ubuntu-fr.org

à te lire

Yves



Modifié par titi6852 le 26/11/2006 11:45
Kaora
 Posté le 26/11/2006 à 16:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

Désolé je n'avais pas précisé qu'il s'agissait du modem-routeur netgear dg 834, utilisé en filaire (4 ports) ; j'ai déjà vu le tuto qui lui est consacré avec attribution d'adresses statiques ( pour une raison particulière), sinon il y est conseillé le mode DHCP, ce que j'ai choisi ici.

Ce qui me pose problème c'est que toute la configuration étant reportée dans le modem-routeur, on dit, à ce que j'ai lu (peut-être pas tout compris) qu'il n'y avait pas sur le pc lui-même à faire de config particulière. Théoriquement ça devrait marcher sans aucune intervention :

1° c'est le cas pour windows (simplement activer => attribuer automatiquement une ip & idem pour les serveurs de dns

2° sur mdv => choisir connexion lan, dhcp ...

3° sur ubuntu => comme j'ai demandé à l'install que la config réseau se fasse ultérieurement, je l'ai en post install effectuée par :

(système / admin/réseau / ethernet n'est pas activé / propriétés / activer eth0, et mode dhcp choisi / activer ethernet0)

Je viens de tester un autre ubuntu sur un port de ce modem-routeur, et no problème !

Est-ce que ça ne viendrait pas du matos sur le pc qui pose pb ?

amd 64 (installé en 32 bits avec alternate cd)

Je dois signaler une chose, mais on m'a dit que ça ne devrait pas avoir de conséquence :

(dans un fdisk -l), il est dit que la partition hda1(xp) ne s'arrête pas à une frontière de cylindre : (j'avais raté le premier partitionnement).

Périphérique Amorce Début Fin Blocs Id Système
/dev/hda1 1 2550 20480008+ 7 HPFS/NTFS
La partition 1 ne se termine pas sur une frontière de cylindre.

/dev/hda2 * 2551 4373 14643247+ 83 Linux
/dev/hda3 4374 7412 24410767+ 83 Linux
/dev/hda4 7413 16044 69336540 5 Extended
/dev/hda5 7413 15922 68356543+ b W95 FAT32
/dev/hda6 15923 16044 979933+ 82 Linux swap / Solaris

Voilà je dis tout car c'est quand même curieux que le pb ne concerne que ce pc

merci de vortre aide pour démêler cett énigme




Kaora
 Posté le 26/11/2006 à 16:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Re

J'oubliais de dire qu'environ 1 fois sur 5 la connexion au wb se faisait automatiquement.

Publicité
titi6852
 Posté le 26/11/2006 à 19:37 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

bonsoir,

ouvres le fichier /etc/network/interfaces en mode root et vérifies que dans les mentions relatives à la liaison ethernet figure auto

à te lire

Yves

Kaora
 Posté le 26/11/2006 à 21:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir ,

Où se situent les anomalies ?

moroe@ubuntu-g:~$ sudo cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback



iface eth0 inet dhcp

auto eth0

Je joins aussi le résultat d'autres commandes:

moroe@ubuntu-g:~$ ifconfig


eth0 Lien encap:Ethernet HWaddr 00:16:E6:44:53:91
inet adr:192.168.0.2 Bcast:192.168.0.255 Masque:255.255.255.0
adr inet6: fe80::216:e6ff:fe44:5391/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Packets reçus:1105 erreurs:0 :0 overruns:0 frame:0
TX packets:1006 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:1055209 (1.0 MiB) Octets transmis:175682 (171.5 KiB)
Interruption:217 Adresse de base:0xe000

lo Lien encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
Packets reçus:5 erreurs:0 :0 overruns:0 frame:0
TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
Octets reçus:272 (272.0 b) Octets transmis:272 (272.0 b)

moroe@ubuntu-g:~$ cat /etc/resolv.conf
search
nameserver 192.168.0.1 <= mon modem-routeur

et la fin de : dmesg

[17179605.636000] NET: Registered protocol family 10
[17179605.636000] lo: Disabled Privacy Extensions
[17179605.636000] IPv6 over IPv4 tunneling driver
[17179615.684000] eth0: no IPv6 routers present
[17179700.368000] eth0: no IPv6 routers present <= ? ? ?

Quelque fois, assez rarement, j'ai la surprise d'avoir une connexion directe. La cause ne semblerait donc pas trop péjorative .

En tout cas merci beaucoup de m'aider comme on le fait dans ce forum.

cordialement

Taras_Boulba
 Posté le 27/11/2006 à 19:15 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

désolé mais je ne peux plus t'aider, j'ai jamais utilisé le protocole pppoa et j'ai jamais eu de modem-routeur... Mais poste sur le forum ubuntu, ils devraient pouvoir t'aider à résoudre le problème.
Kaora
 Posté le 28/11/2006 à 08:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

Merci Taras-Boulba de t'être penché, ainsi que les autres intervenants, sur ce cas à se taper la tête contre les murs.

C'est quand même dommage de ne pouvoir se connecter automatiquement, quand on pense qu'un point fort de linux c'est justement internet.

Encore merci à vous

Bien cordialement

pascal5960
 Posté le 28/11/2006 à 10:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour : Même avis que titi6852 :la connexion est AUTOMATIQUE sur le routeur netgear (j'en ai un) , il ne faut rien modifier sur le routeur : revoie ta config matérielle (utilisateur root) en indiquant connexion éthernet auto ... (C'est plus simple sous linux que sous win98 !!!) Bon courage

PS : hier Linux m'a détecté un disque dur sur port USB automatiquement alors que j'ai galéré 1/2 heure pour l'installer sous win98 !!! Idem pour clé USB...

Kaora
 Posté le 16/12/2006 à 16:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir,

Je vous demande de m'excuser, je pensais ne plus avoir de réponse sur ce topic et le redécouvre en passant par : "Mes suivis".

Je sais tout le monde dit qu'il n'y a rien à faire, que la connexion se fera automatiquement. Sauf chez moi ! ! ! Avec ce pc ! ! !

Avec les autres ports du switch, et quelque soit le type d'OS : windows, mdv, ubuntu, je peux le vérifier moi-même.

Alors la question que je poserais dans l'état actuel des choses après avoir fait en vain moult manips, ce serait de savoir si la prochaine version (6.10) peut me faire oublier ce désagrément.

Excusez encore et merci d'avoir répondu.

Publicité
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
1399 €PC portable 14 pouces Asus ROG Zephyrus G14 (120 Hz, Ryzen 7, 16Go, SSD 512Go, RTX 2060) à 1399 €
Valable jusqu'au 19 Janvier

Boulanger fait une belle promotion sur le PC portable 14 pouces Asus ROG Zephyrus G14-GA401V-110T qui passe à 1399 € au lieu de 1800 €. Ce superbe ordinateur portable ultra puissant est équipé d'un écran Full HD (1920x1080) à 120 Hz, d'un processeur AMZ Ryzen 7 4800 HS, d'un SSD PCIe M.2 de 512 Go et de 16 Go de RAM. Une carte graphique NVIDIA RTX 2060 Max-Q vient vous assurez des performances excellentes en jeux. Le tourne sous Windows 10. Il ne pèse que 1,6 kg avec un superbe chassis en magnésium et vous pourrez facilement l'emmener partout avec vous.


> Voir l'offre
329 €Smartphone Samsung M51 (6,7 pouces FHD+, 6 Go RAM, 128 Go) à 329 €
Valable jusqu'au 20 Janvier

Amazon fait une belle promotion sur le nouveau smartphone Samsung M51 qui passe à 329 € livré gratuitement au lieu de 399 €. Le smartphone Samsung Galaxy M51 dispose d'un écran Super AMOLED6.7 pouces d'une résolution de 1080 x 2400 pixels, d'un processeur 8 coeurs Snapdragon 730G et 6 Go de RAM. 128 Go de stockage sont présents et sont extensibles par MicroSD (512 Go max). Pour les moments inattendus de la vie, le quadruple appareil photo est idéal. Prenez de superbes photos de votre monde avec un appareil photo principal de 64 MP ou obtenez une image plus large avec l’angle de vue de 123 ° de l’objectif ultra grand angle 12 MP. Le capteur de profondeur 5 MP ajoute un flou d’arrière-plan et l’objectif macro 5 MP optimise la mise au point sur les gros plans.  A l'avant, un appareil photo 32 MP vous permettra de réaliser vos selphies avec un léger flou d'arrière-plan grâce à la mise au point en direct. Il est soutenu par une batterie de 7000 mAh avec recharge rapide. Les fonctionnalités de connectivité du smartphone incluent WiFi, Bluetooth, GPS, Volte, etc. 

Le Galaxy M51 dispose d’un capteur d’empreinte digitale à l’arrière pour vous connecter aux applications compatibles et déverrouiller votre appareil en toute simplicité. Le tout tourne sous Android 10.


> Voir l'offre
12,54 €Micro clé USB 3.1 Sandisk Ultra Fit 64 Go à 12,54 €
Valable jusqu'au 20 Janvier

Amazon fait une promotion sur la micro clé USB Sandisk Ultra Fit d'une capacité de 64 Go qui passe à 12,54 €. La minuscule taille de cette clé USB va vous permettre de la laisser brancher en permanence sur votre portable, votre TV ou votre autoradio sans qu'elle dépasse de manière disgracieuse. Sa compatibilité USB 3.1 lui permet d'atteindre des débits jusqu'à 130 Mo/s. 


> Voir l'offre

Sujets relatifs
connexion automatique Kopete
MAJ Automatique Erreur
Connexion kali-linux avec GNS3
Arrière-plan d'écran de connexion Linux Mint
Connexion SIP/visioconférence
Pas de connexion Wifi après installation Linux Mint 17.1
Connexion disque externe
Handy Linux plus de connexion Wifi
Connexion lecteur C.I. impossible
Impossible de trouver le programme de lancement automatique.
Plus de sujets relatifs à connexion automatique au web
 > Tous les forums > Forum Linux