> Tous les forums > Forum Linux
 connexion internet avec virtualbox sous ubuntuSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
dedetoto
  Posté le 12/02/2010 @ 18:55 
Aller en bas de la page 
Petit astucien

Bonjour,

Je suis sous ubuntu et j'ai installé windows XP via une virtualbox tout a bien fonctionné sauf que je n'arrive pas a me connecter a internet.J'ai un modem sagem et j'ai lu que si on choisissait Nat en mode d'acces reseau tout se déroulait automatiquement.Pouvez-vous m'aider s'il vous plait?Attention je suis débutant avec Linux.

Merci d'avance.

Publicité
titi6852
 Posté le 12/02/2010 à 23:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

bonsoir,

voici un lien parmi d'autres qui pourra t'aider

http://doc.ubuntu-fr.org/virtualbox

à te lire

yves

Logicien
 Posté le 13/02/2010 à 00:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut, bonjour dedetoto,

la première chose que je vérifierais, c'est que tu as bien une carte réseau Ethernet, qu'elle est activée et que le mode d'accès réseau est NAT dans les Préférences de ta machine virtuelle. Que "Ce périphérique fonctionne correctement" dans le gestionnaire de périphériques de Windows. Ce ne sont pas tous les modèles de cartes réseaux disponibles dans VirtualBox qui sont automatiquement supportés par Windows XP. Si tel n'est pas le cas, change de modèle de carte réseau dans les Préférences de ta machine virtuelle.

Ensuite, assure-toi que la carte Ethernet est configurée pour "Obtenir automatiquement une adresse IP" dans ses Propriétés TCP/IP dans le Réseau Windows. La machine virtuelle sert de serveur DHCP quand le mode d'accès est NAT. Rien n'est à configurer manuellement. Resterait des pare-feux bloquants dans Windows et Ubuntu qui empêcheraient l'accès réseau à Windows.

dedetoto
 Posté le 15/02/2010 à 19:25 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Merci a vous deux pour vos réponses et excusez mon temps de réaction mais il faut bien travailler de temps en temps{#}.

Logicien,j'ai bien vérifié tout ce que tu m'as dit et effectivement j'avais omis de bridger la virtualbox et mon reseau.Je croyais mon pb résolu mais non mon souci maintenant est que quand je clique sur internet explorer dans la virtualbox une fenetre s'ouvre pour me demander mon nom d'utilisateur et mon mot de passe et quand j'ai mis ceux-ci et que je lance la connexion le système me repond "connexion impossible".Peux-tu venir a mon secours et merci d'avance.



Modifié par dedetoto le 15/02/2010 19:26
Logicien
 Posté le 16/02/2010 à 08:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Justement, il ne faut pas opter pour l'accès par pont, soit bridge en anglais, car tu as de la configuration manuelle à faire autant dans le système hôte que dans le système invité. L'accès réseau par NAT c'est ce qu'il y a de plus facile. Tu devrais faire une sortie de la commande ipconfig de la console de Windows dans ton message afin qu'on sache si l'invité a bien reçu une configuration réseau de VirtualBox.



Modifié par Logicien le 16/02/2010 08:43
dedetoto
 Posté le 16/02/2010 à 12:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour Logicien,

Je te joins l'invite de commande que tu me demandes.merci et à+

Microsoft Windows [version 6.0.6001]
Copyright (c) 2006 Microsoft Corporation. Tous droits réservés.

C:\Users\dedetoto>ipconfig

Configuration IP de Windows


Carte Ethernet Pont réseau :

Suffixe DNS propre à la connexion. . . : home
Adresse IPv6 de liaison locale. . : fe80::21d1:a31b:e02f:9c0e%11
Adresse IPv4. . . . . . . . . . . : 192.168.1.13
Masque de sous-réseau. . . . . . . . . : 255.255.255.0
Passerelle par défaut. . . . . . . . . : 192.168.1.1

Carte Tunnel Connexion au réseau local* :

Statut du média. . . . . . . . . . . . : Média déconnecté
Suffixe DNS propre à la connexion. . . : home

Carte Tunnel Connexion au réseau local* 6 :

Statut du média. . . . . . . . . . . . : Média déconnecté
Suffixe DNS propre à la connexion. . . :

C:\Users\dedetoto>

Logicien
 Posté le 16/02/2010 à 17:15 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Moi avec VirtualBox, la carte Ethernet de l'invité reçoit une adresse IP sur le réseau 10.0.0.0 comme 10.0.2.15, quand la machine virtuelle est configurée pour faire du NAT et que l'invité est configuré pour obtenir une adresse IP automatiquement. Ce n'est pas ton cas. Il faut revoir ta configuration réseau. La seule chose qui être faite c'est de configurer la machine virtuelle pour faire du NAT sur la carte Ethernet choisie.

dedetoto
 Posté le 17/02/2010 à 20:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Salut Logicien,

En définitive j'ai tout desinstallé et tout recommencé en NAT et maintenant ça marche.Merci pour ton aide et bonne soirée.

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Internet avec Ubuntu Live cd
virtualbox ou dual boot avec ubuntu?
Connexion internet avec OpenSuse Linux 11.3 ?..
Connexion Internet avec FEDORA
Lecture de .mp3 avec Rhythmbox (sous Ubuntu 9.10)
Ubuntu 9.10 : PB connexion internet en wifi
Connexion Wi-FI sous Ubuntu
Pas internet avec Ubuntu 8.04
connection internet avec ubuntu
Ubuntu (sous WINXP/VirtualBox), krusader et root
Plus de sujets relatifs à connexion internet avec virtualbox sous ubuntu
 > Tous les forums > Forum Linux