> Tous les forums > Forum Linux
 connexion wifi
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
revilo56
  Posté le 19/02/2012 @ 01:06 
Aller en bas de la page 
Astucien

Je viens de réinstaller Ubuntu 10.10 que j'avais auparavant.... Problème : je ne parviens plus à me connecter sur le web que par ethernet et plus sous wifi que j'utilisais avant sans problème ( juste en tapant mon code WPA )... D'où est-ce que ça vient alors que quand je passe sous windows 7, il n'y a aucun problème !!!!

Publicité
Mimile
 Posté le 19/02/2012 à 12:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut

Peut-être une question d'encodage de ta clef.

Chez moi, mes clefs WEP (vieilles cartes Wi-Fi) doivent être encodées en hexadécimales et non en caractères alpha-numériques.

Par exemple, j'ai indiqué comme clef WEP sur mon modem-routeur "abcde" qui a aussitôt été convertie en quelque chose comme 12 ac 25 p1 20 (j'invente évidemment).

Et bien, sur les PC, si j'entre comme clef wep "abcde", pas de connexion. En revanche, si j'entre la clef convertie en hexadécimale, ça passe.

Ton problème est peut-être là.

revilo56
 Posté le 19/02/2012 à 16:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Merci Mimile, mais ma clé est en WPA personnel et ça fonctionne très bien avec mon téléphone en wifi et avant quand j'avais installé ubuntu 10.10, aucun problème de connexion Wifi avec la clé WPA ... et c'est le même PC portable qu'avant ( HP Probook 4515s )!!!!

Voila où j'en suis : impossible de valider le code... Voir ici :



Modifié par revilo56 le 19/02/2012 20:28
lionelos
 Posté le 19/02/2012 à 20:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

salut,

je me permets ...

si le bouton "appliquer" n est pas cliquable c est qu il manque des caractères (tu en oublies quand tu rentres ta clef) ...

(c est ce qui me vient à l esprit ...)

++



Modifié par lionelos le 19/02/2012 20:45
Logicien
 Posté le 19/02/2012 à 21:51 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut,

je me permet aussi,

es-tu certain que le démon network-manager est démarré? Tu peux essayer d'utiliser d'autres interfaces réseaux sans fil, Wifi-radar, Wicd ou en lignes de commandes wpa_supplicant. Peut-être que si tu installais la dernière version stable de Ubuntu, 11.10, cela résoudrait ton problème. Être à jour est mieux, peut-être même quand c'est pire.



Modifié par Logicien le 19/02/2012 21:52
revilo56
 Posté le 19/02/2012 à 22:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Merci Logicien, non le code est bon et là j'ai installé" wifi radar" mais ça ne fonctionne pas non plus : et si je suis repassé au 10.10, c'est parce que je ne comprenais pas la présentation du 11.10 ...



Modifié par revilo56 le 19/02/2012 22:22
Logicien
 Posté le 19/02/2012 à 23:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Comme pilote (driver) pour Wifi-radar, tu inscris wext . Quand je te demande si le démon network-manager est démarré, je ne parle pas de l'applet dans la barre des tâches, mais plutôt du service qui doit être démarré avec le système pour que l'applet de la barre des tâches puisse fonctionner. Pour le savoir, exécute la commande

service network-manager status

Cela te le dira. Sans ce démon démarré, l'applet ne peut rien. Donc si la commande te retourne que le démon n'est pas démarré, tu peux le démarrer ou même le redémarrer avec les commandes

sudo network-manager start

ou

sudo network-manager restart

Un point encore plus essentiel est de savoir si la carte sans fil est reconnue, prise en charge et activée. Que retourne la commande

ifconfig

Si ta carte sans fil ne détecte pas de réseaux à portés, elle a possiblement besoin d'un firmware, celui-ci doit être installé pour que la carte puisse être opérationnelle. Ça prend le modèle de la carte et le module utilisé, donné par la commande

lspci -vvv | less

Connaissant le nom du module, on peut trouver le firmware nécessaire.


revilo56
 Posté le 19/02/2012 à 23:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

voila ce que j'ai ( connecté en ethernet ) :

olivier@olivier-HP-ProBook-4515s:~$ service network-manager status
network-manager start/running, process 1085
olivier@olivier-HP-ProBook-4515s:~$

olivier@olivier-HP-ProBook-4515s:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:26:55:c9:ec:af
inet adr:192.168.0.104 Bcast:192.168.0.255 Masque:255.255.255.0
adr inet6: fe80::226:55ff:fec9:ecaf/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Packets reçus:760 erreurs:0 :0 overruns:0 frame:0
TX packets:667 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:622982 (622.9 KB) Octets transmis:130582 (130.5 KB)
Interruption:16

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
Packets reçus:8 erreurs:0 :0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
Octets reçus:480 (480.0 B) Octets transmis:480 (480.0 B)

olivier@olivier-HP-ProBook-4515s:~$

Puis avec la dernière commande que tu m'as indiqué :

00:00.0 Host bridge: Advanced Micro Devices [AMD] RS780 Host Bridge
Subsystem: Hewlett-Packard Company Device 3079
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort+ >SERR- <PERR- INTx-
Latency: 0
Capabilities: <access denied>

00:02.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (ext gfx port 0) (prog-if 00 [Normal decode])
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
I/O behind bridge: 00005000-00005fff
Memory behind bridge: d4300000-d43fffff
Prefetchable memory behind bridge: 00000000c0000000-00000000cfffffff
Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ <SERR- <PERR-
BridgeCtl: Parity- SERR- NoISA- VGA+ MAbort- >Reset- FastB2B-
PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
Capabilities: <access denied>
Kernel driver in use: pcieport
Kernel modules: shpchp

00:04.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 0) (prog-if 00 [Normal decode])
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
I/O behind bridge: 00003000-00004fff
Memory behind bridge: d3200000-d42fffff
Prefetchable memory behind bridge: 00000000d0000000-00000000d0ffffff
Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- <SERR- <PERR-
BridgeCtl: Parity- SERR- NoISA- VGA- MAbort- >Reset- FastB2B-
PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
Capabilities: <access denied>
Kernel driver in use: pcieport
Kernel modules: shpchp

00:07.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 3) (prog-if 00 [Normal decode])





Modifié par revilo56 le 19/02/2012 23:41
Logicien
 Posté le 20/02/2012 à 00:10 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Sauf erreur, ta carte sans fil n'est pas activée. Essai la commande

ifconfig -a

et si tu vois l'interface wlan0, alors ta carte sans fil devrait être opérationnelle, à moins qu'il lui manque le firmware du module qui la pilote. Tu actives la carte par la commande

sudo ifconfig wlan0 up

et tu réessais de te connecter avec NetworkManager. Je suppose que eth0 est l'inteface réseau de ta carte filiaire et que ta carte sans fil porte un autre nom. Ce pourrait être eth1 voir autre chose plutôt que wlan0. L'important est quelle soit activée pour que tu puisses te connecter.

Publicité
revilo56
 Posté le 20/02/2012 à 00:17 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

voila ce que donne la fonction "ifconfig -a" :

olivier@olivier-HP-ProBook-4515s:~$ ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:26:55:c9:ec:af
inet adr:192.168.0.104 Bcast:192.168.0.255 Masque:255.255.255.0
adr inet6: fe80::226:55ff:fec9:ecaf/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Packets reçus:5933 erreurs:0 :0 overruns:0 frame:0
TX packets:4365 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:4415306 (4.4 MB) Octets transmis:995066 (995.0 KB)
Interruption:16

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
Packets reçus:8 erreurs:0 :0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
Octets reçus:480 (480.0 B) Octets transmis:480 (480.0 B)

wlan0 Link encap:Ethernet HWaddr 0c:60:76:41:e1:20
BROADCAST MULTICAST MTU:1500 Metric:1
Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)

olivier@olivier-HP-ProBook-4515s:~$

et pour l'activer :

olivier@olivier-HP-ProBook-4515s:~$ sudo ifconfig wlan0 up
[sudo] password for olivier:
SIOCSIFFLAGS: Aucun fichier ou dossier de ce type
olivier@olivier-HP-ProBook-4515s:~$





Modifié par revilo56 le 20/02/2012 00:19
Logicien
 Posté le 20/02/2012 à 00:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Je sors pour la soirée. Il semble que le firmware de ta carte sans fil ne soit pas installé. Essai

sudo lspci -vvv | less

Regarde quel est la marque de ta carte sans fil et le module qui la pilote. Fait une recherche dans la liste des paquets disponibles, peut-être après

sudo apt-get update

Installe le paquet firmware qui correspond à ta carte sans fil et redémarre.



Modifié par Logicien le 20/02/2012 00:42
revilo56
 Posté le 20/02/2012 à 00:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Merci à toi j'essai tout ça!

revilo56
 Posté le 20/02/2012 à 01:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Ce que je ne comprend pas tu vois , c'est que je débranche le cable ethernet sous le boot windows et que le wifi est impeccable ...

voila ce que donne ta commande : sudo lspci -vvv | less :

00:00.0 Host bridge: Advanced Micro Devices [AMD] RS780 Host Bridge
Subsystem: Hewlett-Packard Company Device 3079
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- SERR- Latency: 0
Capabilities: [c4] HyperTransport: Slave or Primary Interface
Command: BaseUnitID=0 UnitCnt=12 MastHost- DefDir- DUL-
Link Control 0: CFlE- CST- CFE- Link Config 0: MLWI=16bit DwFcIn- MLWO=16bit DwFcOut- LWI=16bit DwFcInEn- LWO=16bit DwFcOutEn-
Link Control 1: CFlE- CST- CFE- Link Config 1: MLWI=8bit DwFcIn- MLWO=8bit DwFcOut- LWI=8bit DwFcInEn- LWO=8bit DwFcOutEn-
Revision ID: 3.00
Link Frequency 0: [a]
Link Error 0: Link Frequency Capability 0: 200MHz+ 300MHz- 400MHz+ 500MHz- 600MHz+ 800MHz+ 1.0GHz+ 1.2GHz- 1.4GHz- 1.6GHz- Vend-
Feature Capability: IsocFC- LDTSTOP+ CRCTM- ECTLT- 64bA- UIDRD-

et celle-là : sudo apt -get update :

sudo apt-get update
[sudo] password for olivier:
Atteint http://fr.archive.ubuntu.com maverick Release.gpg
Ign http://fr.archive.ubuntu.com/ubuntu/ maverick/main Translation-en
Atteint http://fr.archive.ubuntu.com/ubuntu/ maverick/main Translation-fr
Réception de : 1 http://extras.ubuntu.com maverick Release.gpg [72B]
Ign http://extras.ubuntu.com/ubuntu/ maverick/main Translation-en
Atteint http://security.ubuntu.com maverick-security Release.gpg
Ign http://security.ubuntu.com/ubuntu/ maverick-security/main Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/main Translation-fr
Ign http://fr.archive.ubuntu.com/ubuntu/ maverick/multiverse Translation-en
Atteint http://fr.archive.ubuntu.com/ubuntu/ maverick/multiverse Translation-fr
Ign http://fr.archive.ubuntu.com/ubuntu/ maverick/restricted Translation-en
Atteint http://fr.archive.ubuntu.com/ubuntu/ maverick/restricted Translation-fr
Ign http://fr.archive.ubuntu.com/ubuntu/ maverick/universe Translation-en
Ign http://extras.ubuntu.com/ubuntu/ maverick/main Translation-fr
Atteint http://extras.ubuntu.com maverick Release
Atteint http://fr.archive.ubuntu.com/ubuntu/ maverick/universe Translation-fr
Atteint http://fr.archive.ubuntu.com maverick-updates Release.gpg
Ign http://fr.archive.ubuntu.com/ubuntu/ maverick-updates/main Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/multiverse Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/multiverse Translation-fr
Ign http://security.ubuntu.com/ubuntu/ maverick-security/restricted Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/restricted Translation-fr
Ign http://security.ubuntu.com/ubuntu/ maverick-security/universe Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/universe Translation-fr
Ign http://fr.archive.ubuntu.com/ubuntu/ maverick-updates/main Translation-fr
Ign http://fr.archive.ubuntu.com/ubuntu/ maverick-updates/multiverse Translation-en
Ign http://fr.archive.ubuntu.com/ubuntu/ maverick-updates/multiverse Translation-fr
Ign http://fr.archive.ubuntu.com/ubuntu/ maverick-updates/restricted Translation-en
Ign http://fr.archive.ubuntu.com/ubuntu/ maverick-updates/restricted Translation-fr
Ign http://fr.archive.ubuntu.com/ubuntu/ maverick-updates/universe Translation-en
Ign http://fr.archive.ubuntu.com/ubuntu/ maverick-updates/universe Translation-fr
Atteint http://security.ubuntu.com maverick-security Release
Atteint http://fr.archive.ubuntu.com maverick Release
Atteint http://fr.archive.ubuntu.com maverick-updates Release
Atteint http://extras.ubuntu.com maverick/main Sources
Atteint http://security.ubuntu.com maverick-security/main Sources
Atteint http://extras.ubuntu.com maverick/main i386 Packages
Atteint http://security.ubuntu.com maverick-security/restricted Sources
Atteint http://security.ubuntu.com maverick-security/universe Sources
Atteint http://security.ubuntu.com maverick-security/multiverse Sources
Atteint http://security.ubuntu.com maverick-security/main i386 Packages
Atteint http://security.ubuntu.com maverick-security/restricted i386 Packages
Atteint http://security.ubuntu.com maverick-security/universe i386 Packages
Atteint http://security.ubuntu.com maverick-security/multiverse i386 Packages
Atteint http://fr.archive.ubuntu.com maverick/main Sources
Atteint http://fr.archive.ubuntu.com maverick/restricted Sources
Atteint http://fr.archive.ubuntu.com maverick/universe Sources
Atteint http://fr.archive.ubuntu.com maverick/multiverse Sources
Atteint http://fr.archive.ubuntu.com maverick/main i386 Packages
Atteint http://fr.archive.ubuntu.com maverick/restricted i386 Packages
Atteint http://fr.archive.ubuntu.com maverick/universe i386 Packages
Atteint http://fr.archive.ubuntu.com maverick/multiverse i386 Packages
Atteint http://fr.archive.ubuntu.com maverick-updates/main Sources
Atteint http://fr.archive.ubuntu.com maverick-updates/restricted Sources
Atteint http://fr.archive.ubuntu.com maverick-updates/universe Sources
Atteint http://fr.archive.ubuntu.com maverick-updates/multiverse Sources
Atteint http://fr.archive.ubuntu.com maverick-updates/main i386 Packages
Atteint http://fr.archive.ubuntu.com maverick-updates/restricted i386 Packages
Atteint http://fr.archive.ubuntu.com maverick-updates/universe i386 Packages
Atteint http://fr.archive.ubuntu.com maverick-updates/multiverse i386 Packages
72o réceptionnés en 0s (105o/s)
Lecture des listes de paquets... Fait



Modifié par revilo56 le 20/02/2012 01:42
Logicien
 Posté le 20/02/2012 à 05:56 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Tu ne saisis pas comment utiliser la sortie de la commande sudo lspci -vvv avec le paginateur less. Plus facile est

sudo lspci -vvv | grep -i driver

La sortie va afficher tous les pilotes utilisés par le port PCI dont celui de la carte sans fil que je saurai reconnaître. De la, je pourrai te dire quel paquet installer comme firmware si nécessaire. Entre temps la commande

dpkg -l *firmware*

peut être utile pour savoir quels firmwares sont installés. La commande

sudo lspci

est la plus simple pour connaître marques et chipsets des composants du port PCI. Si ton problème n'est pas relié au firmware qui peut être manquant, alors, je me creuse la tête.



Modifié par Logicien le 20/02/2012 06:03
revilo56
 Posté le 20/02/2012 à 15:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Je te remercie mais je crois bien que mon install d'ubuntu 10.10 était mal fouttue parce que je n'avais pas branché le cable ethernet .

Là je l'ai réinstallé par dessus ( d'où 4 partitions cachées ) et le wifi est opérant de suite !!!

Bizarre qu'il faille une connexion pour installer ce système ( si on ne veut pas aller sur internet par exemple et ne s'en servir que pour visionner des diaporamas ou faire du traitement de texte, il y a un hic !!! )



Modifié par revilo56 le 20/02/2012 15:04
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Pas de connexion Wifi après installation Linux Mint 17.1
Handy Linux plus de connexion Wifi
Connexion wifi
ordi dell et connexion wifi (box orange)
Wifi US Robotics USR5420 - connexion impossible
connexion wifi impossible
connexion en wifi impossible!
Ubuntu 9.10 et connexion wifi
Ubuntu 9.10 : PB connexion internet en wifi
Rétablir la connexion wifi
Plus de sujets relatifs à connexion wifi
 > Tous les forums > Forum Linux