> Tous les forums > Forum Bureautique
 COPIE SI DEUX CONDITIONS REUNIESSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
ricken
  Posté le 19/05/2008 @ 15:13 
Aller en bas de la page 
Petit astucien

Bonjour,

Dans un même classeur, j'ai deux feuilles. J'aimerais copier des cellules de la feuille 2 à la feuille 1 si deux cellules d'une même ligne sont identiques dans les deux feuilles. J'utilise pour cela la fonction suivante, qui ne fonctionne pas (sinon, pas besoin du forum !!!):

=SI((J2=Feuil2!$A$2:$A$64);SI(H2=Feuil2!$B$2:$B$64;Feuil2!$C$2:$C$64;""))

Si J2 ET H2 de la feuille 1 trouvent une paire identique en feuille 2, alors copier la cellule Cx de la feuille 2 en M2 de la feuille 1 et ainsi de suite dans la colonne M.

Un petit fichier avec une feuille nommée 'A OBTENIR' pour avoir une idée du résultat.

http://cjoint.com/?ftpljjFoIx

Merci d'avance à tous ceux qui voudront bien se pencher sur mon problème

Publicité
Bérylion
 Posté le 19/05/2008 à 16:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien


Salut

en feuil1!M2 tu mets :
=SI(ESTERREUR(DECALER(Feuil2!$B$2;EQUIV(Feuil1!J2;Feuil2!$A$2:$A$64;0);0)=Feuil1!H2);"";SI(DECALER(Feuil2!$B$2;EQUIV(Feuil1!J2;Feuil2!$A$2:$A$64;0);0)=Feuil1!H2;SI(ESTVIDE(DECALER(Feuil2!$C$1;EQUIV(Feuil1!J2;Feuil2!$A$2:$A$64;0);0));"";DECALER(Feuil2!$C$1;EQUIV(Feuil1!J2;Feuil2!$A$2:$A$64;0);0));""))
(pour la 2eme colonne de ton exemple va falloir expliquer paske j'ai pas le temps d'essayer de comprendre...)
ricken
 Posté le 19/05/2008 à 17:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Royal Bérylion

Pour la seconde colonne, il faut mettre ça:

=SI(ESTERREUR(DECALER(Feuil2!$B$2;EQUIV(Feuil1!J2;Feuil2!$A$2:$A$64;0);0)=Feuil1!H2);"";SI(DECALER(Feuil2!$B$2;EQUIV(Feuil1!J2;Feuil2!$A$2:$A$64;0);0)=Feuil1!H2;SI(ESTVIDE(DECALER(Feuil2!$D$1;EQUIV(Feuil1!J2;Feuil2!$A$2:$A$64;0);0));"";DECALER(Feuil2!$D$1;EQUIV(Feuil1!J2;Feuil2!$A$2:$A$64;0);0));"")

Yapuka adapter au vrai fichier, décortiquer et digérer.

Merci de ton aide

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
28,98 €Clé USB 3.0 SanDisk Ultra Flair 256 Go à 28,98 €
Valable jusqu'au 21 Janvier

Amazon fait une promotion sur la clé USB 3.0 SanDisk Ultra Flair 256 Go qui passe à 28,98 € livrée gratuitement alors qu'on la trouve ailleurs à plus de 55 €.


> Voir l'offre
39,40 €Carte mémoire microSDXC UHS-I U3 SanDisk Extreme 256 Go (160 Mo/s) à 39,40 €
Valable jusqu'au 21 Janvier

Amazon fait une promotion sur la carte mémoire microSDXC UHS-I U3 A2 SanDisk Extreme 256 Go qui passe à 39,40 € livrée gratuitement alors qu'on la trouve ailleurs autour de 70 €. Cette carte mémoire offre des vitesses jusqu'à 160 Mo/s et est idéale pour les téléphones, caméras et appareils photo HD/4K.


> Voir l'offre
109,99 €Disque dur Seagate NAS Iron Wolf 4 To à 109,99 €
Valable jusqu'au 20 Janvier

Cdiscount propose le disque dur Seagate IronWolf 4 To à 109,99 €. Ce disque dur 3.5 pouces SATA III est adapté aux NAS et ordinateurs qui fonctionnent 24h/24. On le trouve ailleurs autour de 130 €. 


> Voir l'offre

Sujets relatifs
Copier une série de ligne avec deux conditions
Une copie d'Office sur deux est une version pirate
Copie sous conditions Excel [VBA]
Comparaison de deux tableaux EXCEL pour voir les nouveaux adhérents
Copie trop lente avec cd burner xp
synchroniser deux calendrier
Copie de sauvegarde sur 2 DD différents
Mise en forme conditionnelle 2 conditions 2 couleurs
échelle des x avec deux colonnes date et heure
mettre oui ou non suivant 2 conditions d'après 2 tableaux
Plus de sujets relatifs à COPIE SI DEUX CONDITIONS REUNIES
 > Tous les forums > Forum Bureautique