> Tous les forums > Forum Bureautique
 copier ligne si cellule vide
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
massjipe
  Posté le 13/06/2015 @ 07:19 
Aller en bas de la page 
Petit astucien

Bonjour

J'ai une plage en feuil1 A1 C4 en D la cellule vide

soit par formule ou vba si D1 est vide alors on copie la ligne A1 C1 en feuille 2 ayant la même destination idem pour les lignes du dessous

Merci

Publicité
massjipe
 Posté le 13/06/2015 à 08:00 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

=SI(Feuil1!D1="";Feuil1!A1;"") la formule fonctionne mais et elle bien écrite

ferrand
 Posté le 13/06/2015 à 11:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

Cela dépend de la signification donnée à "vide" d'une part, et du résultat souhaité d'autre part.

Une cellule qui n'affiche rien n'est pas forcément vide : D1="" ou ESTVIDE(D1) ne renvoient pas le même résultat selon le cas.

massjipe
 Posté le 13/06/2015 à 18:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

re

D est vide jusqu'au moment ou on rentre une date qui me sert pour le post export cellule pour image

merci

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Renvoi à la dernière cellule non vide d'une ligne
Rechercher dernière cellule non vide d'une ligne
Une feuille blanche pour une ligne vide en fin de document
Rendre une cellule vide
imprimer si ligne non vide
copier une ligne feuille 1 pour remettre feuille2
Supprimer la ligne de la cellule active sauf une cellule
Incrémentation automatique d'une cellule à chaque nouvelle ligne
Macro Copier ligne vers un autre fichier
Copier cellule (pour Ferrand SVP !)
Plus de sujets relatifs à copier ligne si cellule vide
 > Tous les forums > Forum Bureautique