> Tous les forums > Forum Linux
 Debian 9 et les Mises à jour Sécurité !!!Sujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
eliot3
  Posté le 04/12/2018 @ 11:02 
Aller en bas de la page 
Grand Maître astucien

Sur la Debian 9, ce matin, j'ai eu des Mises à jour et lorsque je redémarre le portable, Le menu du Grub met du temps à s'afficher.

Avez eu le même souci.

Publicité
m_n
 Posté le 04/12/2018 à 14:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

combien de temps ?

chez-moi cela prend environ 5 sec ..

Essaie de faire un update-grub pour remedier a ton probleme ,,

eliot3
 Posté le 04/12/2018 à 14:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

m_n

Après update-grub, il me faut maintenant 1,55 minute pour avoir accès au menu grub contre 5 secondes avant.

Je peux essayer de restaurer le disque C'est suite à la MAJ de Debian

m_n
 Posté le 04/12/2018 à 15:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

c'est la premiere fois que je voie ce probleme de grub ..

etant donné que tu as 4 distro debian dans ton grub ..

j'essairais de booter le grub sur une autre distro Debian pour voir si le probleme persiste ..

sudo blkid

sudo grub-install /dev/sdX

sudo update-grub

eliot3
 Posté le 04/12/2018 à 15:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

eliot3@eliot3-Aspire-5733:~$ sudo blkid
[sudo] Mot de passe de eliot3 :
/dev/sda1: LABEL="RM-CM-)servM-CM-) au systM-CM-(me" UUID="9EB2ACCDB2ACAAEB" TYPE="ntfs" PARTUUID="fb088cfc-01"
/dev/sda2: LABEL="Windows 10" UUID="A616B22D16B1FE7D" TYPE="ntfs" PARTUUID="fb088cfc-02"
/dev/sda3: LABEL="WinPe" UUID="01D487E692BCC6A0" TYPE="ntfs" PARTUUID="fb088cfc-03"
/dev/sda5: LABEL="Linux Mint 19" UUID="7f19fb7b-2568-4401-a4ae-09152183ffc6" TYPE="ext4" PARTUUID="fb088cfc-05"
/dev/sda6: LABEL="Xubuntu" UUID="ee737c45-184a-4156-b380-5395ae1833d5" TYPE="ext4" PARTUUID="fb088cfc-06"
/dev/sda7: LABEL="Kubuntu" UUID="a1f76692-4095-4c9e-a0ac-014a918ed5bb" TYPE="ext2" PARTUUID="fb088cfc-07"
/dev/sda8: LABEL="Debian 9 Cinamon" UUID="116d7afe-f588-42a1-8e3e-96104a496348" TYPE="ext4" PARTUUID="fb088cfc-08"
/dev/sda9: UUID="23fd3ad2-e64a-487f-9c8a-5d27cbe65a68" TYPE="swap" PARTUUID="fb088cfc-09"

Je mets quoi ? ensuite

m_n
 Posté le 04/12/2018 à 15:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

tu as le choix pour ,

sda5

sda6

sda7

================

c'est a dire le choix pour :

sudo grub-install /dev/sda5

sudo grub-install /dev/sda6

sudo grub-install /dev/sda7



Modifié par m_n le 04/12/2018 15:28
eliot3
 Posté le 04/12/2018 à 15:38 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

eliot3@eliot3-Aspire-5733:~$ sudo grub-install /dev/sda5
[sudo] Mot de passe de eliot3 :
Installation pour la plate-forme i386-pc.
grub-install : attention : Le système de fichiers « ext2 » ne prend pas en charge l'embarquage.
grub-install : attention : L'embarquage est impossible. GRUB ne peut être installé sur cette configuration qu'en utilisant les listes de blocs. Cependant, les listes de blocs ne sont PAS fiables et leur utilisation est déconseillée..
grub-install : erreur : refus de continuer avec les listes de blocs.
eliot3@eliot3-Aspire-5733:~$ sudo grub-install /dev/sda6
Installation pour la plate-forme i386-pc.
grub-install : attention : Le système de fichiers « ext2 » ne prend pas en charge l'embarquage.
grub-install : attention : L'embarquage est impossible. GRUB ne peut être installé sur cette configuration qu'en utilisant les listes de blocs. Cependant, les listes de blocs ne sont PAS fiables et leur utilisation est déconseillée..
grub-install : erreur : refus de continuer avec les listes de blocs.
eliot3@eliot3-Aspire-5733:~$

m_n
 Posté le 04/12/2018 à 15:54 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Excuse-moi ... redemarre et boot sur Xubuntu ou Kubuntu

et fait :

sudo grub-install /dev/sda

sudo update-grub

=================================

ou fait le sur ta Cinnamon ..



Modifié par m_n le 04/12/2018 17:47
eliot3
 Posté le 04/12/2018 à 16:21 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Je vais remettre l'image car je n'ai plus rien qui s'affiche mais avant j'essaie Rescatux



Modifié par eliot3 le 04/12/2018 16:23
Publicité
eliot3
 Posté le 04/12/2018 à 16:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Impeccable avec Rescatux, je vais relancer pour voir si c'est mieux

Bon un peu mieux mais plus aussi rapide qu'avant



Modifié par eliot3 le 04/12/2018 16:29
Slyvester
 Posté le 04/12/2018 à 17:18 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonsoir Eliot3n

Bon un peu mieux mais plus aussi rapide qu'avant

Pour être rassuré quant à la lenteur du démarrage de ta Debian sur la partition /dev/sda8, compare les valeurs UUID de la partition Debian /dev/sda8 et celle du fichier /etc/fstab, tout comme tu l'avais très bien fait pour ta Linux Mint 19 Cinnamon.
Pour rappel, ces deux valeurs doivent être identiques, faute de quoi, tu as ou auras un retard au boot/démarrage de ta Debian d'au moins 1 minute 30'.
Regarde ici : https://forum.pcastuces.com/apres_crash_du_disque_changement_par_un_ssd_et_test_avec_clonezilla-f8s15865.htm

Les deux formules à utiliser en terminal : sudo blkid + sudo gedit /etc/fstab. Une différence de valeur UUID entre ces deux valeurs pourraît déterminer l'origine du phénomène de lenteur au démarrage. On ne sait jamais .. Je reste toutefois surpris du fait que tu sembles dire que cela ne se produisait pas avant l'application des mises-à-jour (?).



Modifié par Slyvester le 04/12/2018 17:20
eliot3
 Posté le 04/12/2018 à 17:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Oui c'est venu après la mise à jour qui ne s'était pas bien passé la première fois.

root@Eliot3:/home/eliot3# sudo blkid
/dev/sda1: LABEL="RM-CM-)servM-CM-) au systM-CM-(me" UUID="9EB2ACCDB2ACAAEB" TYPE="ntfs" PARTUUID="fb088cfc-01"
/dev/sda2: LABEL="Windows 10" UUID="A616B22D16B1FE7D" TYPE="ntfs" PARTUUID="fb088cfc-02"
/dev/sda3: LABEL="WinPe" UUID="01D487E692BCC6A0" TYPE="ntfs" PARTUUID="fb088cfc-03"
/dev/sda5: LABEL="Linux Mint 19" UUID="7f19fb7b-2568-4401-a4ae-09152183ffc6" TYPE="ext4" PARTUUID="fb088cfc-05"
/dev/sda6: LABEL="Xubuntu" UUID="ee737c45-184a-4156-b380-5395ae1833d5" TYPE="ext4" PARTUUID="fb088cfc-06"
/dev/sda7: LABEL="Kubuntu" UUID="a1f76692-4095-4c9e-a0ac-014a918ed5bb" TYPE="ext2" PARTUUID="fb088cfc-07"
/dev/sda8: LABEL="Debian 9 Cinamon" UUID="116d7afe-f588-42a1-8e3e-96104a496348" TYPE="ext4" PARTUUID="fb088cfc-08"
/dev/sda9: UUID="23fd3ad2-e64a-487f-9c8a-5d27cbe65a68" TYPE="swap" PARTUUID="fb088cfc-09"

.../...

/etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sda8 during installation
UUID=116d7afe-f588-42a1-8e3e-96104a496348 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda9 during installation
UUID=23fd3ad2-e64a-487f-9c8a-5d27cbe65a68 none swap sw 0 0
/dev/sr0 /media/cdrom0 udf,iso9660 user,noauto 0 0

Si ça te parle.

m_n
 Posté le 04/12/2018 à 17:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

eliot3 a écrit :

Impeccable avec Rescatux, je vais relancer pour voir si c'est mieux

Bon un peu mieux mais plus aussi rapide qu'avant

Hum .. refaire une installation de la meme distro sur la meme partition .. --> Faut quel sois vraiement bien formatter avec GParted avant l'install ..

car les memes defaults re-apparaisse quelques-fois ..

moi, je formatte la partition en ( ntfs ) et en ( ext2 ) et pour finir en ( ext4 ) .. -> pour que la partiion sois vraiement bien formatté ..

Combien de temps prend-t-il maintenant a apparaitre ( Grub ) ?



Modifié par m_n le 04/12/2018 17:53
eliot3
 Posté le 04/12/2018 à 17:42 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Plus d'une minute et demi alors qu'en 5 secondes avant.

C'est pas la mort mais je trouve bizarre quand même.

m_n
 Posté le 04/12/2018 à 17:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

m_n a écrit :

Excuse-moi ... redemarre et boot sur Xubuntu ou Kubuntu

et fait :

sudo grub-install /dev/sda

sudo update-grub

=================================

ou fait le sur ta Cinnamon ..

Si cela ne fonctionne pas .. --> Refait ton install en formattant ta partition avec Gparted avant

comme je l'ai cité plus haut :

Hum .. refaire une installation de la meme distro sur la meme partition .. --> Faut quel sois vraiement bien formatter avec GParted avant l'install ..

car les memes defaults re-apparaisse quelques-fois ..

moi, je formatte la partition en ( ntfs ) et en ( ext2 ) et pour finir en ( ext4 ) .. -> pour que la partiion sois vraiement bien formatté ..



Modifié par m_n le 04/12/2018 17:56
eliot3
 Posté le 04/12/2018 à 17:54 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Je verrais cela demain.

Bonne soirée.

Sil33
 Posté le 04/12/2018 à 18:24 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir.

A chaque fois que j'ai eu ce problème (je suis en dual boot), cela provenait du fstab où les UUID étaient mal déclarés. Lorsque j'installais une autre distribution sur une des 2 partitions, par exemple.

Je ne peux te suggérer que, comme proposé plus haut, de lancer une commande sudo blkid, de comparer avec ton fstab fourni et de modifier au besoin.

Sinon, je ne vois pas sur le moment.

Publicité
eliot3
 Posté le 04/12/2018 à 18:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien
Sil33 a écrit :

Bonsoir.

A chaque fois que j'ai eu ce problème (je suis en dual boot), cela provenait du fstab où les UUID étaient mal déclarés. Lorsque j'installais une autre distribution sur une des 2 partitions, par exemple.

Je ne peux te suggérer que, comme proposé plus haut, de lancer une commande sudo blkid, de comparer avec ton fstab fourni et de modifier au besoin.

Sinon, je ne vois pas sur le moment.

Les résultats sont mis un peu plus haut dans les réponses.

Slyvester
 Posté le 05/12/2018 à 09:25 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

Je souffre du même problème que notre ami Eliot3 que je souhaitais aider, et cela précisément aujourd'hui alors que je me prépare à partir à l'étranger. J'ai effectué des mises à jour sur ma distro wattOS qui en a profité pour installer le Grub sur sa partition.
J'ai voulu - comme je le fais toujours - réinstaller le Grub sur une partition/distribution stable et fiable (Ubunut 18.04 LTS) en saisissant la commande : sudo grub-install /dev/sda8

Et là, mauvaise surprise sur le terminal :

slyvester@slyvester-desktop:~$ sudo grub-install /dev/sda8
Installation pour la plate-forme i386-pc.
grub-install : attention : Le système de fichiers « ext2 » ne prend pas en charge l'embarquage.
grub-install : attention : L'embarquage est impossible. GRUB ne peut être installé sur cette configuration qu'en utilisant les listes de blocs. Cependant, les listes de blocs ne sont PAS fiables et leur utilisation est déconseillée..
grub-install : erreur : refus de continuer avec les listes de blocs.

Ce message reste incompréhensible, surtout que toutes mes partitions Linux sont formatées en .ext4 ! Il ne me reste plus qu'à arpenter les forums pour y découvrir l'origine du problème ...

P.S. c'est la première fois - en presque dix ans d'utilisation de Linux - que je suis confronté à ce problème/message ! Ceci ne doit pas être considéré comme une demande d'aide mais comme une information. Mon but n'est pas de squatter le sujet d'Eliot3.



Modifié par Slyvester le 05/12/2018 09:30
Slyvester
 Posté le 05/12/2018 à 10:00 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Re,

Eurêka ! La formule proposée par m_n et que j'ai trop rapidement appliquée est erronée. Pour installer le Grub sur une partition ou distribution déterminée, il faut ouvrir la distribution choisie (dans mon cas Ubuntu 18.04 LTS = /dev/sda8). Ensuite, ouvrir un terminal via Ctrl + Alt + T et saisir la commande suivante :

sudo grub-install /dev/sda

On peut également utiliser cette commande (plus incisive ! ) :

sudo grub-install --force /dev/sda (et cela sans préciser le n° de partition !)

!! : Il est toujours nécessaire en cas de modification du Grub d'utiliser ensuite la commande : sudo update-grub

Preuve de l'installation de mon Grub sur /dev/sda8 (copie du terminal):

slyvester@slyvester-desktop:~$ sudo grub-install /dev/sda
Installation pour la plate-forme i386-pc.
Installation terminée, sans erreur.

En espérant que cela puisse t'aider, Eliot3 !



Modifié par Slyvester le 05/12/2018 10:01
eliot3
 Posté le 05/12/2018 à 10:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Pas de souci, j'ai réinstallé la Debian et là il m'installe le Grub, mais je trouve que c'est très long updapte-grub reste pour l'instant à 66%

Croisons les doigts



Modifié par eliot3 le 05/12/2018 10:05
eliot3
 Posté le 05/12/2018 à 10:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Bon je vais redescendre l'image car impossible de terminer l'update-grub

C'est parti. J'aurai appris à redescendre une image avec CloneZilla au moins

A suivre .../...

Si vous ne me voyez plus, c'est que j'aurai cassé ma machine



Modifié par eliot3 le 05/12/2018 11:14
eliot3
 Posté le 05/12/2018 à 12:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Le disque est passé en Raw, j'ai lancé CloneZilla pour restaurer le disque avec les options de Vérifications et Réparations. Il me reste 3 H 30 avant la fin de la restauration

eliot3
 Posté le 05/12/2018 à 16:17 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Après 4 Heures pour redescendre l'image, cela s'est soldé par un échec et donc je repars à Zéro

eliot3
 Posté le 05/12/2018 à 19:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Voilà, presque tout réinstallé, il me reste à mettre Kubuntu et Debian

Publicité
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Debian Wheezy : Echec des mises à jour
debian 9 ( mises a jours )
Mint mate mises à jour non précochées
frequence des mises a jour (demande d avis )
À propos des mise-à-jours de sécurité sous Debian
Barre des tâches:impossible actualiser la liste des mises à jour.
Mise à jour de ma Debian Wheezy vers Jessie
mises a jour opensuze
Carte wifi plus reconnue après mise à jour Debian Testing
Besoin de conseils pour mise à jour Debian Testing
Plus de sujets relatifs à Debian 9 et les Mises à jour Sécurité !!!
 > Tous les forums > Forum Linux