> Tous les forums > Forum Linux
 Debian - Iceweasel - Disposer de Flash Player 17 (avec Pipelight)Sujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
fiche
  Posté le 28/12/2014 @ 16:41 
Aller en bas de la page 
Astucien

Bonjour,

Quelle que soit la distribution Linux, sous Firefox-Iceweasel, le plugin Flashplayer n'est plus mis à jour (hors correction de failles de sécurité) et reste donc bloqué en version 11.2.202...

Suite à ce sujet général sur Debian (https://forum.pcastuces.com/debian_et_derivees___questions_diverses-f8s14369.htm?page=3), j'ai tenté l'installation de la dernière version de Adobe Flash Player (malheureusement indispensable pour certains sites tels M6Replay...) à partir des informations sur ce site : (http://pipelight.net/cms/install/installation-debian.html).

Voici la marche à suivre :

Pour la version Debian Testing XFCE "pure" : (future jessie au moment de la rédaction du message)

* Dans le terminal, taper ces commandes :
wget http://repos.fds-team.de/Release.key
sudo apt-key add Release.key

* Vérifier que dans la liste des dépôts, "contrib" soit bien mentionné : éditer le fichier sources.list ou avec le gestionnaire Synaptic, aller dans Configuration - Dépôts (ex : http://ftp.fr.debian.org/debian/ testing non-free contrib main)

* Ajouter un nouveau dépôt (je l'ai fait par Synaptic mais on peut le faire directement dans le fichier sources.list) :

URL : http://repos.fds-team.de/stable/debian/
Distribution : jessie
Catégorie(s) : main

* Mettre à jour les paquets puis installer pipelight (qui permet d'installer des plugins de navigateur prévus sous Windows) en tapant ces commandes dans le terminal :

sudo apt-get update
sudo apt-get install pipelight-multi
sudo pipelight-plugin --update

* Installer la dernière version de Flash Player 17 :

sudo pipelight-plugin --enable flash

* Désinstaller la version 11 de Flash Player (si elle était déjà installée) : je l'ai fait à partir de Synaptic en faisant une recherche sur le mot flashplugin puis en cliquant sur flashplugin-nonfree et en choisissant "Sélectionner pour suppression complète" et valider avec le bouton "Appliquer".

* Afficher Flashplayer dans les plugins :

sudo pipelight-plugin --create-mozilla-plugins

* Relancer Iceweasel-Firefox : le plugin Flash Player 17 apparait désormais dans le menu Outils - Modules Complémentaires - Plugins.

Vérifier que le plugin est activé.

Sur mon PC 32 bits, Debian Testing "pure" XFCE, l'accès à M6Replay fonctionne désormais.

**************

Pour la version Debian Stable XFCE "Handylinux" : (wheezy)

Dans le terminal, taper ces commandes :

wget http://download.opensuse.org/repositories/home:/DarkPlayer:/Pipelight/Debian_7.0/Release.key
sudo apt-key add Release.key

Vérifier que dans la liste des dépôts, "contrib" soit bien mentionné : éditer le fichier sources.list ou avec le gestionnaire Synaptic, aller dans Configuration - Dépôts (ex : http://ftp.fr.debian.org/debian/ wheezy non-free contrib main)

Ajouter un nouveau dépôt (je l'ai fait par Synaptic mais on peut le faire directement dans le fichier sources.list) :

URL : http://download.opensuse.org/repositories/home:/DarkPlayer:/Pipelight/Debian_7.0/
Distribution : ./
Catégorie(s) :

Mettre à jour les paquets puis installer pipelight (qui permet d'installer des plugins de navigateur prévus sous Windows) en tapant ces commandes dans le terminal :

sudo apt-get update
sudo apt-get install pipelight-multi
sudo pipelight-plugin --update

Installer la dernière version de Flash Player 17 : sudo pipelight-plugin --enable flash

Désinstaller la version 11 de Flash Player (si elle était déjà installée) : je l'ai fait à partir de Synaptic en faisant une recherche sur le mot flashplugin puis en cliquant sur flashplugin-nonfree et en choisissant "Sélectionner pour suppression complète" et valider avec le bouton "Appliquer".

Relancer Iceweasel-Firefox : le plugin Flash Player 17 apparait désormais dans le menu Outils - Modules Complémentaires - Plugins.

Vérifier que le plugin est activé.

-------------------

J'avais préalablement essayé avec le plugin Silverlight mais cela ne fonctionnait pas (par contre, je ne sais pas comment le retirer de la liste des plugins de Iceweasel).

-------------------


Il ne me restera plus qu'à voir ce que donne le couple Greasemonkey + Viewtube sur Debian stable 32 bits Handylinux.



Modifié par fiche le 13/06/2015 19:21
Publicité
reivillo
 Posté le 28/12/2014 à 20:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonsoir fiche.

J'avais préalablement essayé avec le plugin Silverlight mais cela ne fonctionnait pas
(par contre,je ne sais pas comment le retirer de la liste des plugins de Iceweasel).

Peut-être dans ton Dossier Personnel, et Dossiers Cachés < .mozilla/plugins >,
si il s'y trouve, voir aussi si il n'est pas accompagné d'un autre Fichier.
Et tu Enlève ou plutôt Renomme avant, pour Tester.

Reivillo.



Modifié par reivillo le 28/12/2014 20:49
reivillo
 Posté le 31/12/2014 à 23:08 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Alors fiche...

Un ch'it RETOUR, s'rai sympa...NON?

Merci pour Tous.

Slyvester
 Posté le 01/01/2015 à 11:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonne année à tous & toutes,

Fiche a écrit : " ... Grâce à vous, je vais pouvoir essayer Viewtube (http://isebaro.com/viewtube/?ln=fr) et peut-être me passer de Adobe Flashplayer pour 99% des sites internet. Verdict en fin de semaine ! ... " : https://forum.pcastuces.com/debian_et_derivees___questions_diverses-f8s14369.htm?page=4

Fiche, faut-il en déduire que ton essai de ViewTube n'a pas été fructueux ?

fiche
 Posté le 01/01/2015 à 12:05 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour à tous,

Le 1er retour, c'est que Pipelight permet de disposer de la dernière version de Flashplayer et donc qu'il n'y a plus de problèmes sur certains sites (avec des DRM...).

C'est déjà un grand pas car cette histoire de flashplayer non mis à jour par défaut pour linux pose tout de même des soucis sur quelques sites et peut freiner les utilisateurs de Windows à franchir le pas.

Désormais, je pourrais proposer Pipelight.

----------------

Pour ce qui est de Greasemonkey+Viewtube, comme je ne veux pas "perturber" le nouveau plugin Flasplayer sur ma Debian testing pure, il faut que j'essaye sur Handylinux (stable).

Après avoir :

- installé l'extension Greasemonkey au navigateur Iceweasel ( https://addons.mozilla.org/fr/firefox/addon/greasemonkey/)

- puis ajouté le script ViewTube 2014.12.17 (http://isebaro.com/viewtube/?ln=fr) et Viewtube+

- et désactivé Flashplayer

je constate que sur les sites M6replay ou Pluzz (France TV), les videos ne sont pas visibles. Les scripts en question ne doivent donc pas gérer ces sites internets.

En revanche, sur Youtube, c'est bon.

Conclusion, Viewtube ne règle pas tous les problèmes de visionnage de vidéos (pour Pluzz, par exemple, le "vieux" Flashplayer v11 est accepté mais pas Viewtube).

Il me reste à vérifier si on peut ajouter de nouvelles adresses dans les Préférences de Viewtube et leur incidence.

C'est chose faite ce soir en ajoutant http://pluzz.francetv.fr/* dans les Préférences - Paramètres de l'utilisateur" mais cela ne change rien, les videos ne se lancent pas.



Modifié par fiche le 01/01/2015 18:46
m_n
 Posté le 02/01/2015 à 00:17 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

petite question :

as-tu d'installé ( flashplugin non-free ) dans synaptic ..

car moi, je n'est jamais eu de problèmes pour lire des vidéo sur quel que sois le site ..



Modifié par m_n le 03/01/2015 23:11
Slyvester
 Posté le 02/01/2015 à 11:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour m_n,

Amusant, mais si j'essaye d'installer - via Synaptic - le module complémentaire :"flashplugin non-free extra 0.0.svn2431-3" sur ma Linux Mint Debian Edition, Synaptic me propose d'abord la désinstallation de "mint-flashplugin" ainsi que celle de "flashplugin-non free" ...

Je dois essayer ce qui précède sur ma "Watt OS R8" (= basée sur Debian stable) ainsi que sur ma "SparkyLinux" (basée sur Debian testing). Entre-nous, des bombes ces deux distributions Linux dérivées de Debian.

En tout cas, chapeau à Fiche pour les explications claires, précises et bien détaillées !



Modifié par Slyvester le 03/01/2015 12:17
fiche
 Posté le 02/01/2015 à 20:21 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonsoir,

Flashplugin-nonfree est bien installé mais seule la version 11 est active.

Dans la grande majorité des cas, cette version 11 obsolète suffit. Mais parfois (site M6replay avec DRM par exemple), cette ancienne version n'est pas fonctionnelle.

A priori, Viewtube peut remplacer Flashplayer 11 (tout en étant moins gourmand en ressources d'après ce que j'ai lu) mais ne semble pas plus doué pour les sites avec DRM.

En conclusion, seul Pipelight (qui utilise Wine) permet de disposer de la toute dernière version de FlashPlayer (16) sous Linux, et donc d'éviter les quelques problèmes rencontrés.

Dans la mesure du possible, j'essaye d'être clair dans mes explications car cela permet aux nuls comme moi d'apprendre et de tester ce Linux qui parfois m'agace considérablement. Je progresse tout doucement

fiche
 Posté le 03/01/2015 à 20:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonsoir,

J'ai mis à jour le 1er message pour présenter les différentes étapes, à la fois pour Debian Testing et pour Debian Stable.

Publicité
fiche
 Posté le 07/05/2015 à 10:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

Je réactive ce sujet car Pipelight qui fonctionnait en janvier sur ma version stable Handylinux (Debian Wheezy) et sur la version Testing à l'époque (Jessie) ne fonctionne plus sur la dernière version stable Handylinux 2 beta (Debian Jessie).

J'ai beau suivre les instructions à la lettre (http://pipelight.net/cms/install/installation-debian.html), je n'ai pas de message d'erreur et à la fin, après la commande "sudo pipelight-plugin --enable flash", le terminal me renvoie bien un "flash enabled" mais flashplayer reste absent des plugins du navigateur Iceweasel !

Je précise qu'avant toutes ces manipulations, j'avais désinstallé plashplugin non free à partir de Synaptic pour éviter toute confusion.

Si quelqu'un à une idée...

amarie
 Posté le 07/05/2015 à 20:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

soir fiche,

Je ne peux pas répondre malheureusement à ta question, parce même si j'ai debian et icewiseal, je ne dispose pas du plugin Flash Player.

En recherchant les plugings actuels, j'ai gnash.

et pour l'installer :

session root :

lancer la commande aptitude

> aptitude

l'aplication démarre et affiche une fenêtre.

Il faut faire ensuite une recherche sur "gnash" avec :

> \

> gnash

(puis entrée)

ensuite, aller dans l'onglet "action" et sélectionner "mettre à jour"

laisser faire l'apli aptitude.

puis quitter :

> q.

Je ne sais pas si ceci pourrait t'aider malgré tout pour flash player.

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Créer une clé USB multiboot (sous Debian) avec/sans UEFI
Debian échanger des fichiers avec mon smartphone samsung galaxy
Mes débuts sous Debian.... Problèmes avec KDE
La prochaine Debian stable s'initialisera avec Systemd
jeu demandant adobe flash player- quelle version 10.04 LTS ??
Funtoo/GNU/Linux avec Debian-sources binaire
flash player ubuntu 12.04
Adobe Flash Player ralenti sous Ubuntu ...
problème driver reseau intel avec debian 5
Flash player sous ubuntu 10.04
Plus de sujets relatifs à Debian - Iceweasel - Disposer de Flash Player 17 (avec Pipelight)
 > Tous les forums > Forum Linux