> Tous les forums > Forum Linux
 Debian Edu sur PC: écran noir juste avant le login
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Gidaz
  Posté le 27/12/2010 @ 22:32 
Aller en bas de la page 
Nouvel astucien

Bonjour

Je viens d'installer DebianEdu 5.0.6 sur un vieux PC (portable DELL, PIII, 256 Mo RAM, 20 Go HDD) pour que ma fille puisse commencer à s'exercer. Ca marche plutôt bien, sauf au démarrage: ça boote normalement, ensuite Debian prend la main (apparition d'une image de l'éclairage nocturne de la terre), puis écran noir et disparition de toute activité du disque dur (la LED reste éteinte). Ca peut rester dans cet état assez longtemps (a priori sans limite, mais je n'ai pas été patient au delà de quelques minutes). Pour reprendre normalement le démarrage, il suffit d'appuyer sur Ctrl-C et j'arrive alors au login en environ 5 secondes. Et ensuite, 0 soucis.

Mes cours d'Unix datent d'un peu loin (1992), à l'époque Linux en était à ses balbutiements, alors si quelqu'un pouvait me dire par où commencer et par quel bout prendre le problème, je lui en serais reconnaissant...

Gidaz

Publicité
Mori
 Posté le 27/12/2010 à 23:21 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

il n'était pas en train de faire une vérification du montage des partitions ext* par hasard ?

Gidaz
 Posté le 28/12/2010 à 00:00 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

Ben j'en sais rien (malheureusement). Comment savoir si c'est bien cela qui se passe ?

C'est quand même pas un peu long pour une vérification de montage de partitions ??

Logicien
 Posté le 28/12/2010 à 06:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Allo,

pour qu'il y ait vérification du système de fichiers, il faut qu'il y ait eu plantage, arrêt à la sauvage (reset, coupure de courant, etc), tout arrêt ou démarrage anormal ou que le système Linux ait été monté plusieurs fois pour qu'une vérification automatique doive se faire. Le nombre de montages croît avec la taille de la ou des partitions, 15 minutes est suffisant.

Si tout est normal et que ça fait ça à chaque fois, le problème est ailleurs. Il faut que tu presses sur la touche Escape quand l'Image s'affiche pour voir quel processus ne se termine pas et oblige Ctrl+c afin de l'arrêter.

Sous Debian, il faut que les scripts de démarrage soient bien configurés ou désactivés si possible, sinon certains processus peuvent s'éterniser. Puisque tu arrives à l'invite de commandes, c'est que le démarrage se termine tout de même. En regardant derrière l'image tu auras des informations pertinentes sur les dernières lignes affichées à la console. Ce sont elles éventuellement qui t'en diront le plus sur le ou les processus qui ne rendent pas la main.

/etc/rc.local est le dernier script exécuté avant la fin du démarrage. Il est le plus souvent vide après l'installation, mais un coup d'oeil te permettra de le vérifier.



Modifié par Logicien le 28/12/2010 07:06
Gidaz
 Posté le 28/12/2010 à 10:10 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

Bonjour

J'ai beau échapper frénétiquement, ça ne change rien au film. En revanche, j'ai fait

dmesg > toto.tmp

en me ménageant un temps d'attente suffisant pour identifier clairement le moment où tout se fige, et j'ai ainsi lu:

[ 26.397243] Adding 499704k swap on /dev/mapper/vg_system-swap_1. Priority:-1 extents:1 across:499704k
[ 108.119328] NET: Registered protocol family 10

Quand Debian s'est installé, j'ai sélectionné le partitionnement par défaut et à ma grande surprise, si je regarde sous cfdisk le résultat, il n'y a pas de partition de swap. Je vais donc faire un partitionnement à la mimine, une nouvelle installation, et j'espère que ça se passera mieux.

Sinon, autre petite surprise: ce PC est raccordé à Internet via une box. Mon fichier /etc/network/interfaces m'a l'air correct:

# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
# This file was created by debian-edu-profile during the Debian installation

# The loopback interface
auto lo
iface lo inet loopback

#allow-hotplug eth0
#iface eth0 inet dhcp

#allow-hotplug eth1
#iface eth1 inet dhcp

#auto lo eth0
iface eth0 inet static
address 192.168.1.50
netmask 255.255.255.0
broadcast 192.168.1.255
network 192.168.1.0
gateway 192.168.1.1
dns-nameservers 192.168.1.1

Mais après le démarrage, ping avec une adresse physique me renvoie "Network is unreachable". Mais si je lance ifup eth0, tout marche correctement (en adresse physique ou en adresse "alphabétique" donc en passant par le DNS). Je ne pense donc pas avoir d'erreur de syntaxe ni d'erreur fonctionnelle dans mon fichier, mais pourquoi ne se lance-t-il pas tout seul dès le démarrage ??

Mimile
 Posté le 28/12/2010 à 14:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

SAlut

J'ignore quel interface graphique tu utilises mais si c'est KDE, tu peux aller dans le centre de configuration de KDe > paramètres réseau > passer en mode SU (il y a un bouton pour ça) et vérifier que la case "activer au démarrage de l'ordinateur" est bien cochée :

Je connais mal Gnome mais je suppose que cette option doit exister quelque part dans les options de configuration de la connexion.

Amicalement,

EDIT : en ce qui concerne la durée anormale du boot, j'ai remarqué que sous Linux Mint, tous les x boots (15 je crois), il y avait une vérification du système de fichier de chacune des deux partitions (racine et home).

Comme elles font chacune environ 6 Go, cela dure assez longtemps (environ 2 à 3 minutes par partition) mais on ne s'en inquiète pas car il y a un affichage de la progression de l'opération exprimée en %.

Sans cet affichage, on serait vite amené à croire que quelque chose coince.

On peut toutefois omettre cette vérification avec la touche ESC qui, apparemment chez toi, ne donne rien ; mais bon, Linux Mint n'est pas Debian et c'est apparemment l'association ctrl + c qui tient lieu d'ESC.



Modifié par Mimile le 28/12/2010 16:43
Logicien
 Posté le 28/12/2010 à 17:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

D'après ce que je comprend, Debian te crée un fichier swap de près de 500 mo, où? Possiblement dans une partition Windows si tu en as une. Si tu as beaucoup de mémoire vive, la partition ou le fichier d'échange est très peu utilisé. Il faut activer le démarrage auto pour ta carte réseau. Change ceci dans ton fichier /etc/network/interfaces:

auto lo eth0

# The loopback interface
iface lo inet loopback

#allow-hotplug eth0
#iface eth0 inet dhcp

#allow-hotplug eth1
#iface eth1 inet dhcp

iface eth0 inet static
address 192.168.1.50
netmask 255.255.255.0
broadcast 192.168.1.255
network 192.168.1.0
gateway 192.168.1.1
dns-nameservers 192.168.1.1



Modifié par Logicien le 28/12/2010 17:50
Gidaz
 Posté le 28/12/2010 à 19:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

Bonjour

Merci à tous

Pour l'histoire du swap : après avoir regardé de plus près, je me suis rendu compte qu'il y a bien une partition de swap, mais incluse dans une partition LVM.

En tapant swapon -s, ça me répond

Filename Type Size Used Priority

/dev/mapper/vg_system-swap_1 partition 499701 1104 -1

A première vue, ça ne me paraît pas délirant (d'autant qu'il y a 1104 Ko utilisés), mais je m'inquiète de la priorité -1. Ca correspond certes à la commande lue dans dmesg, mais les pages man swapon définissent les priorités de 0 à 32767...

Au fait, pour répondre à logicien, /etc/rc.local est bien vide.

Je précise que ce PC est désormais intégralement sous Linux: le précédent propriétaire était en W2000, et après 5 ans de stockage dans son garage, il avait oublié le mot de passe. Ca n'a pas été trop dur de me décider à dégager entièrement Windows. . Le boot longuet est répétitif à 100% à chaque démarrage. Peut-être faudrait-il que je laisse mouliner tranquillement 10 minutes (20 Go sur le disque, dont 10 seulement adressés par les partitions LVM).

Mimile, je ne dois pas avoir la bonne version de KDE, je n'ai en tout cas pas été foutu de trouver l'onglet de config des périphériques réseau.

A bientôt sans doute !

Logicien
 Posté le 28/12/2010 à 20:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Pour la priorité de la partition ou du fichier d'échange, les valeurs comprises entre 0 et 32767 n'ont de sens que pour prioriser une partition ou un fichier d'échange par rapport à d'autres partitions ou fichiers d'échanges. Quand on n'en a qu'une seule, toute la priorité lui est accordée et la valeur -1 doit permettre de ne pas prendre en compte la priorité de partition ou un fichier d'échange que swapon doit monter. Par défaut, je pense que toutes les partitions et fichiers d'échanges sont montés avec la même priorité. Pour modifier la priorité, il faut éditer /etc/fstab ou la préciser lors de l'activation manuelle.

Gidaz, regarde mon message précédent et la modification proposée à ton /etc/network/interfaces pour l'activation automatique de eth0 au démarrage. Cela peut aussi résoudre d'autres problèmes, par exemple avec Samba ou Bind et autes serveurs qui ne peuvent démarrer sans réseau activé. Toutefois, le loopback lo est supposé être suffisant tout en étant indispensable comme configuration réseau.



Modifié par Logicien le 29/12/2010 01:26
Publicité
Mimile
 Posté le 28/12/2010 à 22:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Mon cher Paul,

Je crois que je vais m'abstenir d'encore chercher à intervenir sur le forum Linux ...

L'étendue de tes connaissances me démontre l'étendue de mes ignorances ...

Je vais donc me contenter d'essayer d'en assimiler quelques parcelles ... (je parle de tes connaissances, évidemment )

Respect

Cordialement

EDIT : À l'intention de Gidaz :

puis :

(clic pour agrandir)



Modifié par Mimile le 28/12/2010 22:44
Logicien
 Posté le 29/12/2010 à 01:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Sérieusement Mimile, si tu t'abstiens d'intervenir, ce ne sera pas une bonne chose pour le forum Linux. Tous ont le droit d'intervenir. Je pense que j'aurais intérêt à ralentir quelque peu. Cela pourrait permettre à d'autres d'intervenir plus souvent.



Modifié par Logicien le 29/12/2010 01:38
Mimile
 Posté le 29/12/2010 à 22:52 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Je pense que j'aurais intérêt à ralentir quelque peu

Surtout pas, Paul ...

Nous serions comme des aveugles perdus dans une nuit sans lumière ...

Bon, là, j'exagère mais il n'en est pas moins vrai que tes interventions me montrent le plus souvent à quel point mes connaissances sont limitées.

A ma décharge, je préciserai que ma formation de base n'a rigoureusement rien à voir avec l'informatique (et surtout pas avec Linux), ce qui - ceci dit en toute modestie - ne m'a pas empêché de rédiger les 300 (environ) programmes qui font tourner mon bureau (écrits en DB/C DX 12 appris sur le tas - voir ici) et dont le plus important compte plus de 7000 lignes de code).

Chacune de tes réponses m'en apprend un peu plus et je m'en voudrais que mon précédent message t'incite à réfréner tes interventions.

Cordialement,

Gidaz
 Posté le 30/12/2010 à 12:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

Bonjour à tous

Un peu de délai pour cause de visite familiale, retour à minuit, tour de cadran de ma fille, ...

Bref:

@logicien : ta modification de /etc/network/interfaces est la bonne, merci !

@mimile: j'ai KDE 3.5.10. Le sous-menu que tu m'indiques n'est pas présent. Mais comme la solution de logicien marche, c'est pas très grave.

@tous : le problème de démarrage interminable est toujours présent. J'ai allumé le PC et l'ai laissé se débrouiller tout seul un certain temps (1300 secondes environ, donc un peu de plus 20 minutes), ci-dessous extrait de dmesg. Le souci n'est peut-être pas lié au swap...

[ 25.059627] EXT3 FS on dm-0, internal journal
[ 25.228428] loop: module loaded
[ 26.187167] kjournald starting. Commit interval 5 seconds
[ 26.187363] EXT3 FS on hda1, internal journal
[ 26.187372] EXT3-fs: mounted filesystem with ordered data mode.
[ 26.216128] kjournald starting. Commit interval 5 seconds
[ 26.220321] EXT3 FS on dm-1, internal journal
[ 26.220328] EXT3-fs: mounted filesystem with ordered data mode.
[ 26.669653] Adding 499704k swap on /dev/mapper/vg_system-swap_1. Priority:-1 extents:1 across:499704k
[ 30.715339] eth0: setting full-duplex.
[ 31.464842] NET: Registered protocol family 10
[ 31.465778] lo: Disabled Privacy Extensions
[ 42.244138] eth0: no IPv6 routers present
[ 1389.812625] Bluetooth: Core ver 2.11
[ 1389.814732] NET: Registered protocol family 31
[ 1389.814739] Bluetooth: HCI device and connection manager initialized
[ 1389.814746] Bluetooth: HCI socket layer initialized
[ 1389.834514] Bluetooth: L2CAP ver 2.9
[ 1389.834521] Bluetooth: L2CAP socket layer initialized
[ 1389.928196] Bluetooth: RFCOMM socket layer initialized
[ 1389.928223] Bluetooth: RFCOMM TTY layer initialized
[ 1389.928228] Bluetooth: RFCOMM ver 1.8
[ 1393.934936] lp0: using parport0 (interrupt-driven).
[ 1394.084759] ppdev: user-space parallel port driver
[ 1395.033242] [drm] Initialized drm 1.1.0 20060810
[ 1395.113940] ACPI: PCI Interrupt 0000:01:00.0[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 11

Je suis toujours preneur de bonnes idées de bonnes âmes . Le PC n'a aucune chance de disposer de Bluetooth, mais si c'était cela qui bloquait, on devrait plutôt voir apparaître cela avant la pause de 1200s ?

Gidaz



Modifié par Gidaz le 30/12/2010 13:56
Logicien
 Posté le 30/12/2010 à 22:52 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Dis-moi, est-ce que l'invite de connexion dont tu parles est en noir et blanc dans un terminal caractères ou elle est graphique? J'aimerais savoir si l'interface graphique est démarrée avec le système. Si tu fais la commande

runlevel

quel chiffre cela donne-il? En fonction de cette réponse ils faudrait regarder quels scripts sont exécutés en dernier dans ce niveau d'exécution.

ls /etc/rc?.d

ou tu remplaces le ? par le numéro affiché par runlevel. Si tu fais Ctrl+Alt+F1 après avoir fait Ctrl+c vois-tu les messages de démarrage du système sur la console?

Il faudrait aussi investiguer les fichiers de log du système dans leurs dernières lignes à la fin du démarrage. Cela peut dire ce qui bloque. En root, essai les commandes

tail /var/log/boot

tail /var/log/daemon.log

tail /var/log/dmesg

tail /var/log/kern.log

tail /var/log/messages

tail /var/log/syslog

tail /var/log/Xorg.0.log



Modifié par Logicien le 30/12/2010 22:54
Gidaz
 Posté le 07/01/2011 à 08:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

Désolé pour le retard, mais on y arrive.. Si je reprends le dernier message de logicien:

Dis-moi, est-ce que l'invite de connexion dont tu parles est en noir et blanc dans un terminal caractères ou elle est graphique? J'aimerais savoir si l'interface graphique est démarrée avec le système.

>> invite graphique

Si tu fais la commande

runlevel

quel chiffre cela donne-il?

>> N 2

En fonction de cette réponse ils faudrait regarder quels scripts sont exécutés en dernier dans ce niveau d'exécution.

ls /etc/rc?.d

ou tu remplaces le ? par le numéro affiché par runlevel.

README
S01acpi-support
S01cfengine2
S01jackd
S01loadcpufreq
S01nscd
S01rc.local
S01sysfsutils
S01timidity
S01update-hostname
S01vbesave
S02cpufrequtils
S02rsyslog
S02stop-bootlogd
S03acpid
S03anacron
S03apmd
S03cron
S03dbus
S03enable-nat
S03fetch-ldap-cert
S03hddtemp
S03open-backdoor
S03report-reboot
S03rsync
S03start-wlan
S03xfs
S04avahi-daemon
S04bluetooth
S04dhcdbd
S04hal
S04kdm
S04network-manager-dispatcher
S05cups
S05network-manager
S05saned
S06rmnologin
S06stop-readahead
S06usplash
S06xdebian-edu-firstboot

Si tu fais Ctrl+Alt+F1 après avoir fait Ctrl+c vois-tu les messages de démarrage du système sur la console?

>> non

Il faudrait aussi investiguer les fichiers de log du système dans leurs dernières lignes à la fin du démarrage. Cela peut dire ce qui bloque. En root, essai les commandes

tail /var/log/boot

>> Nothing has been logged yet

tail /var/log/daemon.log

>> pas de réponde

tail /var/log/dmesg

>> [ 25.524947] kjournald starting. Commit interval 5 seconds
[ 25.525047] EXT3 FS on hda1, internal journal
[ 25.525047] EXT3-fs: mounted filesystem with ordered data mode.
[ 25.554302] kjournald starting. Commit interval 5 seconds
[ 25.556259] EXT3 FS on dm-1, internal journal
[ 25.556268] EXT3-fs: mounted filesystem with ordered data mode.
[ 26.007101] Adding 499704k swap on /dev/mapper/vg_system-swap_1. Priority:-1 extents:1 across:499704k
[ 29.766746] eth0: setting full-duplex.
[ 30.788324] NET: Registered protocol family 10
[ 30.789256] lo: Disabled Privacy Extensions

tail /var/log/kern.log

Jan 7 08:36:44 localhost kernel: imklog 3.18.6, log source = /proc/kmsg started.
Jan 7 08:36:44 localhost kernel: imklog 3.18.6, log source = /proc/kmsg started.

tail /var/log/messages

Jan 7 08:36:44 localhost kernel: imklog 3.18.6, log source = /proc/kmsg started.
Jan 7 08:36:44 localhost rsyslogd: [origin software="rsyslogd" swVersion="3.18.6" x-pid="2572" x-info="http://www.rsyslog.com"] restart
Jan 7 08:36:44 localhost kernel: imklog 3.18.6, log source = /proc/kmsg started.
Jan 7 08:36:44 localhost rsyslogd: [origin software="rsyslogd" swVersion="3.18.6" x-pid="2572" x-info="http://www.rsyslog.com"] restart

tail /var/log/syslog

Jan 7 08:36:44 localhost kernel: imklog 3.18.6, log source = /proc/kmsg started.
Jan 7 08:36:44 localhost rsyslogd: [origin software="rsyslogd" swVersion="3.18.6" x-pid="2572" x-info="http://www.rsyslog.com"] restart
Jan 7 08:36:44 localhost kernel: imklog 3.18.6, log source = /proc/kmsg started.
Jan 7 08:36:44 localhost rsyslogd: [origin software="rsyslogd" swVersion="3.18.6" x-pid="2572" x-info="http://www.rsyslog.com"] restart
Jan 7 08:38:23 localhost anacron[2618]: Job `cron.daily' terminated
Jan 7 08:41:33 localhost anacron[2618]: Job `cron.weekly' started
Jan 7 08:41:33 localhost anacron[4738]: Updated timestamp for job `cron.weekly' to 2011-01-07
Jan 7 08:41:39 localhost anacron[2618]: Job `cron.weekly' terminated
Jan 7 08:41:39 localhost anacron[2618]: Normal exit (2 jobs run)

tail /var/log/Xorg.0.log

(--) SynPS/2 Synaptics TouchPad auto-dev sets device to /dev/input/event2
(**) Option "Device" "/dev/input/event2"
(--) SynPS/2 Synaptics TouchPad touchpad found
(**) SynPS/2 Synaptics TouchPad: always reports core events
(II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: MOUSE)
(--) SynPS/2 Synaptics TouchPad auto-dev sets device to /dev/input/event2
(**) Option "Device" "/dev/input/event2"
(--) SynPS/2 Synaptics TouchPad touchpad found
(EE) Error compiling keymap (server-0)
(EE) XKB: Couldn't compile keymap

[ 25.524947] kjournald starting. Commit interval 5 seconds
[ 25.525047] EXT3 FS on hda1, internal journal
[ 25.525047] EXT3-fs: mounted filesystem with ordered data mode.
[ 25.554302] kjournald starting. Commit interval 5 seconds
[ 25.556259] EXT3 FS on dm-1, internal journal
[ 25.556268] EXT3-fs: mounted filesystem with ordered data mode.
[ 26.007101] Adding 499704k swap on /dev/mapper/vg_system-swap_1. Priority:-1 extents:1 across:499704k
[ 29.766746] eth0: setting full-duplex.
[ 30.788324] NET: Registered protocol family 10
[ 30.789256] lo: Disabled Privacy Extensions

Logicien
 Posté le 08/01/2011 à 19:54 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Touct que tu as affiché Gidaz dans ton dernier message me semble normal.

En relisant le premier message, ce n'est pas nécessairement à la fin du démarrage qu'un script bloque l'avancement du démarrage, ça peut être avant. Avec Debian, je n'ai pas d'image au démarrage qui cache les messages du système. Je peux donc voir ce qui ce passe et quels scripts prennent le plus de temps à s'achever. Peut-être que la commande

cat /proc/cmdline

peut dire si un paramètre active le "bootsplash" et comment le désactiver pour voir les messages du système. Je connais la touche Esc qui change l'affichage silencieux pour verbeux. Peut que c'est un script qui démarre l'image. Il faudrait le désactiver.

Tout ça pour dire que si ont veut savoir où ça bloque, il faut voir les messages de démarrage. Sinon, il faut investiguer tous les fichiers de logs dans /var/log. Ça peut être long et la réponse n'est pas certaine. Un script ou autre truc peut bloquer sans afficher de message.



Modifié par Logicien le 08/01/2011 19:58
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
drôles de choses sur bannière de login sur debian 8
demnde de login et mdp sur debian live-8.0.0
Mint 13 - Ecran noir à l'installation
démarrage de backtrack v5 ecran noir led maj clign
Ecran noir après le démarrage d' Ubuntu 11.10
Ecran noir installation ubuntu 11.04.
ecran lcd "hors fréquence" avec "debian linux"
login as root in debian
Écran noir à l'allumage sous Ubuntu 8.10
Ecran noir après mise à jour de logiciels
Plus de sujets relatifs à Debian Edu sur PC: écran noir juste avant le login
 > Tous les forums > Forum Linux