> Tous les forums > Forum Linux
 démarrage de backtrack v5 ecran noir led maj clign
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
gugus54
  Posté le 01/09/2012 @ 17:47 
Aller en bas de la page 
Petit astucien

bonjour

je fais appel à votre aide précieuse, car je viens d'installer backtrack v5 et après l'identification sous DOS (root/toor),

comme beaucoup d'autres qui ont postés sur le web, j'ai un écran noir avec la led du verrouillage maj qui clignote.

j'ai essayé plusieurs solutions que j'ai trouvé grace à google, mais aucune ne marche

svp aidez moi

Publicité
gugus54
 Posté le 02/09/2012 à 12:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

personne?

Logicien
 Posté le 02/09/2012 à 23:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour/Bonsoir,

il faudrait que tu remplisses la description du matériel utilisé pour lancer Backtrack dans ton compte sur PCastuces. Sans savoir si c'est un portable ou un PC de bureau, le type de processeur et de carte graphique, etc, c'est avancé les yeux fermés.

Au fait, utilises-tu Backtrack pour ce qu'elle est ou simplement parce-que tu veux utiliser Linux. Il est toujours possibile d'utiliser une autre distribution. Toutes ne poseront pas nécessairement ce problème.



Modifié par Logicien le 02/09/2012 23:18
gugus54
 Posté le 03/09/2012 à 09:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

ah oui pardon c'est le même matériel que sous windows je suppose:

processeur: intel core i3 x64

carte graphique: ATI Mobility Radeon Premium Graphics

ordinateur portable: HP G62

si tu as besoin d'autres infos, demande moi car je n'ai peut être pas pensé à tout

gugus54
 Posté le 05/09/2012 à 14:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

personne ne peut me répondre? j'ai besoin de votre aide svp

Logicien
 Posté le 06/09/2012 à 06:56 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Avec Backtrack, lors de l'affichage de l'écran de démarrage, y a-t-il une entrée du menu du type 'Démarrage sans échec'?

L'écran noir peut être dû au fait que le pilote libre Radeon ne supporte pas ta carte graphique et que tu doives désactiver ce pilote avec le mode sans échec.

Si tu peux passer le paramètre radeon.modeset=0 au noyau Linux, cela peut résoudre ton problème.

gugus54
 Posté le 06/09/2012 à 18:15 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

merci pour ta réponse mais le mode sans échec ne marche pas non plus

je dois donc passer le paramètre radeon.modeset=0

mais comment c'est avec la touche "e" il me semble?

mais après ou dois-je placer cette comande?

merci de ta réponse

Logicien
 Posté le 06/09/2012 à 21:46 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Je pense que la touche F6 permet d'accéder aux paramètres du noyau. Il y a le paramètre nomodeset qui peut être choisi comme alternative à radeon.modeset=0 .

En pressant sur la touche Esc après F6, tu obtiens la ligne des paramètres du noyau pour l'entrée choisie du menu de démarrage. L'option radeon.modeset=0 peut être placée entre deux options et avec espaces. Puis presser sur la touche Entrée pour démarrer.

En pressant sur la touche Tab, il se peut que la ligne de l'entrée choisie du menu apparaîsse et te permette d'y insérer le paramètre radeon.modeset=0 .

Le paramètre nomodeset désactive le Kernel Mode Setting (KMS) pour toutes les cartes graphiques qui le supportent, alors que le paramètre radeon.modeset=0 ne le désactive que pour les cartes graphiques Amd/Ati/Radeon. Je préfère radeon.modeset=0 . Tu peux aussi essayer radeon.modeset=1 au cas où KMS ne serait activé par défaut.

Il n'est pas certain que l'activation par défaut de KMS soit la cause de ton problème et qu'en le désactivant cela règlera le problème. Si ta carte graphique n'est pas supportée par Linux et Xorg, Il reste le mode Vesa pour piloter l'affichage. C'est la prochaine chose à essayer si rien ne va.



Modifié par Logicien le 06/09/2012 21:48
gugus54
 Posté le 07/09/2012 à 11:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

salut merci de ta réponse

alors j'ai essayé de mettre cette commande, mais il y avait déja "nomodeset" alors je l'ai remplacé par "radeon.modeset=0", et en bootant sur backtrack, après il m'affiche trois ligne:

error:no sush device:(un nombre très grand)

error:no sush disk

error: you need to load the kernel first

d'après ce que j'ai compris, j'ai fais une boulette et j'ai modifié l'emplacement du root ou du kernel :(

j'ai quand même essayé de mettre radeon.modeset=1

sans plus de succes.

j'ai alors remis nomodeset, mais toujours pareil.

je risque d'etre obligé de réinstallé backtrack non?

ah et j'ai oublié de donner un détail assez important quand même, j'ai aussi linux ubuntu qui lui marche très bien.

donc quand je lance backtrack, c'est sous l'interface grub qui vient de ubuntu

merci de tes réponses

Publicité
Logicien
 Posté le 07/09/2012 à 12:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Peut-être que la cause de l'écran noir n'est pas lié au pilote d'affichage. Tu peux encore essayé de démarrer en mode Vesa en passant de la même manière comme ceci les paramètres

vga=0x318 video=vesafb

Le mode Vesa est généralement très sûr. Si tu ne peux démarrer, la source du problème doit être ailleurs.

Si tu affiches les lignes utilisées pour le démarrage (F6), celle du noyau Linux et celle de l'initramfs associé, on pourra les étudier. Il se peut que la ligne de l'initramfs ne s'affiche pas.



Modifié par Logicien le 07/09/2012 12:36
gugus54
 Posté le 12/09/2012 à 17:14 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

salut

tout d'abord, je tiens à m'excuser pour ma réponse très tardive mais avec la reprise des cours, je n'ai pas vraiment eu le remps de m'occuper de ca.

sinon,

merci pour ta réponse, lorsque je met vga=0x318 video=vesafb, ca marche!

le problème, c'est qu'au démarrage suivant, il se remet en nomodeset vga=719

enfin pour le 719 je ne suis pas sur car mon ordi a surchauffé et le bios l'a coupé

bref si je veu avoir accès à backtrack, je suis obligé de remettre cette comande à chaque fois

et lorsque ca marche, je suis obligé de taper root toor startx à l'aveugle, car mon écran reste noir à ce moment, mais après le startx, le bureau s'affiche.

il y a t-il un moyen pour éviter de taper la commande à chaque fois et pour voir l'écran terminal?

merci

Logicien
 Posté le 12/09/2012 à 21:05 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Que te retournent les commandes

find /lib/modules/$(uname -r) -iname *radeon*

grep -ir radeon /etc/modprobe.d/*

grep -i radeon /etc/initramfs-tools/modules

ls -a /boot

Je pense que ton problème vient du fait que le module radeon n'est pas inclue dans l'initramfs et que KMS n'est pas activé au niveau du module radeon. Ces commandes permettent d'en savoir plus.



Modifié par Logicien le 12/09/2012 21:11
gugus54
 Posté le 13/09/2012 à 19:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

merci mais je dois taper ces commandes dans un terminal de backtrack ou dans le menu de boot grub?

merci

Logicien
 Posté le 13/09/2012 à 23:37 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Dans un terminal de Backtrack.

gugus54
 Posté le 14/09/2012 à 17:25 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

ok je test et je te redis ca

IceF0x
 Posté le 15/09/2012 à 00:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Installer le driver propriétaiez peux également règler le problème.

http://wiki.cchtml.com/index.php/Ubuntu_Lucid_Installation_Guide

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Ecran noir après le démarrage d' Ubuntu 11.10
Ecran noir au démarrage
Mint 13 - Ecran noir à l'installation
Ecran noir installation ubuntu 11.04.
Debian Edu sur PC: écran noir juste avant le login
Problème affichage écran au démarrage avec 10.10
Ecran de démarrage
Écran noir à l'allumage sous Ubuntu 8.10
Ecran noir après mise à jour de logiciels
pb installation linux ecran noir et rien
Plus de sujets relatifs à démarrage de backtrack v5 ecran noir led maj clign
 > Tous les forums > Forum Linux