× Aidez la recherche contre le COVID-19 avec votre ordi ! Rejoignez l'équipe PC Astuces Folding@home
 > Tous les forums > Forum Linux
 dual boot w10 linux manjaro absence de grub au démarrageSujet résolu
Ajouter un message à la discussion
Pages : Début ... 4 5 [6] 7 ... Fin
[Début] Page 6 sur 7 [Fin]
Ikewdu_
 Posté le 07/04/2020 à 07:46 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Déjà, ça doit booter sur GRUB directement. Dans l'absolu, ton problème doit te sembler réglé. Confirme-le-moi.

maxfélix
 Posté le 07/04/2020 à 11:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour

Çà démarre sur Windows mais pas sur grub; par contre j'ai toujours les 2 WBM et grub donné sur le second.

Si tu estimes que cela n'est pas possible de faire mieux, on laisse en l'état; je peux sans doute réinstaller le tout en veillant à bien m'informer pour installer Manjaro.

Je préférerai ne pas le faire car j'ai des logiciels qui m'ont été offert gratuitement sur Windows et qui ne seront plus utilisables. Mais comme je ne suis pas pressé et à la retraite je peux bien passer par F11 et perdre quelques secondes.

En tout cas merci encore et une petite question: existe t il un moyen de s'informer sur toutes ce commandes utilisables pour se sortir de ces impasses tant sur Windows que sur linux.

Bonne continuation

Ikewdu_
 Posté le 07/04/2020 à 15:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Salut,

C'est dommage que tu ne fasses pas de photo de ce qu'affiche le BIOS pour les options de boot. Je suis certain qu'on peut ajouter l'entrée Manjaro manuellement depuis là. Une carte mère achetée dans le commerce n'est pas verrouillée comme pour certains portables,

Si tu dois réinstaller, c'est seulement pour Manjaro qu'il faudra le faire. Mais tu devras t'assurer de booter sur le live en uefi. Car ton problème de partition bios-grub est venu d'une mauvaise installation, faiite en mode Legacy. Il te suffira de taper sudo efibootmgr -v avant installation pour le savoir. Si tu n'es pas en uefi, ça retournera un message d'erreur.

En revanche, tu peux craindre de retomber sur la même situation. Celui qui t'a fait modifier la base BCD pour tromper ton BIOS a forcément été confronté à ce même souci. J'aurais bien aimé voir le sujet en question, d'ailleurs.

Pour ce qui concerne les commandes, il n'y a pas de réponse absolue. Je traite souvent des sujets de ce genre sur le forum Ubuntu, et selon les marques et les modèles, on traite les choses différemment.



Modifié par Ikewdu_ le 07/04/2020 15:43
maxfélix
 Posté le 07/04/2020 à 23:05 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

J'essaie de faire passer boot de ma carte mère:

des images concernant le

Ikewdu_
 Posté le 07/04/2020 à 23:15 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

.Tu peux déjà permuter tes deux WBM.... Ce sera déjà ça. Par ailleurs, dans avancé, on voit que c'est configuré pour windows. Peut-être as-tu quelque part une option "other systems"



Modifié par Ikewdu_ le 07/04/2020 23:28
maxfélix
 Posté le 07/04/2020 à 23:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

ok je ferai; pas facile il porte la même mention.

Ikewdu_
 Posté le 07/04/2020 à 23:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Pas évident, en effet. Boot configuration, c'est grisé ?

Dans la page "boot option #1 ou #2" (trois captures avant la fin) qui affiche les deux WBM, que se passe-t-il si tu sélectionnes "disabled" ?



Modifié par Ikewdu_ le 08/04/2020 07:35
maxfélix
 Posté le 08/04/2020 à 23:21 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir

Dans la capture 4 depuis le début j'ai inversé les 2 wbm et au démarrage j'ai directement le grub avec en premier Manjaro et en 3ème wbm; tous 2 sont opérationnels.

Donc il ne me reste plus qu'à inverser Manjaro et WBM si je veux que w démarre en premier.

Est il besoin de désactiver dans la même capture?

Publicité
Ikewdu_
 Posté le 09/04/2020 à 07:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Salut,

C'est bien. Mais tu n'as pas répondu à ma question. J'aurais bien aimé trouver une solution propre, car cette permutation relève un peu du bidouillage.

Quant à l'inversion de l'ordre de démarrage dans GRUB ( que tu sembles confondre avec la Nvram), elle n'est pas difficile à faire. Depuis Manjaro, donne le retour de la commande :

ls /etc/grub.d

maxfélix
 Posté le 09/04/2020 à 14:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Quelle était la question? mettre en disabled dans "boot option #1 ou #2"? Il n'est pas dans le n° capture indiqué.

Qu'entends tu par Nvram?

Je ferai la commande quand je passerai sur manjaro.

Ikewdu_
 Posté le 09/04/2020 à 15:14 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien
maxfélix a écrit :

Quelle était la question? mettre en disabled dans "boot option #1 ou #2"? Il n'est pas dans le n° capture indiqué.

Qu'entends tu par Nvram?

Je ferai la commande quand je passerai sur manjaro.

Dans les 5e et 6e captures (si j'ai bien compté), on voit apparaître les deux WBM (options #1, puis option # 2) + la mention "disabled" en dessous (qui pourrait être alors "option #3). Je me demandais si le fait de sélectionner cette ligne "disabled" pour la modifier ne permettrait pas d'ajouter une vraie entrée Manjaro manuellement (je ne vois pas d'autre endroit possible). Mais si tu es satisfait ainsi, ne change plus rien.

La Nvram, c'est ce qu'affiche ton PC quand tu cliques sur F11... Tes deux WBM. Ils sont enregistrés dans cette partie du bios-uefi appelée "Nvram". A ne pas confondre avec le menu grub qui affiche "Manjaro, options avancées et Windows 10".

La commande demandée permet de voir si Manjaro stocke les fichiers grub comme les dérivées de Debian... Je veux être sûr de ce que je vais te proposer.



Modifié par Ikewdu_ le 09/04/2020 15:20
maxfélix
 Posté le 09/04/2020 à 15:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

ok je vais faire

maxfélix
 Posté le 09/04/2020 à 15:42 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

réponse à la commande:

[max@max-manjaro ~]$ ls /etc/grub.d
00_header 20_linux_xen 40_custom 60_memtest86+
10_linux 30_os-prober 41_custom README
[max@max-manjaro ~]$

En cliquant sur disabled ne risque t on pas de ne plus avoir de boot du tout? et dans ce cas pourra t on revenir à la situation antérieure?

Ikewdu_
 Posté le 09/04/2020 à 17:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

En principe, tant que tu ne sauves pas les modifications dans le BIOS, tu ne modifies rien.... Mais si tu es réticent, ne le fais pas.

Donc, les commandes :

sudo cp /etc/grub.d/30_os-prober /etc/grub.d/09_os-prober

sudo chmod -x /etc/grub.d/30_os-prober

sudo update-grub

Explication de la commande: on fait une copie de 30_os-prober en modifiant le nombre 30 en 09 (le 0 est important) pour que la détection de Windows soit prioritaire sur celle de Manjaro. On désactive avec chmod-x le fichier d'origine qu'on conserve par sécurité (si on veut le réactiver, il suffira de remplacer -x par +x). Et on met GRUB à jour.

Au démarrage suivant, Windows doit être en tête de liste et GRUB doit le lancer par défaut.

maxfélix
 Posté le 09/04/2020 à 22:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

voici le résultat des commandes:

[max@max-manjaro ~]$ sudo cp /etc/grub.d/30_os-prober /etc/grub.d/09_os-prober
[sudo] Mot de passe de max :
[max@max-manjaro ~]$ sudo chmod -x /etc/grub.d/30_os-prober
[max@max-manjaro ~]$ sudo update-grub
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found Windows Boot Manager on /dev/nvme0n1p2@/EFI/Microsoft/Boot/bootmgfw.efi
Found linux image: /boot/vmlinuz-5.4-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-5.4-x86_64.img
Found initrd fallback image: /boot/initramfs-5.4-x86_64-fallback.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe : attention : type de périphérique nvme1n1 inconnu.
done
[max@max-manjaro ~]$

J'ai mis les deux entrées # 1 et #2 en disabled sans enregistrer sans avoir aucune mention particulière

Ikewdu_
 Posté le 10/04/2020 à 08:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Non, tu n'as pas compris ce que je veux dire dans le BIOS. Laisse tomber cette piste. Contente-toi des commandes pour modifier Grub. Et ça devrait rouler.



Modifié par Ikewdu_ le 10/04/2020 08:47
Publicité
maxfélix
 Posté le 10/04/2020 à 18:10 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bon comme tu dis ça devrait rouler.

Une petite remarque si ça peut servir aux observations; à chaque fois que je redémarre, le système qui était utilisé dans la précédente session est celui qui se relance; si c'était manjaro, c'est Manjaro qui est actif et se lance; et inversement si c'était wbm, c'est wbm qui se lance.

Mais rien de grave il suffit d’être devant l'ordinateur pour décider de l'os qu'on veut lancer; et si on veut lancer le même on laisse le système prendre la main.

Donc si tu y consens je vais mettre le sujet en résolu.

m_n
 Posté le 10/04/2020 à 19:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Si cela peux t'aider .. attend l'opignion de notre ami Ikewdu_

--------------------------

Pour que Grub se souvienne, afin que l'ordi ouvre au re-demarrage sur la derniere distro occupé ..

sudo gedit /etc/default/grub

modifier et ajouter ces lignes comme ceci :

GRUB_DEFAULT=saved
GRUB_SAVEDEFAULT=true
GRUB_TIMEOUT=5

sudo update-grub

===============

update-grub sur Arch, rpm :

sudo grub-mkconfig -o /boot/grub/grub.cfg

ou

sudo grub2-mkconfig -o /boot/grub2/grub2.cfg

Ikewdu_
 Posté le 10/04/2020 à 20:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Re,

Rien à ajouter. Une affaire qui fut finalement plus compliquée qu'on pouvait le penser au départ.

maxfélix
 Posté le 10/04/2020 à 21:52 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

@m_n

je ne comprends pas très bien ce qu'apportent ces commandes, puisque comme l'ai dit plus haut, grub redémarre automatiquement sur l'os qui a été utilisé lors de la session précédente, ce qui ne me semble pas le comportement habituel de grub, puisqu'il démarre après le temps imparti, automatiquement sur l'os qui est placé en premier.

Me serai-je trompé?

D’autre part tu mets 2 systèmes de commandes: lesquelles s'appliquent à ma configuration?

Merci de ton intervention.

enigma7
 Posté le 11/04/2020 à 08:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

pour qu'il ne se souviennes pas tu modifies ces 2 lignes:

GRUB_DEFAULT=0

# GRUB_SAVEDEFAULT=true

Tu re-sauvegarde le fichier /etc/default/grub avec gedit puis tu fait sudo update-grub

Comme tu n'est pas sur arch tu ne tien pas compte de cette partie

Ikewdu_
 Posté le 11/04/2020 à 10:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Essaie ce que propose enigma7 (0 est plus logique que saved). Si ça ne fonctionne pas, donne le retour de la commande

cat /etc/default/grub

Il y a sûrement une option foireuse là-dedans....

Edit. Esclapion a visiblement eu ce souci avec le GRUB de Manjaro : https://forum.pcastuces.com/grub2__memoriser_le_dernier_choix_-f8s13695.htm

(Mais je déconseille fortement la piste grub-customizer)



Modifié par Ikewdu_ le 11/04/2020 10:33
Slyvester
 Posté le 12/04/2020 à 09:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

Il y a sûrement une option foireuse là-dedans....

Edit. Esclapion a visiblement eu ce souci avec le GRUB de Manjaro : https://forum.pcastuces.com/grub2__memoriser_le_dernier_choix_-f8s13695.htm

Esclapion : que de bons souvenirs ! Comme j'ai - depuis lors - plusieurs distributions Linux en multiboot, j'ai modifié dans mon fichier "/etc/default/grub" la rubrique (par défaut) : GRUB_TIMEOUT = 10 ==> GRUB_TIMEOUT = -1 (sans le #).
Par conséquent :
apparition du Grub au démarrage + attente jusqu'à ce que l'utilisateur choisisse & clique sur la distribution de son choix.

maxfélix
 Posté le 12/04/2020 à 22:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir à tous:

@enigma7 résultats des commandes avec blocage:

[max@max-manjaro ~]$ GRUB_DEFAULT=0
[max@max-manjaro ~]$ # GRUB_SAVEDEFAULT=true
[max@max-manjaro ~]$ /etc/default/grub
bash: /etc/default/grub: Permission non accordée
[max@max-manjaro ~]$ sudo /etc/default/grub
[sudo] Mot de passe de max :
sudo: /etc/default/grub : commande introuvable
[max@max-manjaro ~]$

@ikwedu: résultat de sa commande:

[max@max-manjaro ~]$ GRUB_DEFAULT=0
[max@max-manjaro ~]$ # GRUB_SAVEDEFAULT=true
[max@max-manjaro ~]$ /etc/default/grub
bash: /etc/default/grub: Permission non accordée
[max@max-manjaro ~]$ sudo /etc/default/grub
[sudo] Mot de passe de max :
sudo: /etc/default/grub : commande introuvable
[max@max-manjaro ~]$ cat /etc/default/grub
GRUB_DEFAULT=saved
GRUB_TIMEOUT=10
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors. Used by normal and wallpaper
# modes only. Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"
[max@max-manjaro ~]$

Ikewdu_
 Posté le 12/04/2020 à 23:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Re,

Tu n'as pas compris ce qu'il faut faire. Quel éditeur de texte as-tu sur ta Manjaro ?

Publicité
Pages : Début ... 4 5 [6] 7 ... Fin
[Début] Page 6 sur 7 [Fin]

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
31,75 €Clé USB 3.0 Sandisk Ultra 256 Go à 31,75 € livrée
Valable jusqu'au 30 Mai

Amazon Allemagne propose la clé USB Sandisk Ultra d'une capacité de 256 Go à 27,23 € (avec la TVA ajustée). Comptez 4,52 € pour la livraison en France soit un total de 31,75 € livrée alors qu'on la trouve ailleurs autour de 50 €. Cette clé USB 3.0 est compatible USB 2.0 et offre de bons débits d'environ 100 Mo/s en lecture et en écriture. Le connecteur est rétractable pour éviter qu'il prenne la poussière.

Vous pouvez utiliser votre compte Amazon France sur Amazon Allemagne et il n'y a pas de douanes. Si vous êtes perdu en allemand, vous pouvez traduire le site en anglais.


> Voir l'offre
9,99 €Adaptateur Bluetooth USB TP-Link UB400 à 9,99 €
Valable jusqu'au 30 Mai

Amazon fait une promotion sur l'adaptateur Bluetooth USB TP-Link UB400 qui passe à 9,99 €. Cet adaptateur à brancher sur un port USB va vous permettre d'ajouter le bluetooth à votre ordinateur et d'utiliser ensuite sans fil vos périphériques bluetooth : souris, clavier, casque, manette, téléphone, ...


> Voir l'offre
25,99 €Souris Logitech Marathon Mouse M705 à 25,99 €
Valable jusqu'au 30 Mai

Amazon fait une promotion sur la souris Logitech Marathon Mouse M705 qui passe à 25,99 € livrée gratuitement. On la trouve ailleurs à partir de 39 €. Cette souris sans fil dispose d'un capteur laser pour un contrôle précis sur toutes les surfaces. Vous bénéficierez d’une autonomie des piles allant jusqu'à trois ans.


> Voir l'offre

Sujets relatifs
absence de grub au dual boot Mint W10 19 09:
pas de démarrage sur linux mint dans le grub w10/linux mint
Démarrage d'un prog. au boot de Linux [résolu]
DualBoot - Pas de démarrage auto sur W10 après suppression de Linux
Dual boot W10 - Ubuntu : Démarrage uniquement sur W10
[TUTO]Linux Mint 17, et l'affichage du Menu Grub au Démarrage.
Au secours : j'ai écrasé Windows XP en installant Linux dual boot
pas de linux au démarrage
Message d'erreur BIOS au boot de Linux
Changer l'ordre de démarrage grub linux Mint 7
Plus de sujets relatifs à dual boot w10 linux manjaro absence de grub au démarrage
 > Tous les forums > Forum Linux