> Tous les forums > Forum Linux
 Ecran noirSujet résolu
Ajouter un message à la discussion
Pages : [1] 2 ... Fin
Page 1 sur 2 [Fin]
xDAML
  Posté le 30/07/2018 @ 16:51 
Aller en bas de la page 
Astucien

Bonjour,

Afin de rester un peu au courant de ce qui se passe du côté de Linux, j'ai installé Linux Mint 19 Cinnamon et Ubuntu en machine virtuelle. Les additions invités sont installés sur Mint et (je suppose) pré-installés sur Ubuntu.

Seulement voila: Dès que j'active l'accélération 3D pour ne plus être en rendu logiciel, l'écran devient noir, seul le pointeur est visible. Au début je me dis "Boarf, c'est surement un problème de Mint, donc je vais attendre que ca se corrige". Or, après Ubuntu, je n'en suis plus aussi sur.

Le plus bizarre c'est que lorsque je tente de fermer la VM, j'ai ceci:

Une image! Mais en fermant la confirmation, l'écran reste gris et l'image reste fixe.

Une idée d'ou cela pourrais provenir? Virtualbox, peut-être?

Merci d'avance de votre aide



Modifié par xDAML le 01/08/2018 21:11
Publicité
Logicien
 Posté le 30/07/2018 à 18:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut,

as-tu bien configuré ta machine virtuelle pour Linux Ubuntu 32 ou 64 bits selon ton installation? Il faudrait plus de détails sur cette configuration. Elle peut être la cause de cet écran noir. L'accélération 2D ne doit pas être activée dans la machine virtuelle pour Linux. Pour arrêter Ubuntu ou Mint tu y vas normalement en fermant ta session etc, ou par arrêt par Acpi. Il ne faut pas arrêter la machine brutalement en lui coupant le courant comme elle te propose de le faire dans l'image que tu produit.

As-tu l'écran noir sur Mint et Ubuntu? Utilisent-ils chacun leur machine virtuelle? Il serait bon de réinstaller les addtions invités à partir du fichier iso9660 ou ce que VirtualBox te propose, tout ça après une mise-à-jour complète de l'hôte (Windows et VirtualBox) et de l'invité (Mint et/ou Ubuntu) et redémarrage de l'hôte et de l'invité sur le noyau le plus récent installé de Linux. Peut-être que les additions invités installées dans et/ou par l'invité ne correspondent pas à aux additions qui doivent être installées, ce que VirtualBox comme hôte pourrait faire depuis le menu ou le cd.

Bon, il y a peut-être autre chose à faire que ça. Attend les autres avis.



Modifié par Logicien le 30/07/2018 19:12
xDAML
 Posté le 30/07/2018 à 19:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Logicien a écrit :

Salut,

as-tu bien configuré ta machine virtuelle pour Linux Ubuntu 32 ou 64 bits selon ton installation? Il faudrait plus de détails sur cette configuration. Elle peut être la cause de cet écran noir. L'accélération 2D ne doit pas être activée dans la machine virtuelle pour Linux. Pour arrêter Ubuntu ou Mint tu y vas normalement en fermant ta session etc, ou par arrêt par Acpi. Il ne faut pas arrêter la machine brutalement en lui coupant le courant comme elle te propose de le faire dans l'image que tu produit.

As-tu l'écran noir sur Mint et Ubuntu? Utilisent-ils chacun leur machine virtuelle? Il serait bon de réinstaller les addtions invités à partir du fichier iso9660 ou ce que VirtualBox te propose, tout ça après une mise-à-jour complète de l'hôte (Windows et VirtualBox) et de l'invité (Mint et/ou Ubuntu) et redémarrage de l'hôte et de l'invité sur le noyau le plus récent installé de Linux. Peut-être que les additions invités installées dans et/ou par l'invité ne correspondent pas à aux additions qui doivent être installées, ce que VirtualBox comme hôte pourrait faire depuis le menu ou le cd.

Bon, il y a peut-être autre chose à faire que ça. Attend les autres avis.

Je vais répondre dans l'ordre d'apparition

-Les machines virtuelles sont en 64 bits (en principe (Sur VBox) et en pratique (Le système sur la machine). Quant à la config....

-L'écran noir est sur Mint et Ubuntu. Les deux ont leur propre machine virtuelle

-Je vais tenter une mise à jour via la console ("sudo apt-get update" et "sudo apt-get upgrade" ???) et je te tiens au corant

Logicien
 Posté le 30/07/2018 à 20:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

24 mo pour la carte graphique virtuelle ne me semble pas beaucoup surtout avec les additions invités et vboxvideo qui offre la résolution native de l'écran de l'hôte. Par contre, tu donnes beaucoup de RAM à l'invité peut-être trop. Ce n'est probablement pas là que réside la cause du problème.



Modifié par Logicien le 30/07/2018 20:37
xDAML
 Posté le 30/07/2018 à 21:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Je viens d'augmenter la mémoire vidéo et j'ai mis a jour Ubuntu, même problème

Logicien
 Posté le 30/07/2018 à 22:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Si tu alloues trop de mémoire vive à l'invité et que l'hôte n'en a pas assez pour fonctionner tu peux avoir des problèmes. Moi je donne 2Go à la machine virtuelle sur les 8Go que l'hôte possède. Comme je te le dis, les additions invités installés par l'invité via le gestionnaire de paquets peuvent ne pas être compatibles avec la version de VirtualBox qui tourne depuis l'hôte.

Je pense toutefois que l'accélération 3D c'est l'hôte qui la donne à l'invité par le biais de la machine VirtualBox. Essayer de jouer entre le rendu logiciel et l'accélération 3D dans la machine virtuelle est jouer avec le feu en quelque sorte. Essais-tu de faire ce changement dans la machine virtuelle avec Mint et Ubuntu ou dans la configuration de la machine virtuelle depuis l'hôte?

Encore là, tu peux attendre d'autre opinions.



Modifié par Logicien le 30/07/2018 22:29
Daneel Olivaw
 Posté le 31/07/2018 à 01:52 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

La mémoire n'a rien à voir.

Tu as cet écran parce que tu as cliqué sur le X de fermeture de la machine virtuelle. Coche alors Envoyer le signal d'extinction pour avoir un shutdown normal. Sinon si tu laisses coché Éteindre la machine, tu éteins à la sauvage (c'est équivalent au bouton On/Off).

Sinon, pourquoi tu ne fais pas un shutdown normal de Linux ?

Et il faut quand-même installer les Additions invité sur ubuntu. Mais il faut installer GCC avant.

$ sudo apt update
$ sudo apt upgrade
$ sudo apt install build-essential



Modifié par Daneel Olivaw le 31/07/2018 02:13
xDAML
 Posté le 31/07/2018 à 11:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Je ne peux pas arrêter Ubuntu normalement vu que je ne vois rien à l'écran... Donc pour l'arrêter, j'envoie le signal d'extinction via VirtualBox

xDAML
 Posté le 31/07/2018 à 13:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Je viens de tester la même VM sur mon PC portable avec une version plus ancienne de VBox...Et RAS. Je pense que cela peut provenir de Virtualbox...

Publicité
Daneel Olivaw
 Posté le 31/07/2018 à 16:12 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Qu'est-ce que tu as comme paramètres VB et c'est quoi comme carte mère ?

xDAML
 Posté le 31/07/2018 à 18:28 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Sur le PC ou ca ne marche pas, la carte mère est une MSI H110M PRO-VD.

Je tente de rétrograder la version de VBox (Au cas ou que cela vienne de la). Je vous tiens au courant



Modifié par xDAML le 31/07/2018 19:13
xDAML
 Posté le 31/07/2018 à 21:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Cela n'a pas fonctionné. Et vu que j'ai oublié de joindre les config (Désolé ), les voici:

Daneel Olivaw
 Posté le 31/07/2018 à 21:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

C'est nettement insuffisant. Minimum 128 MO.

xDAML
 Posté le 31/07/2018 à 21:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

D'accord, je vais faire la modif alors

xDAML
 Posté le 31/07/2018 à 21:37 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Je peux pas aller plus loin que 128 Mo (Malgré que les animations 3D dont activés). Rien n'a changé

Daneel Olivaw
 Posté le 31/07/2018 à 21:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Dans le manuel de ta carte mère, il n'y a rien sur le BIOS, à part comment rentrer et mettre à jour.

Il doit y avoir quelque chose qui ressemble à ça et qui doit être activé. C'est quoi comme processeur ?

xDAML
 Posté le 31/07/2018 à 21:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Mon processeur est un Intel Pentium G4400

EDIT: J'ai activé l'option, mais je ne peux toujours pas augmenter la mémoire vidéo



Modifié par xDAML le 31/07/2018 21:59
Publicité
Daneel Olivaw
 Posté le 31/07/2018 à 22:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

La carte mère et le processeur supportent la virtualisation, mails il faut que ce soit activé dans le BIOS.

Je ne trouve aucun tuto pour les BIOS MSI. Tu dois chercher.

Daneel Olivaw
 Posté le 31/07/2018 à 22:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Et si tu utilise la carte graphique intégrée, il faut lui donner suffisemment de mémoire.

xDAML
 Posté le 31/07/2018 à 22:05 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Je vais regarder alors

xDAML
 Posté le 01/08/2018 à 18:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Les accélérations pour la virtualisation et le Intel VT-D est acrivé, mais ca ne marche toujours pas....

Daneel Olivaw
 Posté le 01/08/2018 à 19:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

As-tu essayé d'installer une VM Windows quelconque ?

Ça se produit seulement avec Ubuntu ?

Essaye de supprimer l'accélération matérielle de la CG.



Modifié par Daneel Olivaw le 01/08/2018 19:07
xDAML
 Posté le 01/08/2018 à 19:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Je n'ai pas essayé en installant une VM Windows. J'ai des CD sous la main, je vais tenter cela

Non, avec Mint aussi

Je vais voir ca et je te dis

En passant, la ou ca "foire", c'est quand les additions invités sont installés. Sans ces additions-la, RAS. Mais ce n'est pas très fluide

xDAML
 Posté le 01/08/2018 à 20:56 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Avec une machine Windows lambda, ca pose aussi un problème. Je vais essayer de réparer VBox, je reviens après

EDIT: Ca marche pas non plus, je songe sérieusement à passer à VMWare, vu que je n'ai jamais été autant emdé qu'avec Virtualbox

EDIT 2: Je ne trouve pas comment enlever l'accélération graphique dans le BIOS....



Modifié par xDAML le 01/08/2018 21:17
Ikewdu_
 Posté le 01/08/2018 à 21:15 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Salut,

EDIT: Ca marche pas non plus, je songe sérieusement à passer à VMWare, vu que je n'ai jamais été autant emdé qu'avec Virtualbox

C'est ce que j'allais te conseiller. Perso, je trouve VMware nettement plus "professionnel" que Vbox.

xDAML
 Posté le 01/08/2018 à 21:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Je télécharge VMWare Workstation Player et je vous tiens au courant

Publicité
Pages : [1] 2 ... Fin
Page 1 sur 2 [Fin]

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Mint 18 Cinnamon Ecran noir suite changement pilote Nvidia
Ecran noir au début de l'installation
Démarrage avec écran noir
Debian Jessie 8.2 : écran noir au boot
Mint 13 - Ecran noir à l'installation
démarrage de backtrack v5 ecran noir led maj clign
Ecran noir après le démarrage d' Ubuntu 11.10
Ecran noir installation ubuntu 11.04.
Debian Edu sur PC: écran noir juste avant le login
Écran noir à l'allumage sous Ubuntu 8.10
Plus de sujets relatifs à Ecran noir
 > Tous les forums > Forum Linux