> Tous les forums > Forum Linux
 Ecran ou carte graphique non reconnue + Pas de sonSujet résolu
Ajouter un message à la discussion
Pages : [1] 2 3 4 5 ... Fin
Page 1 sur 5 [Fin]
xDAML
  Posté le 06/05/2017 @ 14:44 
Aller en bas de la page 
Astucien

Bonjour,

Ayant installé Debian 8 sur un vieux Dell Optiplex gx620 series, la résolution de l'écran est malheureusement minimale (1024x768) alors que mon écran est un 16/9.

De plus, normalement, le son sort de la CM du pc (En tout cas, c'etait le cas avec XP). Mais la, pas de son, sauf si je branche des HP.

J'ai regardé sur internet, mais les solutions était en anglais et pas très accessibles pour moi.

J'ai aussi essayé d'installer le paquet xorg d'Intel, il était déja installé.

Donc, je me remets vers vous pour savoir si vous aurez une idée d'ou pourrait provenir ces problèmes.

Merci d'avance de votre aide

EDIT: Voici le retour de lspci -v pour la CG et le son:

VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
Subsystem: Dell Device 01ad
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at feb00000 (32-bit, non-prefetchable) [size=512K]
I/O ports at e898 [size=8]
Memory at e0000000 (32-bit, prefetchable) [size=256M]
Memory at feac0000 (32-bit, non-prefetchable) [size=256K]
Expansion ROM at <unassigned> [disabled]
Capabilities: <access denied>
Kernel driver in use: i915

Multimedia audio controller: Intel Corporation 82801G (ICH7 Family) AC'97 Audio Controller (rev 01)
Subsystem: Dell OptiPlex GX620
Flags: bus master, medium devsel, latency 0, IRQ 23
I/O ports at ec00 [size=256]
I/O ports at e8c0 [size=64]
Memory at feabfa00 (32-bit, non-prefetchable) [size=512]
Memory at feabf900 (32-bit, non-prefetchable) [size=256]
Capabilities: <access denied>
Kernel driver in use: snd_intel8x0



Modifié par xDAML le 06/05/2017 14:51
Publicité
mchl
 Posté le 06/05/2017 à 15:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour

https://wiki.debian.org/fr/ALSA



Modifié par mchl le 06/05/2017 15:38
paul74
 Posté le 06/05/2017 à 16:21 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

Le son ne passe pas par la prise VGA, donc normal de devoir mettre des HP ou de devoir branché un cable stéréo sur la sortie HP vers l'écran munis de HP.

Pour l'écran, il faut ajuster la définition dans les paramètres d'affichage.

xDAML
 Posté le 06/05/2017 à 16:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

En utilisant alsactl init, le son revient, mais disparait quand on va dans les paramètres du son ou lors d'un redémarrage

Slyvester
 Posté le 06/05/2017 à 16:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

Bonjour,

Ayant installé Debian 8 sur un vieux Dell Optiplex gx620 series, ... J'ai regardé sur internet, mais les solutions était en anglais et pas très accessibles pour moi.

Heureusement, il existe des sites en français : https://debian-handbook.info/browse/fr-FR/stable/

ou encore : https://debian-facile.org/viewforum.php?id=10

xDAML
 Posté le 06/05/2017 à 16:42 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

paul74 a écrit :

Bonjour,

Le son ne passe pas par la prise VGA, donc normal de devoir mettre des HP ou de devoir branché un cable stéréo sur la sortie HP vers l'écran munis de HP.

Pour l'écran, il faut ajuster la définition dans les paramètres d'affichage.

Je sais, mais le son sortait de la tour quand l'ordi étais sous XP.

En allant dans les paramètres de résolution d'écran, j'ai ceci:

xDAML
 Posté le 06/05/2017 à 16:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Slyvester a écrit :

Bonjour,

Bonjour,

Ayant installé Debian 8 sur un vieux Dell Optiplex gx620 series, ... J'ai regardé sur internet, mais les solutions était en anglais et pas très accessibles pour moi.

Heureusement, il existe des sites en français : https://debian-handbook.info/browse/fr-FR/stable/

ou encore : https://debian-facile.org/viewforum.php?id=10

J'ai lancé une recherche sur mon problème, on verra bien ce que cela donne...

xDAML
 Posté le 06/05/2017 à 16:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

J'ai trouvé ceci: https://debian-facile.org/viewtopic.php?pid=197557#p197557 mais je ne sais pas comment faire la démarche inverse..

mchl
 Posté le 06/05/2017 à 17:12 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

xDAML a écrit :

En utilisant alsactl init, le son revient, mais disparait quand on va dans les paramètres du son ou lors d'un redémarrage

il faut sauvegarder avec la commande:

https://forum.pcastuces.com/img/sprites.svg?v=68e3d30a286e'), none; background-size: initial; background-repeat: no-repeat; overflow: hidden; display: block; text-indent: -9999em; width: 40px; height: 25px; background-position: 0px -220px;" title="Cette réponse n'est pas utile">vers le bas vote

Exécuter:

sudo alsactl store

https://askubuntu.com/questions/50067/howto-save-alsamixer-settings

Publicité
xDAML
 Posté le 06/05/2017 à 17:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

mchl a écrit :
xDAML a écrit :

En utilisant alsactl init, le son revient, mais disparait quand on va dans les paramètres du son ou lors d'un redémarrage

il faut sauvegarder avec la commande:

https://forum.pcastuces.com/img/sprites.svg?v=68e3d30a286e'), none; background-size: initial; background-repeat: no-repeat; overflow: hidden; display: block; text-indent: -9999em; width: 40px; height: 25px; background-position: 0px -220px;" title="Cette réponse n'est pas utile">vers lebas vote

Exécuter:

sudo alsactl store

https://askubuntu.com/questions/50067/howto-save-alsamixer-settings

J'ai exécuté la commande précédente et celle-la, redémarré, et je n'ai toujours pas de son..

mchl
 Posté le 06/05/2017 à 17:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

xDAML
 Posté le 06/05/2017 à 18:08 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

La carte son a l'air reconnue par ALSA, mais quand je quitte, c'est ce satané PulseAudio qui est remis par défaut

mchl
 Posté le 06/05/2017 à 18:42 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

xDAML a écrit :

La carte son a l'air reconnue par ALSA, mais quand je quitte, c'est ce satané PulseAudio qui est remis par défaut

essaye en supprimant pulse audio

http://doc.ufr.yoboy.fr/pulseaudio

xDAML
 Posté le 06/05/2017 à 18:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

J'ai supprimé pulseausio, et je n'ai plus l'icone su son...Apparament, il me faut installer alsatray mais je n'y arrive pas...

mchl
 Posté le 06/05/2017 à 19:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

xDAML a écrit :

J'ai supprimé pulseausio, et je n'ai plus l'icone su son...Apparament, il me faut installer alsatray mais je n'y arrive pas...

oui c'est précisé dans mon lien suppression pulse audio=le réglage du son est supprimé lui aussi ,il y à un moyen pour y remédier

Plus d'icône de réglage du son, solution 1

Ajouter le dépôt ppa:dtl131/ppa puis faire les mises à jour pour installer une version compatible Alsa de l'applet permettant le réglage du son !

Pour ajouter l'applet faites clic droit→Ajouter au tableau de bord sur votre … heu … Tableau de bord … Et choisissez Contrôleur de volume ou applet de notification si vous n'avez pas le précédent.

Ceci ajoutera le réglage du volume, que vous pouvez ensuite déplacer où ça vous convient le mieux !

Plus d'icône de réglage du son, solution 2

Installer ALSA Tray pour retrouver l'icône de réglage du son et le support des touches multimédia. Voir la page alsa-tray pour plus d'informations.

http://doc.ufr.yoboy.fr/alsa-tray#installation



Modifié par mchl le 06/05/2017 19:29
xDAML
 Posté le 07/05/2017 à 13:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Ca marche pas. Quand je recherge les paquets, je tombe sur une erreur 404. J'ai fait quelques recherches et ton paquet ne s'appliquerais qu'a Ubuntu...

EDIT: J'ai installé une extension GNOME pour Debian, mais cela controle le volume master, et moi il faut controler le volume Master M



Modifié par xDAML le 07/05/2017 14:08
Slyvester
 Posté le 07/05/2017 à 16:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

J'ai l'impression que - malgré la bonne volonté des intervenants/aidants - l'on tourne en rond pour une vieille machine dont la Mémoire-Ram est nettement insuffisante : 512 MB : https://www.cnet.com/products/dell-optiplex-gx620-business/specs/

Il est - à mon humble avis - très difficile, voire Impossible de faire tourner de façon satisfaisante une distribution Linux "normale" ou habituelle.En effet, celles-ci requièrent actuellement au moins 1024 MB ou 2048 MB ... Sans doute, faut-il abandonner Debian et se tourner vers un nouvelle installation avec une distribution Linux telle que PuppyLinux, ...



Modifié par Slyvester le 07/05/2017 16:10
Publicité
xDAML
 Posté le 07/05/2017 à 16:25 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Je ne savais pas cela. Quand j'ai récupéré l'ordi, il avais 1.5Go de RAM. Je l'ai augmenté a 2Go et je m'étais dis que ca irais pour Debian...

Logicien
 Posté le 07/05/2017 à 18:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut,

j'ai un Asus Eeepc 900 32 bits qui roule de manière respectable Debian 9 testing Stretch avec 2 go de memoire vive.

Pour l'affichage, la résolution par défaut est donnée lors du démarrage par le support i915 du noyau Linux en ce qui concerne les cartes graphiques Intel. En principe i915 supporte la résolution par défaut de l'écran par le KMS (Kernel Mode Setting) dont se sert le pilote intel d'Xorg pour la résolution graphique. Tu peux installer les paquets hwinfo et fbset . Fait Ctrl+Alt+F1 et ouvre une session root dans ce terminal Linux. Avec la commande

hwinfo --framebuffer

tu vas connaître les résolutions supportées par l'écran et avec la commande

fbset

tu vas savoir quelle résolution i915 utillise pour l'affichage côté noyau Linux. Si ce n'est pas la résolution native de l'écran, il peut y avoir des ajustements à faire an passant des paramètres au noyau Linux lors du démarrage. Selon la sortie de la commande lscpi que tu donnes, le noyau Linux utilise bien i915. Il faut aussi vérifier qu'Xorg utilise le module intel en regardant les messages d'Xorg dans le fichier /var/log/Xorg.0.log. Sinon, cela peut expliquer pourquoi tu n'as pas la résolution que tu souhaites.

Je pense que tu devrais utiliser Pulseaudio pour gérer le son de ton ordinateur. Si tu supprimes le paquet pulseaudio et ceux qui lui sont reliés, ils seront réinstallés lors d'une mise-à-jour. Plusieurs environnements de bureaux utilisent Pulseaudio. Il est difficile de s'en passer. Installe le paquet pavucontrol . Tu peux gérer toutes les entrées et sorties audios avec cette interface graphique de Pulseaudio, sortie par défault des haut-parleurs, des écouteurs, etc ainsi qu'activer et désactiver une carte de son.

Je pense que l'essentiel dont tu as de besoin pour résoudre tes problèmes est dans la sortie des commandes

dmesg | less

less /var/log/Xorg.0.log

journalctl

Tout ce qui va et ne va pas y est généralement affiché.



Modifié par Logicien le 07/05/2017 18:47
xDAML
 Posté le 07/05/2017 à 19:14 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Je t'envoie le retour des differentes commandes

Retour de hwinfo --framebuffer:

Retour de fbset:

Retour de lspci:

EDIT: En rentrant les trois dernières commandes, a ce que j'ai compris, il n'y a pas d'erreurs...



Modifié par xDAML le 07/05/2017 19:15
Logicien
 Posté le 07/05/2017 à 20:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Si tu veux une résolution de 1600x1200 ou 1280x1024 en 24 bits côté Linux, tu édites (avec droits root) le fichier /etc/default/grub , tu décommentes et/ou ajoute les valeurs vuivantes, avec espace si plus d'une, à ces variables

GRUB_GFXMODE="1600x1200-24"

GRUB_GFXPAYLOAD_LINUX=keep

GRUB_CMDLINE_LINUX_DEFAULT="quiet video=inteldrmfb:1600x1200-24"
GRUB_CMDLINE_LINUX="quiet video=inteldrmfb:1600x1200-24"

puis tu exécutes la commande

sudo update-grub

Redémarre et vérifie si la sortie de la commande fbset affiche la résolution définie dans ces variables. Pour voir si les paramètres configurés on bien été lu par le noyau Linux

cat /proc/cmdline



Modifié par Logicien le 07/05/2017 20:41
xDAML
 Posté le 07/05/2017 à 20:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Retour de fbset. En passant, le GRUB affichais la bonne résolution, mais pas l'interface graphique

EDIT: Voici ce qu'il y a dans le fichier cmdline

BOOT_IMAGE=/boot/vmlinuz-3.16.0-4-686-pae root=UUID=16e1bf85-89f4-4a2b-b884-b2383b058957 ro quiet video=inteldrmfb:1600x1200-24 quiet video=inteldrmfb:1600x1200-24



Modifié par xDAML le 07/05/2017 21:04
Logicien
 Posté le 07/05/2017 à 21:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

et que donne la commande

cat /proc/cmdline

Ok, si tu veux, tu peux essayer de commenter les deux dernières variables et refaire

sudo update-grub

et redémarrer. Tu peux alternativement commenter les deux premières variables et faire de même. J'ai configuré les princpiaux éléments qui concernent l'affichage côté Linux, je ne vois pas comment ils pourraient être en conflits.



Modifié par Logicien le 07/05/2017 21:24
xDAML
 Posté le 07/05/2017 à 21:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

La commande cat /proc/cmdline donne ce que je t'ai écris en citation.

Je fais les manips et te tiens au courant

xDAML
 Posté le 07/05/2017 à 22:00 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Cela n'a pas marché, ca marche sur l'écran de choix du système et sur le "Loading please wait" mais une fois au login, la résolution redeviens basse

Logicien
 Posté le 07/05/2017 à 22:08 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Puisque le paramètre video=inteldrmfb:1600x1200-24 se répète deux fois tu peux mettre en commentaire la ligne

#GRUB_CMDLINE_LINUX_DEFAULT="quiet video=inteldrmfb:1600x1200-24"

et faire

sudo update-grub

Peut-être dois-tu utiliser un noyau Linux version 4 plutôt que version 3 comme actuellement. C'est ce que j'ai du faire avec une carte graphique Nvidia pour qu'elle soit supportée par Linux. Avec les cartes Intel ça peut être différent. Pour mettre à jour le système avec un noyau version 4 tu crées ou édite le fichier

/etc/apt/preferences comme ceci:

Package: *linux*
Pin: release unstable
Pin-Priority: 1001

puis tu met à jour les dépôts et le système avec Synaptic ou avec

sudo apt-get update

sudo apt-get dist-upgrade

Puis redémarrer avec un noyau version 4.

Note: il faut avant tout ajouter les dépôts testing et unstable au fichier /etc/apt/sources.list . Voici le mien:

deb http://ftp.ca.debian.org/debian/ unstable main contrib non-free

deb-src http://ftp.ca.debian.org/debian/ unstable main contrib non-free

deb http://ftp.ca.debian.org/debian-security/ testing/updates main contrib non-free

deb http://ftp.ca.debian.org/debian/ testing main contrib non-free

deb-src http://ftp.ca.debian.org/debian-security/ testing/updates main contrib non-free

deb-src http://ftp.ca.debian.org/debian/ testing main contrib non-free

deb http://ftp.ca.debian.org/debian-security/ stable/updates main contrib non-free

deb http://ftp.ca.debian.org/debian/ stable main contrib non-free

deb-src http://ftp.ca.debian.org/debian-security/ stable/updates main contrib non-free

deb-src http://ftp.ca.debian.org/debian/ stable main contrib non-free

deb http://download.virtualbox.org/virtualbox/debian stretch contrib



Modifié par Logicien le 07/05/2017 23:32
Publicité
Pages : [1] 2 3 4 5 ... Fin
Page 1 sur 5 [Fin]

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
49,90 €Microphone USB Bird UM1 à 49,90 €
Valable jusqu'au 22 Février

Amazon fait une vente flash sur le Microphone USB Bird UM1 qui passe à 49,90 € alors qu'on le trouve ailleurs à partir de 69 €. La livraison est gratuite. Le Bird UM1 est un micro de studio d'excellente qualité avec interface USB intégrée. C'est une solution idéale et tout-en-un qui évite d'avoir à acheter un préampli ou une interface audio supplémentaire.  Idéal pour le studio, YouTube ou l'animation de votre blog.


> Voir l'offre
GratuitJeu PC Aztez gratuit
Valable jusqu'au 20 Février

Epic Game Store offre actuellement le jeu PC Aztez. Aztez est un jeu hybride unique, entre beat them all et stratégie au tour par tour, qui se déroule au sein de l'Empire aztèque. Mettez fin aux conflits qui ravagent votre empire en pleine expansion dans des combats beat them all en temps réel et hautement techniques.


> Voir l'offre
86,90 €Disque dur Western Digital Blue 4 To à 86,90 € livré
Valable jusqu'au 20 Février

Amazon Espagne propose actuellement le disque dur Western Digital Blue 4 To à 81,19 € (avec la TVA ajustée). Comptez 5,71 € pour la livraison en France soit un total de 86,90 € livré. Ce disque dur 3.5 pouces SATA III  tourne à 5400 tr/min. On le trouve ailleurs à partir de 100 €. Vous pouvez utiliser votre compte Amazon France sur Amazon Espagne et il n'y a pas de douane.


> Voir l'offre

Sujets relatifs
Pb avec la carte graphique : écran noir !
carte SD non reconnue, ajout 2è disque USB
Mint pilotes carte graphique
Carte wifi plus reconnue après mise à jour Debian Testing
Double écran Sur mint 14 avec carte Intel
ubuntu 12.04 et carte graphique
carte réseau sans fil non reconnue
pbl carte graphique sous ubuntu 9.04
problème de carte graphique ?
2 écrans sur une même carte graphique
Plus de sujets relatifs à Ecran ou carte graphique non reconnue + Pas de son
 > Tous les forums > Forum Linux