> Tous les forums > Forum Linux
 Ecran ou carte graphique non reconnue + Pas de sonSujet résolu
Ajouter un message à la discussion
Pages : 1 [2] 3 4 5 ... Fin
Page 2 sur 5 [Fin]
Logicien
 Posté le 07/05/2017 à 22:08 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Puisque le paramètre video=inteldrmfb:1600x1200-24 se répète deux fois tu peux mettre en commentaire la ligne

#GRUB_CMDLINE_LINUX_DEFAULT="quiet video=inteldrmfb:1600x1200-24"

et faire

sudo update-grub

Peut-être dois-tu utiliser un noyau Linux version 4 plutôt que version 3 comme actuellement. C'est ce que j'ai du faire avec une carte graphique Nvidia pour qu'elle soit supportée par Linux. Avec les cartes Intel ça peut être différent. Pour mettre à jour le système avec un noyau version 4 tu crées ou édite le fichier

/etc/apt/preferences comme ceci:

Package: *linux*
Pin: release unstable
Pin-Priority: 1001

puis tu met à jour les dépôts et le système avec Synaptic ou avec

sudo apt-get update

sudo apt-get dist-upgrade

Puis redémarrer avec un noyau version 4.

Note: il faut avant tout ajouter les dépôts testing et unstable au fichier /etc/apt/sources.list . Voici le mien:

deb http://ftp.ca.debian.org/debian/ unstable main contrib non-free

deb-src http://ftp.ca.debian.org/debian/ unstable main contrib non-free

deb http://ftp.ca.debian.org/debian-security/ testing/updates main contrib non-free

deb http://ftp.ca.debian.org/debian/ testing main contrib non-free

deb-src http://ftp.ca.debian.org/debian-security/ testing/updates main contrib non-free

deb-src http://ftp.ca.debian.org/debian/ testing main contrib non-free

deb http://ftp.ca.debian.org/debian-security/ stable/updates main contrib non-free

deb http://ftp.ca.debian.org/debian/ stable main contrib non-free

deb-src http://ftp.ca.debian.org/debian-security/ stable/updates main contrib non-free

deb-src http://ftp.ca.debian.org/debian/ stable main contrib non-free

deb http://download.virtualbox.org/virtualbox/debian stretch contrib



Modifié par Logicien le 07/05/2017 23:32
xDAML
 Posté le 07/05/2017 à 23:15 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Je fais ceci et je te tiens au courant

paul74
 Posté le 08/05/2017 à 08:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Slyvester a écrit :

Bonjour,

J'ai l'impression que - malgré la bonne volonté des intervenants/aidants - l'on tourne en rond pour une vieille machine dont la Mémoire-Ram est nettement insuffisante : 512 MB : https://www.cnet.com/products/dell-optiplex-gx620-business/specs/

Il est - à mon humble avis - très difficile, voire Impossible de faire tourner de façon satisfaisante une distribution Linux "normale" ou habituelle.En effet, celles-ci requièrent actuellement au moins 1024 MB ou 2048 MB ... Sans doute, faut-il abandonner Debian et se tourner vers un nouvelle installation avec une distribution Linux telle que PuppyLinux, ...

Bonjour,

Tout à fait d'accord !

Perso, j'avais installé Handylinux (Debian) sur mon vieux HP Pavilion avec 1 GB de RAM, j'avais plusieurs petits problèmes, dont celui du son, j'ai essayé diverses solutions, je ne suis jamais arrivé à remettre le son....

J'ai ajouté une barrette pour avoir 2 GB (le maxi possible sur ma CM), réinstallé Handylinux (même version) etcurieusement, je n'ai plus de problèmes...et en plus le fonctionnement du PC est devenu très confortable.

J'ai aussi un LinuxLite (Ubuntu) sur un autre vieux PC et 2 GB, là aussi tout fonctionne merveilleusement bien !

xDAML
 Posté le 08/05/2017 à 10:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Logicien a écrit :

Puisque le paramètre video=inteldrmfb:1600x1200-24 se répète deux fois tu peux mettre en commentaire la ligne

#GRUB_CMDLINE_LINUX_DEFAULT="quiet video=inteldrmfb:1600x1200-24"

et faire

sudo update-grub

Peut-être dois-tu utiliser un noyau Linux version 4 plutôt que version 3 comme actuellement. C'est ce que j'ai du faire avec une carte graphique Nvidia pour qu'elle soit supportée par Linux. Avec les cartes Intel ça peut être différent. Pour mettre à jour le système avec un noyau version 4 tu crées ou édite le fichier

/etc/apt/preferences comme ceci:

Package: *linux*
Pin: release unstable
Pin-Priority: 1001

puis tu met à jour les dépôts et le système avec Synaptic ou avec

sudo apt-get update

sudo apt-get dist-upgrade

Puis redémarrer avec un noyau version 4.

Note: il faut avant tout ajouter les dépôts testing et unstable au fichier /etc/apt/sources.list . Voici le mien:

deb http://ftp.ca.debian.org/debian/ unstable main contrib non-free

deb-src http://ftp.ca.debian.org/debian/ unstable main contrib non-free

deb http://ftp.ca.debian.org/debian-security/ testing/updates main contrib non-free

deb http://ftp.ca.debian.org/debian/ testing main contrib non-free

deb-src http://ftp.ca.debian.org/debian-security/ testing/updates main contrib non-free

deb-src http://ftp.ca.debian.org/debian/ testing main contrib non-free

deb http://ftp.ca.debian.org/debian-security/ stable/updates main contrib non-free

deb http://ftp.ca.debian.org/debian/ stable main contrib non-free

deb-src http://ftp.ca.debian.org/debian-security/ stable/updates main contrib non-free

deb-src http://ftp.ca.debian.org/debian/ stable main contrib non-free

deb http://download.virtualbox.org/virtualbox/debian stretch contrib

Cela ne semble pas avoir marche, la résolution est toujours minimale...

xDAML
 Posté le 08/05/2017 à 10:28 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

paul74 a écrit :
Slyvester a écrit :

Bonjour,

J'ai l'impression que - malgré la bonne volonté des intervenants/aidants - l'on tourne en rond pour une vieille machine dont la Mémoire-Ram est nettement insuffisante : 512 MB : https://www.cnet.com/products/dell-optiplex-gx620-business/specs/

Il est - à mon humble avis - très difficile, voire Impossible de faire tourner de façon satisfaisante une distribution Linux "normale" ou habituelle.En effet, celles-ci requièrent actuellement au moins 1024 MB ou 2048 MB ... Sans doute, faut-il abandonner Debian et se tourner vers un nouvelle installation avec une distribution Linux telle que PuppyLinux, ...

Bonjour,

Tout à fait d'accord !

Perso, j'avais installé Handylinux (Debian) sur mon vieux HP Pavilion avec 1 GB de RAM, j'avais plusieurs petits problèmes, dont celui du son, j'ai essayé diverses solutions, je ne suis jamais arrivé à remettre le son....

J'ai ajouté une barrette pour avoir 2 GB (le maxi possible sur ma CM), réinstallé Handylinux (même version) etcurieusement, je n'ai plus de problèmes...et en plus le fonctionnement du PC est devenu très confortable.

J'ai aussi un LinuxLite (Ubuntu) sur un autre vieux PC et 2 GB, là aussi tout fonctionne merveilleusement bien !

Peut être le matériel qui est trop ancien...En tout cas niveau RAM j'ai 2Go

Slyvester
 Posté le 08/05/2017 à 10:51 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

En tout cas niveau RAM j'ai 2Go

Je me suis basé sur ce qui est repris dans les spécifications du p.c. : https://www.cnet.com/products/dell-optiplex-gx620-business/specs/

soit 2 x 256 MB. Mais, avec 2 Go, c'est déjà beaucoup mieux.

j'avais installé Handylinux (Debian) sur mon vieux HP Pavilion avec 1 GB de RAM, j'avais plusieurs petits problèmes, ... J'ai ajouté une barrette pour avoir 2 GB (le maxi possible sur ma CM), réinstallé Handylinux (même version) et curieusement, je n'ai plus de problèmes...et en plus le fonctionnement du PC est devenu très confortable.
J'ai aussi un LinuxLite (Ubuntu) sur un autre vieux PC et 2 GB, là aussi tout fonctionne merveilleusement bien !

Merci, Paul74, pour ces explications qui m'intéressent beaucoup ! Cela va me permettra de faire des essais/modifications sur un vieux p.c. portable ayant des problèmes graphiques et que j'ai failli balancer à la décharge ...

xDAML
 Posté le 08/05/2017 à 11:38 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

D'accord

Slyvester
 Posté le 08/05/2017 à 12:13 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Re,

En tout cas niveau RAM j'ai 2Go

Ce n'est pas tout-à-fait ce qui est repris dans ta configuration ...

Configuration de xDAML PC de bureauUbuntu 16.04 x64Carte vidéo: ATI Radeon HD 4600 SeriesRAM: 6 GoDisque dur: 465 GoCPU: Intel Pentium CPU G620 2,60 GHz_________________________________________________________________PC portableCompaq Presario A900Linux Mint 18 Cinnamon x644 Go de RAMCapacité du disque dur: 111,1 GoIntel Pentium Dual CPU T2390 1,86 GHz

Publicité
xDAML
 Posté le 08/05/2017 à 12:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Je sais, la je traite une tour que j'ai récupéré. Dans ma config, c'est mon PC fixe principal

Logicien
 Posté le 08/05/2017 à 13:18 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

C'est quand même bizarre que tu ne puisses pas avoir la résolution désirée. Est-ce bien 1600x1200 que tu as avec Windows XP? En prenant pour acquit que tu as exactement le même matériel maintenant qu'avec Windows XP !? Peux-tu afficher la sortie de ces commandes

uname -a

cat /proc/cmdline

dmesg| grep inteldrmfb

Je suis à court d'idées.



Modifié par Logicien le 08/05/2017 13:28
xDAML
 Posté le 08/05/2017 à 13:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Voici ce que retourne les commandes

EDIT: je ne sais pas vu que j'ai récupéré la tour de chez un proche. Mais mon écran a une résolution de 1920x1080 (Je pense que cette résolution n'est pas supportée par la CG)



Modifié par xDAML le 08/05/2017 13:39
Logicien
 Posté le 08/05/2017 à 14:05 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

En tous cas, tu tournes présentement avec un noyau Linux 3.16.0-4-686-pae avec un doublon du paramètre video=. Cela veut dire que tu n'as pas suivi les étapes pour avoir un noyau version 4 et supprimer le paramètre doublon. La commande dmesg doit être précédée de sudo

sudo dmesg | grep inteldrmfb

Mon écran Samsung est reconnu en 1920x1080 par Debian testing, mais j'ai une carte graphique récente. Je vais voir les spécifications de ta carte graphique. Il existe de images CD/DVD/USB/SD de Debian testing. Peut-être essayer une installation de Debian testing si tu ne peux configurer Debian stable pour un noyau Linux testing/unstable. Sinon une autre distribution peut peut-être faire mieux.



Modifié par Logicien le 08/05/2017 14:07
xDAML
 Posté le 08/05/2017 à 14:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Pourtant, j'ai fais a la lettre ce que tu m'a dis... Je tape ta commande et te tiens au courant. JE vais aussi essayer Ubuntu MATE. Est-ce une bonne ou une mauvaise idée?

EDIT: Voila le retour de la commande



Modifié par xDAML le 08/05/2017 14:17
Logicien
 Posté le 08/05/2017 à 14:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Selon la sortie de la commande hwinfo --framebuffer de tantôt, la résolution maximale que supporte ta carte graphique est de 1600x1200. Il y a une autre façon de le savoir. Lors de l'affichage du menu de Grub2 tu presses la touche c pour accéder à l'interpréteur de commandes de Grub2 puis, tu exécutes la commande

videoinfo

Les résolutions supportées par le Bios devraient être affichées. Pour revenir au menu de Grub2, tu presses la touche Escape.

Je pense que tu devrais installer une distribution qui utilise un noyau Linux version 4. Je n'ai pas les détails des résolutions supportées par ta carte graphique dans les spécifications.

Sur mon Thinkpad T420, le Bios supporte la résolution maximale de 1600x1200, ce que Grub2 qui dépend du Bios utilise, mais Linux, avec le support i915, me donne la résolution maximale de l'écran 1920x1080. Donc, c,est vraiment le noyau Linux qui peut te donner la résolution maximale de ton écran.



Modifié par Logicien le 08/05/2017 14:59
xDAML
 Posté le 08/05/2017 à 15:24 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Voici le retour de la commande

EDIT: je vais tester Ubuntu MATE en live USB



Modifié par xDAML le 08/05/2017 15:24
xDAML
 Posté le 08/05/2017 à 15:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Je suis actuellement sous Ubuntu MATE, et j'ai toujours ce meme problème



Modifié par xDAML le 08/05/2017 15:55
Publicité
Logicien
 Posté le 08/05/2017 à 15:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

xDAML,

le type de connecteur qui relie l'écran à l'ordinateur influe sur les résolutions disponibles. Par exemple, lorsque la carte graphique Nvidia de ma tour est reliée par le port Hdmi au port Hdmi de mon écran Samsung, le Bios, Grub2 et Linux me donnent la résolution maximale de 1920x1080 de mon écran.

Par contre, lorsque la carte graphique Nvidia de ma tour est reliée par le port Vga au port Vga de mon écran Samsung, le Bios et Grub2 ne me donnent que 1600x1200 comme résolution maximale même si mon écran supporte jusqu'à 1920x1080. Mais Linux lui me donne quand même 1920x1080 en mode Vga.

J'imagine que ton vieil ordinateur n'a pas de connecteur Hdmi mais, si ton écran en a un, essai un adaptateur Hdmi vers Vga pour relier ton écran par port Hdmi vers le port Vga de ton ordinateur. Peut-être auras-tu une meilleure résolution. Il faut prévilégier le port Hdmi, suivi du Display Port et finalement Vga.



Modifié par Logicien le 08/05/2017 16:02
xDAML
 Posté le 08/05/2017 à 16:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Mon écran ne dispose pas de port HDMI...

Logicien
 Posté le 08/05/2017 à 16:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Que te retourne la commande (installer le paquet x11-xserver-utils au besoin)

xrandr

Est-ce que ton ordinateur possède seulement le port Vga pour l'affichage? As-tu regardé les options disponibles dans le Bios de ton ordinateur qui pourraient influer sur l'affichage? Essai au besoin un autre écran si possible.



Modifié par Logicien le 08/05/2017 16:11
xDAML
 Posté le 08/05/2017 à 16:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Même pas, il a un port DVI a la base, j'ai du mettre un convertisseur DVI vers VGA

Logicien
 Posté le 08/05/2017 à 16:12 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Que te retourne la commande (installer le paquet x11-xserver-utils au besoin)

xrandr

xDAML
 Posté le 08/05/2017 à 16:24 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Voila le retour de xrandr

Logicien
 Posté le 08/05/2017 à 16:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Sous Ubuntu, quelle version du noyau Linux as-tu?

uname -a

et quels sont les paramètres qui lui sont passés?

cat /proc/cmdline

et est-ce que Ubuntu utilise i915?

sudo dmesg | grep inteldrmfb

Je pense qu'à ce stade, tu pourrais faire une recherche sur le support Linux pour le modèle de ta tour. Peut-être auras-tu des solutions. Je ne comprend pas pourquoi la résolution maximale de ton écran n'est pas disponible. Peut-être est-ce dû au convertisseur Dvi vers Vga.



Modifié par Logicien le 08/05/2017 16:33
xDAML
 Posté le 08/05/2017 à 17:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Voila le retour des commandes

Logicien
 Posté le 08/05/2017 à 17:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Et que donne avec un noyau version 4 la commande (installer hwinfo au besoin)

sudo hwinfo --framebuffer

Si la résolution 1600x1200 s'affiche essai de modifier le fichier /etc/default/grub comme tantôt en n'oubliant pas de faire

sudo update-grub

et de redémarrer. Je pense que le problème restera parce-qu'il est matériel plutôt que logiciel.



Modifié par Logicien le 08/05/2017 17:11
Publicité
Pages : 1 [2] 3 4 5 ... Fin
Page 2 sur 5 [Fin]

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
9,99 €Bloc multiprise parasurtenseur BRENNENSTUHL 8 prises à 9,99 €
Valable jusqu'au 29 Février

Amazon fait une promotion sur le bloc multiprise parasurtenseur BRENNENSTUHL avec 8 prises à orientation interversée qui passe à 9,99 € au lieu de 20 €. Le câble fait 1,4 m.


> Voir l'offre
329,90 €Ecran ultra large LG 34 pouces 34WL50S-B à 329,90 €
Valable jusqu'au 03 Mars

Amazon propose actuellement l'écran 34 pouces LG 34WL50S-B à 329,90 € livré gratuitement alors qu'on le trouve à partir de 400 € ailleurs. Cet écran ultra large est au format 21/9, possède une dalle IPS et offre une résolution de 2560 x 1080 pixels. Avec lui, vous pourrez bénéficier d'une plus grande immersion dans les jeux et les films. Cet écran est compatible FreeSync.


> Voir l'offre
141,50 €Disque dur externe Western Digital Elements Desktop USB 3.0 8 To à 141,50 € livré
Valable jusqu'au 29 Février

Amazon Allemagne propose actuellement le disque dur externe Western Digital Elements Desktop USB 3.0 8 To à 135,13 € (avec la TVA ajustée) Comptez 6,37 € pour la livraison en France (gratuite en Belgique) soit un total de 141,50 livré. On le trouve ailleurs à partir de 210 €. Ce disque dur dispose d'un grande capacité de stockage (8 To) et d'une connectique USB 3.0 qui vous offrira des transferts rapides. Il est compatible USB 2.0. Une très bonne affaire. 

Vous pouvez utiliser votre compte Amazon France sur Amazon Allemagne et il n'y a pas de douanes. Si vous êtes perdu en allemand, vous pouvez traduire le site en anglais.


> Voir l'offre

Sujets relatifs
Pb avec la carte graphique : écran noir !
carte SD non reconnue, ajout 2è disque USB
Mint pilotes carte graphique
Carte wifi plus reconnue après mise à jour Debian Testing
Double écran Sur mint 14 avec carte Intel
ubuntu 12.04 et carte graphique
carte réseau sans fil non reconnue
pbl carte graphique sous ubuntu 9.04
problème de carte graphique ?
2 écrans sur une même carte graphique
Plus de sujets relatifs à Ecran ou carte graphique non reconnue + Pas de son
 > Tous les forums > Forum Linux