> Tous les forums > Forum Linux
 Ecran ou carte graphique non reconnue + Pas de sonSujet résolu
Ajouter un message à la discussion
Pages : Début ... 1 2 [3] 4 5 ... Fin
[Début] Page 3 sur 5 [Fin]
xDAML
 Posté le 08/05/2017 à 17:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Retour de hwinfo --framebuffer:

02: None 00.0: 11001 VESA Framebuffer
[Created at bios.459]
Unique ID: rdCR.0JA8akUvXT7
Hardware Class: framebuffer
Model: "Intel(r)Lakeport-G Graphics Controller"
Vendor: "Intel Corporation"
Device: "Intel(r)Lakeport-G Graphics Controller"
SubVendor: "Intel(r)Lakeport-G Graphics Chip Accelerated VGA BIOS"
SubDevice:
Revision: "Hardware Version 0.0"
Memory Size: 7 MB + 704 kB
Memory Range: 0xe0000000-0xe07affff (rw)
Mode 0x0361: 848x480 (+1728), 16 bits
Mode 0x0362: 848x480 (+3392), 24 bits
Mode 0x033a: 1600x1200 (+1600), 8 bits
Mode 0x034b: 1600x1200 (+3200), 16 bits
Mode 0x035a: 1600x1200 (+6400), 24 bits
Mode 0x0307: 1280x1024 (+1280), 8 bits
Mode 0x031a: 1280x1024 (+2560), 16 bits
Mode 0x031b: 1280x1024 (+5120), 24 bits
Mode 0x0305: 1024x768 (+1024), 8 bits
Mode 0x0317: 1024x768 (+2048), 16 bits
Mode 0x0318: 1024x768 (+4096), 24 bits
Mode 0x0312: 640x480 (+2560), 24 bits
Mode 0x0314: 800x600 (+1600), 16 bits
Mode 0x0315: 800x600 (+3200), 24 bits
Mode 0x0301: 640x480 (+640), 8 bits
Mode 0x0303: 800x600 (+832), 8 bits
Mode 0x0311: 640x480 (+1280), 16 bits
Config Status: cfg=new, avail=yes, need=no, active=unknown

EDIT: Je suis en Live-USB...Je ne pense pas que les modifs soient prises en compte. Et pourquoi materiel? LA CG marche parfaitement sous XP (J'ai eu l'occasion d'utiliser cet ordi sous XP)



Modifié par xDAML le 08/05/2017 17:33
Logicien
 Posté le 08/05/2017 à 17:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Je cherche encore une solution à ton problème. J'avais oublié mais le module i915 doit être préférablement inclus dans l'initramfs. Pour ce faire, édite le fichier /etc/initramfs-tools/modules et si le module i915 n'apparaît pas sur une ligne ajoute le

i915

Sauvegarde et exécute la commande

sudo update-initramfs -k all -u

Surveille si la commande ne se plaint pas du manque de fichiers firmwares.

En ce qui concerne le paramètre video= du noyau Linux tu peux essayer

video=VGA-1:1600x1200

dans le fichier /etc/default/grub plutôt que video=inteldrmfb:1600x1200-24. Il faut redémarrer dans chacun des cas. Alternativement tu peux essayer

vga=035a

pour le code hexadécimal de 1600x1200 en 24 bits. Mais là, ce paramètre n'est plus supporté et tu pourrais avoir un message d'erreur. En tous cas, si tu réussis à avoir cette résolution côté Linux, tu l'auras côté Xorg.



Modifié par Logicien le 08/05/2017 17:57
xDAML
 Posté le 08/05/2017 à 18:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Voivi ce que donne la MaJ de initramfs:

xDAML
 Posté le 08/05/2017 à 18:56 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

La bonne résolution s'est mise pendant la séquence de démarrage, puis elle est redevenu minimale au login

Logicien
 Posté le 08/05/2017 à 19:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Ok, il y a donc du progrès. Fait Ctrl+Alt+ F2 sous Ubuntu, ouvre une session root et fait

fbset

afin de voir quelle est la résolution qu'utilise le noyau Linux. Peut-être faut-il installer le paquet fbset d'abord. Aussi fait dans un terminal graphique

xrandr

Note: tu peux obtenir la sortie de la commande fbset sans ouvrir de session dans un terminal Linux mais seulement depuis un terminal graphique sous X.



Modifié par Logicien le 08/05/2017 19:34
xDAML
 Posté le 08/05/2017 à 20:13 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Comment on fait pour se loguer en root en live-usb?

EDIT: j'ai trouvé et voila le retour de fbset:

Et celui de xrandr:



Modifié par xDAML le 08/05/2017 20:23
Logicien
 Posté le 08/05/2017 à 20:37 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Il faut utiliser sudo pour donner un mot-de-passe à root. Exemple

sudo passwd root

et tu suis les étapes.

Si tu changes de distribution sans arrêt, ça va être difficile de savoir ce qu'on fait. Si tu dis que tu as la résolution 1600x1200 sous Xp avec la même configuration matérielle, c'est peut-être que Linux utilise le mode VGA alors qu'il devrait utilise le mode DVI.

On peut forcer Linux à utiliser un type de connecteur plutôt qu'un autre par défaut. Il faut que tu explores toutes les avenues du paramètre Linux video=. Par exemple pour désactiver le mode VGA tu passes en paramètre au noyau Linux

video=VGA-1:d

Pour activer le mode DVI

video=DVI-A-1:e

Il y a deux types de connecteurs DVI, DVI-A et DVI-I. Ce pourrait être

video=DVI-I-1:e

On peut passer deux fois le paramètre video=au noyau Linux. Exemple

video=VGA-1:d video=DVI-A-1:e

ou

video=VGA-1:d video=DVI-I-1:e

Renseigne-toi car une faute de syntaxe et/ou un paramètre approprié peut te donner un écran noir.

En tous cas, c'est important que le module i915 soit dans l'initramfs avec n'importe quelle distribution parce-que les firmwares sont alors présent dans l'initramfs qui est utilisée comme système de fichiers racine lors de la première détection du matériel. Avec Debian, je dois ajouter moi-même la ligne i915 dans le fichier /etc/initramfs-tools/modules et refaire l'initramfs

update-initramfs -k all -u



Modifié par Logicien le 08/05/2017 20:44
xDAML
 Posté le 08/05/2017 à 20:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Logicien a écrit :

Avec les distributions basées sur Ubuntu, il faut utiliser sudo pour donner un mot-de-passe à root. Exemple

sudo passwd root

et tu suis les étapes. Si tu change de distribution sans arrêt, ça va être difficile de savoir ce qu'on fait. Si tu dis que tu as la résolution 1600x1200 sous Xp avec la même configuration matérielle, c'est peut-être que Linux utilise le mode VGA alors qu'il devrait utilise le mode DVI.

On peut forcer Linux à utiliser un type de connecteur plutôt qu'un autre par défaut. Il faut que tu explore toutes les avenues du paramètre Linux video=. Par exemple pour désactiver le mode VGA tu passes en paramètre au noyau Linux

video=VGA-1:d

Pour activer le mode DVI

video=DVI-A-1:e

Il y a deux types de connecterus DVI, DVI-A et DVI-I. Ce pourrait être

video=DVI-I-1:e

En tous cas, c'est important que le module i915 soit dans l'initramfs avec n'importe quelle distribution parce-que les firmwares sont alors présent dans l'initramfs qui est utilisée comme système de fichiers racine lors de la première détection du matériel. Avec Debian, je dois ajouter moi-même la ligne i915 dans le fichier /etc/initramfs-tools/modules et refaire l'initramfs

update-initramfs -k all -u

En fait, j'ai juste testé Ubuntu MATE avec un live USB. JE suis toujours sous Debian

Je fais tes manips et te tiens au courant

Publicité
Logicien
 Posté le 08/05/2017 à 20:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Relie mon dernier message, je l'ai édité, je part pour quelques heures. Sujet intéressant.

xDAML
 Posté le 08/05/2017 à 20:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

D'accord. J'aurais juste une question: Comment passer en paramètres du noyau Linux?

Logicien
 Posté le 09/05/2017 à 01:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Les paramètres qui me semblent intéressant sont

video=VGA-1:1600x1200

video=VGA-1:d

Le premier paramètre vise l'utilisation du port VGA avec la résolution 1600x1200. Le second vise à désactiver le port VGA et permettre à un autre port graphique, par exemple le port DVI, d'être celui utilisé par défaut par Linux. Enfin,

video=DVI-A:e

et

video=DVI-I:e

visent explicitement à activer le port DVI. Il faut éditer le fichier /etc/default/grub et passer ce paramètre à la variable GRUB_CMDLINE_LINUX. Exemples

GRUB_CMDLINE_LINUX="video=VGA-1:1600x1200"

GRUB_CMDLINE_LINUX="video=VGA-1:d"

GRUB_CMDLINE_LINUX="video=DVI-A:e"

GRUB_CMDLINE_LINUX="video=DVI-I:e"

Ces combinaisons sont aussi possibles:

GRUB_CMDLINE_LINUX="video=VGA-1:d video=DVI-A:e"

GRUB_CMDLINE_LINUX="video=VGA-1:d video=DVI-I:e"

À essayer à tour de rôle. Il faut à chaque modification de la variable GRUB_CMDLINE_LINUX faire

sudo update-grub

et redémarrer. Après redémarrage il faut vérifier que le paramètre a bien été passé au noyau Linux avec

cat /proc/cmdline

et voir la résolution du noyau et d'Xorg avec les commandes

fbset

xrandr

Si tu es familier avec la ligne de commandes de Grub2, tu peux à l'affichage du menu de Grub2 presser la touche e pour éditer l'entrée sélectionnée et modifier à la volée les paramètres qui s'affichent. Faire Ctrl+x pour exécuter l'entrée ou Escape pour revenir au menu original et abandonner les modifications. Éditer manuellement une entrée est utile quand un paramètre empêche le démarrage normal et ne peut être modifié autrement qu'à partir d'un autre système Linux, un média live par exemple.

Je pense que tu as du pain sur la planche.



Modifié par Logicien le 09/05/2017 01:54
xDAML
 Posté le 09/05/2017 à 12:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

En effet

N'ayant pas le PC sous la main, je ferais ca ce soir

xDAML
 Posté le 09/05/2017 à 18:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Voici le retour des commandes, en précisant que j'en suis toujours au même point

Logicien
 Posté le 09/05/2017 à 20:42 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bien, pour la première fois il me semble la résolution du côté Linux est en 1600x1200. Si je vois bien, c'est là une victoire.

Par contre, il faudrait que tu enlêves le paramètre video=DVI-I:e du fichier /etc/default/grub pour ne garder que

GRUB_CMDLINE_LINUX="video=VGA-1:1600x1200"

Ça m'étonne que Linux utilise 1600x1200 alors qu'Xorg n'offre que 1024x768 comme résolution maximale.

Si tu veux essayer cette combinaison pour forcer l'Utilisation du port DVI, édite /etc/default/grub comme ceci:

GRUB_CMDLINE_LINUX="video=VGA-1:d video=DVI-1:1600x1200"

Mai là, je ne garantie pas que ça va marcher. La syntaxe pour le port DVI n'est pas claire. Il faudra peut être que tu remettres à la volée le paramètre video=VGA-1:1600x1200 seul depuis le menu de Grub2 avant de rééditer le fichier /etc/default/grub pour revenir avec

GRUB_CMDLINE_LINUX="video=VGA-1:1600x1200"

Je pars pour quelques heures.



Modifié par Logicien le 09/05/2017 21:00
xDAML
 Posté le 09/05/2017 à 21:17 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Pour l'instant, rien n'a changé, malgré les modifications

Logicien
 Posté le 10/05/2017 à 00:42 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

xDAML,

si la sortie de la commande fbset affiche toujours 1600x1200 c'est que Linux comprend la paramètre video=VGA-1:1600x1200 . C'était mon but premier. Le paramètre video=inteldrmfb:1600x1200-24 n'ayant pas été reconnu cela explique probablement pourquoi Xorg reste en 1024x768. Il y a des solutions. L'une d'elles est d'utiliser le module modesetting d'Xorg plutôt que le module intel. Pour ce faire, il faut créer le répertoire /etc/X11/xorg.conf.d s'il n'existe pas

sudo mkdir /etc/X11/xorg.conf.d

puis, créer avec les droits root le fichier /etc/X11/xorg.conf.d/modesetting.conf avec ce contenu:

Section "Device"
BoardName "VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])"
# BusID ""
Driver "modesetting"
Identifier "Modesetting"
Option "AccelMethod" "glamor"
VendorName "Intel Corporation"
EndSection

puis, redémarrer Debian ou fermer sa session graphique et retourner à l'invite de connexion graphique. Se reconnecter et faire encore

cat /proc/cmdline

fbset

xrandr



Modifié par Logicien le 10/05/2017 00:49
Publicité
xDAML
 Posté le 10/05/2017 à 16:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Voici le retour des commandes

Logicien
 Posté le 10/05/2017 à 17:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Supprime le fichier

sudo rm -f /etc/X11/xorg.conf.d/modesetting.conf

Crée le fichier /etc/X11/xorg.conf.d/intel.conf avec ce contenu

Section "Device"
BoardName "VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])"
Driver "intel"
Identifier "Intel"
Option "AccelMethod" "UXA"
Option "SwapbuffersWait" "off"
Option "VSync" "off"
VendorName "Intel Corporation"
EndSection

Section "Monitor"
Identifier "Moniteur 0"
VendorName "À remplir"
HorizSync 0-100
VertRefresh 0-100
ModelName "À emplir"
Option "DPMS"
#ModeLine "1600x1200" 132.000 1600 1608 1672 1776 1200 1205 1215 1239 +hsync +vsync
EndSection

Sauvegarde et redémarre le système. Si xrandr ne te donne pas 1600x1200 décommente la ligne du fichier /etc/X11/xorg.conf.d/intel.conf en enlevant le # . Sauvegarde et redémarre. Affiche

cat /proc/cmdline

fbset

xrandr



Modifié par Logicien le 10/05/2017 17:44
xDAML
 Posté le 10/05/2017 à 18:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Voila le retour des commandes. Je crois qu'il n'y a pas du mieux

Logicien
 Posté le 11/05/2017 à 00:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Édite le fichier /etc/default/grub pour n'avoir qu'une seule variable GRUB_CMDLINE_LINUX= avec comme seule valeure video=VGA-1:1600x1200 . Il ne faut pas que le paramètre video= apparaisse plus d'une fois dans le fichier. La ligne doit se présenter comme ceci:

GRUB_CMDLINE_LINUX="video=VGA-1:1600x1200"

Sauvegarde et fait

update-grub

Je dois dire que je sèche à comprendre pourquoi le noyau Linux utilise la résolution 1600x1200 alors qu'Xorg ne veut pas dépasser 1024x768

Sans être devant l'ordinateur ça ne simplifie pas les choses. Je pense que tu devras continuer par toi-même. Il y a tellement de détails et de variations de paramètres que je te félicite d'avoir tenu le coup jusqu'à présent.

xDAML
 Posté le 11/05/2017 à 19:51 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

J'ai appliqué la commande mais le problème persiste...

Logicien
 Posté le 12/05/2017 à 05:15 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Il y a encore 2 possibilités qu'on peut explorer si tu veux. Il s'agit d'utiliser le module framebuffer d'Xorg. Linux utilise 1600x1200 pour son framebuffer et Xorg peut utiliser le framebuffer de Linux pour l'affichage graphique grâce au module fbdev. Tu fais en copier/coller

sudo rm -f /etc/X11/xorg.conf.d/{intel.conf,modesetting.conf}

Tu crées ensuite le fichier /etc/X11/xorg.conf.d/fbdev.conf avec ce contenu

Section "Device"
BoardName "VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])"
#BusID ""
Driver "fbdev"
Identifier "Fbdev"
VendorName "Intel Corporation"
EndSection

Tu sauvegardes et tu redémarres l'ordinateur. Tu fais au terminal graphique

sudo dmesg | grep -i -e fb -e i915 -e intel

cat /proc/cmdline

fbset

xrandr

Si la sortie de la commande xrandr n'offre pas 1600x1200 tu peux encore faire ce qui suit pour essayer de forcer le module i915 de Linux à utiliser 1600x1200 comme résolution. Mais je doute que ça fonctionne

sudo rm -f /etc/X11/xorg.conf.d/{fbdev.conf,intel.conf,modesetting.conf}

Tu édites le fichier /etc/default/grub et tu remplaces la ligne

GRUB_CMDLINE_LINUX="video=VGA-1:1600x1200"

par

GRUB_CMDLINE_LINUX="video=inteldrmfb:1600x1200"

Tu sauvegardes et exécutes la commande

sudo update-grub

Tu redémarres et affiches la sortie de ces commandes

sudo dmesg | grep -i -e fb -e i915 -e intel

cat /proc/cmdline

fbset

xrandr



Modifié par Logicien le 12/05/2017 15:01
xDAML
 Posté le 12/05/2017 à 20:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Voici le retour des commandes, en précisant que cette fois, ca a marché . Mais par contre, qu'est ce que ca rame ! Même sous XP je n'avais pas cela

EDIT: J'ai trouvé un pilote pour ma carte graphique. Or, c'est un tar.bz2 avec plein de fichiers *, dont un main.c. Il faudrais -je pense- le compiler, mais comment?



Modifié par xDAML le 12/05/2017 20:15
Logicien
 Posté le 13/05/2017 à 09:13 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Il y a du progrès. Pour la première fois Xorg utilise la résolution 1600x1200 mais, comme le pilote I915 de Linux n'offre aucune accélération matérielle, quand Xorg utilise le pilote video de Linux via le module fbdev, lui aussi n'offre aucune accélération matérielle. Efin, pour l'essentiel ça peut passer.

Avant de compiler et d'installer quoique ce soit en dehors d'APT et dpkg, assure-toi de quel pilote il s'agit. Il est peut-être déjà installé ou installable via le gestionnaire de paquets de Debian. Fait des tests graphiques en 1600x1200 pour voir si ça te satisfait. Toutes les possibilités d'améliorations n'ont pas encore été épuisées.

Si tu as la page de référence du fichier bz2, j'aimerais la voir.



Modifié par Logicien le 13/05/2017 09:16
xDAML
 Posté le 14/05/2017 à 20:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Désolé de l'absence, je n'értais pas la ce week-end.

Voila l'adresse du fichier: https://www.x.org/archive/individual/driver/xf86-video-intel-2.99.906.tar.bz2

Publicité
Pages : Début ... 1 2 [3] 4 5 ... Fin
[Début] Page 3 sur 5 [Fin]

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
11,07 €Clé USB 3.0 Kingston DataTraveler 50 64 Go à 11,07 €
Valable jusqu'au 20 Février

Amazon vous propose actuellement la clé USB 3.0 Kingston DataTraveler 50 DT50 64 Go à 11,07 €. La livraison est gratuite.


> Voir l'offre
599,99 €Portable 15,6 pouces HP (FullHD, Core i5, 8 Go, SSD 128 Go + DD 1 To, GTX 1050 3 Go) à 599,99 €
Valable jusqu'au 18 Février

Cdiscount fait une belle promotion sur l'ordinateur portable HP Pavilion 15-bc511nf qui passe à 599,99 € livré gratuirement alors qu'on le trouve ailleurs autour de 700 €. Ce portable possède un écran 15,6 pouces HD Full HD (1920x1080), un processeur Intel Core i5 9300H, 8 Go de RAM, un SSD de 128 Go, un disque dur de 1 to et une carte graphique dédiée GeForce GTX 1050 3 Go. Le tout tourne sous Windows 10.


> Voir l'offre
30,17 €SSD SanDisk Plus 240 Go à 30,17 €
Valable jusqu'au 18 Février

Amazon propose actuellement le SSD SanDisk Plus 240 Go à 30,17 € livré gratuitement. Une bonne affaire pour ce SSD très fiable et performant qui offre des débits de 530 Mo/s en lecture et 445 Mo/s en écriture. Il est garanti 3 ans. On le trouve ailleurs à partir de 42 €.


> Voir l'offre

Sujets relatifs
Pb avec la carte graphique : écran noir !
carte SD non reconnue, ajout 2è disque USB
Mint pilotes carte graphique
Carte wifi plus reconnue après mise à jour Debian Testing
Double écran Sur mint 14 avec carte Intel
ubuntu 12.04 et carte graphique
carte réseau sans fil non reconnue
pbl carte graphique sous ubuntu 9.04
problème de carte graphique ?
2 écrans sur une même carte graphique
Plus de sujets relatifs à Ecran ou carte graphique non reconnue + Pas de son
 > Tous les forums > Forum Linux