× Aidez la recherche contre le COVID-19 avec votre ordi ! Rejoignez l'équipe PC Astuces Folding@home
 > Tous les forums > Forum Bureautique
 erreur dans une formule sur excelSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
mistigette84
  Posté le 25/11/2007 @ 20:50 
Aller en bas de la page 
Nouvelle astucienne

je n'arrive pas à enlever #Valeur dans une cellule ça fait plusieurs jours que je cherche et je finis par comme lui

Publicité
kleretnet
 Posté le 25/11/2007 à 21:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maîtresse astucienne

à faire déplacer par les modérateur en cliquant sur le triangle jaune et demander à mettre sur le forum bureautique.
triode94
 Posté le 25/11/2007 à 21:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Bonjour et bienvenue sur PCA.

Tu n'es pas dans le bon forum. Clique sur le triangle jaune et demande au modérateur de déplacer ta question sur le forum bureautique.

Maintenant si tu ne donnes pas plus d'explication sur ta formule, le type de tes cellules, etc, il sera difficile de te répondre utilement.

kristian_wsl
 Posté le 25/11/2007 à 21:37 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

nidan55
 Posté le 25/11/2007 à 21:39 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Faut aussi nous donner ta formule. Sans explication on aura du mal à t'aider !
mistigette84
 Posté le 25/11/2007 à 22:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvelle astucienne
Message original par mistigette84

je n'arrive pas à enlever #Valeur dans une cellule ça fait plusieurs jours que je cherche et je finis par comme lui


Formule en F6 =SI((E6>160;E6-130)*H8/100*1.524

Formule en E6 =(H8=0;"";E6/H8)

Formule en H8 =SOMME(H9:H23)

Formule en F1 =F6

pcastuces
 Posté le 25/11/2007 à 23:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Equipe PC Astuces
Sujet déplacé par la modération

Vous pouvez continuer la discussion à la suite.
galopin01
 Posté le 26/11/2007 à 00:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

bonjour,

Les 2 premières formules sont fausses et incompréhensibles. Il me parait souhaitable de nous mettre une pièce jointe (contenant des données numériques vraisemblables et un petit commentaire indiquant la fourchette des valeurs vraisemblables)

Veuillez utiliser cjoint et nous donner le lien

A+



Modifié par galopin01 le 26/11/2007 00:42
vieuxmonsieur
 Posté le 26/11/2007 à 02:46 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour kristian_wsl, nidan55, galoopin01, mistigette84, le forum,

Un essai (si j'ai bien compris) en F6 :

=SI(ET(E6<>0;E6>160);E6-130*(H8/100)*1,524;"")

Bonne journée à vous

Publicité
galopin01
 Posté le 26/11/2007 à 07:56 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bah !

On peut aussi enlever la formule. Carrément !

Plus sérieusement :

Je n'arrive pas à enlever #Valeur dans une cellule : Laquelle ?

Les 2 premières formules n'ont pas de sens aussi il est difficile de donner une réponse sans dénaturer la condition...
F6 =SI((E6>160;E6-130)*H8/100*1.524

La syntaxe générale est :

= SI(Condition; RésultatSiVrai; RésultatSiFaux)

Comme il y a 3 parenthèses dans ta formule et un seul ; on peut penser que... la condition est E6>160 mais il est difficile d'imaginer les résultats attendus.

F6 =SI(E6>160; E6-130*H8/100*1.524; "?" )

...mais ce n'est qu'une hypothèse parmi tant d'autres !


Pour la deuxième formule :

E6 =(H8=0;"";E6/H8) La formule faisant référence à elle, même difficile d'imaginer la bonne cible !

Comme on retrouve la structure ( ; ; ) on peut penser qu'il manque un SI . ça donnerait quelque chose comme :

E6 =SI(H8=0; ""; ?/H8)

A+

nidan55
 Posté le 26/11/2007 à 09:15 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Soyons positifs !

Les deux là sont justes :

Formule en H8 =SOMME(H9:H23)

Formule en F1 =F6

mistigette84
 Posté le 26/11/2007 à 19:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvelle astucienne
Message original par mistigette84

je n'arrive pas à enlever #Valeur dans une cellule ça fait plusieurs jours que je cherche et je finis par comme lui


j'ai envoyé le tableau avec mes formules dans les cellules, est ce que ce sera plus clair

nidan55
 Posté le 26/11/2007 à 20:39 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Si tu donnes l'adresse du fichier, un lien, oui ce sera plus clair !
mistigette84
 Posté le 27/11/2007 à 15:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvelle astucienne
Message original par mistigette84

je n'arrive pas à enlever #Valeur dans une cellule ça fait plusieurs jours que je cherche et je finis par comme lui


j'ai envoyé le tableau avec les formules sur http://cjoint.com/?IBprkpkmGI

gilbert_rgi
 Posté le 27/11/2007 à 16:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour

Le lien n'est pas disponible !!!!

Cdlt

RGI



Modifié par gilbert_rgi le 27/11/2007 16:07
sourisdeservice
 Posté le 27/11/2007 à 16:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grande Maîtresse astucienne

bonjour mistigette,

un p'tit effort pour plus de précision

Clique sur l'icône prévisualisation (la dernière) quand tu rédiges et teste ton lien avant de le publier

mistigette84
 Posté le 27/11/2007 à 16:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvelle astucienne
Message original par mistigette84

je n'arrive pas à enlever #Valeur dans une cellule ça fait plusieurs jours que je cherche et je finis par comme lui


http://cjoint.com/?lBqVMliB0A j'ai suivi tes conseils sourisdeservice, ça marche desolé mais c'est la 1ère fois que je fais ça.

Merci de votre patience

Publicité
usularrakis
 Posté le 27/11/2007 à 17:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

salut

voici la formule qui retourne #Valeur :

= SI( (A6)>160;A6-160)*D8/100*1,524

elle n'est pas correcte il manque 1 argument pour la fonction SI et il y a une ( en trop

si A6 > 160 ça doit donner A6-160 mais sinon quel est le résutat attendu

regarde ce qu'a écrit Galopin plus haut sur la fonction SI

ferrand
 Posté le 27/11/2007 à 22:28 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

Je suppose que tu as voulu écrire cette formule en B6 : =SI(A6>160;(A6-160)*D8/100*1,524;"")

Même rectifiée, elle renverra #VALEUR parce que A6 contient "" (qui n'est pas un nombre). Il faut donc la modifier comme suit pour que la cellule ne renvoie pas d'erreur : =SI(N(A6)>160;(A6-160)*D8/100*1,524;"")

Si c'est bien la formule que tu souhaitais, il te faudra aussi rectifier les autres cellules concernées de la même façon.

Quant à la cellule F1, pour régler le même problème, il faut (après rectification des formules contenues dans les cellule additionnées) utiliser somme au lieu de l'opérateur +, soit :
=SOMME(B6;F6;J6;N6;R6;B28;F28;J28;N28;R28)



Modifié par ferrand le 27/11/2007 22:32
mistigette84
 Posté le 28/11/2007 à 06:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvelle astucienne
ferrand a écrit :

Bonjour,

Je suppose que tu as voulu écrire cette formule en B6 : =SI(A6>160;(A6-160)*D8/100*1,524;"")

Même rectifiée, elle renverra #VALEUR parce que A6 contient "" (qui n'est pas un nombre). Il faut donc la modifier comme suit pour que la cellule ne renvoie pas d'erreur : =SI(N(A6)>160;(A6-160)*D8/100*1,524;"")

Si c'est bien la formule que tu souhaitais, il te faudra aussi rectifier les autres cellules concernées de la même façon.

Quant à la cellule F1, pour régler le même problème, il faut (après rectification des formules contenues dans les cellule additionnées) utiliser somme au lieu de l'opérateur +, soit :
=SOMME(B6;F6;J6;N6;R6;B28;F28;J28;N28;R28)


Je vais essayer et te tiendrais au courant.

Merci pour ton aide

galopin01
 Posté le 28/11/2007 à 09:15 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

ya p'têt d'autres options possibles mébon...

Les colonnes DIMPT sont inutiles (et les formules fausses) si on veut le temps en minute, il suffit de mettre le format personnalisé [mm] sur les cellules C9 et suivantes et mettre le total en C8.

Il est inutile d'afficher un total à 8 décimales : Même si on n'affiche pas les décimales, Excel les totalise quand même.

A+

ferrand
 Posté le 28/11/2007 à 19:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Fichtre, tu as pris le temps de regarder en détail. J'ignore absolument le contenu et je n'ai pas conservé le classeur...
mistigette84
 Posté le 28/11/2007 à 19:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvelle astucienne

j 'ai mis en place les formules de ferrand et ca marche comme je veux , ce soir je peux drmir comme un bébé.

encore merci et a plus

Publicité
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
92,89 €Enceinte connectée Amazon Echo avec Alexa + 2 ampoules connectées Philips Hue White à 92,89 €
Valable jusqu'au 28 Mai

Amazon propose l'enceinte Echo de 3ème génération accompagnée de 2 ampoules Philips Hue White E27 à 92,89 € (au lieu de 129,99 €). L'appareil piloté par la voix fonctionne avec Alexa, l’intelligence artificielle développée par Amazon. Vous pourrez avec elle écouter de la musique, interagir avec vos appareils domotiques dont les 2 ampoules fournies (pour allumer et éteindre la lumière à la voix), écouter les infos, la radio, connaître la météo et d’accéder à des milliers d’autres possibilités grâce aux Skills : recettes de cuisine, petits jeux, etc. Par rapport à la génération précédente, le son est amélioré et l'enceinte arbore un nouveau design. L'enceinte est équipée du son Dolby qui remplira la pièce d'un son immersif et omnidirectionnel, avec des voix nettes, des basses profondes et des aigus clairs à volume élevé. Grâce à ses sept microphones, ses technologies de beamforming et de réduction du bruit, Amazon Echo vous entend où que vous soyez dans la pièce, même lorsqu'il y a de la musique. 


> Voir l'offre
99 €Ring Video Doorbell 2 à 99 €
Valable jusqu'au 27 Mai

Boulanger fait une promotion sur la sonnette / caméra connectée Ring Video Doorbell 2 qui passe à 99 € livrée gratuitement alors qu'on le trouve habituellement à partir de 199 €. Veillez sur votre maison et répondez à la porte depuis votre téléphone, votre tablette ou votre ordinateur grâce à la sécurité nouvelle génération de Ring Video Doorbell 2. Ring vous envoie des alertes lorsque quelqu’un se présente à votre porte, de sorte que vous pouvez voir, entendre et parler aux visiteurs depuis n’importe où.


> Voir l'offre
63,71 €Disque dur Seagate BarraCuda 2 To à 63,71 € livré
Valable jusqu'au 26 Mai

Amazon Espagne propose actuellement le disque dur Seagate BarraCuda - 2 To (ST2000DM008) à 58,50 €Comptez 5,21 € pour la livraison en France soit un total de 63,71 € livré. On le trouve ailleurs autour de 79 €. Ce disque dur 3.5 pouces SATA III tourne à 7200tr/min et possède 256 Mo de cache. Vous pouvez utiliser votre compte Amazon France sur Amazon Espagne et il n'y a pas de frais de douane. 


> Voir l'offre

Sujets relatifs
une erreur dans la formule de calcul avec excel
Excell 2007: erreur dans formule
erreur dans une formule
Excel reporter détail de calcul dans formule
HELP => Formule conditionnelle dans Excel 2007
Excel 2007 résultat formule dans une autre cellule
Excel 2007 formule et saisie dans la même cellule
FORMULE EXCEL POUR RECHERCHE DANS UNE TABLE
formule modifiée dans excel donne pas résultat
Formule dans Excel
Plus de sujets relatifs à erreur dans une formule sur excel
 > Tous les forums > Forum Bureautique