× Aidez la recherche contre le COVID-19 avec votre ordi ! Rejoignez l'équipe PC Astuces Folding@home
 > Tous les forums > Forum Bureautique
 Excel 2007/ Calcul de salaire avec nbre d'heures
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
alane
  Posté le 08/07/2010 @ 17:24 
Aller en bas de la page 
Petit astucien

Alane- 8/7/2010-

Bonjour à tous , Excel me semble formidable mais quelle boite de Pandorre . Quand on l'ouvre ,que de choses!! Vous l'avez compris , je suis le candide de service !

Voila ,j'aimerai savoir (en termes simples, de tout les jours, SVP) comment , pour agir sur une cellule , 1 -enregistrer un montant horaire (visible ou non dans la feuille ).

2- En mentionnant le temps passé dans une cellule , j'obtienne dans la cellule d'a coté ,le montant de la prestation pour cette portion de temps .

1 exemple ?

1- Je "rentre" le prix de l'heure, mettons 10 € (où et comment SVP ?)

2-cellule A, je note le temps passé : 8H09 - 8H42. ou ( 8:09-8:42 ) ou encore ( 8:09 / 8:42 ) ??

3- Dans la cellule B s'affiche automatiquement en résultat le montant de la prestation soit (si je calcule bien !) = 5,49 €

Pour certains cela va sembler ridiculement simple,mais pour moi....

Selon l'adage chinois (un peu perso aussi,un peu!)

" Il vaut mieux un qui sait ,qu'un autre qui se gratte la tète,jusqu'à en faire échapper le peu de matière grise qui y séjournait encore."

Tiré du précieux recueuil du 3ème siécle de LAO t'Sais .

Amitiès à tous , et bon courage (ne vous grattez pas trop la tète quand mème ! )

Alane .

Publicité
Marmotte18
 Posté le 08/07/2010 à 21:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonsoir alane,

En A2, saisir 10 (montant horaire)

De A4 à A11, saisir l'heure de début sous la forme hh:mm (08:09 pour 8 heure 9)
De B4 à B11, saisir l'heure de fin sous la forme hh:mm (08:42 pour 8 heure 42)

NB : dans mon exemple, j'ai supposé que l'heure de début et l'heure de fin se trouve dans la même journée !

En C4, on met la formule :

=SI(A4="";"";(HEURE(B4)*60+MINUTE(B4)-(HEURE(A4)*60+MINUTE(A4)))*($B$1/60))

et on recopie cette formule dans les cellules C5 à C11

Ci-joint mon fichier de démonstration : http://www.cijoint.fr/cjlink.php?file=cj201007/cijJdXpgBB.xls

alane
 Posté le 15/07/2010 à 14:39 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Jeudi 15/7 -Marmotte 18 , bonjour ,

J'étais absent ces derniers jours et , je ne t'ai lu que hier soir aussi m'excusera-tu du retard de ma réponse ,et merci de t'ètre penché sur mon souci . Résultat ,j'ai rentré la formule ,mais lorsque je tape "entrée" à la place du résultat escompté ,dans la cellule prévue ,j'obtiens seulement le mot "Valeur". L'heure de début et de fin d'activité se situe bien dans la mème journée. Peut-être as-tu le bon Césame , ou encore peut-être ais-je fait une erreur ? Le mystère reste pour l'instant ...entier .

A bientôt de te lire . Alane .

Marmotte18
 Posté le 15/07/2010 à 18:15 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonsoir alane,

As-tu essayé le fichier que je t'ai joint ? Tu as seulement à rentrer les heures de début et de fin comme je l'ai fait sur la ligne 4. Les formules sont déjà en place ! => Ne tape rien dans la colonne C, Excel se chargera d'effectuer les calculs.

Dis-moi si tu arrives à le faire fonctionner ?

alane
 Posté le 18/07/2010 à 13:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Dimanche 18/7- Marmotte , bonjour et une nouvelle fois, merci de revenir vers moi . Je prends note mème si je n'ai pas le temps de tester cette solution. Merci en tout cas ...Et à bientôt , je te donnerai la T°.

Alane .

boubinette
 Posté le 18/07/2010 à 19:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Bonsoir

Proposition de fonction :

=SI(D6="";"";(F6-D6)*24*10)

avec en D6 et F6 tes heures (attention à les personnaliser dans le format de cellule en h:mm

A bientôt

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
-40%Jusqu'à 40% de réduction sur la marque Rowenta
Valable jusqu'au 22 Septembre

Amazon offre actuellement jusqu'à 40% de réduction sur une sélection de petit électroménager de marque Rowenta. Vous trouverez des aspirateurs, des centrales vapeur, des robots, des fers à lisser, ...


> Voir l'offre
34,90 €Routeur TP-Link Archer C6 Gigabit et Wifi double bande AC à 34,90 €
Valable jusqu'au 23 Septembre

Amazon fait une vente flash sur le routeur TP-Link Archer C6 qui passe à 34,90 € livré gratuitement. On le trouve ailleurs à partir de 50 €.  Ce routeur dispose de 5 ports Ethernet Gigabit, du WiFi 802.11 AC sur 2 bandes (délivre des débits combinés allant jusqu’à 1.2Gbps). Vous pouvez le convertir en point d'accès pour partager votre réseau filaire avec d'autres appareils WiFi.


> Voir l'offre
29,74 €Casque bluetooth à réduction de bruit TaoTronics CVC 8.0 à 29,74 € avec le code 69ZNOBQP
Valable jusqu'au 21 Septembre

Amazon fait une promotion sur le casque bluetooth 5.0 à réduction de bruit TaoTronics CVC 8.0 qui passe à 29,74 € livré gratuitement avec le code promo 69ZNOBQP. Ce casque offre une réduction active qui atténuera le bruit extérieurs pour vous plonger dans vos chansons préférées. Le casque offre une autonomie de 30 heures. Grâce à sa charge rapide, 5 minutes de charge suffisent pour obtenir 2 heures de son complet.

Pour profiter de l'offre, passez la souris sur le bandeau Message promotionnel et cliquez sur le bouton Appliquer à côté de la promotion de 30%. Vous pouvez aussi utiliser le code promo 69ZNOBQP sur la page de paiement.


> Voir l'offre

Sujets relatifs
Créer une formule de calcul avec excel 2007
Feuille de calcul d'heures avec Excel?
Calcul des heures avec EXCEL
Avec Excel = Somme jour+Heures+minutes
Excel 2007 extraction feuille 1 dans feuille 2 avec mise en forme
Exécuter graphique avec Excel 2007
Comment recuperer des fichiers Excel 2007 avec Excel 2003
Calcul avec excel entre 2 dates sur plusiuers années
Probleme d'enregistrement avec excel 2007
Calcul automatique word ou excel 2007
Plus de sujets relatifs à Excel 2007/ Calcul de salaire avec nbre d''heures
 > Tous les forums > Forum Bureautique