> Tous les forums > Forum Bureautique
 Excel 2007 RechercheV code figure pas dans matriceSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Cecilia2
  Posté le 21/01/2012 @ 17:20 
Aller en bas de la page 
Petite astucienne

Bonjour,
J'ai un fichier Base de 1800 lignes environs colonne A et B, je souhaite faire une rechercheV dans la colonne B, car il y a des nouveaux codes d'insérés.
Si un code de la base ne figure pas dans la matrice, je souhaite qu'il soit conservé et non écrasé, tant qu'aux autres lignes qu'elles soient modifiées au cas ou une réf aurait été modifiées.
Ci-joint un petit extrait

http://cjoint.com/?3Avq7lnNgiX

Merci par avance.

Publicité
Mytå
 Posté le 21/01/2012 à 17:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Salut le forum

Ta formule modifie

=SI(ESTNA(RECHERCHEV(E2;MATRICE!A$1:B$9;2;FAUX));B2;RECHERCHEV(E2;MATRICE!A$1:B$9;2;FAUX))

Mytå



Modifié par Mytå le 21/01/2012 17:46
rj390111
 Posté le 21/01/2012 à 18:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

Dans le fichier joint à hauteur de 50 on voit 72 d'où vient ce 72.

Si dans RECHERCHEV au lieu de FAUX vous mettez VRAI ou vous ne mettez rien il va chercher la valeur proche immédiatement inférieure.

Il faut pour cela que la matrice soit ordonnée en valeur croissante sur la colonne A ce qui a l'air d'être le cas.

Il faut également que la valeur de la cellule A2 soit 0 c'est à dire une valeur plus petite que la valeur cherchée.

Si en E4 vous tapez 150 valeur qui n'est pas dans la Matrice en F4 vous aurez alors JU850/b la valeur la plus proche et < à celle demandée.

Mais je ne sais pas si c'est cela que vous voulez.

Cecilia2
 Posté le 21/01/2012 à 21:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Bonsoir,

La formule est dans la feuille BASE et la Table matrice dans feuille MATRICE ou table de recherche .

Dans BASE, en F2 à l'origine il y avait 72 et comme il ne figure pas dans MATRICE, il a disparu et j'aurai souhaité qu'i reste. (Si un code figure dans la BASE mais pas dans MATRICE, je ne souhaite pas qu'il soit effacé ?).

Maintenant, je travaillerai en mode absolu.

Je ne peux pas utiliser VRAI car il me faut les valeurs exactes car ce sont des références produits.

Merci par avance,

Cécilia

Cecilia2
 Posté le 22/01/2012 à 17:37 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Bonjour,

Dans ce cas, après la RECHERCHEV, il faut que je fasse un COPIER et un COLLAGE SPECIAL VALEUR en colonne G et que je fasse une autre formule en colonne H=SI(G2<=0;B2;G2)

N'y aurait-il pas quelque de plus simple encore ?

Merci par avance.

Cecilia2
 Posté le 05/02/2012 à 22:21 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Bonsoir,

Merci à tous pour vos réponses, la dernière me convient parfaitement. Désolée de ne pas avoir répondu plus tôt mais ma connexion internet ne fonctionné plus.

Bonne soirée

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Excel 2007 Copier/Coller d’une feuille à l’autre Dans un même classeur.
Récupération dates dans tableau excel 2007
Date en abscisse dans excel 2007
Excel 2007 extraction feuille 1 dans feuille 2 avec mise en forme
Formulaire dans Excel 2007
Windows xp copier fichier répertoire dans excel 2007
Probleme excel - tri dans macro Excel 2007
fichier Excel 2010 s'ouvre mal dans 2007
macro majuscule dans excel 2007
Liste déroulante + saisie dans excel 2007
Plus de sujets relatifs à Excel 2007 RechercheV code figure pas dans matrice
 > Tous les forums > Forum Bureautique