> Tous les forums > Forum Bureautique
 excel 2010 : sélection de valeurs mensuelles en fonction du mois choisiSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
goachel
  Posté le 19/04/2013 @ 14:44 
Aller en bas de la page 
Nouvel astucien

Bonjour à tous les astuciens,

Voilà je suis à la peine avec un tableau excel. J'ai un tableau de valeurs mensuelles et je voudrais faire dans une cellule une moyenne de mes valeurs suivant le mois choisi.

Pour mars la moyenne se fait de janvier à mars, donc 3 mois à prendre en compte et pour avril 4 mois à prendre en compte. Quelqu'un a t-il une solution pour réaliser ce calcul automatiquement dès la sélection du mois.

Je joins mon fichier pour faciliter la compréhension : http://www.cjoint.com/?0DtoFo0hqDu

Merci de vos lumières et bonne journée

Publicité
w36xb2w
 Posté le 19/04/2013 à 15:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour

Voici le fichier

http://www.sendspace.com/file/0gqr8u

galopin01
 Posté le 19/04/2013 à 15:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

Une solution avec fonction personnalisée. (à télécharger dans ton répertoire de travail excel)

A+



Modifié par galopin01 le 19/04/2013 15:25
ferrand
 Posté le 19/04/2013 à 20:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonsoir,

Tu peux utiliser cette formule : =SOMME.SI(B1:M1;"<="&O2;B3:M3)/O2

ferrand
 Posté le 19/04/2013 à 21:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Ou pourquoi pas celle-ci : =SOMME(DECALER(B3;;;;O2))/O2

goachel
 Posté le 19/04/2013 à 22:42 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

Bonsoir à tous.

Formidable ça fonctionne comme je le souhaitais. Je vais sans doute opter pour la formule de Ferrand qui m'est plus familière !

Encore merci à vous pour votre assistance

Bon week end et un grand merci ...

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
129,99 €Ecran 24 pouces AOC 24G2U5/BK (IPS, FullHD, 1 ms, 75 Hz, FreeSync) à 129,99 €
Valable jusqu'au 03 Avril

Amazon propose actuellement l'écran incurvé 24 pouces AOC 24G2U5/BK à 129,99 € alors qu'on le trouve ailleurs à partir de 160 €. Cet écran à rétroéclairage LED dispose d'une dalle IPS Full HD (1920x1080), dispose d'entrées VGA, HDMI et DisplayPort. Grâce à son temps de réponse ultra rapide de 1 ms et à sa fréquence de 75 Hz, compatible FreeSync, il se distingue par sa bonne réactivité ! Il possède les technologies anti-scintillement (Flicker Free) et anti lumière bleue (Eye Care).  


> Voir l'offre
59,99 €SSD SanDisk Plus 480 Go à 59,99 €
Valable jusqu'au 31 Mars

Amazon fait une promotion  sur le SSD SanDisk SSD Plus 480 Go à 59,99 € livré gratuitement alors qu'on le trouve actuellement autour de 80 € ailleurs. Une bonne affaire pour ce SSD performant qui offre des débits de 535 Mo/s en lecture et 445 Mo/s en écriture. Cette version est garantie 3 ans. 


> Voir l'offre
8,99 €McAfee Internet Security 2020 (3 appareils, 1 an) à 8,99 €
Valable jusqu'au 03 Avril

Amazon fait une promotion sur la suite antivirus Internet Security 2020 qui passe à 8,99 €. Cette protection intégrale alliant antivirus, protection de l'identité et protection de la confidentialité des données pour tous vos PC, Mac, smartphones et tablettes est valide pour 3 appareils pendant 1 an. La clé d'activation ainsi que le lien de téléchargement vous seront envoyés par email une fois la commande passée. Une très bonne affaire.


> Voir l'offre

Sujets relatifs
Excel 2010 fonction SI imbriquée
Excel 2010, fonction SI (affichage)
fonction FIN.MOIS Excel 2007
Excel 2010
Excel 2010
Changement dans Excel 2010 ?
case à cocher dans cellule Excel 2010
Mise en forme conditionnelle Excel 2010
Extraction Excel 2010
EXCEL: Fonction DATEDIF
Plus de sujets relatifs à excel 2010 : sélection de valeurs mensuelles en fonction du mois choisi
 > Tous les forums > Forum Bureautique