> Tous les forums > Forum Bureautique
 Excel - Ajouter un nombre à un groupe de cellulesSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Mikenrion
  Posté le 25/02/2021 @ 12:23 
Aller en bas de la page 
Petit astucien

Bonjour

N'étant pas un expert sur Excel, je sais au moins ajouter la valeur d'une cellule à celles d'une ligne ou d'une colonne.

Pour aller plus vite je souhaiterais pouvoir ajouter directement la valeur d'une cellule à toutes celles d'un groupe de cellules sélectionnées (au moins à celles d'un groupe de m lignes par n colonnes). Je n'ai pas trouvé sur google, mais je suppose que cela doit être possible

Merci d'avance pour vos suggestions.

Publicité
poussebois
 Posté le 25/02/2021 à 12:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Bonjour ,

Directement, ce n'est pas possible.

La valeur étant dans la cellule A1 (par exemple, mais ça peut être n'importe où ailleurs)

Il te faut une zone distincte de même dimension m fois n.

Dans la première cellule de ta zone distincte, tu écris la formule =SOMME(première cellule zone primaire + $A$1), puis tu recopies dans les autres cellules de la zone distincte.

@ +

Mikenrion
 Posté le 25/02/2021 à 14:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour poussebois

Merci de ton aide, mais je ne suis vraiment pas doué, je n'y arrive pas.

J'essaie par exemple d'ajouter la valeur 1000 (dans la cellule AE5) dans un groupe de 50 l. x 4 c. cellules.

Je sélectionne les 200 cellules de ce groupe.

Puis dans la première cellule en haut et à droite de ce groupe (Z8 qui contient la valeur 1), je remplace sa valeur 1 par =SOMME(Z8 + $AE$5), mais en cliquant sur une autre cellule pour voir le résultat, ça me donne une erreur:

Merci de me dire où je ne fais pas comme il faut !

Mikenrion
 Posté le 25/02/2021 à 14:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bon je vois que je n'ai pas utilisé une zone distincte, grrr!

Prenons le même d'exemple d'ajouter la valeur 1000 (dans la cellule AE5) dans un groupe de 50 l. x 4 c. cellules dont la première cellule en haut et à droite set Z8 contenant la valeur 1.

Je sélectionne à côté une zone distincte de même dimension de 50 l. x 4 c. cellules.

Dans la première cellule en haut et à droite de cette zone distincte, j'écris =SOMME(Z8 + $AE$5).

Je clique sur une autre cellule pour voir le résultat, ça me donne bien la somme correcte (1 + 1000 =) 1001 dans première cellule de la zone distincte, mais rien pour les autres!

Mikenrion
 Posté le 25/02/2021 à 14:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Apparemment il y a quelque chose que je ne fais pas correctement pour que l'addition se fasse sur toutes les cellules de mon groupe...

poussebois
 Posté le 25/02/2021 à 14:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

,

C'est normal : dans Z8, tu mets une formule qui ajoute le contenu de Z8 à une autre cellule. Ça ne peut pas marcher et il te dit qu'il y a une référence circulaire.

C'est pourquoi je te disais que ce n'était pas possible directement. Ou alors, cela peut se faire avec une macro.

Si ton groupe occupe les cellules Z8 à AC57 (50 lignes par 4 colonnes). Tu crées une autre zone allant de AH8 à AK57 par exemple (mêmes dimensions).

En AH8, tu écris la formule : =(Z8+$AE$5).

Enfin, tu recopies cette formule dans toutes les autres cellules de la zone AH8 à AK57.



Modifié par poussebois le 25/02/2021 15:05
Mikenrion
 Posté le 25/02/2021 à 15:17 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Ah excuse moi, j'avais cru que cela pourrait donner toutes les additions pour le groupe. C'était trop beau; en fait ta proposition est de faire ainsi l'addition individuelle pour chacune des cellules du groupe.

Jusqu'à présent j'ai utilisé une autre méthode consistant à travailler par colonne de mon groupe.

Pour chacune, je colle à côté une colonne remplie de ma valeur à ajouter, et ensuite je fais l'addition ligne par ligne avec la fonction SIGMA.

Mais finalement cela reste des opérations à effectuer pour chacune des m x n cellules du groupe; je rêvais d'une facilité permettant l'addition d'une valeur sur toutes ces cellules du groupe en une seule opération...

Merci encore

poussebois
 Posté le 25/02/2021 à 15:56 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

,

S'il n'y a rien d'indiscret, peux-tu poster ton fichier via www.cjoint.com.

Cela sera plus facile à expliquer avec un renvoi du fichier traité...

DjiDji59430
 Posté le 25/02/2021 à 16:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour à tous,

un tuto :

https://www.cjoint.com/c/KBzpudXIYXz


Crdlmt

Mikenrion
 Posté le 25/02/2021 à 17:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Merci à tous deux; je reprendrai demain

poussebois
 Posté le 25/02/2021 à 18:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

@ DjiDji59430 ,

J'ai toujours utilisé le Collage spécial pour les valeurs ou les formules et je n'avais jamais fait attention aux opérations ... .

J'ai honte d'ignorer ce genre de choses élémentaires .

J'imagine qu'il y en a beaucoup d'autres simplement parce que, n'en ayant pas besoin, l'on ne s'en sert pas.

@ Mikenrion : oublie ce que je t'ai dit et applique ce que t'a dit DjiDji59430

Bonne soirée



Modifié par poussebois le 25/02/2021 18:07
Mikenrion
 Posté le 26/02/2021 à 07:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour DjiDji59430

Je me disais aussi qu'un soft aussi élaboré qu'Excel devait bien avoir prévu une fonction d'addition aussi simple.

C'est assez surprenant qu'en cherchant "Excel addition groupe de cellules" sur google, on ne parle pas du collage spécial !

Super, j'ai appris quelque chose aujourd'hui et j'en profiterai pour explorer les possibilités de ce collage spécial.

Merci et bonne journée

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
84,07 €SSD externe portable USB 3.1 Crucial X6 1 To à 84,07 €
Valable jusqu'au 27 Janvier

RueDuCommerce fait une promotion sur le SSD externe Crucial CT1000X6SSD9 1 To qui passe à 84,07 € au lieu de 110 €. Ce SSD externe portable offre des vitesses jusqu'à 540 Mo/s. Il se branche sur un port USB C ou A (adapteur fourni). Il est compatible PC, Mac, PS4, Xbox, Android.


> Voir l'offre
169,99 €Tablette 10.4 pouces Realme Pad (8 coeurs, 3 Go RAM, 32 Go) à 169,99 €
Valable jusqu'au 27 Janvier

Cdiscount fait une promotion la tablette 10.4 pouces Realme Pad qui passe à 169,99 € au lieu de 289 €. La tablette possède un écran de 26.31 cm WUXGA+ (2000x1200 pixels) à bords fins, un processeur octo core, 3 Go de RAM, 32 Go de stockage extensibles jusqu'à 1 To par MicroSD et tourne sous Android 11. Le WiFi, le bluetooth et le GPS sont également de la partie. Sa batterie de 7100 mAh à charge rapide 18W offre une large autonomie (65 jours en veille, 12h en lecture vidéo).

Notez qu'un mode "Plusieurs utilisateurs" vous permettra de partager votre tablette entre plusieurs membres de votre famille en toute sécurité.


> Voir l'offre
40,89 €Alimentation PC Gigabyte P650B (650W, 80+Bronze) à 40,89 €
Valable jusqu'au 28 Janvier

RueDuCommerce solde l'alimentation PC Gigabyte P650B (650W, 80+Bronze) qui passe à 40,89 € au lieu de 52,90 € ailleurs. Tous les condensateurs haute qualité de l'alimentation sont d'origine japonaise. Ils garantissent performances et stabilité sur le long terme. Avec Le ventilateur à roulement hydraulique silencieux de 120 mm optimise la réduction du bruit et les performances thermiques. La vitesse du ventilateur est ajustée en fonction de la détection automatique de la puissance. Le ventilateur à roulement hydraulique offre une durée de vie plus longue et plus stable. 


> Voir l'offre

Sujets relatifs
Excel 2003 : changer couleur de cellules par macro
Pb de dim. de cellules entre EXCEL & LIbre Office
Convertir nombre de jours en heures Excel
Compter le nombre de cellules identique
excel 2013, formule de cellules
excel 2013, déplacement de cellules
VBA Excel valeur en fonction de cellules
De-selectionner des lignes dans un groupe sous Excel
Excel - Copie de cellules selon choix
Arrondir les bords d'un groupe de cellules fusionnées
Plus de sujets relatifs à Excel - Ajouter un nombre à un groupe de cellules
 > Tous les forums > Forum Bureautique