> Tous les forums > Forum Bureautique
 Excel : transformer une date en texteSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Marmotte18
  Posté le 26/10/2008 @ 16:58 
Aller en bas de la page 
Astucien

Bonjour,

J'ai un trou de mémoire ! Pourriez-vous m'aider ?

Je souhaite transformer une cellule A1 (format = jj/mm/aaaa) qui comporte une date (par exemple 31/12/2007) en un texte, dans la cellule B1.

Je voudrais pouvoir m'en servir dans une concaténation de texte.

J'ai bien une réponse à donner. Elle me paraît lourde et mal formatée :

=CTXT(JOUR(A1);0) &"/"& CTXT(MOIS(A1);0)&"/"&CTXT(ANNEE(A1);0)

C'est bien un texte que j'obtiens mais la date arrive dans une présentation étrange : 31/12/2 007 au lieu de 31/12/2007

Pour obtenir la présentation correcte, j'ai bien la formule suivante mais quelle lourdeur !

=CTXT(JOUR(A1);0) &"/"& CTXT(MOIS(A1);0)&"/"&GAUCHE(CTXT(ANNEE(A1);0);1)&DROITE(CTXT(ANNEE(A1);0);3)



Modifié par Marmotte18 le 26/10/2008 17:10
Publicité
Bérylion
 Posté le 26/10/2008 à 17:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Salut

pas besoin de convertir en texte.

="texte à concatener "&JOUR(A1) &"/"&MOIS(A1)&"/"&ANNEE(A1)

suffit largement !

Marmotte18
 Posté le 26/10/2008 à 17:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Merci Bérylion,

C'est effectivement plus simple ! Pourquoi faire compliquer ce que l'on peut faire simplement ?

C'est drôle tout de même! Il existe une fonction pour transformer un texte en date mais pas l'inverse !

Mytå
 Posté le 26/10/2008 à 19:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Salut le forum

C'est drôle tout de même! Il existe une fonction pour transformer un texte en date mais pas l'inverse !

Elle existe la fonction =TEXTE(A1;"jj/mm/aaaa")

Mytå

Marmotte18
 Posté le 27/10/2008 à 18:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Merci Mytå,

Voilà une excellente réponse qui me convient parfaitement !

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Excel:Transformer du texte en lien vers un fichier
report automatique date et compteur fichier excel.
report automatique date et compteur fichier excel.
format date excel
Transformer un fichier html en fichier texte
Graphique excel 2007 : entrer la date en direct
Date en abscisse dans excel 2007
comment inscrire la date dans excel
EXCEL : Heure dans une case sans la date
Excel 2007 MAX + DATE
Plus de sujets relatifs à Excel : transformer une date en texte
 > Tous les forums > Forum Bureautique